parent
73057187ea
commit
65c4dc9575
@ -0,0 +1,33 @@
|
||||
diff -up OpenCV-2.1.0/CMakeLists.txt.lapack OpenCV-2.1.0/CMakeLists.txt
|
||||
--- OpenCV-2.1.0/CMakeLists.txt.lapack 2010-06-25 15:59:47.000000000 +0200
|
||||
+++ OpenCV-2.1.0/CMakeLists.txt 2010-06-25 16:01:04.000000000 +0200
|
||||
@@ -839,7 +839,7 @@ IF(NOT BUILD_SHARED_LIBS)
|
||||
set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} stdc++)
|
||||
endif()
|
||||
|
||||
- set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} flann zlib opencv_lapack)
|
||||
+ set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} flann z lapack)
|
||||
endif()
|
||||
|
||||
|
||||
diff -up OpenCV-2.1.0/src/cxcore/CMakeLists.txt.lapack OpenCV-2.1.0/src/cxcore/CMakeLists.txt
|
||||
--- OpenCV-2.1.0/src/cxcore/CMakeLists.txt.lapack 2010-06-25 15:59:47.000000000 +0200
|
||||
+++ OpenCV-2.1.0/src/cxcore/CMakeLists.txt 2010-06-25 16:00:35.000000000 +0200
|
||||
@@ -53,7 +53,7 @@ set_target_properties(${the_target} PROP
|
||||
)
|
||||
|
||||
# Add the required libraries for linking:
|
||||
-target_link_libraries(${the_target} ${OPENCV_LINKER_LIBS} ${IPP_LIBS} opencv_lapack zlib flann)
|
||||
+target_link_libraries(${the_target} ${OPENCV_LINKER_LIBS} ${IPP_LIBS} lapack z flann)
|
||||
|
||||
# Linker flag needed for Windows Mobile 5 and 6 SDKs
|
||||
if(MSVC)
|
||||
@@ -67,7 +67,7 @@ if(MSVC)
|
||||
)
|
||||
endif()
|
||||
|
||||
-add_dependencies(${the_target} opencv_lapack zlib)
|
||||
+add_dependencies(${the_target} lapack z)
|
||||
|
||||
install(TARGETS ${the_target}
|
||||
RUNTIME DESTINATION bin COMPONENT main
|
@ -0,0 +1,12 @@
|
||||
diff -up OpenCV-2.1.0/3rdparty/CMakeLists.txt.nointernal OpenCV-2.1.0/3rdparty/CMakeLists.txt
|
||||
--- OpenCV-2.1.0/3rdparty/CMakeLists.txt.nointernal 2010-04-06 03:24:34.000000000 +0200
|
||||
+++ OpenCV-2.1.0/3rdparty/CMakeLists.txt 2010-06-25 15:48:06.000000000 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
add_subdirectory(flann)
|
||||
-add_subdirectory(lapack)
|
||||
-add_subdirectory(zlib)
|
||||
+#add_subdirectory(lapack)
|
||||
+#add_subdirectory(zlib)
|
||||
if(WITH_JASPER AND NOT JASPER_FOUND)
|
||||
add_subdirectory(libjasper)
|
||||
endif()
|
@ -0,0 +1,12 @@
|
||||
diff -up OpenCV-2.1.0/CMakeLists.txt.rpath OpenCV-2.1.0/CMakeLists.txt
|
||||
--- OpenCV-2.1.0/CMakeLists.txt.rpath 2010-06-25 17:13:42.000000000 +0200
|
||||
+++ OpenCV-2.1.0/CMakeLists.txt 2010-06-25 17:13:55.000000000 +0200
|
||||
@@ -13,7 +13,7 @@ set(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS tr
|
||||
# Add these standard paths to the search paths for FIND_LIBRARY
|
||||
# to find libraries from these locations first
|
||||
if(UNIX)
|
||||
- set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /lib /usr/lib)
|
||||
+ set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /lib /lib64 /usr/lib /usr/lib64)
|
||||
endif()
|
||||
# it _must_ go before PROJECT(OpenCV) in order to work
|
||||
if (NOT CMAKE_INSTALL_PREFIX)
|
@ -1 +1,2 @@
|
||||
opencv-2_1_0-1_fc11:HEAD:opencv-2.1.0-1.fc11.src.rpm:1273158513
|
||||
opencv-2_1_0-2_fc13:HEAD:opencv-2.1.0-2.fc13.src.rpm:1277484612
|
||||
|
Loading…
Reference in new issue