You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
12 lines
399 B
12 lines
399 B
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -411,7 +411,7 @@ endif()
|
|
|
|
# Check for ARM Neon support
|
|
option(ALSOFT_REQUIRE_NEON "Require ARM NEON support" OFF)
|
|
-if(HAVE_ARM_NEON_H)
|
|
+if(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
|
option(ALSOFT_CPUEXT_NEON "Enable ARM NEON support" ON)
|
|
if(ALSOFT_CPUEXT_NEON)
|
|
check_c_source_compiles("#include <arm_neon.h>
|