- new bugfix upstream

- drop all patches, upstream now
----------------------------------------------------------------------
    Modified Files: devel/.cvsignore devel/ogdi.spec devel/sources Removed
    Files: devel/ogdi-3.2.0.beta1-optflags.patch
    devel/ogdi-fix-matrix.patch devel/ogdi-mfix.patch
----------------------------------------------------------------------
epel9
Balint Cristian 17 years ago
parent 04b77c9e7a
commit c0b5d51fe7

@ -1,2 +1,2 @@
ogdi-3.2.0.beta1.tar.gz
ogdi.pdf
ogdi-3.2.0.beta2.tar.gz

@ -1,25 +0,0 @@
diff -up ogdi-3.2.0.beta1/configure.in~ ogdi-3.2.0.beta1/configure.in
--- ogdi-3.2.0.beta1/configure.in~ 2007-02-24 19:37:33.000000000 +0200
+++ ogdi-3.2.0.beta1/configure.in 2007-10-12 22:13:58.000000000 +0300
@@ -36,9 +36,6 @@ AC_COMPILER_WFLAGS
AC_COMPILER_PIC
AC_LD_SHARED
-dnl Strip out optimization if already added
-CFLAGS=`echo "$CFLAGS " | sed "s/-O2 //"`
-
dnl ---------------------------------------------------------------------------
dnl Do we have rpc/pmap_clnt.h, float.h, dlfcn.h?
dnl ---------------------------------------------------------------------------
diff -up ogdi-3.2.0.beta1/configure~ ogdi-3.2.0.beta1/configure
--- ogdi-3.2.0.beta1/configure~ 2007-02-24 19:37:33.000000000 +0200
+++ ogdi-3.2.0.beta1/configure 2007-10-12 22:14:14.000000000 +0300
@@ -2425,8 +2425,6 @@ _ACEOF
-CFLAGS=`echo "$CFLAGS " | sed "s/-O2 //"`
-
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'

@ -1,58 +0,0 @@
--- ogdi/c-api/matrix.c 2007-02-19 20:31:33.000000000 +0100
+++ ogdi/c-api/matrix.c 2007-02-25 12:28:21.000000000 +0100
@@ -42,6 +42,9 @@
/* initialize loop iterators */
int i=0, j=0, k=0;
+
+ /* initialise result matrix */
+ mat_init( matrix_result, width_a, width_b );
/* compute multiply of each elements into destination matrix */
for ( i = 0 ; i< height_a; i++ )
@@ -65,14 +68,17 @@
double **matrix_result;
{
/* initialize loop iterators */
- int i=0, j=0, k=0;
+ int i=0, j=0, k=0;
+
+ /* initialise result matrix */
+ mat_init( matrix_result, width_a, width_b );
/* compute multiply of each elements into destination matrix */
- for ( i = 0 ; i< height_a; i++ )
- for ( j = 0 ; j< width_b; j++ )
- for ( k = 0 ; k< width_a; k++ )
- matrix_result[i][j] += matrix_a[i][k]*matrix_b[j][k];
- return;
+ for( i=0; i<width_a; ++i )
+ for( j=0; j<width_b; ++j )
+ for( k=0; k<height_a; ++k )
+ matrix_result[i][j] += matrix_a[k][i] * matrix_b[k][j];
+ return;
}
/*
@@ -194,7 +200,7 @@
*/
double **mat_malloc(int height,int width)
{
- unsigned i=0;
+ int i=0;
double **matrix=NULL;
matrix = (double **)malloc(height*sizeof(double *));
@@ -204,9 +210,9 @@
exit(1);
}
- for (i=0;i < width;i++) {
- matrix[i] = (double *)malloc(width * sizeof(double));
- if(matrix == NULL) {
+ for (i=0;i < height;i++) {
+ matrix[i] = (double *)malloc(width*sizeof(double));
+ if(matrix == NULL) {
printf("Allocating memory for matrix data failed. \n");
free(matrix);
exit(1);

@ -1,11 +0,0 @@
--- ogdi/driver/vrf/utils.c.mfix 2004-10-26 21:57:36.000000000 +0200
+++ ogdi/driver/vrf/utils.c 2007-02-25 10:19:57.000000000 +0100
@@ -1784,7 +1784,7 @@
free(tval);break;
case 'I':
get_table_element(val_pos,row,table,&ival,&n);
- sprintf(buffer," %12ld = %s \n",ival,des_buf);
+ sprintf(buffer," %12d = %s \n",ival,des_buf);
if (!ecs_AddText(&(s->result),buffer)) {
free(fclass); free(coverage); free(expression); return FALSE;
}

@ -1,15 +1,12 @@
Name: ogdi
Version: 3.2.0
Release: 0.9.beta1%{?dist}
Release: 0.10.beta2%{?dist}
Summary: Open Geographic Datastore Interface
Group: Applications/Engineering
License: BSD
URL: http://ogdi.sourceforge.net/
Source0: http://dl.sourceforge.net/ogdi/%{name}-%{version}.beta1.tar.gz
Source0: http://dl.sourceforge.net/ogdi/%{name}-%{version}.beta2.tar.gz
Source1: http://ogdi.sourceforge.net/ogdi.pdf
Patch0: ogdi-fix-matrix.patch
Patch1: ogdi-mfix.patch
Patch2: ogdi-3.2.0.beta1-optflags.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
BuildRequires: unixODBC-devel zlib-devel
@ -52,12 +49,8 @@ Requires: %{name} = %{version}-%{release}
TCL wrapper for OGDI.
%prep
%setup -q -n %{name}-%{version}.beta1
%patch0 -p0 -b .matrix
%patch1 -p0 -b .warrn
touch -r configure.in configure.in.stamp
%patch2 -p1 -b .optflags
touch -r configure.in.stamp configure.in
%setup -q -n %{name}-%{version}.beta2
# include documentation
cp -p %{SOURCE1} .
@ -128,6 +121,21 @@ touch -r ogdi-config.in ogdi-config
mkdir -p %{buildroot}%{_libdir}/pkgconfig
install -p -m 644 ogdi.pc %{buildroot}%{_libdir}/pkgconfig/
install -p -m 755 ogdi-config %{buildroot}%{_bindir}/ogdi-config-%{cpuarch}
# ogdi-config wrapper for multiarch
cat > %{buildroot}%{_bindir}/%{name}-config <<EOF
#!/bin/bash
ARCH=$(uname -m)
case $ARCH in
x86_64 | ppc64 | ia64 | s390x | sparc64 | alpha | alphaev6 )
gdal-config-64 ${*}
;;
*)
gdal-config-32 ${*}
;;
esac
EOF
touch -r ogdi-config.in %{buildroot}%{_bindir}/%{name}-config
%clean
rm -rf %{buildroot}
@ -151,6 +159,7 @@ rm -rf %{buildroot}
%doc ogdi.pdf
%doc ogdi/examples/example1/example1.c
%doc ogdi/examples/example2/example2.c
%{_bindir}/%{name}-config
%{_bindir}/%{name}-config-%{cpuarch}
%{_libdir}/pkgconfig/%{name}.pc
%dir %{_includedir}/%{name}
@ -166,6 +175,10 @@ rm -rf %{buildroot}
%{_libdir}/%{name}/libecs_tcl.so
%changelog
* Wed May 28 2008 Balint Cristian <rezso@rdsor.ro> - 3.2.0-0.10.beta2
- new bugfix upstream
- drop all patches, upstream now
* Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> - 3.2.0-0.9.beta1
- fix debuginfo bz#329921

@ -1,2 +1,2 @@
193da3f154985d37bb5aaa886e78f650 ogdi-3.2.0.beta1.tar.gz
029a8cdcd36bee73df92196ee769040e ogdi.pdf
8efc8f1e1dc77bfeda431d9b8e08d871 ogdi-3.2.0.beta2.tar.gz

Loading…
Cancel
Save