You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
ocserv/ocserv-tests.patch

92 lines
3.4 KiB

diff -ur ocserv-0.2.1.orig/tests/Makefile.in ocserv-0.2.1/tests/Makefile.in
--- ocserv-0.2.1.orig/tests/Makefile.in 2013-11-06 20:47:51.000000000 +0100
+++ ocserv-0.2.1/tests/Makefile.in 2013-11-11 13:56:15.231784324 +0100
@@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.14 from Makefile.am.
+# Makefile.in generated by automake 1.13.4 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
@@ -721,6 +721,8 @@
HAVE_WCHAR_T = @HAVE_WCHAR_T@
HAVE__BOOL = @HAVE__BOOL@
HAVE__EXIT = @HAVE__EXIT@
+HTTP_PARSER_CFLAGS = @HTTP_PARSER_CFLAGS@
+HTTP_PARSER_LIBS = @HTTP_PARSER_LIBS@
INCLUDE_NEXT = @INCLUDE_NEXT@
INCLUDE_NEXT_AS_FIRST_DIRECTIVE = @INCLUDE_NEXT_AS_FIRST_DIRECTIVE@
INSTALL = @INSTALL@
diff -ur ocserv-0.2.1.orig/tests/test1.config ocserv-0.2.1/tests/test1.config
--- ocserv-0.2.1.orig/tests/test1.config 2013-07-06 15:10:57.000000000 +0200
+++ ocserv-0.2.1/tests/test1.config 2013-11-11 13:56:15.231784324 +0100
@@ -132,7 +132,7 @@
# The user the worker processes will be run as. It should be
# unique (no other services run as this user).
run-as-user = nobody
-run-as-group = nogroup
+run-as-group = nobody
# Network settings
diff -ur ocserv-0.2.1.orig/tests/test2.config ocserv-0.2.1/tests/test2.config
--- ocserv-0.2.1.orig/tests/test2.config 2013-07-06 16:54:44.000000000 +0200
+++ ocserv-0.2.1/tests/test2.config 2013-11-11 13:56:15.231784324 +0100
@@ -132,7 +132,7 @@
# The user the worker processes will be run as. It should be
# unique (no other services run as this user).
run-as-user = nobody
-run-as-group = nogroup
+run-as-group = nobody
# Network settings
diff -ur ocserv-0.2.1.orig/tests/test3.config ocserv-0.2.1/tests/test3.config
--- ocserv-0.2.1.orig/tests/test3.config 2013-10-29 20:11:52.000000000 +0100
+++ ocserv-0.2.1/tests/test3.config 2013-11-11 13:56:15.232784330 +0100
@@ -132,7 +132,7 @@
# The user the worker processes will be run as. It should be
# unique (no other services run as this user).
run-as-user = nobody
-run-as-group = nogroup
+run-as-group = nobody
# Network settings
diff -ur ocserv-0.2.1.orig/tests/test-iroute ocserv-0.2.1/tests/test-iroute
--- ocserv-0.2.1.orig/tests/test-iroute 2013-10-30 12:39:28.000000000 +0100
+++ ocserv-0.2.1/tests/test-iroute 2013-11-11 13:56:32.933878367 +0100
@@ -35,7 +35,7 @@
echo -n "Checking if routes have been applied... "
-if [ ! -f test-iroute.tmp ];then
+if [ ! -f ./test-iroute.tmp ];then
fail $PID "Temporary file cannot be found"
fi
Only in ocserv-0.2.1/tests: test-iroute~
diff -ur ocserv-0.2.1.orig/tests/test-iroute.config ocserv-0.2.1/tests/test-iroute.config
--- ocserv-0.2.1.orig/tests/test-iroute.config 2013-10-30 12:31:33.000000000 +0100
+++ ocserv-0.2.1/tests/test-iroute.config 2013-11-11 13:56:15.232784330 +0100
@@ -132,7 +132,7 @@
# The user the worker processes will be run as. It should be
# unique (no other services run as this user).
run-as-user = nobody
-run-as-group = nogroup
+run-as-group = nobody
# Network settings
diff -ur ocserv-0.2.1.orig/tests/test-pass-script.config ocserv-0.2.1/tests/test-pass-script.config
--- ocserv-0.2.1.orig/tests/test-pass-script.config 2013-10-31 17:20:37.000000000 +0100
+++ ocserv-0.2.1/tests/test-pass-script.config 2013-11-11 13:56:15.232784330 +0100
@@ -132,7 +132,7 @@
# The user the worker processes will be run as. It should be
# unique (no other services run as this user).
run-as-user = nobody
-run-as-group = nogroup
+run-as-group = nobody
# Network settings