You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
ocserv/SPECS/ocserv.spec

837 lines
27 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.6.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
Version: 1.3.0
Release: %autorelease
%global _hardened_build 1
%if 0%{?fedora} || 0%{?rhel} >= 7
%define use_systemd 1
%define have_gpgv2 1
%else
%define use_systemd 0
%define have_gpgv2 0
%endif
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
%define use_libwrap 0
%define use_geoip 0
%else
%define use_libwrap 1
%define use_geoip 1
%endif
%define use_local_protobuf 0
Name: ocserv
Summary: OpenConnect SSL VPN server
# For a breakdown of the licensing, see PACKAGE-LICENSING
# To simplify licenses LGPLv2+ files have been promoted to GPLv2+.
License: GPLv2+ and BSD and MIT and CC0
URL: https://gui.openconnect-vpn.net
Source0: https://www.infradead.org/ocserv/download/%{name}-%{version}.tar.xz
Source1: https://www.infradead.org/ocserv/download/%{name}-%{version}.tar.xz.sig
Source2: gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg
Source3: ocserv.conf
Source4: ocserv.service
Source5: ocserv-pamd.conf
Source6: PACKAGE-LICENSING
Source8: ocserv-genkey
Source9: ocserv-script
Source10: gpgkey-56EE7FA9E8173B19FE86268D763712747F343FA7.gpg
Source11: ocserv.init
# Taken from upstream:
# http://git.infradead.org/ocserv.git/commitdiff/7d70006a2dbddf783213f1856374bacc74217e09
BuildRequires: make
BuildRequires: gcc
%if 0%{?rhel} && 0%{?rhel} <= 6
BuildRequires: gnutls30-devel
%else
BuildRequires: gnutls-devel
%endif
BuildRequires: pam-devel, iproute, ipcalc, openconnect, gnutls-utils
%if (0%{?use_local_protobuf} == 0)
BuildRequires: protobuf-c-devel
%endif
BuildRequires: libnl3-devel, krb5-devel, libtasn1-devel, gperf, libtalloc-devel
BuildRequires: libev-devel, llhttp-devel, radcli-devel, lz4-devel, readline-devel
BuildRequires: automake, autoconf
%if %{use_libwrap}
BuildRequires: tcp_wrappers-devel
%endif
%if %{use_geoip}
BuildRequires: GeoIP-devel
%else
BuildRequires: libmaxminddb-devel
%endif
%if %{use_systemd}
BuildRequires: systemd
BuildRequires: systemd-devel
BuildRequires: liboath-devel
BuildRequires: uid_wrapper
# Disable socket_wrapper on certain architectures because it
# introduces new syscalls that the worker cannot handle.
%ifnarch aarch64 %{ix86} %{arm}
BuildRequires: socket_wrapper
%endif
BuildRequires: gnupg2
%if 0%{?rhel} && 0%{?rhel} >= 7
%ifarch x86_64 %{ix86}
BuildRequires: libseccomp-devel
%endif
%else
%ifarch x86_64 %{ix86} %{arm} aarch64
BuildRequires: libseccomp-devel
%endif
%endif
%endif
# no rubygem in epel7
%if 0%{?fedora}
BuildRequires: rubygem-ronn-ng
%endif
Recommends: gnutls-utils
Recommends: iproute
Recommends: pam
Requires(pre): shadow-utils
%if %{use_systemd}
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%endif
#gnulib is bundled. See https://fedorahosted.org/fpc/ticket/174
Provides: bundled(gnulib)
#CCAN is bundled. See https://fedorahosted.org/fpc/ticket/364
Provides: bundled(bobjenkins-hash) bundled(ccan-container_of)
Provides: bundled(ccan-htable) bundled(ccan-list)
Provides: bundled(ccan-check_type) bundled(ccan-build_assert)
%description
OpenConnect server (ocserv) is an SSL VPN server. Its purpose is to be a
secure, small, fast and configurable VPN server. It implements the OpenConnect
SSL VPN protocol, and has also (currently experimental) compatibility with
clients using the AnyConnect SSL VPN protocol. The OpenConnect VPN protocol
uses the standard IETF security protocols such as TLS 1.2, and Datagram TLS
to provide the secure VPN service.
%prep
%if %{have_gpgv2}
gpgv2 --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0} || gpgv2 --keyring %{SOURCE10} %{SOURCE1} %{SOURCE0}
%endif
%autosetup -p1
%if (0%{?use_local_protobuf} == 0)
rm -rf src/protobuf/protobuf-c/
touch src/*.proto
%endif
rm -rf src/ccan/talloc
sed -i 's|/etc/ocserv.conf|/etc/ocserv/ocserv.conf|g' src/config.c
sed -i 's/run-as-group = nogroup/run-as-group = nobody/g' tests/data/*.config
%if 0%{?rhel} && 0%{?rhel} <= 6
echo "int main() { return 77; }" > tests/valid-hostname.c
%endif
%build
%if 0%{?rhel} && 0%{?rhel} <= 6
export PKG_CONFIG_LIBDIR="%{_libdir}/gnutls30/pkgconfig:%{_libdir}/pkgconfig"
export LIBGNUTLS_CFLAGS="-I/usr/include/gnutls30"
export LIBGNUTLS_LIBS="-L%{_libdir}/gnutls30/ -lgnutls"
export CFLAGS="$CFLAGS -I/usr/include/libev -I/usr/include/gnutls30"
sed -i 's/AM_PROG_AR//g' configure.ac
autoreconf -fvi
%endif
%configure \
--without-pcl-lib \
%if %{use_systemd}
--enable-systemd \
%else
--disable-systemd \
%endif
%if %{use_local_protobuf}
--without-protobuf \
%endif
%if %{use_libwrap}
--with-libwrap
%else
--without-libwrap
%endif
make %{?_smp_mflags}
%pre
getent group ocserv &>/dev/null || groupadd -r ocserv
getent passwd ocserv &>/dev/null || \
/usr/sbin/useradd -r -g ocserv -s /sbin/nologin -c ocserv \
-d %{_localstatedir}/lib/ocserv ocserv
mkdir -p %{_sysconfdir}/pki/ocserv/public
mkdir -p -m 700 %{_sysconfdir}/pki/ocserv/private
mkdir -p %{_sysconfdir}/pki/ocserv/cacerts
%check
make check %{?_smp_mflags} VERBOSE=1
%if %{use_systemd}
%post
%systemd_post ocserv.service
%preun
%systemd_preun ocserv.service
%postun
%systemd_postun_with_restart ocserv.service
%endif
%install
rm -rf %{buildroot}
cp -a %{SOURCE6} PACKAGE-LICENSING
mkdir -p %{buildroot}/%{_sysconfdir}/pam.d/
mkdir -p %{buildroot}/%{_sysconfdir}/ocserv/
install -p -m 644 %{SOURCE5} %{buildroot}/%{_sysconfdir}/pam.d/ocserv
install -p -m 644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/ocserv/
mkdir -p %{buildroot}%{_localstatedir}/lib/ocserv/
install -p -m 644 doc/profile.xml %{buildroot}%{_localstatedir}/lib/ocserv/
mkdir -p %{buildroot}/%{_sbindir}
install -p -m 755 %{SOURCE8} %{buildroot}/%{_sbindir}
mkdir -p %{buildroot}/%{_bindir}
install -p -m 755 %{SOURCE9} %{buildroot}/%{_bindir}
%if 0%{?rhel} && 0%{?rhel} <= 7
sed -i 's|expiration_days=-1|expiration_days=9999|' %{buildroot}/%{_sbindir}/ocserv-genkey
sed -i 's|tls-priorities = "@SYSTEM"|tls-priorities = "NORMAL:%SERVER_PRECEDENCE:%COMPAT:-VERS-SSL3.0"|' %{buildroot}/%{_sysconfdir}/ocserv/ocserv.conf
%if 0%{?rhel} <= 6
sed -i 's|isolate-workers = true|isolate-workers = false|' %{buildroot}/%{_sysconfdir}/ocserv/ocserv.conf
%endif
%endif
%if %{use_systemd}
mkdir -p %{buildroot}/%{_unitdir}
install -p -m 644 %{SOURCE4} %{buildroot}/%{_unitdir}
%else
mkdir -p %{buildroot}/%{_initrddir}
install -D -m 0755 %{SOURCE11} %{buildroot}/%{_initrddir}/%{name}
%endif
%make_install
%files
%defattr(-,root,root,-)
%dir %{_localstatedir}/lib/ocserv
%dir %{_sysconfdir}/ocserv
%config(noreplace) %{_sysconfdir}/ocserv/ocserv.conf
%config(noreplace) %{_sysconfdir}/pam.d/ocserv
%config(noreplace) %{_localstatedir}/lib/ocserv/profile.xml
%doc AUTHORS ChangeLog NEWS COPYING README.md PACKAGE-LICENSING doc/README-radius.md
%doc src/ccan/licenses/CC0 src/ccan/licenses/LGPL-2.1 src/ccan/licenses/BSD-MIT
%{_mandir}/man8/ocserv.8*
%{_mandir}/man8/occtl.8*
%{_mandir}/man8/ocpasswd.8*
%{_bindir}/ocpasswd
%{_bindir}/occtl
%{_libexecdir}/ocserv-fw
%{_bindir}/ocserv-script
%{_sbindir}/ocserv
%{_sbindir}/ocserv-worker
%{_sbindir}/ocserv-genkey
%{_localstatedir}/lib/ocserv/profile.xml
%if %{use_systemd}
%{_unitdir}/ocserv.service
%else
%{_initrddir}/%{name}
%endif
%changelog
## START: Generated by rpmautospec
* Wed May 08 2024 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.3.0-4
- Depend on llhttp from epel9
* Wed May 08 2024 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.3.0-3
- removed http-parser dependency
* Mon May 06 2024 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.3.0-2
- updated URI and added bundled
* Sun May 05 2024 Packit <hello@packit.dev> - 1.3.0-1
- Update to 1.3.0 upstream release
- Resolves: rhbz#2279186
* Thu Jan 25 2024 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.4-2
- spec: added ipcalc and updated the location of ocserv-fw
* Wed Jan 24 2024 Packit <hello@packit.dev> - 1.2.4-1
- [packit] 1.2.4 upstream release
* Fri Sep 22 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.2-2
- Added packit config
* Thu Sep 21 2023 Packit <hello@packit.dev> - 1.2.2-1
- [packit] 1.2.2 upstream release
* Tue Aug 29 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.1-3
- config: increased log level to 3
* Wed Aug 23 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.1-2
- make check: no longer use xfail for missing file
* Wed Aug 23 2023 Packit <hello@packit.dev> - 1.2.1-1
- [packit] 1.2.1 upstream release
* Wed Aug 23 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.0-4
- corrected download link
* Tue Aug 22 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.0-3
- updated URIs of source
* Tue Aug 15 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.0-2
- use %%systemd_postun_with_restart
* Thu Aug 03 2023 Arkady L. Shane <ashejn@msvsphere.ru> - 1.2.0-1
- Rebuilt for MSVSphere 9.2
* Tue Jul 11 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.2.0-1
- Updated to 1.2.0
* Tue Jul 11 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.7-3
- use %%autorelease and %%autochangelog
* Thu Jun 22 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.7-2
- Backported fixes for expired certificates
* Sun May 07 2023 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.7-1
- updated to 1.1.7
* Thu Feb 17 2022 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.6-1
- Updated to 1.1.6
* Thu Feb 10 2022 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.4-3
- Fixes for gnutls 3.7.3 and glibc new syscalls
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sat Nov 13 2021 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.4-1
- update to 1.1.4
* Sat Nov 06 2021 Adrian Reber <adrian@lisas.de> - 1.1.3-5
- Rebuilt for protobuf 3.19.0
* Tue Oct 26 2021 Adrian Reber <adrian@lisas.de> - 1.1.3-4
- Rebuilt for protobuf 3.18.1
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jun 02 2021 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.3-2
- removed unused file
* Wed Jun 02 2021 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.3-1
- updated to 1.1.3
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Jan 14 2021 Adrian Reber <adrian@lisas.de> - 1.1.2-5
- Rebuilt for protobuf 3.14
* Sat Jan 09 2021 Tom Stellard <tstellar@redhat.com> - 1.1.2-4
- Add BuildRequires: make
* Wed Dec 09 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.2-3
- do not special case rhel8 for http-parser
* Sun Dec 06 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.2-2
- skip patch that needs root
* Sun Dec 06 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.2-1
- Update to upstream 1.1.2 release
* Mon Nov 23 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-15
- Rebuilt for ronn successor
* Thu Nov 12 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.1-14
- rebuilt for new radcli
* Fri Oct 30 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-13
- spec: removed seccomp-trap debugging option
* Fri Oct 30 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-12
- Compile with new glibc
* Thu Oct 29 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-11
- rebuild without pcllib
* Fri Oct 23 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-10
- do not treat TODO as document to install
* Thu Sep 24 2020 Adrian Reber <adrian@lisas.de> - 1.1.1-9
- Rebuilt for protobuf 3.13
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-8
- corrected bogus date
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-7
- disable socket_wrapper on archs where it causes problems
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-6
- make check: be verbose
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-5
- removed xfail tests; they no longer fail
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-4
- ensure gnutls-utils are installed when building
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-3
- added resumption to XFAIL
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-2
- documented crypto policies change
* Mon Sep 21 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.1.1-1
- updated to 1.1.1
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sun Jun 21 2020 Adrian Reber <adrian@lisas.de> - 1.1.0-2
- Rebuilt for protobuf 3.12
* Tue Jun 16 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.1.0-1
- updated to 1.1.0
* Wed May 06 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.0.1-4
- Requirements turned to recommendations
* Fri May 01 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.0.1-3
- sources: removed unnecessary files
* Wed Apr 15 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.1-2
- Rebuild for http-parser 2.9.4
* Thu Apr 09 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.0.1-1
- Update to 1.0.1-1
- Update to upstream 1.0.1 release
* Thu Apr 09 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 1.0.0-2
- sources: removed unnecessary files
* Fri Mar 20 2020 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 1.0.0-1
- Update to 1.0.0-1
- Update to upstream 1.0.0 release
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jan 02 2020 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.12.6-3
- updated configuration to mark profile as configuration
* Sat Dec 28 2019 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 0.12.6-2
- ocserv.conf: updated to latest upstream version
* Sat Dec 28 2019 Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com> - 0.12.6-1
- Update to 0.12.6-1
- Update to upstream 0.12.6 release
* Wed Oct 16 2019 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.5-1
- Update to 0.12.5-1
- Update to upstream 0.12.5 release
* Wed Oct 16 2019 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.4-4
- spec: fix missing definition
* Mon Oct 14 2019 Nikos Mavrogiannopoulos <nmav@redhat.com>
- spec: updated for rhel8
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Wed Jul 03 2019 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.4-1
- Update to 0.12.4-1
- Update to upstream 0.12.4 release
* Tue Mar 12 2019 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.3-1
- Update to 0.12.3-1
- Update to upstream 0.12.3 release
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.2-4
- Rebuild for readline 8.0
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 0.12.2-2
- Rebuilt for libcrypt.so.2 (#1666033)
* Thu Jan 10 2019 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.2-1
- Update to 0.12.2-1
- Update to upstream 0.12.2 release
* Tue Jul 24 2018 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.12.1-5
- Added gcc as build-dependency
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jul 10 2018 Jason Tibbitts <tibbs@math.uh.edu> - 0.12.1-3
- Remove needless use of %%defattr
* Mon Jul 09 2018 Igor Gnatenko <ignatenko@redhat.com> - 0.12.1-2
- add BuildRequires: gcc
* Sat May 12 2018 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.12.1-1
- Update to 0.12.1-1
- Update to upstream 0.12.1 release
* Mon Apr 23 2018 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.12.0-1
- Update to 0.12.0-1
- Update to upstream 0.12.0 release
* Thu Apr 12 2018 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.11-2
- Update to 0.11.11-2
- Update to upstream 0.11.11 release
- include crypt.h to use crypt()
* Mon Mar 05 2018 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.11-1
- Update to 0.11.11-1
- Update to upstream 0.11.11 release
* Wed Feb 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.10-5
- Remove %%clean section
* Tue Feb 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.10-4
- Remove BuildRoot definition
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 0.11.10-2
- Rebuilt for switch to libxcrypt
* Mon Jan 08 2018 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.10-1
- Update to 0.11.10-1
- Update to upstream 0.11.10 release
* Tue Nov 21 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.9-3
- Update to 0.11.9-3
- Update to upstream 0.11.9 release
* Thu Nov 16 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.9-2
- do not enable libwrap
* Tue Oct 10 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.9-1
- Update to 0.11.9-1
- Update to upstream 0.11.9 release
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.8-3
- Rebuilt for
https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Wed May 03 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.8-1
- Update to 0.11.8-1
- Update to upstream 0.11.8 release
* Mon Feb 13 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.7-1
- Update to 0.11.7-1
- Update to upstream 0.11.7 release
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.11.6-4
- Rebuild for readline 7.x
* Tue Nov 15 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.6-3
- Removed gpg keys from sources
* Tue Nov 15 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.6-2
- ocserv.conf: include switch-to-tcp-timeout
* Tue Nov 15 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.6-1
- updated to 0.11.6
* Fri Sep 23 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.5-1
- updated to 0.11.5
* Wed Sep 14 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.4-3
- Added getrandom to the list of allowed syscalls (#1375851)
* Thu Sep 08 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.4-2
- Rebuild to address http-parser breakage (#1374081)
* Fri Aug 05 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.4-1
- updated to 0.11.4
* Thu Jun 16 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.3-1
- updated to 0.11.3
* Tue Apr 26 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.2-2
- fixed date and removed legacy config options
* Tue Apr 26 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.2-1
- updated to 0.11.2 and added auto sig verification
* Mon Mar 21 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.1-1
- updated to 0.11.1
* Fri Feb 19 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.0-1
- updated to 0.11.0
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Tue Feb 02 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.11-2
- corrected license to apply to the real one
* Mon Jan 11 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.11-1
- updated to 0.10.11
* Mon Nov 30 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.10-1
- updated to 0.10.10
* Thu Oct 08 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.9-1
- updated to 0.10.9
* Thu Sep 17 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.8-2
- compile ocserv using radcli
* Mon Sep 07 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.8-1
- updated to 0.10.8
* Fri Aug 07 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.7-1
- updated to 0.10.7
* Thu Jul 09 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.6-2
- corrected JSON output in occtl
* Thu Jul 02 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.6-1
- updated to 0.10.6
* Wed Jun 17 2015 Dennis Gilmore <dennis@ausil.us> - 0.10.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon May 25 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.5-1
- updated to 0.10.5
* Mon Apr 27 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.4-1
- new upstream release
* Mon Mar 30 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.2-1
- new upstream release
* Mon Mar 16 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.1-1
- updated to 0.10.1
* Wed Mar 11 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.0-2
- updated dependencies and files for 0.10.0
* Wed Mar 11 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.10.0-1
- updated to 0.10.0
* Wed Feb 18 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.2-1
- new upstream release
* Mon Feb 16 2015 Peter Robinson <pbrobinson@gmail.com> - 0.9.1-3
- aarch64 (and ARMv7) now has seccomp support
* Mon Feb 16 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.1-2
- depend on freeradius-client
* Mon Feb 16 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.1-1
- updated to 0.9.1
* Thu Jan 29 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.0-3
- run make check
* Thu Jan 29 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.0-2
- Do not enable seccomp in x86. It is broken.
* Thu Jan 22 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.9.0-1
- new upstream release
* Tue Jan 13 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-10
- compile without support for smp to prevent issues with autogen
* Fri Jan 09 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-9
- enable PIE
* Tue Jan 06 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-8
- Comply with system-wide crypto policies
* Tue Jan 06 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-7
- enable seccomp on x86 platforms only
* Tue Jan 06 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-6
- mention the enabling of seccomp
* Tue Jan 06 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-5
- disable seccomp on arm
* Tue Jan 06 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-4
- ocserv.service: depend on network-online.target (#1178760)
* Mon Dec 29 2014 Nikos Mavrogiannopoulos <nmav@gnutls.org> - 0.8.9-3
- Added seccomp dependency
* Thu Dec 11 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-2
- updated for bundled script
* Thu Dec 11 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.9-1
- new upstream release
* Wed Nov 26 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.8-1
- new upstream release
* Mon Oct 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.7-2
- corrected bogus date
* Mon Oct 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.7-1
- updated to 0.8.7
* Tue Sep 09 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.4-3
- Ship a default ocserv-script, which will put connecting clients into the
internal firewall zone.
* Thu Aug 28 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.4-2
- removed unused config file
* Thu Aug 28 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.4-1
- updated to 0.8.4 and removed unused file
* Sun Aug 17 2014 Peter Robinson <pbrobinson@fedoraproject.org> - 0.8.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Fri Aug 08 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.2-4
- rebuilt
* Tue Aug 05 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.2-3
- rebuilt for new protobuf-c
* Fri Aug 01 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.2-2
- disabled auto-select-group by default
* Mon Jul 28 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.2-1
- new upstream release
* Mon Jun 30 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.1-1
- Updated to 0.8.1
* Fri Jun 06 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-6
- Added ocserv-genkey
* Fri Jun 06 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-5
- corrected date
* Fri Jun 06 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-4
- doc update
* Fri Jun 06 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-3
- corrected chroot path
* Fri Jun 06 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-2
- Generate the certificates and private keys before the first run
* Mon Jun 02 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0-1
- updated ocserv to 0.8.0
* Tue May 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0pre0-4
- Updated license information
* Mon May 26 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0pre0-3
- depend on systemd-devel
* Mon May 26 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0pre0-2
- depend on talloc
* Mon May 26 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.8.0pre0-1
- new upstream release
* Fri May 09 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.5-1
- new upstream release
* Fri May 02 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.4-2
- updated default config file
* Fri May 02 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.4-1
- new upstream release
* Thu Apr 10 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.3-1
- new upstream release
* Fri Mar 14 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.2-1
- new upstream release
* Mon Feb 17 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.1-4
- Added missing profile file.
* Mon Feb 17 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.1-3
- more config updates
* Mon Feb 17 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.1-2
- fixes in default config
* Mon Feb 17 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.1-1
- new upstream release
* Wed Jan 29 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-6
- bumped version
* Wed Jan 29 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-5
- remove expiration date by default
* Mon Jan 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-4
- more uniform handling of buildrequires
* Mon Jan 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-3
- do not output anything when generating certificates
* Mon Jan 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-2
- added changelog entry
* Mon Jan 27 2014 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.3.0-1
- updated to ocserv 0.3.0
* Mon Dec 16 2013 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.2.3-1
- updated to 0.2.3
* Fri Dec 06 2013 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.2.1-4
- use the correct config file
* Fri Dec 06 2013 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.2.1-3
- corrected chroot directory
* Fri Dec 06 2013 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.2.1-2
- compile with any version of libopts
* Fri Dec 06 2013 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.2.1-1
- Initial import (#1027770)
## END: Generated by rpmautospec