import nvml-1.12.1-1.el9

i9c changed/i9c/nvml-1.12.1-1.el9
MSVSphere Packaging Team 2 years ago
parent 7d361a10e5
commit af8e56bbe6

4
.gitignore vendored

@ -1,2 +1,2 @@
SOURCES/pmdk-1.10.1-man.tar.gz
SOURCES/pmdk-1.10.1.tar.gz
SOURCES/pmdk-1.12.1-man.tar.gz
SOURCES/pmdk-1.12.1.tar.gz

@ -1,2 +1,2 @@
0f61c6dba3937a288dc90d8d16073b36cb117e93 SOURCES/pmdk-1.10.1-man.tar.gz
935735fab582deb56388eb09387ec0a6038e9177 SOURCES/pmdk-1.10.1.tar.gz
7d082f9737c9239b0c7f990d555d20e3b2fa59e1 SOURCES/pmdk-1.12.1-man.tar.gz
f6dfb57243a6f5ab7624ea6543ab2ae1eb70bb9f SOURCES/pmdk-1.12.1.tar.gz

@ -1,27 +0,0 @@
--- pmdk-1.10.1/src/Makefile.inc.orig 2022-02-01 10:57:54.530694627 -0500
+++ pmdk-1.10.1/src/Makefile.inc 2022-02-01 10:59:19.461777353 -0500
@@ -67,14 +67,10 @@ DEFAULT_CFLAGS += -DSTRINGOP_TRUNCATION_
endif
ifeq ($(DEBUG),1)
-# Undefine _FORTIFY_SOURCE in case it's set in system-default or
-# user-defined CFLAGS as it conflicts with -O0.
-DEBUG_CFLAGS += -Wp,-U_FORTIFY_SOURCE
-DEBUG_CFLAGS += -O0 -ggdb -DDEBUG
LIB_SUBDIR = /pmdk_debug
OBJDIR = debug
else
-DEFAULT_CFLAGS += -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+DEFAULT_CFLAGS += -O2 -g -D_FORTIFY_SOURCE=2
LIB_SUBDIR =
OBJDIR = nondebug
endif
@@ -119,7 +115,7 @@ endif
CFLAGS += $(EXTRA_CFLAGS)
ifeq ($(DEBUG),1)
-CFLAGS += $(EXTRA_CFLAGS_DEBUG) $(DEBUG_CFLAGS)
+CFLAGS += $(EXTRA_CFLAGS_DEBUG) -DDEBUG
else
CFLAGS += $(EXTRA_CFLAGS_RELEASE)
endif

@ -0,0 +1,18 @@
--- pmdk-1.12.1/src/Makefile.inc.orig 2022-10-17 11:06:39.232365095 -0400
+++ pmdk-1.12.1/src/Makefile.inc 2022-10-17 11:09:28.751365095 -0400
@@ -73,14 +73,10 @@ endif
DEFAULT_CFLAGS += -Wno-deprecated-declarations
ifeq ($(DEBUG),1)
-# Undefine _FORTIFY_SOURCE in case it's set in system-default or
-# user-defined CFLAGS as it conflicts with -O0.
-DEBUG_CFLAGS += -Wp,-U_FORTIFY_SOURCE
-DEBUG_CFLAGS += -O0 -ggdb -DDEBUG
LIB_SUBDIR = /pmdk_debug
OBJDIR = debug
else
-DEFAULT_CFLAGS += -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+DEFAULT_CFLAGS += -O2 -g -D_FORTIFY_SOURCE=2
LIB_SUBDIR =
OBJDIR = nondebug
endif

@ -17,11 +17,11 @@
%bcond_with pmemcheck
%define min_ndctl_ver 60.1
%define upstreamversion 1.10.1
%define upstreamversion 1.12.1
Name: nvml
Version: 1.10.1
Release: 2%{?dist}
Version: 1.12.1
Release: 1%{?dist}
Summary: Persistent Memory Development Kit (formerly NVML)
License: BSD
URL: http://pmem.io/pmdk
@ -36,11 +36,12 @@ Source1: pmdk-%{version}-man.tar.gz
# but do_open never initializes "attr"
# may read that object
Patch0: Makefile-bypass-check-doc-in-check.patch
Patch1: pmdk-1.10.1-use_ddebug_instead_of_debug_cflags.patch
Patch1: pmdk-1.12.1-use_ddebug_instead_of_debug_cflags.patch
BuildRequires: gcc
BuildRequires: make
BuildRequires: cmake
BuildRequires: glibc-devel
BuildRequires: autoconf
BuildRequires: automake
@ -597,6 +598,10 @@ mkdir -p %{buildroot}%{_mandir}
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 1.10.1-2
- Rebuilt for MSVSphere 9.1.
* Tue Oct 18 2022 Bryan Gurney <bgurney@redhat.com > 1.12.1-1
- Update to PMDK version 1.12.1
- Related: rhbz#2111431
* Mon Feb 07 2022 Bryan Gurney <bgurney@redhat.com> - 1.10.1-2
- Use DDEBUG in Makefile.inc instead of DEBUG_CFLAGS
- Related: rhbz#2044882

Loading…
Cancel
Save