You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
numpy/SOURCES/f2py-setup.patch

18 lines
735 B

diff --git a/numpy/f2py/setup.py b/numpy/f2py/setup.py
index 3204129..0d47580 100644
--- a/numpy/f2py/setup.py
+++ b/numpy/f2py/setup.py
@@ -55,9 +55,9 @@ def configuration(parent_package='', top_path=None):
config.make_svn_version_py()
def generate_f2py_py(build_dir):
- f2py_exe = 'f2py' + os.path.basename(sys.executable)[6:]
- if f2py_exe[-4:] == '.exe':
- f2py_exe = f2py_exe[:-4] + '.py'
+ f2py_exe = 'f2py' + str(sys.version_info.major)
+ if sys.executable.endswith('.exe'):
+ f2py_exe = f2py_exe + '.py'
if 'bdist_wininst' in sys.argv and f2py_exe[-3:] != '.py':
f2py_exe = f2py_exe + '.py'
target = os.path.join(build_dir, f2py_exe)