parent
3a0adb6bbb
commit
d5cb0276dc
@ -1,88 +0,0 @@
|
||||
diff -urNr client-2.3.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h client-2.3.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h
|
||||
--- client-2.3.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2016-10-11 07:58:58.953393364 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
**
|
||||
****************************************************************************/
|
||||
|
||||
-#include <qtlockedfile.h>
|
||||
+#include <QTSolutions/qtlockedfile.h>
|
||||
|
||||
#include <QLocalServer>
|
||||
#include <QLocalSocket>
|
||||
diff -urNr client-2.3.0-orig/src/gui/application.cpp client-2.3.0/src/gui/application.cpp
|
||||
--- client-2.3.0-orig/src/gui/application.cpp 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/application.cpp 2016-10-11 08:00:25.875964871 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
// ----------------------------------------------------------------------------------
|
||||
|
||||
Application::Application(int &argc, char **argv) :
|
||||
- SharedTools::QtSingleApplication(Theme::instance()->appName() ,argc, argv),
|
||||
+ QtSingleApplication(Theme::instance()->appName() ,argc, argv),
|
||||
_gui(0),
|
||||
_theme(Theme::instance()),
|
||||
_helpOnly(false),
|
||||
diff -urNr client-2.3.0-orig/src/gui/application.h client-2.3.0/src/gui/application.h
|
||||
--- client-2.3.0-orig/src/gui/application.h 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/application.h 2016-10-11 08:01:58.240768785 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <QElapsedTimer>
|
||||
#include <QNetworkConfigurationManager>
|
||||
|
||||
-#include "qtsingleapplication.h"
|
||||
+#include "QtSolutions/QtSingleApplication"
|
||||
|
||||
#include "syncresult.h"
|
||||
#include "logbrowser.h"
|
||||
@@ -49,7 +49,7 @@
|
||||
* @brief The Application class
|
||||
* @ingroup gui
|
||||
*/
|
||||
-class Application : public SharedTools::QtSingleApplication
|
||||
+class Application : public QtSingleApplication
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
||||
diff -urNr client-2.3.0-orig/src/gui/CMakeLists.txt client-2.3.0/src/gui/CMakeLists.txt
|
||||
--- client-2.3.0-orig/src/gui/CMakeLists.txt 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/CMakeLists.txt 2016-10-11 08:05:03.906753374 +0200
|
||||
@@ -147,10 +147,6 @@
|
||||
|
||||
set(3rdparty_SRC
|
||||
../3rdparty/QProgressIndicator/QProgressIndicator.cpp
|
||||
- ../3rdparty/qtlockedfile/qtlockedfile.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtlocalpeer.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsingleapplication.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsinglecoreapplication.cpp
|
||||
)
|
||||
|
||||
if (APPLE)
|
||||
@@ -161,18 +157,10 @@
|
||||
)
|
||||
endif()
|
||||
|
||||
-if(NOT WIN32)
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_unix.cpp)
|
||||
-else()
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_win.cpp )
|
||||
-endif()
|
||||
-
|
||||
set(3rdparty_INC
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/qjson
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/QProgressIndicator
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtlockedfile
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/qtmacgoodies/src
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtsingleapplication
|
||||
)
|
||||
|
||||
include_directories(${3rdparty_INC})
|
||||
@@ -298,6 +286,8 @@
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${QT_LIBRARIES} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${synclib_NAME} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} updater )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_LockedFile-2.4 )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_SingleApplication-2.6 )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${OS_SPECIFIC_LINK_LIBRARIES} )
|
||||
|
||||
if(WITH_CRASHREPORTER)
|
||||
|
@ -1,88 +0,0 @@
|
||||
diff -urNr client-2.3.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h client-2.3.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h
|
||||
--- client-2.3.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2016-10-11 07:58:58.953393364 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
**
|
||||
****************************************************************************/
|
||||
|
||||
-#include <qtlockedfile.h>
|
||||
+#include <QTSolutions/qtlockedfile.h>
|
||||
|
||||
#include <QLocalServer>
|
||||
#include <QLocalSocket>
|
||||
diff -urNr client-2.3.0-orig/src/gui/application.cpp client-2.3.0/src/gui/application.cpp
|
||||
--- client-2.3.0-orig/src/gui/application.cpp 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/application.cpp 2016-10-11 08:00:25.875964871 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
// ----------------------------------------------------------------------------------
|
||||
|
||||
Application::Application(int &argc, char **argv) :
|
||||
- SharedTools::QtSingleApplication(Theme::instance()->appName() ,argc, argv),
|
||||
+ QtSingleApplication(Theme::instance()->appName() ,argc, argv),
|
||||
_gui(0),
|
||||
_theme(Theme::instance()),
|
||||
_helpOnly(false),
|
||||
diff -urNr client-2.3.0-orig/src/gui/application.h client-2.3.0/src/gui/application.h
|
||||
--- client-2.3.0-orig/src/gui/application.h 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/application.h 2016-10-11 08:01:58.240768785 +0200
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <QElapsedTimer>
|
||||
#include <QNetworkConfigurationManager>
|
||||
|
||||
-#include "qtsingleapplication.h"
|
||||
+#include "QtSolutions/QtSingleApplication"
|
||||
|
||||
#include "syncresult.h"
|
||||
#include "logbrowser.h"
|
||||
@@ -49,7 +49,7 @@
|
||||
* @brief The Application class
|
||||
* @ingroup gui
|
||||
*/
|
||||
-class Application : public SharedTools::QtSingleApplication
|
||||
+class Application : public QtSingleApplication
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
||||
diff -urNr client-2.3.0-orig/src/gui/CMakeLists.txt client-2.3.0/src/gui/CMakeLists.txt
|
||||
--- client-2.3.0-orig/src/gui/CMakeLists.txt 2016-09-27 10:53:37.000000000 +0200
|
||||
+++ client-2.3.0/src/gui/CMakeLists.txt 2016-10-11 08:05:03.906753374 +0200
|
||||
@@ -147,10 +147,6 @@
|
||||
|
||||
set(3rdparty_SRC
|
||||
../3rdparty/QProgressIndicator/QProgressIndicator.cpp
|
||||
- ../3rdparty/qtlockedfile/qtlockedfile.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtlocalpeer.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsingleapplication.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsinglecoreapplication.cpp
|
||||
)
|
||||
|
||||
if (APPLE)
|
||||
@@ -161,18 +157,10 @@
|
||||
)
|
||||
endif()
|
||||
|
||||
-if(NOT WIN32)
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_unix.cpp)
|
||||
-else()
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_win.cpp )
|
||||
-endif()
|
||||
-
|
||||
set(3rdparty_INC
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/qjson
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/QProgressIndicator
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtlockedfile
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/qtmacgoodies/src
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtsingleapplication
|
||||
)
|
||||
|
||||
include_directories(${3rdparty_INC})
|
||||
@@ -298,6 +286,8 @@
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${QT_LIBRARIES} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${synclib_NAME} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} updater )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_LockedFile-2.4 )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_SingleApplication-2.6 )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${OS_SPECIFIC_LINK_LIBRARIES} )
|
||||
|
||||
if(WITH_CRASHREPORTER)
|
||||
|
@ -1,114 +0,0 @@
|
||||
diff -urNr owncloudclient-2.4.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h owncloudclient-2.4.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h
|
||||
--- owncloudclient-2.4.0-orig/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2017-12-20 18:42:11.000000000 +0100
|
||||
+++ owncloudclient-2.4.0/src/3rdparty/qtsingleapplication/qtlocalpeer.h 2018-02-13 22:23:26.772426256 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
**
|
||||
****************************************************************************/
|
||||
|
||||
-#include <qtlockedfile.h>
|
||||
+#include <QTSolutions/qtlockedfile.h>
|
||||
|
||||
#include <QLocalServer>
|
||||
#include <QLocalSocket>
|
||||
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.cpp owncloudclient-2.4.0/src/gui/application.cpp
|
||||
--- owncloudclient-2.4.0-orig/src/gui/application.cpp 2017-12-20 18:42:11.000000000 +0100
|
||||
+++ owncloudclient-2.4.0/src/gui/application.cpp 2018-02-13 22:25:51.846015381 +0100
|
||||
@@ -95,7 +95,7 @@ namespace {
|
||||
// ----------------------------------------------------------------------------------
|
||||
|
||||
Application::Application(int &argc, char **argv)
|
||||
- : SharedTools::QtSingleApplication(Theme::instance()->appName(), argc, argv)
|
||||
+ : QtSingleApplication(Theme::instance()->appName(), argc, argv)
|
||||
, _gui(0)
|
||||
, _theme(Theme::instance())
|
||||
, _helpOnly(false)
|
||||
@@ -150,7 +150,7 @@ Application::Application(int &argc, char **argv)
|
||||
|
||||
_folderManager.reset(new FolderMan);
|
||||
|
||||
- connect(this, &SharedTools::QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
|
||||
+ connect(this, &QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
|
||||
|
||||
if (!AccountManager::instance()->restore()) {
|
||||
// If there is an error reading the account settings, try again
|
||||
@@ -363,7 +363,7 @@ void Application::slotUseMonoIconsChange
|
||||
_gui->slotComputeOverallSyncStatus();
|
||||
}
|
||||
|
||||
-void Application::slotParseMessage(const QString &msg, QObject *)
|
||||
+void Application::slotParseMessage(const QString &msg)
|
||||
{
|
||||
if (msg.startsWith(QLatin1String("MSG_PARSEOPTIONS:"))) {
|
||||
const int lengthOfMsgPrefix = 17;
|
||||
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.h owncloudclient-2.4.0/src/gui/application.h
|
||||
--- owncloudclient-2.4.0-orig/src/gui/application.h 2017-12-20 18:42:11.000000000 +0100
|
||||
+++ owncloudclient-2.4.0/src/gui/application.h 2018-02-13 22:27:18.007583524 +0100
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <QElapsedTimer>
|
||||
#include <QNetworkConfigurationManager>
|
||||
|
||||
-#include "qtsingleapplication.h"
|
||||
+#include "QtSolutions/QtSingleApplication"
|
||||
|
||||
#include "syncresult.h"
|
||||
#include "logbrowser.h"
|
||||
@@ -52,7 +52,7 @@
|
||||
* @brief The Application class
|
||||
* @ingroup gui
|
||||
*/
|
||||
-class Application : public SharedTools::QtSingleApplication
|
||||
+class Application : public QtSingleApplication
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
||||
@@ -85,7 +85,7 @@ signals:
|
||||
void folderStateChanged(Folder *);
|
||||
|
||||
protected slots:
|
||||
- void slotParseMessage(const QString &, QObject *);
|
||||
+ void slotParseMessage(const QString &);
|
||||
void slotCheckConnection();
|
||||
void slotUseMonoIconsChanged(bool);
|
||||
void slotCleanup();
|
||||
|
||||
diff -urNr owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt owncloudclient-2.4.0/src/gui/CMakeLists.txt
|
||||
--- owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt 2017-12-20 18:42:11.000000000 +0100
|
||||
+++ owncloudclient-2.4.0/src/gui/CMakeLists.txt 2018-02-13 22:29:10.917707151 +0100
|
||||
@@ -152,10 +152,6 @@
|
||||
|
||||
set(3rdparty_SRC
|
||||
../3rdparty/QProgressIndicator/QProgressIndicator.cpp
|
||||
- ../3rdparty/qtlockedfile/qtlockedfile.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtlocalpeer.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsingleapplication.cpp
|
||||
- ../3rdparty/qtsingleapplication/qtsinglecoreapplication.cpp
|
||||
)
|
||||
|
||||
if (APPLE)
|
||||
@@ -166,17 +162,9 @@
|
||||
)
|
||||
endif()
|
||||
|
||||
-if(NOT WIN32)
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_unix.cpp)
|
||||
-else()
|
||||
- list(APPEND 3rdparty_SRC ../3rdparty/qtlockedfile/qtlockedfile_win.cpp )
|
||||
-endif()
|
||||
-
|
||||
set(3rdparty_INC
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/QProgressIndicator
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtlockedfile
|
||||
${CMAKE_SOURCE_DIR}/src/3rdparty/qtmacgoodies/src
|
||||
- ${CMAKE_SOURCE_DIR}/src/3rdparty/qtsingleapplication
|
||||
)
|
||||
|
||||
include_directories(${3rdparty_INC})
|
||||
@@ -303,6 +291,8 @@
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${QT_LIBRARIES} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${synclib_NAME} )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} updater )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_LockedFile-2.4 )
|
||||
+target_link_libraries( ${APPLICATION_EXECUTABLE} Qt5Solutions_SingleApplication-2.6 )
|
||||
target_link_libraries( ${APPLICATION_EXECUTABLE} ${OS_SPECIFIC_LINK_LIBRARIES} )
|
||||
|
||||
if(WITH_CRASHREPORTER)
|
@ -1 +1 @@
|
||||
SHA512 (desktop-2.5.1.tar.gz) = 04301f4b6283c4003ec4fed7926e11e2a627903a1b20e0b7cb4bb24b522e133d41001f48c633cad4fe3b100496d3a7826893b78074c2e3985a4c9c90122e3108
|
||||
SHA512 (desktop-2.5.2.tar.gz) = 1000b420355d7a4104ca5b41e813d467dcb345b60c79c78ce532de9c58ea89cad10d5565a433409bd512f0f7771c18c7c27974b968c74f84ccfda1ed3510d3ae
|
||||
|
Loading…
Reference in new issue