Updated syslibs patch and added comments in spec file, thanks to Robert-André Mauchin

f40
Germano Massullo 7 years ago
parent c487f0c386
commit d1f8979dc2

@ -13,15 +13,33 @@ diff -urNr owncloudclient-2.4.0-orig/src/3rdparty/qtsingleapplication/qtlocalpee
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.cpp owncloudclient-2.4.0/src/gui/application.cpp
--- owncloudclient-2.4.0-orig/src/gui/application.cpp 2017-12-20 18:42:11.000000000 +0100
+++ owncloudclient-2.4.0/src/gui/application.cpp 2018-02-13 22:25:51.846015381 +0100
@@ -95,7 +95,7 @@
@@ -95,7 +95,7 @@ namespace {
// ----------------------------------------------------------------------------------
Application::Application(int &argc, char **argv)
- : SharedTools::QtSingleApplication(Theme::instance()->appName(), argc, argv)
+ : QtSingleApplication(Theme::instance()->appName() ,argc, argv)
+ : QtSingleApplication(Theme::instance()->appName(), argc, argv)
, _gui(0)
, _theme(Theme::instance())
, _helpOnly(false)
@@ -150,7 +150,7 @@ Application::Application(int &argc, char **argv)
_folderManager.reset(new FolderMan);
- connect(this, &SharedTools::QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
+ connect(this, &QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
if (!AccountManager::instance()->restore()) {
// If there is an error reading the account settings, try again
@@ -363,7 +363,7 @@ void Application::slotUseMonoIconsChange
_gui->slotComputeOverallSyncStatus();
}
-void Application::slotParseMessage(const QString &msg, QObject *)
+void Application::slotParseMessage(const QString &msg)
{
if (msg.startsWith(QLatin1String("MSG_PARSEOPTIONS:"))) {
const int lengthOfMsgPrefix = 17;
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.h owncloudclient-2.4.0/src/gui/application.h
--- owncloudclient-2.4.0-orig/src/gui/application.h 2017-12-20 18:42:11.000000000 +0100
+++ owncloudclient-2.4.0/src/gui/application.h 2018-02-13 22:27:18.007583524 +0100
@ -43,6 +61,16 @@ diff -urNr owncloudclient-2.4.0-orig/src/gui/application.h owncloudclient-2.4.0/
{
Q_OBJECT
public:
@@ -85,7 +85,7 @@ signals:
void folderStateChanged(Folder *);
protected slots:
- void slotParseMessage(const QString &, QObject *);
+ void slotParseMessage(const QString &);
void slotCheckConnection();
void slotUseMonoIconsChanged(bool);
void slotCleanup();
diff -urNr owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt owncloudclient-2.4.0/src/gui/CMakeLists.txt
--- owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt 2017-12-20 18:42:11.000000000 +0100
+++ owncloudclient-2.4.0/src/gui/CMakeLists.txt 2018-02-13 22:29:10.917707151 +0100

@ -13,6 +13,13 @@ Url: https://nextcloud.com/install/#install-clients
Source0: https://github.com/nextcloud/client_theming/archive/v2.3.2.tar.gz
Source1: https://download.owncloud.com/desktop/stable/owncloudclient-%{version}.tar.xz
Source2: nextcloud.appdata.xml
# The patch does 3 things:
# - Depends on system lib for QtSingleApplication and QtLockedFile
# - Remove the extraneous namespace when calling QtSingleApplication
# - Fix a mismatch in the QtSingleApplication::messageReceived signal and the
# Application::slotParseMessage slot
# These fix are needed because the system wide QtSingleApplication is slightly
# different from the bundled one.
Patch0: %{name}-%{version}-syslibs.patch
## patch 1 solves https://bugzilla.redhat.com/show_bug.cgi?id=1409252
Patch1: %{name}-icon.patch
@ -236,6 +243,8 @@ fi
%changelog
* Tue Feb 13 2018 Germano Massullo <germano.massullo@gmail.com> - 2.4.0-1
- 2.4.0 release
- Updated syslibs patch, thanks to Robert-André Mauchin
- Added comment to syslibs patch, thanks to Robert-André Mauchin
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Loading…
Cancel
Save