|
|
|
@ -13,15 +13,33 @@ diff -urNr owncloudclient-2.4.0-orig/src/3rdparty/qtsingleapplication/qtlocalpee
|
|
|
|
|
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.cpp owncloudclient-2.4.0/src/gui/application.cpp
|
|
|
|
|
--- owncloudclient-2.4.0-orig/src/gui/application.cpp 2017-12-20 18:42:11.000000000 +0100
|
|
|
|
|
+++ owncloudclient-2.4.0/src/gui/application.cpp 2018-02-13 22:25:51.846015381 +0100
|
|
|
|
|
@@ -95,7 +95,7 @@
|
|
|
|
|
@@ -95,7 +95,7 @@ namespace {
|
|
|
|
|
// ----------------------------------------------------------------------------------
|
|
|
|
|
|
|
|
|
|
Application::Application(int &argc, char **argv)
|
|
|
|
|
- : SharedTools::QtSingleApplication(Theme::instance()->appName(), argc, argv)
|
|
|
|
|
+ : QtSingleApplication(Theme::instance()->appName() ,argc, argv)
|
|
|
|
|
+ : QtSingleApplication(Theme::instance()->appName(), argc, argv)
|
|
|
|
|
, _gui(0)
|
|
|
|
|
, _theme(Theme::instance())
|
|
|
|
|
, _helpOnly(false)
|
|
|
|
|
@@ -150,7 +150,7 @@ Application::Application(int &argc, char **argv)
|
|
|
|
|
|
|
|
|
|
_folderManager.reset(new FolderMan);
|
|
|
|
|
|
|
|
|
|
- connect(this, &SharedTools::QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
|
|
|
|
|
+ connect(this, &QtSingleApplication::messageReceived, this, &Application::slotParseMessage);
|
|
|
|
|
|
|
|
|
|
if (!AccountManager::instance()->restore()) {
|
|
|
|
|
// If there is an error reading the account settings, try again
|
|
|
|
|
@@ -363,7 +363,7 @@ void Application::slotUseMonoIconsChange
|
|
|
|
|
_gui->slotComputeOverallSyncStatus();
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
-void Application::slotParseMessage(const QString &msg, QObject *)
|
|
|
|
|
+void Application::slotParseMessage(const QString &msg)
|
|
|
|
|
{
|
|
|
|
|
if (msg.startsWith(QLatin1String("MSG_PARSEOPTIONS:"))) {
|
|
|
|
|
const int lengthOfMsgPrefix = 17;
|
|
|
|
|
diff -urNr owncloudclient-2.4.0-orig/src/gui/application.h owncloudclient-2.4.0/src/gui/application.h
|
|
|
|
|
--- owncloudclient-2.4.0-orig/src/gui/application.h 2017-12-20 18:42:11.000000000 +0100
|
|
|
|
|
+++ owncloudclient-2.4.0/src/gui/application.h 2018-02-13 22:27:18.007583524 +0100
|
|
|
|
@ -43,6 +61,16 @@ diff -urNr owncloudclient-2.4.0-orig/src/gui/application.h owncloudclient-2.4.0/
|
|
|
|
|
{
|
|
|
|
|
Q_OBJECT
|
|
|
|
|
public:
|
|
|
|
|
@@ -85,7 +85,7 @@ signals:
|
|
|
|
|
void folderStateChanged(Folder *);
|
|
|
|
|
|
|
|
|
|
protected slots:
|
|
|
|
|
- void slotParseMessage(const QString &, QObject *);
|
|
|
|
|
+ void slotParseMessage(const QString &);
|
|
|
|
|
void slotCheckConnection();
|
|
|
|
|
void slotUseMonoIconsChanged(bool);
|
|
|
|
|
void slotCleanup();
|
|
|
|
|
|
|
|
|
|
diff -urNr owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt owncloudclient-2.4.0/src/gui/CMakeLists.txt
|
|
|
|
|
--- owncloudclient-2.4.0-orig/src/gui/CMakeLists.txt 2017-12-20 18:42:11.000000000 +0100
|
|
|
|
|
+++ owncloudclient-2.4.0/src/gui/CMakeLists.txt 2018-02-13 22:29:10.917707151 +0100
|
|
|
|
|