Replace picpie patch with sed (fixes FTBFS)

f40
Mukundan Ragavan 4 years ago
parent d1da7faae7
commit 9af0022d32

@ -1,26 +0,0 @@
--- desktop-3.2.0-orig/src/gui/CMakeLists.txt 2021-04-08 18:54:35.506219040 -0400
+++ desktop-3.2.0/src/gui/CMakeLists.txt 2021-04-08 18:44:45.982858065 -0400
@@ -256,8 +256,8 @@
ecm_add_app_icon(final_src ICONS "${OWNCLOUD_ICONS}" SIDEBAR_ICONS "${OWNCLOUD_SIDEBAR_ICONS}" OUTFILE_BASENAME "${APPLICATION_ICON_NAME}")
if(UNIX AND NOT APPLE)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIE")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIE")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
endif()
--- desktop-3.2.0-orig/src/cmd/CMakeLists.txt 2021-04-08 18:40:13.902337507 -0400
+++ desktop-3.2.0/src/cmd/CMakeLists.txt 2021-04-08 18:41:51.291490488 -0400
@@ -17,8 +17,8 @@
target_include_directories(cmdCore PRIVATE ${CMAKE_SOURCE_DIR}/src/3rdparty/qtokenizer)
if(UNIX AND NOT APPLE)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIE")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIE")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
endif()

@ -4,7 +4,7 @@
Name: nextcloud-client
Version: 3.2.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: The Nextcloud Client
# -libs are LGPLv2+, rest GPLv2
@ -20,7 +20,6 @@ Source1: nextcloud.appdata.xml
# These fix are needed because the system wide QtSingleApplication is slightly
# different from the bundled one.
#Patch0: %%{name}-%%{version}-syslibs.patch
Patch1: nextcloud-client-picpie.patch
# Patch0: fixes GNOME quirks on Wayland sessions. Read
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/3BVLBS4B3XHJEXFVGD7RK2ZMXZG6JQZT/
Patch2: xcb.patch
@ -151,9 +150,11 @@ The nextcloud desktop client dolphin extension.
%prep
%setup -q -n desktop-%{version}
%patch1 -p1
%patch2 -p1
#rm -rf src/3rdparty/qtlockedfile src/3rdparty/qtsingleapplication
# change compiler flag
sed -i 's/-fPIE/-fPIC/g' src/gui/CMakeLists.txt
sed -i 's/-fPIE/-fPIC/g' src/cmd/CMakeLists.txt
%build
%cmake_kf5 \
@ -237,6 +238,9 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/appdata/nextcloud.
%endif
%changelog
* Mon May 03 2021 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 3.2.1-2
- Replace picpie patch with sed (fixes FTBFS)
* Sat May 01 2021 Germano Massullo <germano.massullo@gmail.com> - 3.2.1-1
- 3.2.1 release

Loading…
Cancel
Save