- Use -fPIC rather than -fPIE. Re-enable LTO.

f40
Jeff Law 4 years ago
parent 12f221e1db
commit 1d24e04008

@ -0,0 +1,30 @@
diff --git a/src/cmd/CMakeLists.txt b/src/cmd/CMakeLists.txt
index abb3620..5702702 100644
--- a/src/cmd/CMakeLists.txt
+++ b/src/cmd/CMakeLists.txt
@@ -10,8 +10,8 @@ set(cmd_SRC
if(UNIX AND NOT APPLE)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIE")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIE")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
endif()
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 2f1e99e..54a143c 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -250,8 +250,8 @@ endif()
ecm_add_app_icon(final_src ICONS "${OWNCLOUD_ICONS}" SIDEBAR_ICONS "${OWNCLOUD_SIDEBAR_ICONS}" OUTFILE_BASENAME "${APPLICATION_ICON_NAME}")
if(UNIX AND NOT APPLE)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIE")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIE")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
endif()

@ -1,11 +1,10 @@
%undefine __cmake_in_source_build
%undefine _cmake_skip_rpath
%define _lto_cflags %{nil}
%global _hardened_build 1
Name: nextcloud-client
Version: 3.0.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: The Nextcloud Client
# -libs are LGPLv2+, rest GPLv2
@ -21,6 +20,7 @@ Source1: nextcloud.appdata.xml
# These fix are needed because the system wide QtSingleApplication is slightly
# different from the bundled one.
#Patch0: %%{name}-%%{version}-syslibs.patch
Patch1: nextcloud-client-picpie.patch
BuildRequires: check
BuildRequires: chrpath
@ -145,6 +145,7 @@ The nextcloud desktop client dolphin extension.
%prep
%setup -q -n desktop-%{version}
%patch1 -p1
#rm -rf src/3rdparty/qtlockedfile src/3rdparty/qtsingleapplication
@ -231,6 +232,9 @@ test "$(chrpath --list %{buildroot}%{_bindir}/nextcloud)" = "%{buildroot}%{_bind
%endif
%changelog
* Fri Oct 02 2020 Jeff Law <law@redhat.com> - 3.0.2-2
- Use -fPIC rather than -fPIE. Re-enable LTO.
* Sat Sep 26 2020 Mukundan Ragavan <nonamedotc@fedoraproject.org> - 3.0.2-1
- Update to 3.0.2

Loading…
Cancel
Save