parent
b7f7c0ec11
commit
b00fa1d617
@ -1 +1,2 @@
|
||||
nautilus-python-0.7.0.tar.bz2
|
||||
/nautilus-python-1.0.tar.bz2
|
||||
|
@ -0,0 +1,23 @@
|
||||
From 58f061b6ecadb8f55f2e88a5fe6cce18113a3428 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Plumb <adamplumb@gmail.com>
|
||||
Date: Mon, 27 Jun 2011 12:50:41 -0500
|
||||
Subject: [PATCH 2/6] Fixes bug #652032 Update the pythondir variable in the
|
||||
nautilus-python.pc.in file.
|
||||
|
||||
---
|
||||
nautilus-python.pc.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/nautilus-python.pc.in b/nautilus-python.pc.in
|
||||
index f73fbb0..8a43f0e 100644
|
||||
--- a/nautilus-python.pc.in
|
||||
+++ b/nautilus-python.pc.in
|
||||
@@ -4,4 +4,4 @@ Version: @VERSION@
|
||||
|
||||
prefix=@prefix@
|
||||
libdir=${prefix}/lib
|
||||
-pythondir=@NAUTILUS_EXTENSION_DIR@/python
|
||||
+pythondir=@datadir@/nautilus-python/extensions
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -0,0 +1,24 @@
|
||||
From a76bba7ea9d1be82ae43cae2c1ea839a2708925d Mon Sep 17 00:00:00 2001
|
||||
From: Hicham HAOUARI <hicham.haouari@gmail.com>
|
||||
Date: Tue, 27 Sep 2011 18:02:46 +0000
|
||||
Subject: [PATCH 3/6] Fix html doc installation location
|
||||
|
||||
---
|
||||
docs/Makefile.am | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/docs/Makefile.am b/docs/Makefile.am
|
||||
index 12bd1a2..1f73cbc 100644
|
||||
--- a/docs/Makefile.am
|
||||
+++ b/docs/Makefile.am
|
||||
@@ -48,6 +48,7 @@ HTMLFILES = \
|
||||
html/nautilus-python-enum-reference.html \
|
||||
html/enum-nautilus-python-operation-result.html \
|
||||
html/nautilus-python.devhelp
|
||||
+HTML_DATA = $(HTMLFILES)
|
||||
|
||||
CSS_FILES = $(PYGOBJECT_PYGDOCS)/style.css
|
||||
CSSdir = $(HTMLdir)
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -0,0 +1,25 @@
|
||||
From 023e60f01d1c7b4f4e186308060b598e1473238f Mon Sep 17 00:00:00 2001
|
||||
From: Hicham HAOUARI <hicham.haouari@gmail.com>
|
||||
Date: Tue, 27 Sep 2011 18:05:38 +0000
|
||||
Subject: [PATCH 4/6] Fix underquoted macro warning
|
||||
|
||||
---
|
||||
m4/python.m4 | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/m4/python.m4 b/m4/python.m4
|
||||
index 18685f1..c61a0d3 100644
|
||||
--- a/m4/python.m4
|
||||
+++ b/m4/python.m4
|
||||
@@ -1,7 +1,7 @@
|
||||
## this one is commonly used with AM_PATH_PYTHONDIR ...
|
||||
dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
|
||||
dnl Check if a module containing a given symbol is visible to python.
|
||||
-AC_DEFUN(AM_CHECK_PYMOD,
|
||||
+AC_DEFUN([AM_CHECK_PYMOD],
|
||||
[AC_REQUIRE([AM_PATH_PYTHON])
|
||||
py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
|
||||
AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -0,0 +1,36 @@
|
||||
From 463aca8190dea99d321ea3faf38a2e330b546e50 Mon Sep 17 00:00:00 2001
|
||||
From: Hicham HAOUARI <hicham.haouari@gmail.com>
|
||||
Date: Tue, 27 Sep 2011 19:01:51 +0000
|
||||
Subject: [PATCH 5/6] Use autoconf's variable
|
||||
|
||||
---
|
||||
configure.in | 1 +
|
||||
examples/Makefile.am | 4 ++--
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 407b0c5..9ea04f9 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -1,3 +1,4 @@
|
||||
+AC_PREREQ(2.60)
|
||||
AC_INIT
|
||||
|
||||
PACKAGE=nautilus-python
|
||||
diff --git a/examples/Makefile.am b/examples/Makefile.am
|
||||
index 45e8909..b2a5903 100644
|
||||
--- a/examples/Makefile.am
|
||||
+++ b/examples/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
-docsdir = $(datadir)/doc/$(PACKAGE)
|
||||
+docsdir = $(docdir)
|
||||
docs_DATA = README
|
||||
|
||||
-examplesdir = $(datadir)/doc/$(PACKAGE)/examples
|
||||
+examplesdir = $(docdir)/examples
|
||||
examples_DATA = \
|
||||
background-image.py \
|
||||
block-size-column.py \
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -0,0 +1,22 @@
|
||||
From f7c12f909be2caf3235397f9178c594e5fdc76b1 Mon Sep 17 00:00:00 2001
|
||||
From: Hicham HAOUARI <hicham.haouari@gmail.com>
|
||||
Date: Tue, 27 Sep 2011 19:03:10 +0000
|
||||
Subject: [PATCH 6/6] Add '-I m4' to top Makefile.am
|
||||
|
||||
---
|
||||
Makefile.am | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 2afeb5f..144e7d2 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,3 +1,5 @@
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
+
|
||||
SUBDIRS = src examples
|
||||
|
||||
if ENABLE_GTK_DOC
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -0,0 +1,25 @@
|
||||
From f35a3f210999328e5fa7ee025271a53b13d7822e Mon Sep 17 00:00:00 2001
|
||||
From: Hicham HAOUARI <hicham.haouari@gmail.com>
|
||||
Date: Tue, 27 Sep 2011 20:36:33 +0000
|
||||
Subject: [PATCH 7/7] Fix fsf address
|
||||
|
||||
---
|
||||
src/nautilus-python.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/nautilus-python.c b/src/nautilus-python.c
|
||||
index 0e00285..1bcfc9f 100644
|
||||
--- a/src/nautilus-python.c
|
||||
+++ b/src/nautilus-python.c
|
||||
@@ -14,7 +14,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the Free Software
|
||||
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||
*/
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
--
|
||||
1.7.6.4
|
||||
|
@ -1,102 +0,0 @@
|
||||
diff -Naurp nautilus-python-0.5.1.orig/acinclude.m4 nautilus-python-0.5.1/acinclude.m4
|
||||
--- nautilus-python-0.5.1.orig/acinclude.m4 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ nautilus-python-0.5.1/acinclude.m4 2008-01-11 09:16:01.000000000 -0500
|
||||
@@ -0,0 +1,87 @@
|
||||
+## this one is commonly used with AM_PATH_PYTHONDIR ...
|
||||
+dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
|
||||
+dnl Check if a module containing a given symbol is visible to python.
|
||||
+AC_DEFUN(AM_CHECK_PYMOD,
|
||||
+[AC_REQUIRE([AM_PATH_PYTHON])
|
||||
+py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
|
||||
+AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
|
||||
+AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
|
||||
+ifelse([$2],[], [prog="
|
||||
+import sys
|
||||
+try:
|
||||
+ import $1
|
||||
+except ImportError:
|
||||
+ sys.exit(1)
|
||||
+except:
|
||||
+ sys.exit(0)
|
||||
+sys.exit(0)"], [prog="
|
||||
+import $1
|
||||
+$1.$2"])
|
||||
+if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
|
||||
+ then
|
||||
+ eval "py_cv_mod_$py_mod_var=yes"
|
||||
+ else
|
||||
+ eval "py_cv_mod_$py_mod_var=no"
|
||||
+ fi
|
||||
+])
|
||||
+py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
|
||||
+if test "x$py_val" != xno; then
|
||||
+ AC_MSG_RESULT(yes)
|
||||
+ ifelse([$3], [],, [$3
|
||||
+])dnl
|
||||
+else
|
||||
+ AC_MSG_RESULT(no)
|
||||
+ ifelse([$4], [],, [$4
|
||||
+])dnl
|
||||
+fi
|
||||
+])
|
||||
+
|
||||
+dnl a macro to check for ability to create python extensions
|
||||
+dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
|
||||
+dnl function also defines PYTHON_INCLUDES
|
||||
+AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
|
||||
+[AC_REQUIRE([AM_PATH_PYTHON])
|
||||
+AC_MSG_CHECKING(for headers required to compile python extensions)
|
||||
+dnl deduce PYTHON_INCLUDES
|
||||
+py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
|
||||
+py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
|
||||
+PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
|
||||
+if test "$py_prefix" != "$py_exec_prefix"; then
|
||||
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
|
||||
+fi
|
||||
+AC_SUBST(PYTHON_INCLUDES)
|
||||
+dnl check if the headers exist:
|
||||
+save_CPPFLAGS="$CPPFLAGS"
|
||||
+CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
|
||||
+AC_TRY_CPP([#include <Python.h>],dnl
|
||||
+[AC_MSG_RESULT(found)
|
||||
+$1],dnl
|
||||
+[AC_MSG_RESULT(not found)
|
||||
+$2])
|
||||
+CPPFLAGS="$save_CPPFLAGS"
|
||||
+])
|
||||
+
|
||||
+dnl a macro to check for ability to embed python
|
||||
+dnl AM_CHECK_PYTHON_LIBS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
|
||||
+dnl function also defines PYTHON_LIBS
|
||||
+AC_DEFUN([AM_CHECK_PYTHON_LIBS],
|
||||
+[AC_REQUIRE([AM_CHECK_PYTHON_HEADERS])
|
||||
+AC_MSG_CHECKING(for libraries required to embed python)
|
||||
+dnl deduce PYTHON_LIBS
|
||||
+py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
|
||||
+if test "x$PYTHON_LIBS" == x; then
|
||||
+ PYTHON_LIBS="-L${py_prefix}/lib -lpython${PYTHON_VERSION}"
|
||||
+fi
|
||||
+if test "x$PYTHON_LIB_LOC" == x; then
|
||||
+ PYTHON_LIB_LOC="${py_prefix}/lib"
|
||||
+fi
|
||||
+AC_SUBST(PYTHON_LIBS)
|
||||
+AC_SUBST(PYTHON_LIB_LOC)
|
||||
+dnl check if the headers exist:
|
||||
+save_LIBS="$LIBS"
|
||||
+LIBS="$LIBS $PYTHON_LIBS"
|
||||
+AC_TRY_LINK_FUNC(Py_Initialize, dnl
|
||||
+ [LIBS="$save_LIBS"; AC_MSG_RESULT(yes); $1], dnl
|
||||
+ [LIBS="$save_LIBS"; AC_MSG_RESULT(no); $2])
|
||||
+
|
||||
+])
|
||||
diff -Naurp nautilus-python-0.5.1.orig/configure.in nautilus-python-0.5.1/configure.in
|
||||
--- nautilus-python-0.5.1.orig/configure.in 2008-09-16 15:16:05.000000000 -0400
|
||||
+++ nautilus-python-0.5.1/configure.in 2008-12-09 14:41:32.000000000 -0500
|
||||
@@ -39,6 +39,7 @@ AM_CHECK_PYTHON_LIBS(,[AC_MSG_ERROR(coul
|
||||
PKG_CHECK_MODULES(NAUTILUS_PYTHON, [pygtk-2.0 >= $PYGTK_REQUIRED
|
||||
gnome-python-2.0 >= $GNOME_PYTHON_REQUIRED
|
||||
libnautilus-extension >= $NAUTILUS_REQUIRED
|
||||
+ gnome-vfs-2.0 >= $GNOME_PYTHON_REQUIRED
|
||||
eel-2.0 >= $EEL_REQUIRED])
|
||||
|
||||
AC_MSG_CHECKING(for pygtk defs)
|
Loading…
Reference in new issue