import mstflint-4.30.0-1.el10

i10cs changed/i10cs/mstflint-4.30.0-1.el10
MSVSphere Packaging Team 3 months ago
parent db8158d58d
commit 1e6e57ee2d
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/mstflint-4.26.0-1.tar.gz SOURCES/mstflint-4.30.0-1.tar.gz

@ -1 +1 @@
0ae1b90ef5c66a7d9e335b8bf4921ab20fd82f4a SOURCES/mstflint-4.26.0-1.tar.gz 9e7596c709156b4cda0f2e78fcdce64eda6be7c8 SOURCES/mstflint-4.30.0-1.tar.gz

@ -1,26 +0,0 @@
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
index 420b82f..0a20bcd 100644
--- a/flint/subcommands.cpp
+++ b/flint/subcommands.cpp
@@ -4484,7 +4484,7 @@ FlintStatus SgSubCommand::sgFs2()
return FLINT_SUCCESS;
}
-#define FW_RESET_MSG "To load new configuration run mlxfwreset or reboot machine"
+#define FW_RESET_MSG "To load new configuration run mstfwreset or reboot machine"
FlintStatus SgSubCommand::sgFs3()
{
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
index f3edc43..a85e43d 100644
--- a/mlxfwops/lib/flint_base.h
+++ b/mlxfwops/lib/flint_base.h
@@ -364,7 +364,7 @@ struct GPH {
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
#ifndef MST_UL
-#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mlxfwreset or reboot machine."
+#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mstfwreset or reboot machine."
#else
#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mstfwreset or reboot machine."
#endif

@ -2,7 +2,7 @@
## (rpmautospec version 0.6.5) ## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog ## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua: %define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 7; release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}")); base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1); print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}} }%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
@ -12,7 +12,7 @@
Name: mstflint Name: mstflint
Summary: Mellanox firmware burning tool Summary: Mellanox firmware burning tool
Version: 4.26.0 Version: 4.30.0
Release: %autorelease Release: %autorelease
# COPYING says the license is your choice of OpenIB.org BSD or GPLv2. # COPYING says the license is your choice of OpenIB.org BSD or GPLv2.
# kernel/Makefile has the 3-clause BSD. # kernel/Makefile has the 3-clause BSD.
@ -25,7 +25,6 @@ Group: Applications/System
Patch1: 0001-Fix-bind-now-test.patch Patch1: 0001-Fix-bind-now-test.patch
Patch4: add-default-link-flags-for-shared-libraries.patch Patch4: add-default-link-flags-for-shared-libraries.patch
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
BuildRequires: make BuildRequires: make
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
@ -47,7 +46,6 @@ for network adapters based on Mellanox Technologies chips.
%patch1 -p1 %patch1 -p1
%patch4 -p1 %patch4 -p1
%patch6 -p1
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';' find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';' find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';'
@ -75,12 +73,16 @@ chmod +x %{buildroot}/%{_libdir}/mstflint/sdk/*.so
%doc README %doc README
%_bindir/* %_bindir/*
%{_libdir}/mstflint %{_libdir}/mstflint
%{_libdir}/libmtcr_ul.a
%{_datadir}/mstflint %{_datadir}/mstflint
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
## START: Generated by rpmautospec ## START: Generated by rpmautospec
* Mon Nov 18 2024 Kamal Heib <kheib@redhat.com> - 4.30.0-1
- Update to upstream release 4.30.0
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 4.26.0-7 * Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 4.26.0-7
- Bump release for October 2024 mass rebuild: - Bump release for October 2024 mass rebuild:

Loading…
Cancel
Save