|
|
|
@ -1,17 +1,16 @@
|
|
|
|
|
diff -up mplayer-export-2011-04-12/configure.ffmpeg mplayer-export-2011-04-12/configure
|
|
|
|
|
--- mplayer-export-2011-04-12/configure.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/configure 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
@@ -6888,7 +6888,8 @@ elif test "$ffmpeg_so" = auto ; then
|
|
|
|
|
diff -up mplayer-export-2011-08-16/configure.ffmpeg mplayer-export-2011-08-16/configure
|
|
|
|
|
--- mplayer-export-2011-08-16/configure.ffmpeg 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-08-16/configure 2011-08-16 21:56:38.000000000 +0200
|
|
|
|
|
@@ -6792,7 +6792,7 @@ elif test "$ffmpeg_so" = auto ; then
|
|
|
|
|
inc_ffmpeg=$($_pkg_config --cflags libpostproc libswscale libavformat libavcodec libavutil)
|
|
|
|
|
_ld_tmp=$($_pkg_config --libs libpostproc libswscale libavformat libavcodec libavutil)
|
|
|
|
|
header_check libavutil/avutil.h $inc_ffmpeg $_ld_tmp &&
|
|
|
|
|
- extra_ldflags="$extra_ldflags $_ld_tmp" && ffmpeg_so=yes && ffmpeg=yes
|
|
|
|
|
+ extra_ldflags="$extra_ldflags $_ld_tmp" && ffmpeg_so=yes && ffmpeg=yes &&
|
|
|
|
|
+ extra_cflags="$extra_cflags $inc_ffmpeg"
|
|
|
|
|
elif header_check libavutil/avutil.h -lpostproc -lswscale -lavformat -lavcodec -lavutil $_ld_lm ; then
|
|
|
|
|
ld_tmp=$($_pkg_config --libs libpostproc libswscale libavformat libavcodec libavutil)
|
|
|
|
|
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
|
|
|
|
|
- extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes
|
|
|
|
|
+ extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes && extra_cflags="$extra_cflags $inc_ffmpeg"
|
|
|
|
|
elif header_check libavutil/avutil.h -lpostproc -lswscale -lavformat -lavcodec -lavutil ; then
|
|
|
|
|
extra_ldflags="$extra_ldflags -lpostproc -lswscale -lavformat -lavcodec -lavutil"
|
|
|
|
|
ffmpeg_so=yes
|
|
|
|
|
@@ -7593,7 +7594,7 @@ if test "$_gui" = yes ; then
|
|
|
|
|
@@ -7481,7 +7481,7 @@ if test "$_gui" = yes ; then
|
|
|
|
|
|
|
|
|
|
# Required libraries
|
|
|
|
|
if test "$ffmpeg" != yes ||
|
|
|
|
@ -20,9 +19,9 @@ diff -up mplayer-export-2011-04-12/configure.ffmpeg mplayer-export-2011-04-12/co
|
|
|
|
|
die "The GUI requires libavcodec with PNG support (needs zlib)."
|
|
|
|
|
fi
|
|
|
|
|
test "$_freetype" = no && test "$_bitmap_font" = no &&
|
|
|
|
|
diff -up mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h
|
|
|
|
|
--- mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
diff -up mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h.ffmpeg mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h
|
|
|
|
|
--- mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h.ffmpeg 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,41 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * RIFF codec tags
|
|
|
|
@ -65,120 +64,9 @@ diff -up mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg mplayer-expo
|
|
|
|
|
+extern const AVCodecTag ff_codec_wav_tags[];
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVFORMAT_RIFF_H */
|
|
|
|
|
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h
|
|
|
|
|
--- mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,47 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * copyright (c) 2007 Michael Niedermayer <michaelni@gmx.at>
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is part of FFmpeg.
|
|
|
|
|
+ *
|
|
|
|
|
+ * FFmpeg is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU Lesser General Public
|
|
|
|
|
+ * License as published by the Free Software Foundation; either
|
|
|
|
|
+ * version 2.1 of the License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * FFmpeg is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
|
|
|
+ * Lesser General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * You should have received a copy of the GNU Lesser General Public
|
|
|
|
|
+ * License along with FFmpeg; if not, write to the Free Software
|
|
|
|
|
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#ifndef AVUTIL_AES_H
|
|
|
|
|
+#define AVUTIL_AES_H
|
|
|
|
|
+
|
|
|
|
|
+#include <stdint.h>
|
|
|
|
|
+
|
|
|
|
|
+extern const int av_aes_size;
|
|
|
|
|
+
|
|
|
|
|
+struct AVAES;
|
|
|
|
|
+
|
|
|
|
|
+/**
|
|
|
|
|
+ * Initialize an AVAES context.
|
|
|
|
|
+ * @param key_bits 128, 192 or 256
|
|
|
|
|
+ * @param decrypt 0 for encryption, 1 for decryption
|
|
|
|
|
+ */
|
|
|
|
|
+int av_aes_init(struct AVAES *a, const uint8_t *key, int key_bits, int decrypt);
|
|
|
|
|
+
|
|
|
|
|
+/**
|
|
|
|
|
+ * Encrypt or decrypt a buffer using a previously initialized context.
|
|
|
|
|
+ * @param count number of 16 byte blocks
|
|
|
|
|
+ * @param dst destination array, can be equal to src
|
|
|
|
|
+ * @param src source array, can be equal to dst
|
|
|
|
|
+ * @param iv initialization vector for CBC mode, if NULL then ECB will be used
|
|
|
|
|
+ * @param decrypt 0 for encryption, 1 for decryption
|
|
|
|
|
+ */
|
|
|
|
|
+void av_aes_crypt(struct AVAES *a, uint8_t *dst, const uint8_t *src, int count, uint8_t *iv, int decrypt);
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVUTIL_AES_H */
|
|
|
|
|
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h
|
|
|
|
|
--- mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,56 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * Copyright (C) 2007 Michael Niedermayer <michaelni@gmx.at>
|
|
|
|
|
+ *
|
|
|
|
|
+ * This file is part of FFmpeg.
|
|
|
|
|
+ *
|
|
|
|
|
+ * FFmpeg is free software; you can redistribute it and/or
|
|
|
|
|
+ * modify it under the terms of the GNU Lesser General Public
|
|
|
|
|
+ * License as published by the Free Software Foundation; either
|
|
|
|
|
+ * version 2.1 of the License, or (at your option) any later version.
|
|
|
|
|
+ *
|
|
|
|
|
+ * FFmpeg is distributed in the hope that it will be useful,
|
|
|
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
|
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
|
|
|
+ * Lesser General Public License for more details.
|
|
|
|
|
+ *
|
|
|
|
|
+ * You should have received a copy of the GNU Lesser General Public
|
|
|
|
|
+ * License along with FFmpeg; if not, write to the Free Software
|
|
|
|
|
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
|
|
|
|
+ */
|
|
|
|
|
+
|
|
|
|
|
+#ifndef AVUTIL_SHA_H
|
|
|
|
|
+#define AVUTIL_SHA_H
|
|
|
|
|
+
|
|
|
|
|
+#include <stdint.h>
|
|
|
|
|
+
|
|
|
|
|
+extern const int av_sha_size;
|
|
|
|
|
+
|
|
|
|
|
+struct AVSHA;
|
|
|
|
|
+
|
|
|
|
|
+/**
|
|
|
|
|
+ * Initialize SHA-1 or SHA-2 hashing.
|
|
|
|
|
+ *
|
|
|
|
|
+ * @param context pointer to the function context (of size av_sha_size)
|
|
|
|
|
+ * @param bits number of bits in digest (SHA-1 - 160 bits, SHA-2 224 or 256 bits)
|
|
|
|
|
+ * @return zero if initialization succeeded, -1 otherwise
|
|
|
|
|
+ */
|
|
|
|
|
+int av_sha_init(struct AVSHA* context, int bits);
|
|
|
|
|
+
|
|
|
|
|
+/**
|
|
|
|
|
+ * Update hash value.
|
|
|
|
|
+ *
|
|
|
|
|
+ * @param context hash function context
|
|
|
|
|
+ * @param data input data to update hash with
|
|
|
|
|
+ * @param len input data length
|
|
|
|
|
+ */
|
|
|
|
|
+void av_sha_update(struct AVSHA* context, const uint8_t* data, unsigned int len);
|
|
|
|
|
+
|
|
|
|
|
+/**
|
|
|
|
|
+ * Finish hashing and output digest value.
|
|
|
|
|
+ *
|
|
|
|
|
+ * @param context hash function context
|
|
|
|
|
+ * @param digest buffer where output digest value is stored
|
|
|
|
|
+ */
|
|
|
|
|
+void av_sha_final(struct AVSHA* context, uint8_t *digest);
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVUTIL_SHA_H */
|
|
|
|
|
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h
|
|
|
|
|
--- mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
diff -up mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h
|
|
|
|
|
--- mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
@@ -0,0 +1,98 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
|
|
|
|
@ -278,10 +166,10 @@ diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-exp
|
|
|
|
|
+#endif
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVUTIL_X86_CPU_H */
|
|
|
|
|
diff -up mplayer-export-2011-04-12/Makefile.ffmpeg mplayer-export-2011-04-12/Makefile
|
|
|
|
|
--- mplayer-export-2011-04-12/Makefile.ffmpeg 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-04-12/Makefile 2011-04-12 17:18:33.000000000 +0200
|
|
|
|
|
@@ -809,7 +809,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
|
|
|
|
|
diff -up mplayer-export-2011-08-16/Makefile.ffmpeg mplayer-export-2011-08-16/Makefile
|
|
|
|
|
--- mplayer-export-2011-08-16/Makefile.ffmpeg 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
+++ mplayer-export-2011-08-16/Makefile 2011-08-16 21:55:01.000000000 +0200
|
|
|
|
|
@@ -779,7 +779,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
|
|
|
|
|
$(CC) -o $@ $^ $(EXTRALIBS)
|
|
|
|
|
|
|
|
|
|
codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
|
|
|
|
|