* Fri Sep 23 2011 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.126.20110816svn

- 20110816 snapshot
- drop obsolete pause crash patch
- re-enable mp3lib decoder
- enable libmpg123 decoder
el8
Dominik Mierzejewski 13 years ago
parent 4118a4d1b6
commit b773743a3c

1
.gitignore vendored

@ -3,3 +3,4 @@ mplayer-export-2011-01-10.tar.bz2
mplayer-export-2011-02-27.tar.bz2
mplayer-export-2011-04-04.tar.bz2
mplayer-export-2011-04-12.tar.bz2
mplayer-export-2011-08-16.tar.bz2

@ -1,17 +1,16 @@
diff -up mplayer-export-2011-04-12/configure.ffmpeg mplayer-export-2011-04-12/configure
--- mplayer-export-2011-04-12/configure.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/configure 2011-04-12 17:18:33.000000000 +0200
@@ -6888,7 +6888,8 @@ elif test "$ffmpeg_so" = auto ; then
diff -up mplayer-export-2011-08-16/configure.ffmpeg mplayer-export-2011-08-16/configure
--- mplayer-export-2011-08-16/configure.ffmpeg 2011-08-16 21:55:01.000000000 +0200
+++ mplayer-export-2011-08-16/configure 2011-08-16 21:56:38.000000000 +0200
@@ -6792,7 +6792,7 @@ elif test "$ffmpeg_so" = auto ; then
inc_ffmpeg=$($_pkg_config --cflags libpostproc libswscale libavformat libavcodec libavutil)
_ld_tmp=$($_pkg_config --libs libpostproc libswscale libavformat libavcodec libavutil)
header_check libavutil/avutil.h $inc_ffmpeg $_ld_tmp &&
- extra_ldflags="$extra_ldflags $_ld_tmp" && ffmpeg_so=yes && ffmpeg=yes
+ extra_ldflags="$extra_ldflags $_ld_tmp" && ffmpeg_so=yes && ffmpeg=yes &&
+ extra_cflags="$extra_cflags $inc_ffmpeg"
elif header_check libavutil/avutil.h -lpostproc -lswscale -lavformat -lavcodec -lavutil $_ld_lm ; then
ld_tmp=$($_pkg_config --libs libpostproc libswscale libavformat libavcodec libavutil)
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
- extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes
+ extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes && extra_cflags="$extra_cflags $inc_ffmpeg"
elif header_check libavutil/avutil.h -lpostproc -lswscale -lavformat -lavcodec -lavutil ; then
extra_ldflags="$extra_ldflags -lpostproc -lswscale -lavformat -lavcodec -lavutil"
ffmpeg_so=yes
@@ -7593,7 +7594,7 @@ if test "$_gui" = yes ; then
@@ -7481,7 +7481,7 @@ if test "$_gui" = yes ; then
# Required libraries
if test "$ffmpeg" != yes ||
@ -20,9 +19,9 @@ diff -up mplayer-export-2011-04-12/configure.ffmpeg mplayer-export-2011-04-12/co
die "The GUI requires libavcodec with PNG support (needs zlib)."
fi
test "$_freetype" = no && test "$_bitmap_font" = no &&
diff -up mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h
--- mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h 2011-04-12 17:18:33.000000000 +0200
diff -up mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h.ffmpeg mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h
--- mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h.ffmpeg 2011-08-16 21:55:01.000000000 +0200
+++ mplayer-export-2011-08-16/ffmpeg/libavformat/riff.h 2011-08-16 21:55:01.000000000 +0200
@@ -0,0 +1,41 @@
+/*
+ * RIFF codec tags
@ -65,120 +64,9 @@ diff -up mplayer-export-2011-04-12/ffmpeg/libavformat/riff.h.ffmpeg mplayer-expo
+extern const AVCodecTag ff_codec_wav_tags[];
+
+#endif /* AVFORMAT_RIFF_H */
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h
--- mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/aes.h 2011-04-12 17:18:33.000000000 +0200
@@ -0,0 +1,47 @@
+/*
+ * copyright (c) 2007 Michael Niedermayer <michaelni@gmx.at>
+ *
+ * This file is part of FFmpeg.
+ *
+ * FFmpeg is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * FFmpeg is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with FFmpeg; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#ifndef AVUTIL_AES_H
+#define AVUTIL_AES_H
+
+#include <stdint.h>
+
+extern const int av_aes_size;
+
+struct AVAES;
+
+/**
+ * Initialize an AVAES context.
+ * @param key_bits 128, 192 or 256
+ * @param decrypt 0 for encryption, 1 for decryption
+ */
+int av_aes_init(struct AVAES *a, const uint8_t *key, int key_bits, int decrypt);
+
+/**
+ * Encrypt or decrypt a buffer using a previously initialized context.
+ * @param count number of 16 byte blocks
+ * @param dst destination array, can be equal to src
+ * @param src source array, can be equal to dst
+ * @param iv initialization vector for CBC mode, if NULL then ECB will be used
+ * @param decrypt 0 for encryption, 1 for decryption
+ */
+void av_aes_crypt(struct AVAES *a, uint8_t *dst, const uint8_t *src, int count, uint8_t *iv, int decrypt);
+
+#endif /* AVUTIL_AES_H */
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h
--- mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/sha.h 2011-04-12 17:18:33.000000000 +0200
@@ -0,0 +1,56 @@
+/*
+ * Copyright (C) 2007 Michael Niedermayer <michaelni@gmx.at>
+ *
+ * This file is part of FFmpeg.
+ *
+ * FFmpeg is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * FFmpeg is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with FFmpeg; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+#ifndef AVUTIL_SHA_H
+#define AVUTIL_SHA_H
+
+#include <stdint.h>
+
+extern const int av_sha_size;
+
+struct AVSHA;
+
+/**
+ * Initialize SHA-1 or SHA-2 hashing.
+ *
+ * @param context pointer to the function context (of size av_sha_size)
+ * @param bits number of bits in digest (SHA-1 - 160 bits, SHA-2 224 or 256 bits)
+ * @return zero if initialization succeeded, -1 otherwise
+ */
+int av_sha_init(struct AVSHA* context, int bits);
+
+/**
+ * Update hash value.
+ *
+ * @param context hash function context
+ * @param data input data to update hash with
+ * @param len input data length
+ */
+void av_sha_update(struct AVSHA* context, const uint8_t* data, unsigned int len);
+
+/**
+ * Finish hashing and output digest value.
+ *
+ * @param context hash function context
+ * @param digest buffer where output digest value is stored
+ */
+void av_sha_final(struct AVSHA* context, uint8_t *digest);
+
+#endif /* AVUTIL_SHA_H */
diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h
--- mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h 2011-04-12 17:18:33.000000000 +0200
diff -up mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h
--- mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2011-08-16 21:55:01.000000000 +0200
+++ mplayer-export-2011-08-16/ffmpeg/libavutil/x86_cpu.h 2011-08-16 21:55:01.000000000 +0200
@@ -0,0 +1,98 @@
+/*
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
@ -278,10 +166,10 @@ diff -up mplayer-export-2011-04-12/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-exp
+#endif
+
+#endif /* AVUTIL_X86_CPU_H */
diff -up mplayer-export-2011-04-12/Makefile.ffmpeg mplayer-export-2011-04-12/Makefile
--- mplayer-export-2011-04-12/Makefile.ffmpeg 2011-04-12 17:18:33.000000000 +0200
+++ mplayer-export-2011-04-12/Makefile 2011-04-12 17:18:33.000000000 +0200
@@ -809,7 +809,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
diff -up mplayer-export-2011-08-16/Makefile.ffmpeg mplayer-export-2011-08-16/Makefile
--- mplayer-export-2011-08-16/Makefile.ffmpeg 2011-08-16 21:55:01.000000000 +0200
+++ mplayer-export-2011-08-16/Makefile 2011-08-16 21:55:01.000000000 +0200
@@ -779,7 +779,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
$(CC) -o $@ $^ $(EXTRALIBS)
codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h

@ -1,7 +1,7 @@
diff -up mplayer-export-2011-01-10/configure.nodvdcss mplayer-export-2011-01-10/configure
--- mplayer-export-2011-01-10/configure.nodvdcss 2011-01-06 13:42:59.000000000 +0100
+++ mplayer-export-2011-01-10/configure 2011-01-10 19:02:59.000000000 +0100
@@ -689,7 +689,7 @@ _dvdnavconfig=dvdnav-config
diff -up mplayer-export-2011-08-16/configure.nodvdcss mplayer-export-2011-08-16/configure
--- mplayer-export-2011-08-16/configure.nodvdcss 2011-08-11 19:45:43.000000000 +0200
+++ mplayer-export-2011-08-16/configure 2011-08-16 21:53:23.000000000 +0200
@@ -731,7 +731,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
@ -10,10 +10,10 @@ diff -up mplayer-export-2011-01-10/configure.nodvdcss mplayer-export-2011-01-10/
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2011-01-10/Makefile.nodvdcss mplayer-export-2011-01-10/Makefile
--- mplayer-export-2011-01-10/Makefile.nodvdcss 2011-01-10 19:02:59.000000000 +0100
+++ mplayer-export-2011-01-10/Makefile 2011-01-10 19:03:25.000000000 +0100
@@ -111,11 +111,6 @@ SRCS_COMMON-$(LIBDCA) +=
diff -up mplayer-export-2011-08-16/Makefile.nodvdcss mplayer-export-2011-08-16/Makefile
--- mplayer-export-2011-08-16/Makefile.nodvdcss 2011-08-16 21:53:23.000000000 +0200
+++ mplayer-export-2011-08-16/Makefile 2011-08-16 21:53:55.000000000 +0200
@@ -112,11 +112,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
libmpdemux/demux_rawdv.c
@ -25,15 +25,15 @@ diff -up mplayer-export-2011-01-10/Makefile.nodvdcss mplayer-export-2011-01-10/M
SRCS_COMMON-$(LIBMAD) += libmpcodecs/ad_libmad.c
@@ -742,7 +737,6 @@ DIRS = . \
libaf \
libao2 \
@@ -741,7 +736,6 @@ DIRS = . \
ALL_DIRS = $(DIRS) \
libass \
- libdvdcss \
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -858,7 +852,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
@@ -830,7 +824,6 @@ osdep/mplayer-rc.o: osdep/mplayer.exe.ma
gui/%: CFLAGS += -Wno-strict-prototypes

@ -1,23 +0,0 @@
commit b2dce9463216e55484918caa553604b44dfd3f11
Author: reimar <reimar@b3059339-0415-0410-9bf9-f77b7e298cf2>
Date: Fri Apr 15 20:41:40 2011 +0000
Avoid crash when pausing an audio-only file.
git-svn-id: svn://git.mplayerhq.hu/mplayer/trunk@33268 b3059339-0415-0410-9bf9-f77b7e298cf2
diff --git a/mplayer.c b/mplayer.c
index 22d3baf..c946b4a 100644
--- a/mplayer.c
+++ b/mplayer.c
@@ -2539,7 +2539,8 @@ static void pause_loop(void)
}
}
#endif
- handle_udp_master(mpctx->sh_video->pts);
+ if (mpctx->sh_video)
+ handle_udp_master(mpctx->sh_video->pts);
usec_sleep(20000);
}
if (cmd && cmd->id == MP_CMD_PAUSE) {

@ -1,12 +1,12 @@
%define codecdir %{_libdir}/codecs
%define pre 20110412svn
%define pre 20110816svn
%define svn 1
%define svnbuild 2011-04-12
%define svnbuild 2011-08-16
%define faad2min 1:2.6.1
Name: mplayer
Version: 1.0
Release: 0.125.%{pre}%{?dist}
Release: 0.126.%{pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
Group: Applications/Multimedia
@ -32,8 +32,6 @@ Patch8: %{name}-manlinks.patch
Patch14: %{name}-nodvdcss.patch
# use system FFmpeg libraries
Patch18: %{name}-ffmpeg.patch
# Upstream fix for http://bugzilla.mplayerhq.hu/show_bug.cgi?id=1904
Patch19: %{name}-pause.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: SDL-devel
@ -46,7 +44,7 @@ BuildRequires: desktop-file-utils
BuildRequires: em8300-devel
BuildRequires: enca-devel
BuildRequires: faad2-devel >= %{faad2min}
BuildRequires: ffmpeg-devel >= 0.6.90-0.1.rc0
BuildRequires: ffmpeg-devel >= 0.7.3
BuildRequires: fontconfig-devel
BuildRequires: freetype-devel >= 2.0.9
BuildRequires: fribidi-devel
@ -70,6 +68,7 @@ BuildRequires: libdvdnav-devel >= 4.1.3-1
BuildRequires: libjpeg-devel
BuildRequires: libmpcdec-devel
BuildRequires: libmpeg2-devel
BuildRequires: libmpg123-devel
BuildRequires: librtmp-devel
BuildRequires: libtheora-devel
BuildRequires: libvdpau-devel
@ -184,7 +183,6 @@ This package contains various scripts from MPlayer TOOLS directory.
--language=all \\\
\\\
--enable-joystick \\\
--enable-largefiles \\\
--enable-lirc \\\
--enable-menu \\\
--enable-radio \\\
@ -219,7 +217,6 @@ This package contains various scripts from MPlayer TOOLS directory.
%{!?_with_esound:--disable-esd} \\\
%{!?_with_jack:--disable-jack} \\\
%{!?_with_openal:--disable-openal} \\\
--disable-mp3lib \\\
%prep
@ -232,7 +229,6 @@ This package contains various scripts from MPlayer TOOLS directory.
%patch8 -p1 -b .manlinks
%patch14 -p1 -b .nodvdcss
%patch18 -p1 -b .ffmpeg
%patch19 -p1 -b .pause
doconv() {
iconv -f $1 -t $2 -o DOCS/man/$3/mplayer.1.utf8 DOCS/man/$3/mplayer.1 && \
@ -304,9 +300,9 @@ tar xjC $RPM_BUILD_ROOT%{_datadir}/mplayer/skins --exclude=.svn -f %{SOURCE1}
ln -s Blue $RPM_BUILD_ROOT%{_datadir}/mplayer/skins/default
# Icons
install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
install -pm 644 etc/mplayer.xpm \
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
install -pm 644 etc/mplayer.png \
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
# Desktop file
desktop-file-install \
@ -360,7 +356,7 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-, root, root, -)
%{_bindir}/gmplayer
%{_datadir}/applications/*mplayer.desktop
%{_datadir}/icons/hicolor/32x32/apps/mplayer.xpm
%{_datadir}/icons/hicolor/48x48/apps/mplayer.png
%{_datadir}/mplayer/skins/
%files -n mencoder
@ -405,6 +401,12 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/mplayer/*.fp
%changelog
* Fri Sep 23 2011 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.126.20110816svn
- 20110816 snapshot
- drop obsolete pause crash patch
- re-enable mp3lib decoder
- enable libmpg123 decoder
* Fri Jul 15 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.0-0.125.20110412svn
- Rebuilt for x264 ABI 115

@ -1,2 +1,2 @@
e4e2020d11b681aac898103b3ba723c4 Blue-1.7.tar.bz2
8d56ef3c6200b81e1b9b6824afb2fba2 mplayer-export-2011-04-12.tar.bz2
a63483caa8a603ccefbb8e29bf94b4c7 mplayer-export-2011-08-16.tar.bz2

Loading…
Cancel
Save