* Thu Jun 14 2012 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-1

- Updated to 1.1
- Made %pre, %svn and %svnbuild defines optional
- Switched to .xz sources
- Updated the ffmpeg patch
el8
Julian Sikorski 13 years ago
parent 42b0176c2e
commit 9b26a272d4

2
.gitignore vendored

@ -1,2 +1,2 @@
Blue-1.8.tar.bz2
mplayer-export-2012-02-05.tar.bz2
MPlayer-1.1.tar.xz

@ -1,16 +1,16 @@
diff -up mplayer-export-2012-02-05/configure.ffmpeg mplayer-export-2012-02-05/configure
--- mplayer-export-2012-02-05/configure.ffmpeg 2012-03-12 00:18:05.000000000 +0100
+++ mplayer-export-2012-02-05/configure 2012-03-12 00:18:05.000000000 +0100
@@ -6718,7 +6718,7 @@ elif test "$ffmpeg_so" = auto ; then
inc_ffmpeg=$($_pkg_config --cflags libpostproc libswscale libavformat libavcodec libavutil)
ld_tmp=$($_pkg_config --libs libpostproc libswscale libavformat libavcodec libavutil)
diff -up MPlayer-1.1/configure.ffmpeg MPlayer-1.1/configure
--- MPlayer-1.1/configure.ffmpeg 2012-06-12 19:54:45.573647100 +0200
+++ MPlayer-1.1/configure 2012-06-12 19:55:00.444732663 +0200
@@ -6755,7 +6755,7 @@ elif test "$ffmpeg_so" = auto ; then
inc_ffmpeg=$($_pkg_config --cflags libswscale libavformat libavcodec libavutil)
ld_tmp=$($_pkg_config --libs libswscale libavformat libavcodec libavutil)
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
- extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes
+ extra_ldflags="$extra_ldflags $ld_tmp" && ffmpeg_so=yes && ffmpeg=yes && extra_cflags="$extra_cflags $inc_ffmpeg"
elif header_check libavutil/avutil.h -lpostproc -lswscale -lavformat -lavcodec -lavutil ; then
extra_ldflags="$extra_ldflags -lpostproc -lswscale -lavformat -lavcodec -lavutil"
elif header_check libavutil/avutil.h -lswscale -lavformat -lavcodec -lavutil ; then
extra_ldflags="$extra_ldflags -lswscale -lavformat -lavcodec -lavutil"
ffmpeg_so=yes
@@ -7407,7 +7407,7 @@ if test "$_gui" = yes ; then
@@ -7464,7 +7464,7 @@ if test "$_gui" = yes ; then
# Required libraries
if test "$ffmpeg" != yes ||
@ -19,9 +19,9 @@ diff -up mplayer-export-2012-02-05/configure.ffmpeg mplayer-export-2012-02-05/co
die "The GUI requires libavcodec with PNG support (needs zlib)."
fi
test "$_freetype" = no && test "$_bitmap_font" = no &&
diff -up mplayer-export-2012-02-05/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2012-02-05/ffmpeg/libavformat/internal.h
--- mplayer-export-2012-02-05/ffmpeg/libavformat/internal.h.ffmpeg 2012-03-12 00:20:43.000000000 +0100
+++ mplayer-export-2012-02-05/ffmpeg/libavformat/internal.h 2012-03-12 00:23:13.000000000 +0100
diff -up MPlayer-1.1/ffmpeg/libavformat/internal.h.ffmpeg MPlayer-1.1/ffmpeg/libavformat/internal.h
--- MPlayer-1.1/ffmpeg/libavformat/internal.h.ffmpeg 2012-06-12 19:54:45.578647128 +0200
+++ MPlayer-1.1/ffmpeg/libavformat/internal.h 2012-06-12 19:54:45.578647128 +0200
@@ -0,0 +1,32 @@
+/*
+ * copyright (c) 2001 Fabrice Bellard
@ -55,9 +55,9 @@ diff -up mplayer-export-2012-02-05/ffmpeg/libavformat/internal.h.ffmpeg mplayer-
+} AVCodecTag;
+
+#endif /* AVFORMAT_INTERNAL_H */
diff -up mplayer-export-2012-02-05/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-export-2012-02-05/ffmpeg/libavutil/x86_cpu.h
--- mplayer-export-2012-02-05/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2012-03-12 00:18:05.000000000 +0100
+++ mplayer-export-2012-02-05/ffmpeg/libavutil/x86_cpu.h 2012-03-12 00:18:05.000000000 +0100
diff -up MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h
--- MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h.ffmpeg 2012-06-12 19:54:45.615647342 +0200
+++ MPlayer-1.1/ffmpeg/libavutil/x86_cpu.h 2012-06-12 19:54:45.615647342 +0200
@@ -0,0 +1,98 @@
+/*
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
@ -157,10 +157,10 @@ diff -up mplayer-export-2012-02-05/ffmpeg/libavutil/x86_cpu.h.ffmpeg mplayer-exp
+#endif
+
+#endif /* AVUTIL_X86_CPU_H */
diff -up mplayer-export-2012-02-05/Makefile.ffmpeg mplayer-export-2012-02-05/Makefile
--- mplayer-export-2012-02-05/Makefile.ffmpeg 2012-03-12 00:18:05.000000000 +0100
+++ mplayer-export-2012-02-05/Makefile 2012-03-12 00:18:05.000000000 +0100
@@ -787,7 +787,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
diff -up MPlayer-1.1/Makefile.ffmpeg MPlayer-1.1/Makefile
--- MPlayer-1.1/Makefile.ffmpeg 2012-06-12 19:54:45.573647100 +0200
+++ MPlayer-1.1/Makefile 2012-06-12 19:54:45.616647347 +0200
@@ -788,7 +788,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
$(CC) -o $@ $^ $(EXTRALIBS)
codec-cfg$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h

@ -1,12 +1,12 @@
%define codecdir %{_libdir}/codecs
%define pre 20120205svn
%define svn 1
%define svnbuild 2012-02-05
#define pre 20120205svn
#define svn 1
#define svnbuild 2012-02-05
%define faad2min 1:2.6.1
Name: mplayer
Version: 1.0
Release: 0.139.%{pre}%{?dist}
Version: 1.1
Release: 1%{?pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
%if 0%{!?_without_amr:1}
@ -15,11 +15,11 @@ License: GPLv3+
License: GPLv2+
%endif
URL: http://www.mplayerhq.hu/
%if %{svn}
%if 0%{?svn}
# run ./mplayer-snapshot.sh to get this
Source0: mplayer-export-%{svnbuild}.tar.bz2
%else
Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{pre}.tar.bz2
Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{?pre}.tar.xz
%endif
Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
Source10: mplayer-snapshot.sh
@ -94,7 +94,7 @@ BuildRequires: yasm
%{?_with_samba:BuildRequires: libsmbclient-devel}
%{?_with_svgalib:BuildRequires: svgalib-devel}
%{?_with_xmms:BuildRequires: xmms-devel}
%if %{svn}
%if 0%{?svn}
# for XML docs, SVN only
BuildRequires: docbook-dtds
BuildRequires: docbook-style-xsl
@ -216,10 +216,11 @@ This package contains various scripts from MPlayer TOOLS directory.
%prep
%if %{svn}
%if 0%{?svn}
%setup -q -n mplayer-export-%{svnbuild}
%else
%setup -q -n MPlayer-%{version}%{pre}
%setup -q -n MPlayer-%{version}%{?pre}
rm -rf ffmpeg libdvdcss libdvdnav libdvdread4
%endif
%patch0 -p0 -b .gmplayer-subtitles
%patch2 -p1 -b .config
@ -241,7 +242,7 @@ popd
%{__make} V=1 %{?_smp_mflags}
%if %{svn}
%if 0%{?svn}
# build HTML documentation from XML files
%{__make} html-chunked
%endif
@ -381,6 +382,12 @@ update-desktop-database &>/dev/null || :
%{_datadir}/mplayer/*.fp
%changelog
* Thu Jun 14 2012 Julian Sikorski <belegdol@fedoraproject.org> - 1.1-1
- Updated to 1.1
- Made %%pre, %%svn and %%svnbuild defines optional
- Switched to .xz sources
- Updated the ffmpeg patch
* Wed Jun 13 2012 Julian Sikorski <belegdol@fedoraproject.org> - 1.0-0.139.20120205svn
- Restored the ability to disable subtitles in gmplayer (RPM Fusion bug #2373)
- Rebuilt for ffmpeg-0.10.4

@ -1,2 +1,2 @@
340368f4e33f767d9df109990fb29c02 Blue-1.8.tar.bz2
3f7055dd51cc3f5e95a555dd655924ad mplayer-export-2012-02-05.tar.bz2
ac7bf1cfedc1c5c24bfc83107eefb1d9 MPlayer-1.1.tar.xz

Loading…
Cancel
Save