* Sat Apr 24 2010 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.115.20100424svn

- 20100424 snapshot
- patch to build against older x264
el8
Dominik Mierzejewski 15 years ago
parent ad4c5ab0d0
commit 920155bf25

2
.gitignore vendored

@ -1,2 +1,2 @@
Blue-1.7.tar.bz2
mplayer-export-2010-03-27.tar.bz2
mplayer-export-2010-04-24.tar.bz2

@ -0,0 +1,19 @@
--- mplayer.orig/configure
+++ mplayer/configure
@@ -3041,7 +3041,7 @@
fi
echores "$_posix4"
-for func in exp2 exp2f llrint log2 log2f lrint lrintf round roundf truncf; do
+for func in exp2 exp2f llrint llrintf log2 log2f lrint lrintf round roundf truncf; do
echocheck $func
cat > $TMPC << EOF
#include <math.h>
@@ -9167,6 +9167,7 @@
$def_hardcoded_tables
$def_libavcodec_mpegaudio_hp
$def_llrint
+$def_llrintf
$def_local_aligned_8
$def_local_aligned_16
$def_log2

@ -1,7 +1,7 @@
diff -up mplayer-export-2009-10-29/configure.nodvdcss mplayer-export-2009-10-29/configure
--- mplayer-export-2009-10-29/configure.nodvdcss 2009-10-28 14:55:18.000000000 +0100
+++ mplayer-export-2009-10-29/configure 2009-10-30 00:36:25.000000000 +0100
@@ -639,7 +639,7 @@ _dvdnavconfig=dvdnav-config
diff -up mplayer-export-2010-03-27/configure.nodvdcss mplayer-export-2010-03-27/configure
--- mplayer-export-2010-03-27/configure.nodvdcss 2010-03-25 20:53:05.000000000 +0100
+++ mplayer-export-2010-03-27/configure 2010-03-27 22:54:31.000000000 +0100
@@ -648,7 +648,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
@ -10,10 +10,10 @@ diff -up mplayer-export-2009-10-29/configure.nodvdcss mplayer-export-2009-10-29/
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2009-10-29/Makefile.nodvdcss mplayer-export-2009-10-29/Makefile
--- mplayer-export-2009-10-29/Makefile.nodvdcss 2009-10-19 11:56:18.000000000 +0200
+++ mplayer-export-2009-10-29/Makefile 2009-10-30 00:37:10.000000000 +0100
@@ -150,11 +150,6 @@ SRCS_COMMON-$(LIBDCA) +=
diff -up mplayer-export-2010-03-27/Makefile.nodvdcss mplayer-export-2010-03-27/Makefile
--- mplayer-export-2010-03-27/Makefile.nodvdcss 2010-03-27 22:54:31.000000000 +0100
+++ mplayer-export-2010-03-27/Makefile 2010-03-27 22:55:40.000000000 +0100
@@ -158,11 +158,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \
libmpdemux/demux_rawdv.c
@ -25,17 +25,17 @@ diff -up mplayer-export-2009-10-29/Makefile.nodvdcss mplayer-export-2009-10-29/M
SRCS_COMMON-$(LIBMAD) += libmpcodecs/ad_libmad.c
@@ -752,7 +747,6 @@ DIRS = . \
libavutil/ppc \
@@ -778,7 +773,6 @@ DIRS = . \
libavutil/sh4 \
libavutil/tomi \
libavutil/x86 \
- libdvdcss \
libdvdnav \
libdvdnav/vm \
libdvdread4 \
@@ -871,7 +865,6 @@ codec-cfg.d codec-cfg.o: codecs.conf.h
@@ -907,7 +901,6 @@ codec-cfg.d codec-cfg.o: codecs.conf.h
$(DEPS) $(MENCODER_DEPS) $(MPLAYER_DEPS): help_mp.h
$(call ADDSUFFIXES,.d .o,mpcommon vobsub stream/stream_cddb stream/network libmpdemux/muxer_avi gui/win32/gui): version.h
$(call ADDSUFFIXES,.d .o,mpcommon vobsub stream/stream_cddb stream/network libmpdemux/muxer_avi gui/win32/gui osdep/mplayer.rc): version.h
-libdvdcss/%: CFLAGS := -Ilibdvdcss -D__USE_UNIX98 -D_GNU_SOURCE -DVERSION=\"1.2.10\" $(CFLAGS_LIBDVDCSS) $(CFLAGS)
libdvdnav/%: CFLAGS := -Ilibdvdnav -D__USE_UNIX98 -D_GNU_SOURCE -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)

@ -1,11 +0,0 @@
diff -up mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c.qcelp mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c
--- mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c.qcelp 2009-05-13 04:58:57.000000000 +0200
+++ mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c 2009-10-30 00:36:02.000000000 +0100
@@ -42,6 +42,7 @@ MIMEto4CC supported_audio[NMS_MAX_FORMAT
{"MPA", 0x55},
{"vorbis", mmioFOURCC('v','r','b','s')},
{"mpeg4-generic", mmioFOURCC('M','P','4','A')},
+ {"x-Purevoice", mmioFOURCC('Q','c','l','p')},
{NULL, 0},
};

@ -0,0 +1,12 @@
diff -up mplayer-export-2010-04-24/configure.x264 mplayer-export-2010-04-24/configure
--- mplayer-export-2010-04-24/configure.x264 2010-04-24 19:00:26.000000000 +0200
+++ mplayer-export-2010-04-24/configure 2010-04-24 19:00:26.000000000 +0200
@@ -7482,7 +7482,7 @@ if test "$_x264" = auto ; then
cat > $TMPC << EOF
#include <inttypes.h>
#include <x264.h>
-#if X264_BUILD < 89
+#if X264_BUILD < 83
#error We do not support old versions of x264. Get the latest from git.
#endif
int main(void) { x264_encoder_open((void*)0); return 0; }

@ -1,12 +1,12 @@
%define codecdir %{_libdir}/codecs
%define pre 20100327svn
%define pre 20100424svn
%define svn 1
%define svnbuild 2010-03-27
%define svnbuild 2010-04-24
%define faad2min 1:2.6.1
Name: mplayer
Version: 1.0
Release: 0.114.%{pre}%{?dist}
Release: 0.115.%{pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
Group: Applications/Multimedia
@ -28,6 +28,8 @@ Patch2: %{name}-config.patch
Patch8: %{name}-manlinks.patch
Patch14: %{name}-nodvdcss.patch
Patch15: %{name}-libgif.patch
Patch16: %{name}-x264.patch
Patch17: %{name}-llrintf.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: SDL-devel
@ -221,6 +223,8 @@ This package contains various scripts from MPlayer TOOLS directory.
%patch8 -p1 -b .manlinks
%patch14 -p1 -b .nodvdcss
%patch15 -p1 -b .libgif
%patch16 -p1 -b .x264
%patch17 -p1 -b .llrintf
doconv() {
iconv -f $1 -t $2 -o DOCS/man/$3/mplayer.1.utf8 DOCS/man/$3/mplayer.1 && \
@ -235,7 +239,7 @@ cp -a `ls -1|grep -v GUI` GUI/
%build
pushd GUI
%{mp_configure}--enable-gui
%{mp_configure}--enable-gui --disable-mencoder
%{__make} %{?_smp_mflags}
popd
@ -254,7 +258,7 @@ popd
%install
rm -rf $RPM_BUILD_ROOT doc
make install DESTDIR=$RPM_BUILD_ROOT STRIPBINARIES=no
make install DESTDIR=$RPM_BUILD_ROOT INSTALLSTRIP=
for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
done
@ -393,6 +397,10 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/mplayer/*.fp
%changelog
* Sat Apr 24 2010 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.115.20100424svn
- 20100424 snapshot
- patch to build against older x264
* Sat Mar 27 2010 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.114.20100327svn
- 20100327 snapshot
- drop unused patch

@ -1,2 +1,2 @@
e4e2020d11b681aac898103b3ba723c4 Blue-1.7.tar.bz2
2046c98215915a4cc5cf47335a3e23e9 mplayer-export-2010-03-27.tar.bz2
db1f4d70e2c1dc400e543269a525208b mplayer-export-2010-04-24.tar.bz2

Loading…
Cancel
Save