mplayer svn rev: 29776 ffmpeg : HEAD dvdnav : HEAD - Move from amrnb amrwb to opencore-amr - Conditionalize faac (moved to nonfree).el8
parent
ae1a21e41b
commit
714f1aa6ad
@ -1,2 +1,2 @@
|
||||
Blue-1.7.tar.bz2
|
||||
mplayer-export-2009-03-29.tar.bz2
|
||||
mplayer-export-20091021.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up mplayer-export-2009-03-29/configure.cflags mplayer-export-2009-03-29/configure
|
||||
--- mplayer-export-2009-03-29/configure.cflags 2009-03-29 00:21:21.000000000 +0100
|
||||
+++ mplayer-export-2009-03-29/configure 2009-03-30 22:58:32.000000000 +0200
|
||||
@@ -795,7 +795,7 @@ for ac_option do
|
||||
;;
|
||||
|
||||
--extra-cflags=*)
|
||||
- extra_cflags=`echo $ac_option | cut -d '=' -f 2`
|
||||
+ extra_cflags=`echo $ac_option | cut -d '=' -f 2-`
|
||||
;;
|
||||
--extra-ldflags=*)
|
||||
extra_ldflags=`echo $ac_option | cut -d '=' -f 2`
|
@ -1,21 +0,0 @@
|
||||
diff -up mplayer-export-2008-08-18/Makefile.manlinks mplayer-export-2008-08-18/Makefile
|
||||
--- mplayer-export-2008-08-18/Makefile.manlinks 2008-08-14 22:42:54.000000000 +0200
|
||||
+++ mplayer-export-2008-08-18/Makefile 2008-08-19 13:50:17.000000000 +0200
|
||||
@@ -830,7 +830,7 @@ install-mencoder-man: $(foreach lang,$(M
|
||||
install-mplayer-man: $(foreach lang,$(MAN_LANGS),install-mplayer-man-$(lang))
|
||||
|
||||
install-mencoder-man-en: install-mplayer-man-en
|
||||
- cd $(MANDIR)/man1 && ln -sf mplayer.1 mencoder.1
|
||||
+ echo ".so mplayer.1" > $(MANDIR)/man1/mencoder.1
|
||||
|
||||
install-mplayer-man-en:
|
||||
$(INSTALL) -d $(MANDIR)/man1
|
||||
@@ -838,7 +838,7 @@ install-mplayer-man-en:
|
||||
|
||||
define MENCODER_MAN_RULE
|
||||
install-mencoder-man-$(lang): install-mplayer-man-$(lang)
|
||||
- cd $(MANDIR)/$(lang)/man1 && ln -sf mplayer.1 mencoder.1
|
||||
+ echo ".so mplayer.1" > $(MANDIR)/$(lang)/man1/mencoder.1
|
||||
endef
|
||||
|
||||
define MPLAYER_MAN_RULE
|
@ -1,18 +0,0 @@
|
||||
diff -up mplayer-export-2009-02-04/libswscale/swscale.c.ppc-compile mplayer-export-2009-02-04/libswscale/swscale.c
|
||||
--- mplayer-export-2009-02-04/libswscale/swscale.c.ppc-compile 2009-01-25 20:58:33.000000000 +0100
|
||||
+++ mplayer-export-2009-02-04/libswscale/swscale.c 2009-02-13 15:00:57.000000000 +0100
|
||||
@@ -955,13 +955,12 @@ static inline void yuv2rgbXinC_full(SwsC
|
||||
|
||||
//Note: we have C, X86, MMX, MMX2, 3DNOW versions, there is no 3DNOW+MMX2 one
|
||||
//Plain C versions
|
||||
-#if !HAVE_MMX || defined (RUNTIME_CPUDETECT) || !CONFIG_GPL
|
||||
+#if !HAVE_MMX || !HAVE_ALTIVEC || defined (RUNTIME_CPUDETECT) || !CONFIG_GPL
|
||||
#define COMPILE_C
|
||||
#endif
|
||||
|
||||
#if ARCH_PPC
|
||||
#if (HAVE_ALTIVEC || defined (RUNTIME_CPUDETECT)) && CONFIG_GPL
|
||||
-#undef COMPILE_C
|
||||
#define COMPILE_ALTIVEC
|
||||
#endif
|
||||
#endif //ARCH_PPC
|
Loading…
Reference in new issue