* Sun Mar 29 2009 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.109.20090329svn

- 20090329 snapshot from 1.0rc3 branch
- fix RPM_OPT_FLAGS usage
el8
Dominik Mierzejewski 16 years ago
parent cb216606fc
commit 64d9abd556

2
.gitignore vendored

@ -1,2 +1,2 @@
Blue-1.7.tar.bz2
mplayer-export-2009-03-19.tar.bz2
mplayer-export-2009-03-29.tar.bz2

@ -0,0 +1,12 @@
diff -up mplayer-export-2009-03-29/configure.cflags mplayer-export-2009-03-29/configure
--- mplayer-export-2009-03-29/configure.cflags 2009-03-29 00:21:21.000000000 +0100
+++ mplayer-export-2009-03-29/configure 2009-03-30 22:58:32.000000000 +0200
@@ -795,7 +795,7 @@ for ac_option do
;;
--extra-cflags=*)
- extra_cflags=`echo $ac_option | cut -d '=' -f 2`
+ extra_cflags=`echo $ac_option | cut -d '=' -f 2-`
;;
--extra-ldflags=*)
extra_ldflags=`echo $ac_option | cut -d '=' -f 2`

@ -1,7 +1,7 @@
diff -up mplayer-export-2009-03-19/configure.nodvdcss mplayer-export-2009-03-19/configure
--- mplayer-export-2009-03-19/configure.nodvdcss 2009-03-18 22:48:35.000000000 +0100
+++ mplayer-export-2009-03-19/configure 2009-03-19 00:16:32.000000000 +0100
@@ -623,7 +623,7 @@ _dvdnavconfig=dvdnav-config
diff -up mplayer-export-2009-03-29/configure.nodvdcss mplayer-export-2009-03-29/configure
--- mplayer-export-2009-03-29/configure.nodvdcss 2009-03-29 00:21:21.000000000 +0100
+++ mplayer-export-2009-03-29/configure 2009-03-29 11:20:11.000000000 +0200
@@ -622,7 +622,7 @@ _dvdnavconfig=dvdnav-config
_dvdreadconfig=dvdread-config
_dvdread=auto
_dvdread_internal=auto
@ -10,9 +10,9 @@ diff -up mplayer-export-2009-03-19/configure.nodvdcss mplayer-export-2009-03-19/
_xanim=auto
_real=auto
_live=auto
diff -up mplayer-export-2009-03-19/Makefile.nodvdcss mplayer-export-2009-03-19/Makefile
--- mplayer-export-2009-03-19/Makefile.nodvdcss 2009-03-19 00:16:32.000000000 +0100
+++ mplayer-export-2009-03-19/Makefile 2009-03-19 00:17:04.000000000 +0100
diff -up mplayer-export-2009-03-29/Makefile.nodvdcss mplayer-export-2009-03-29/Makefile
--- mplayer-export-2009-03-29/Makefile.nodvdcss 2009-03-29 11:20:11.000000000 +0200
+++ mplayer-export-2009-03-29/Makefile 2009-03-29 11:20:55.000000000 +0200
@@ -345,11 +345,6 @@ SRCS_COMMON-$(LIBDCA) +=
SRCS_COMMON-$(LIBDV) += libmpcodecs/ad_libdv.c \
libmpcodecs/vd_libdv.c \

@ -1,11 +0,0 @@
diff -up mplayer-export-2009-01-07/libavcodec/Makefile.compile mplayer-export-2009-01-07/libavcodec/Makefile
--- mplayer-export-2009-01-07/libavcodec/Makefile.compile 2009-01-06 23:01:57.000000000 +0100
+++ mplayer-export-2009-01-07/libavcodec/Makefile 2009-01-08 21:32:58.000000000 +0100
@@ -511,3 +511,7 @@ include $(SUBDIR)../subdir.mak
$(SUBDIR)dct-test$(EXESUF): $(SUBDIR)fdctref.o $(SUBDIR)aandcttab.o
$(SUBDIR)fft-test$(EXESUF): $(SUBDIR)fdctref.o
+ifeq ($(ARCH_X86_32),yes)
+$(SUBDIR)x86/snowdsp_mmx.o: CFLAGS += -fomit-frame-pointer
+$(SUBDIR)h264.o: CFLAGS += -fomit-frame-pointer
+endif

@ -1,12 +1,12 @@
%define codecdir %{_libdir}/codecs
%define pre 20090319svn
%define pre 20090329svn
%define svn 1
%define svnbuild 2009-03-19
%define svnbuild 2009-03-29
%define faad2min 1:2.6.1
Name: mplayer
Version: 1.0
Release: 0.108.%{pre}%{?dist}
Release: 0.109.%{pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
Group: Applications/Multimedia
@ -22,7 +22,7 @@ Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
Source10: mplayer-snapshot.sh
Patch1: %{name}-htmldocs.patch
Patch2: %{name}-config.patch
Patch5: %{name}-x86_32-compile.patch
Patch3: %{name}-cflags.patch
Patch8: %{name}-manlinks.patch
Patch10: %{name}-qcelp.patch
Patch14: %{name}-nodvdcss.patch
@ -144,7 +144,7 @@ MPlayer documentation in various languages.
--libdir=%{_libdir} \\\
--codecsdir=%{codecdir} \\\
\\\
--target=%{_target_cpu}-%{_target_os} \\\
--extra-cflags="`echo $RPM_OPT_FLAGS|sed -e s,i386,i486,`" \\\
--language=all \\\
\\\
--enable-joystick \\\
@ -192,7 +192,7 @@ MPlayer documentation in various languages.
%endif
%patch1 -p1 -b .htmldocs
%patch2 -p1 -b .config
%patch5 -p1 -b .compile
%patch3 -p1 -b .cflags
%patch8 -p1 -b .manlinks
%patch10 -p1 -b .qclp
%patch14 -p1 -b .nodvdcss
@ -206,7 +206,6 @@ for lang in hu pl ; do doconv iso-8859-2 utf-8 $lang ; done
for lang in ru ; do doconv koi8-r utf-8 $lang ; done
%build
export CFLAGS="$RPM_OPT_FLAGS -ffast-math --std=gnu99"
%{mp_configure}--enable-gui
%{__make} %{?_smp_mflags}
@ -341,6 +340,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sun Mar 29 2009 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.109.20090329svn
- 20090329 snapshot from 1.0rc3 branch
- fix RPM_OPT_FLAGS usage
* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.0-0.108.20090319svn
- rebuild for new F11 features

@ -1,2 +1,2 @@
e4e2020d11b681aac898103b3ba723c4 Blue-1.7.tar.bz2
76d04b3854c6af71af4f609c049933dc mplayer-export-2009-03-19.tar.bz2
96ec2dfd73bbd2e2f5d3476870a9fbcb mplayer-export-2009-03-29.tar.bz2

Loading…
Cancel
Save