* Tue Aug 19 2008 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.98.20080818svn

- moved config settings to config patch
- rebased patches against current snapshot
el8
Dominik Mierzejewski 17 years ago
parent c18f2bef03
commit 39fe124265

@ -1,23 +1,56 @@
--- etc/example.conf~ 2006-06-11 21:35:46.000000000 +0300
+++ etc/example.conf 2006-08-10 01:18:25.000000000 +0300
@@ -3,3 +3,3 @@
diff -up mplayer-export-2008-08-18/etc/example.conf.orig mplayer-export-2008-08-18/etc/example.conf
--- mplayer-export-2008-08-18/etc/example.conf.orig 2008-02-08 19:33:39.000000000 +0100
+++ mplayer-export-2008-08-18/etc/example.conf 2008-08-19 13:47:15.000000000 +0200
@@ -1,7 +1,7 @@
#
# MPlayer configuration file
#
-# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
+# Configuration files are read system-wide from /etc/mplayer/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
@@ -93,3 +93,3 @@
# system-wide settings, all of which are overrriden by the command line.
#
@@ -71,7 +71,7 @@
##################
# Specify default audio driver (see -ao help for a list).
-#ao=oss
+ao = pulse,alsa,
# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd
@@ -95,7 +95,7 @@
#framedrop = yes
# Specify your preferred skin here (skins are searched for in
-# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
+# /usr/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss
@@ -120,4 +120,9 @@
+# A plugged in joystick can interfere with keyboard shortcuts
+joystick = no
+
# Resample the font alphamap.
@@ -105,6 +105,15 @@
# 10 bold black outline
#ffactor = 0.75
+# FriBidi can do "funny" things to some ISO-8859-* subtitles
+flip-hebrew = no
+
+# Use fontconfig for font selection
+fontconfig = yes
+
+# Default font for unstyled subtitles
+font = "Sans"
+
# cache settings
#
# Use 8MB input cache by default.
@@ -122,6 +131,9 @@
# DVD: Play English audio tracks if available.
#alang = en
# You can also include other configuration files.
-#include = /path/to/the/file/you/want/to/include
+#include = /home/me/.mplayer/something
+# A plugged in joystick can interfere with keyboard shortcuts
+joystick = no
+
###################
# DVDNAV Settings #
###################

@ -1,16 +1,16 @@
diff -up mplayer-export-2008-06-04/Makefile.manlinks mplayer-export-2008-06-04/Makefile
--- mplayer-export-2008-06-04/Makefile.manlinks 2008-05-30 22:10:36.000000000 +0200
+++ mplayer-export-2008-06-04/Makefile 2008-06-04 23:13:37.000000000 +0200
@@ -805,7 +805,7 @@ install-mplayer-man-en:
$(INSTALL) -c -m 644 DOCS/man/en/mplayer.1 $(MANDIR)/man1/
diff -up mplayer-export-2008-08-18/Makefile.manlinks mplayer-export-2008-08-18/Makefile
--- mplayer-export-2008-08-18/Makefile.manlinks 2008-08-14 22:42:54.000000000 +0200
+++ mplayer-export-2008-08-18/Makefile 2008-08-19 13:50:17.000000000 +0200
@@ -830,7 +830,7 @@ install-mencoder-man: $(foreach lang,$(M
install-mplayer-man: $(foreach lang,$(MAN_LANGS),install-mplayer-man-$(lang))
install-mencoder-man-en: install-mplayer-man-en
- cd $(MANDIR)/man1 && ln -sf mplayer.1 mencoder.1
+ echo ".so mplayer.1" > $(MANDIR)/man1/mencoder.1
define MPLAYER_MAN_RULE
install-mplayer-man-$(lang):
@@ -815,7 +815,7 @@ endef
install-mplayer-man-en:
$(INSTALL) -d $(MANDIR)/man1
@@ -838,7 +838,7 @@ install-mplayer-man-en:
define MENCODER_MAN_RULE
install-mencoder-man-$(lang): install-mplayer-man-$(lang)
@ -18,4 +18,4 @@ diff -up mplayer-export-2008-06-04/Makefile.manlinks mplayer-export-2008-06-04/M
+ echo ".so mplayer.1" > $(MANDIR)/$(lang)/man1/mencoder.1
endef
$(foreach lang,$(MAN_LANG),$(eval $(MPLAYER_MAN_RULE)))
define MPLAYER_MAN_RULE

@ -7,7 +7,7 @@
Name: mplayer
Version: 1.0
Release: 0.97.%{pre}%{?dist}
Release: 0.98.%{pre}%{?dist}
Summary: Movie player playing most video formats and DVDs
Group: Applications/Multimedia
@ -140,7 +140,7 @@ MPlayer documentation in various languages.
%else
%setup -q -n MPlayer-%{version}%{pre}
%endif
%patch2 -p0
%patch2 -p1 -b .config
%patch5 -p1 -b .compile
%patch8 -p1 -b .manlinks
%patch10 -p1 -b .qclp
@ -292,10 +292,6 @@ rm -rf doc/HTML
# Default config files
install -Dpm 644 etc/example.conf \
$RPM_BUILD_ROOT%{_sysconfdir}/mplayer/mplayer.conf
# use Nimbus Sans L font for OSD (via fontconfig)
echo "fontconfig=yes" >>$RPM_BUILD_ROOT%{_sysconfdir}/mplayer/mplayer.conf
echo "font=\"Sans\"" >>$RPM_BUILD_ROOT%{_sysconfdir}/mplayer/mplayer.conf
echo "ao=pulse,alsa," >>$RPM_BUILD_ROOT%{_sysconfdir}/mplayer/mplayer.conf
install -pm 644 etc/{input,menu}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer/
@ -394,6 +390,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Aug 19 2008 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.98.20080818svn
- moved config settings to config patch
- rebased patches against current snapshot
* Mon Aug 18 2008 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.97.20080818svn
- updated to latest SVN snapshot
- dropped obsolete patches

Loading…
Cancel
Save