diff --git a/.gitignore b/.gitignore
index e89ce23..4b932f4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
 Blue-1.7.tar.bz2
-mplayer-export-20091021.tar.bz2
+mplayer-export-2009-10-29.tar.bz2
diff --git a/mplayer-config.patch b/mplayer-config.patch
index 0fa7906..fe352ba 100644
--- a/mplayer-config.patch
+++ b/mplayer-config.patch
@@ -1,6 +1,6 @@
-diff -up mplayer-export-2008-08-18/etc/example.conf.orig mplayer-export-2008-08-18/etc/example.conf
---- mplayer-export-2008-08-18/etc/example.conf.orig	2008-02-08 19:33:39.000000000 +0100
-+++ mplayer-export-2008-08-18/etc/example.conf	2008-08-19 13:47:15.000000000 +0200
+diff -up mplayer-export-2009-10-29/etc/example.conf.config mplayer-export-2009-10-29/etc/example.conf
+--- mplayer-export-2009-10-29/etc/example.conf.config	2008-02-08 19:33:39.000000000 +0100
++++ mplayer-export-2009-10-29/etc/example.conf	2009-10-29 23:54:30.000000000 +0100
 @@ -1,7 +1,7 @@
  #
  # MPlayer configuration file
@@ -44,12 +44,15 @@ diff -up mplayer-export-2008-08-18/etc/example.conf.orig mplayer-export-2008-08-
  # cache settings
  #
  # Use 8MB input cache by default.
-@@ -122,6 +131,9 @@
+@@ -122,6 +131,12 @@
  # DVD: Play English audio tracks if available.
  #alang = en
  
 +# A plugged in joystick can interfere with keyboard shortcuts
 +joystick = no
++
++# Inhibit (a XScrnSaver compatible) screensaver while playing a movie
++stop-xscreensaver = yes
 +
  ###################
  # DVDNAV Settings #
diff --git a/mplayer-manlinks.patch b/mplayer-manlinks.patch
new file mode 100644
index 0000000..252a09d
--- /dev/null
+++ b/mplayer-manlinks.patch
@@ -0,0 +1,31 @@
+diff -up mplayer-export-2009-10-29/Makefile.manlinks mplayer-export-2009-10-29/Makefile
+--- mplayer-export-2009-10-29/Makefile.manlinks	2009-10-19 11:56:18.000000000 +0200
++++ mplayer-export-2009-10-29/Makefile	2009-10-30 00:42:36.000000000 +0100
+@@ -922,10 +922,10 @@ install-mencoder-man: $(foreach lang,$(M
+ install-mplayer-man:  $(foreach lang,$(MAN_LANGS),install-mplayer-man-$(lang))
+ 
+ install-gui-man-en: install-mplayer-man-en
+-	cd $(MANDIR)/man1/ && ln -sf mplayer.1 gmplayer.1
++	echo ".so mplayer.1" > $(MANDIR)/man1/gmplayer.1
+ 
+ install-mencoder-man-en: install-mplayer-man-en
+-	cd $(MANDIR)/man1 && ln -sf mplayer.1 mencoder.1
++	echo ".so mplayer.1" > $(MANDIR)/man1/mencoder.1
+ 
+ install-mplayer-man-en:
+ 	$(INSTALL) -d $(MANDIR)/man1
+@@ -933,12 +933,12 @@ install-mplayer-man-en:
+ 
+ define GUI_MAN_RULE
+ install-gui-man-$(lang): install-mplayer-man-$(lang)
+-	cd $(MANDIR)/$(lang)/man1/ && ln -sf mplayer.1 gmplayer.1
++	echo ".so mplayer.1" > $(MANDIR)/$(lang)/man1/gmplayer.1
+ endef
+ 
+ define MENCODER_MAN_RULE
+ install-mencoder-man-$(lang): install-mplayer-man-$(lang)
+-	cd $(MANDIR)/$(lang)/man1 && ln -sf mplayer.1 mencoder.1
++	echo ".so mplayer.1" > $(MANDIR)/$(lang)/man1/mencoder.1
+ endef
+ 
+ define MPLAYER_MAN_RULE
diff --git a/mplayer-nodvdcss.patch b/mplayer-nodvdcss.patch
index 7f894be..7020a4b 100644
--- a/mplayer-nodvdcss.patch
+++ b/mplayer-nodvdcss.patch
@@ -1,7 +1,7 @@
-diff -up mplayer-export-2009-03-29/configure.nodvdcss mplayer-export-2009-03-29/configure
---- mplayer-export-2009-03-29/configure.nodvdcss	2009-03-29 00:21:21.000000000 +0100
-+++ mplayer-export-2009-03-29/configure	2009-03-29 11:20:11.000000000 +0200
-@@ -622,7 +622,7 @@ _dvdnavconfig=dvdnav-config
+diff -up mplayer-export-2009-10-29/configure.nodvdcss mplayer-export-2009-10-29/configure
+--- mplayer-export-2009-10-29/configure.nodvdcss	2009-10-28 14:55:18.000000000 +0100
++++ mplayer-export-2009-10-29/configure	2009-10-30 00:36:25.000000000 +0100
+@@ -639,7 +639,7 @@ _dvdnavconfig=dvdnav-config
  _dvdreadconfig=dvdread-config
  _dvdread=auto
  _dvdread_internal=auto
@@ -10,10 +10,10 @@ diff -up mplayer-export-2009-03-29/configure.nodvdcss mplayer-export-2009-03-29/
  _xanim=auto
  _real=auto
  _live=auto
-diff -up mplayer-export-2009-03-29/Makefile.nodvdcss mplayer-export-2009-03-29/Makefile
---- mplayer-export-2009-03-29/Makefile.nodvdcss	2009-03-29 11:20:11.000000000 +0200
-+++ mplayer-export-2009-03-29/Makefile	2009-03-29 11:20:55.000000000 +0200
-@@ -345,11 +345,6 @@ SRCS_COMMON-$(LIBDCA)                += 
+diff -up mplayer-export-2009-10-29/Makefile.nodvdcss mplayer-export-2009-10-29/Makefile
+--- mplayer-export-2009-10-29/Makefile.nodvdcss	2009-10-19 11:56:18.000000000 +0200
++++ mplayer-export-2009-10-29/Makefile	2009-10-30 00:37:10.000000000 +0100
+@@ -150,11 +150,6 @@ SRCS_COMMON-$(LIBDCA)                += 
  SRCS_COMMON-$(LIBDV)                 += libmpcodecs/ad_libdv.c \
                                          libmpcodecs/vd_libdv.c \
                                          libmpdemux/demux_rawdv.c
@@ -24,20 +24,20 @@ diff -up mplayer-export-2009-03-29/Makefile.nodvdcss mplayer-export-2009-03-29/M
 -                                        libdvdcss/libdvdcss.c \
  
  SRCS_COMMON-$(LIBMAD)                += libmpcodecs/ad_libmad.c
- SRCS_COMMON-$(LIBMPEG2)              += libmpcodecs/vd_libmpeg2.c \
-@@ -745,7 +740,6 @@ DIRS =  . \
-         libavcodec/x86 \
-         libavformat \
-         libavutil \
+ 
+@@ -752,7 +747,6 @@ DIRS =  . \
+         libavutil/ppc \
+         libavutil/sh4 \
+         libavutil/x86 \
 -        libdvdcss \
          libdvdnav \
          libdvdnav/vm \
          libdvdread4 \
-@@ -852,7 +846,6 @@ version.h: version.sh
- # Make sure all generated header files are created.
- $(DEPS) $(MENCODER_DEPS) $(MPLAYER_DEPS): codecs.conf.h help_mp.h version.h
+@@ -871,7 +865,6 @@ codec-cfg.d codec-cfg.o: codecs.conf.h
+ $(DEPS) $(MENCODER_DEPS) $(MPLAYER_DEPS): help_mp.h
+ $(call ADDSUFFIXES,.d .o,mpcommon vobsub stream/stream_cddb stream/network libmpdemux/muxer_avi gui/win32/gui): version.h
  
--libdvdcss/%: CFLAGS += -D__USE_UNIX98 -D_GNU_SOURCE -DVERSION=\"1.2.10\" $(CFLAGS_LIBDVDCSS)
- libdvdnav/%: CFLAGS += -D__USE_UNIX98 -D_GNU_SOURCE -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\"
- libdvdnav/% stream/stream_dvdnav%: CFLAGS += $(CFLAGS_LIBDVDNAV)
- libdvdread4/%: CFLAGS += -D__USE_UNIX98 -D_GNU_SOURCE -DHAVE_CONFIG_H $(CFLAGS_LIBDVDCSS_DVDREAD)
+-libdvdcss/%:   CFLAGS := -Ilibdvdcss -D__USE_UNIX98 -D_GNU_SOURCE -DVERSION=\"1.2.10\" $(CFLAGS_LIBDVDCSS) $(CFLAGS)
+ libdvdnav/%:   CFLAGS := -Ilibdvdnav -D__USE_UNIX98 -D_GNU_SOURCE -DHAVE_CONFIG_H -DVERSION=\"MPlayer-custom\" $(CFLAGS)
+ libdvdread4/%: CFLAGS := -Ilibdvdread4 -D__USE_UNIX98 -D_GNU_SOURCE $(CFLAGS_LIBDVDCSS_DVDREAD) $(CFLAGS)
+ libfaad2/%:    CFLAGS := -Ilibfaad2 -D_GNU_SOURCE -DHAVE_CONFIG_H $(CFLAGS_FAAD_FIXED) $(CFLAGS)
diff --git a/mplayer-qcelp.patch b/mplayer-qcelp.patch
index 0d13fc4..1e36631 100644
--- a/mplayer-qcelp.patch
+++ b/mplayer-qcelp.patch
@@ -1,8 +1,8 @@
-diff -up mplayer-export-2008-02-11/libmpdemux/demux_nemesi.c.qclp mplayer-export-2008-02-11/libmpdemux/demux_nemesi.c
---- mplayer-export-2008-02-11/libmpdemux/demux_nemesi.c.qclp	2008-01-13 17:00:39.000000000 +0100
-+++ mplayer-export-2008-02-11/libmpdemux/demux_nemesi.c	2008-02-22 21:19:57.000000000 +0100
-@@ -40,6 +40,7 @@ MIMEto4CC supported_audio[NMS_MAX_FORMAT
-     {"MPA", 0x55}, 
+diff -up mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c.qcelp mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c
+--- mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c.qcelp	2009-05-13 04:58:57.000000000 +0200
++++ mplayer-export-2009-10-29/libmpdemux/demux_nemesi.c	2009-10-30 00:36:02.000000000 +0100
+@@ -42,6 +42,7 @@ MIMEto4CC supported_audio[NMS_MAX_FORMAT
+     {"MPA", 0x55},
      {"vorbis", mmioFOURCC('v','r','b','s')},
      {"mpeg4-generic", mmioFOURCC('M','P','4','A')},
 +    {"x-Purevoice", mmioFOURCC('Q','c','l','p')},
diff --git a/mplayer-snapshot.sh b/mplayer-snapshot.sh
index cf766a4..1a17cf9 100755
--- a/mplayer-snapshot.sh
+++ b/mplayer-snapshot.sh
@@ -14,25 +14,21 @@ unset CDPATH
 pwd=$(pwd)
 svn=$(date +%Y-%m-%d)
 dirname=mplayer-export-$svn
-mplayer_rev=29776
-ffmpeg_rev=HEAD
-dvdnav_rev=HEAD
+mplayer_rev={$svn}
 
 cd "$tmp"
 svn checkout -r ${mplayer_rev} svn://svn.mplayerhq.hu/mplayer/trunk $dirname
 cd $dirname
 
 rm -rf libdvdcss
-for dir in libav* libpostproc ; do
+for dir in libav* libdvd* libpostproc ; do
 	cd $dir
-	svn update -r ${ffmpeg_rev}
+	svn update -r ${mplayer_rev}
 	cd ..
 done
-svn update -r ${dvdnav_rev} svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdread/src libdvdread4
-svn update -r ${dvdnav_rev} svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav/src libdvdnav
 
 svn_revision=`LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2`
-sed -i -e 's/\(SVN-r[0-9]* \)/\1rpmfusion /' -e "s/UNKNOWN/$svn_revision/" version.sh
+sed -i -e 's/\(SVN-r[0-9]* \)/\1rpmfusion /' -e "s/UNKNOWN/SVN-r$svn_revision/" version.sh
 find . -type d -name .svn -print0 | xargs -0r rm -rf
 cd ..
 tar jcf "$pwd"/$dirname.tar.bz2 $dirname
diff --git a/mplayer.spec b/mplayer.spec
index 5790aac..971b524 100644
--- a/mplayer.spec
+++ b/mplayer.spec
@@ -1,12 +1,12 @@
 %define         codecdir %{_libdir}/codecs
-%define         pre 20091021svn
+%define         pre 20091029svn
 %define         svn 1
-%define         svnbuild 20091021
+%define         svnbuild 2009-10-29
 %define         faad2min 1:2.6.1
 
 Name:           mplayer
 Version:        1.0
-Release:        0.110.%{pre}%{?dist}
+Release:        0.111.%{pre}%{?dist}
 Summary:        Movie player playing most video formats and DVDs
 
 Group:          Applications/Multimedia
@@ -21,11 +21,13 @@ Source0:        http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{pre
 Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
 Source10:       mplayer-snapshot.sh
 Patch2:         %{name}-config.patch
+Patch8:         %{name}-manlinks.patch
 Patch10:        %{name}-qcelp.patch
 Patch14:        %{name}-nodvdcss.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  SDL-devel
+BuildRequires:  a52dec-devel
 BuildRequires:  aalib-devel
 BuildRequires:  alsa-lib-devel
 BuildRequires:  cdparanoia-devel
@@ -61,9 +63,10 @@ BuildRequires:  lirc-devel
 BuildRequires:  live555-devel
 BuildRequires:  lzo-devel >= 2
 BuildRequires:  pulseaudio-lib-devel
+BuildRequires:  schroedinger-devel
 BuildRequires:  speex-devel >= 1.1
 BuildRequires:  twolame-devel
-BuildRequires:  x264-devel >= 0.0.0-0.14.20080613
+BuildRequires:  x264-devel >= 0.0.0-0.26.20091026
 BuildRequires:  xvidcore-devel >= 0.9.2
 BuildRequires:  yasm
 %{?_with_arts:BuildRequires: arts-devel}
@@ -142,7 +145,7 @@ MPlayer documentation in various languages.
     --libdir=%{_libdir} \\\
     --codecsdir=%{codecdir} \\\
     \\\
-    --extra-cflags="`echo $RPM_OPT_FLAGS|sed -e s,i386,i486,`" \\\
+    --extra-cflags="$RPM_OPT_FLAGS" \\\
     --language=all \\\
     \\\
     --enable-joystick \\\
@@ -161,6 +164,7 @@ MPlayer documentation in various languages.
     --disable-mp3lame-lavc \\\
     --disable-x264-lavc \\\
     \\\
+    --disable-liba52-internal \\\
     %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \\\
     --disable-faad-internal \\\
     %{!?_with_libmad:--disable-mad} \\\
@@ -191,6 +195,9 @@ MPlayer documentation in various languages.
 %patch2 -p1 -b .config
 
 
+%patch8 -p1 -b .manlinks
+%patch10 -p1 -b .qcelp
+%patch14 -p1 -b .nodvdcss
 doconv() {
     iconv -f $1 -t $2 -o DOCS/man/$3/mplayer.1.utf8 DOCS/man/$3/mplayer.1 && \
     mv DOCS/man/$3/mplayer.1.utf8 DOCS/man/$3/mplayer.1
@@ -199,13 +206,15 @@ for lang in de es fr it ; do doconv iso-8859-1 utf-8 $lang ; done
 for lang in hu pl ; do doconv iso-8859-2 utf-8 $lang ; done
 for lang in ru ; do doconv koi8-r utf-8 $lang ; done
 
+mkdir GUI
+cp -a `ls -1|grep -v GUI` GUI/
+
 %build
-%{mp_configure}--enable-gui
+pushd GUI
+%{mp_configure}--enable-gui --disable-mencoder
 
 %{__make} %{?_smp_mflags}
-
-mv -f mplayer gmplayer
-%{__make} distclean
+popd
 
 %{mp_configure}
 
@@ -240,7 +249,7 @@ install -Dpm 644 etc/example.conf \
 install -pm 644 etc/{input,menu}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer/
 
 # GUI mplayer
-install -pm 755 g%{name} $RPM_BUILD_ROOT%{_bindir}/
+install -pm 755 GUI/%{name} $RPM_BUILD_ROOT%{_bindir}/gmplayer
 
 # Default skin
 install -dm 755 $RPM_BUILD_ROOT%{_datadir}/mplayer/skins
@@ -283,7 +292,6 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
 %config(noreplace) %{_sysconfdir}/mplayer/input.conf
 %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
-%{_bindir}/aconvert
 %{_bindir}/midentify
 %{_bindir}/mplayer
 %dir %{codecdir}/
@@ -308,6 +316,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n mencoder
 %defattr(-, root, root, -)
+%{_bindir}/aconvert
 %{_bindir}/mencoder
 %{_mandir}/man1/mencoder.1*
 %lang(cs) %{_mandir}/cs/man1/mencoder.1*
@@ -334,6 +343,17 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Oct 29 2009 Dominik Mierzejewski <rpm at greysector.net> - 1.0-0.111.20091029svn
+- 20091029 snapshot
+- rebuild against current x264
+- fix debuginfo generation (bug #101)
+- move aconvert to mencoder package (bug #544)
+- fix snapshot script not to mangle version string (bug #577)
+- disable screensaver by default (bug #672)
+- restore and rebase some of the dropped patches
+- build against external liba52
+- enable dirac decoding via libschroedinger
+
 * Wed Oct 21 2009 kwizart < kwizart at gmail.com > - 1.0-0.110.20091021svn
 - Update to snapshot 20091021
   mplayer svn rev: 29776
diff --git a/sources b/sources
index 64cbc14..0eb9558 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
 e4e2020d11b681aac898103b3ba723c4  Blue-1.7.tar.bz2
-416fa47da802f9aa256de0ce98371613  mplayer-export-20091021.tar.bz2
+101e633734544dfc735ea27d218342eb  mplayer-export-2009-10-29.tar.bz2