|
|
|
@ -1,7 +1,7 @@
|
|
|
|
|
diff -up mplayer-export-2013-03-24/configure.ffmpeg mplayer-export-2013-03-24/configure
|
|
|
|
|
--- mplayer-export-2013-03-24/configure.ffmpeg 2013-03-23 08:28:55.993725707 +0100
|
|
|
|
|
+++ mplayer-export-2013-03-24/configure 2013-03-23 08:28:56.003725776 +0100
|
|
|
|
|
@@ -6973,7 +6973,7 @@ elif test "$ffmpeg_so" = auto ; then
|
|
|
|
|
diff -up mplayer-export-2013-08-01/configure.ffmpeg mplayer-export-2013-08-01/configure
|
|
|
|
|
--- mplayer-export-2013-08-01/configure.ffmpeg 2013-08-01 12:37:20.815714081 +0200
|
|
|
|
|
+++ mplayer-export-2013-08-01/configure 2013-08-01 12:37:20.817714096 +0200
|
|
|
|
|
@@ -6987,7 +6987,7 @@ elif test "$ffmpeg_so" = auto ; then
|
|
|
|
|
inc_ffmpeg=$($_pkg_config --cflags libswscale libavformat libavcodec libavutil)
|
|
|
|
|
ld_tmp=$($_pkg_config --libs libswscale libavformat libavcodec libavutil)
|
|
|
|
|
header_check libavutil/avutil.h $inc_ffmpeg $ld_tmp &&
|
|
|
|
@ -10,7 +10,7 @@ diff -up mplayer-export-2013-03-24/configure.ffmpeg mplayer-export-2013-03-24/co
|
|
|
|
|
elif header_check libavutil/avutil.h -lswscale -lavformat -lavcodec -lavutil ; then
|
|
|
|
|
extra_ldflags="$extra_ldflags -lswscale -lavformat -lavcodec -lavutil"
|
|
|
|
|
ffmpeg_so=yes
|
|
|
|
|
@@ -7682,7 +7682,7 @@ if test "$_gui" = yes ; then
|
|
|
|
|
@@ -7696,7 +7696,7 @@ if test "$_gui" = yes ; then
|
|
|
|
|
|
|
|
|
|
# Required libraries
|
|
|
|
|
if test "$ffmpeg" != yes ||
|
|
|
|
@ -19,9 +19,9 @@ diff -up mplayer-export-2013-03-24/configure.ffmpeg mplayer-export-2013-03-24/co
|
|
|
|
|
die "The GUI requires libavcodec with PNG support (needs zlib)."
|
|
|
|
|
fi
|
|
|
|
|
test "$_freetype" = no && test "$_bitmap_font" = no &&
|
|
|
|
|
diff -up mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h
|
|
|
|
|
--- mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h.ffmpeg 2013-03-23 08:28:56.004725783 +0100
|
|
|
|
|
+++ mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h 2013-03-23 08:28:56.004725783 +0100
|
|
|
|
|
diff -up mplayer-export-2013-08-01/ffmpeg/libavformat/internal.h.ffmpeg mplayer-export-2013-08-01/ffmpeg/libavformat/internal.h
|
|
|
|
|
--- mplayer-export-2013-08-01/ffmpeg/libavformat/internal.h.ffmpeg 2013-08-01 12:37:20.818714103 +0200
|
|
|
|
|
+++ mplayer-export-2013-08-01/ffmpeg/libavformat/internal.h 2013-08-01 12:37:20.818714103 +0200
|
|
|
|
|
@@ -0,0 +1,32 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * copyright (c) 2001 Fabrice Bellard
|
|
|
|
@ -50,15 +50,15 @@ diff -up mplayer-export-2013-03-24/ffmpeg/libavformat/internal.h.ffmpeg mplayer-
|
|
|
|
|
+#include <libavformat/avformat.h>
|
|
|
|
|
+
|
|
|
|
|
+typedef struct AVCodecTag {
|
|
|
|
|
+ enum CodecID id;
|
|
|
|
|
+ enum AVCodecID id;
|
|
|
|
|
+ unsigned int tag;
|
|
|
|
|
+} AVCodecTag;
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVFORMAT_INTERNAL_H */
|
|
|
|
|
diff -up mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h
|
|
|
|
|
--- mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg 2013-03-23 08:28:56.005725790 +0100
|
|
|
|
|
+++ mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h 2013-03-23 08:28:56.005725790 +0100
|
|
|
|
|
@@ -0,0 +1,110 @@
|
|
|
|
|
diff -up mplayer-export-2013-08-01/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-export-2013-08-01/ffmpeg/libavutil/x86/asm.h
|
|
|
|
|
--- mplayer-export-2013-08-01/ffmpeg/libavutil/x86/asm.h.ffmpeg 2013-08-01 12:37:20.818714103 +0200
|
|
|
|
|
+++ mplayer-export-2013-08-01/ffmpeg/libavutil/x86/asm.h 2013-08-01 12:39:29.232657100 +0200
|
|
|
|
|
@@ -0,0 +1,112 @@
|
|
|
|
|
+/*
|
|
|
|
|
+ * copyright (c) 2006 Michael Niedermayer <michaelni@gmx.at>
|
|
|
|
|
+ *
|
|
|
|
@ -85,6 +85,8 @@ diff -up mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-exp
|
|
|
|
|
+#include <stdint.h>
|
|
|
|
|
+#include "config.h"
|
|
|
|
|
+
|
|
|
|
|
+typedef struct xmm_reg { uint64_t a, b; } xmm_reg;
|
|
|
|
|
+
|
|
|
|
|
+#if ARCH_X86_64
|
|
|
|
|
+# define OPSIZE "q"
|
|
|
|
|
+# define REG_a "rax"
|
|
|
|
@ -169,10 +171,10 @@ diff -up mplayer-export-2013-03-24/ffmpeg/libavutil/x86/asm.h.ffmpeg mplayer-exp
|
|
|
|
|
+#define MANGLE(a) EXTERN_PREFIX LOCAL_MANGLE(a)
|
|
|
|
|
+
|
|
|
|
|
+#endif /* AVUTIL_X86_ASM_H */
|
|
|
|
|
diff -up mplayer-export-2013-03-24/Makefile.ffmpeg mplayer-export-2013-03-24/Makefile
|
|
|
|
|
--- mplayer-export-2013-03-24/Makefile.ffmpeg 2013-03-23 08:28:55.000000000 +0100
|
|
|
|
|
+++ mplayer-export-2013-03-24/Makefile 2013-03-23 08:29:01.000760529 +0100
|
|
|
|
|
@@ -773,7 +773,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
|
|
|
|
|
diff -up mplayer-export-2013-08-01/Makefile.ffmpeg mplayer-export-2013-08-01/Makefile
|
|
|
|
|
--- mplayer-export-2013-08-01/Makefile.ffmpeg 2013-08-01 12:37:20.815714081 +0200
|
|
|
|
|
+++ mplayer-export-2013-08-01/Makefile 2013-08-01 12:37:20.818714103 +0200
|
|
|
|
|
@@ -775,7 +775,7 @@ mencoder$(EXESUF) mplayer$(EXESUF):
|
|
|
|
|
codec-cfg-test$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DTESTING
|
|
|
|
|
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
|
|
|
|
|
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
|
|
|
|
|