Update to latest svn

el8
Leigh Scott 4 years ago
parent 5dcb87b1ea
commit 08c92d47d2

1
.gitignore vendored

@ -5,3 +5,4 @@ MPlayer-1.3.0.tar.xz
/mplayer-export-2018-06-20.tar.bz2
/mplayer-export-2019-04-16.tar.bz2
/MPlayer-1.4.tar.xz
/mplayer-export-2021-03-13.tar.xz

@ -1,46 +0,0 @@
From 03e10eabcd7b72c3730ca75ffe5276db2b7de1b6 Mon Sep 17 00:00:00 2001
From: al <al@b3059339-0415-0410-9bf9-f77b7e298cf2>
Date: Tue, 24 Dec 2019 10:41:24 +0000
Subject: [PATCH 1/5] codecs.conf: Add AV1 decoder dav1d via FFmpeg
Thanks to
* Andrew-R (in ticket #2355)
* Sylvain (on mplayer-dev-eng ml)
* Carl Eugen Hoyos (in private communication)
You all provided helpful patches, suggestions and comments!
Fixes part of ticket #2355
git-svn-id: svn://git.mplayerhq.hu/mplayer/trunk@38155 b3059339-0415-0410-9bf9-f77b7e298cf2
---
etc/codecs.conf | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/etc/codecs.conf b/etc/codecs.conf
index 8b3db9797..a0757c79d 100644
--- a/etc/codecs.conf
+++ b/etc/codecs.conf
@@ -8,6 +8,16 @@ release 20111012
;=============================================================================
; VIDEO CODECS
;=============================================================================
+videocodec fflibdav1d
+ info "FFmpeg wrapper for libdav1d"
+ status working
+ fourcc AV01,av01
+ driver ffmpeg
+ dll libdav1d
+ out YV12,420P10,420P12
+ out 422P,422P10,422P12
+ out 444P,444P10,444P12
+ out GBR24P,GBR10P,GBR12P
videocodec ffiff
info "FFmpeg IFF ANIM/ILBM/PBM/RGB8/RGBN"
--
2.26.0

@ -1,34 +0,0 @@
From 327dd40996e0eb671c3f6cdcdc429d9a7be25187 Mon Sep 17 00:00:00 2001
From: al <al@b3059339-0415-0410-9bf9-f77b7e298cf2>
Date: Tue, 24 Dec 2019 10:43:45 +0000
Subject: [PATCH 2/5] codecs.conf: Add AOM AV1 decoder via FFmpeg
git-svn-id: svn://git.mplayerhq.hu/mplayer/trunk@38156 b3059339-0415-0410-9bf9-f77b7e298cf2
---
etc/codecs.conf | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/etc/codecs.conf b/etc/codecs.conf
index a0757c79d..fa8f1fedb 100644
--- a/etc/codecs.conf
+++ b/etc/codecs.conf
@@ -19,6 +19,16 @@ videocodec fflibdav1d
out 444P,444P10,444P12
out GBR24P,GBR10P,GBR12P
+videocodec fflibaomav1
+ info "FFmpeg wrapper for libaom/AV1"
+ status working
+ fourcc AV01,av01
+ driver ffmpeg
+ dll libaom-av1
+ out YV12,420P10,420P12
+ out 422P,422P10,422P12
+ out 444P,444P10,444P12
+
videocodec ffiff
info "FFmpeg IFF ANIM/ILBM/PBM/RGB8/RGBN"
status working
--
2.26.0

@ -1,38 +0,0 @@
From 667b86fb135c4ee16a3dc1978c170c42b43a0ae3 Mon Sep 17 00:00:00 2001
From: al <al@b3059339-0415-0410-9bf9-f77b7e298cf2>
Date: Tue, 24 Dec 2019 10:46:23 +0000
Subject: [PATCH 3/5] codecs.conf: Bump version
In SVN r38154 , ffmpeg12vdpau was removed and ffmpeg1vdpau and
ffmpeg2vdpau were added as replacement.
In previous commits AV1 codecs were added, and a lot more changes
were done in 8 years.
Bump codecs.conf, so users with a customized codecs.conf based on
an older version will fallback to the internal version and get a
message about having an outdated codecs.conf lying around.
git-svn-id: svn://git.mplayerhq.hu/mplayer/trunk@38157 b3059339-0415-0410-9bf9-f77b7e298cf2
---
etc/codecs.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/etc/codecs.conf b/etc/codecs.conf
index fa8f1fedb..f4ff4425b 100644
--- a/etc/codecs.conf
+++ b/etc/codecs.conf
@@ -3,7 +3,7 @@
; Before editing this file, please read DOCS/tech/codecs.conf.txt !
;=============================================================================
-release 20111012
+release 20191203
;=============================================================================
; VIDEO CODECS
--
2.26.0

@ -6,7 +6,7 @@ diff -up mplayer-export-2015-05-05/Makefile.ffmpeg mplayer-export-2015-05-05/Mak
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
- $(HOST_CC) $(HOSTCFLAGS) -o $@ $<
+ $(HOST_CC) $(HOSTCFLAGS) $(CFLAGS)-o $@ $<
+ $(HOST_CC) $(HOSTCFLAGS) $(CFLAGS) -o $@ $<
codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
./$^ > $@

@ -1,7 +1,6 @@
diff -up mplayer-export-2009-10-29/Makefile.manlinks mplayer-export-2009-10-29/Makefile
--- mplayer-export-2009-10-29/Makefile.manlinks 2009-10-19 11:56:18.000000000 +0200
+++ mplayer-export-2009-10-29/Makefile 2009-10-30 00:42:36.000000000 +0100
@@ -922,10 +922,10 @@ install-mencoder-man: $(foreach lang,$(M
--- a/Makefile
+++ b/Makefile
@@ -880,10 +880,10 @@ install-mencoder-man: $(foreach lang,$(M
install-mplayer-man: $(foreach lang,$(MAN_LANGS),install-mplayer-man-$(lang))
install-gui-man-en: install-mplayer-man-en
@ -14,7 +13,7 @@ diff -up mplayer-export-2009-10-29/Makefile.manlinks mplayer-export-2009-10-29/M
install-mplayer-man-en:
$(INSTALL) -d $(MANDIR)/man1
@@ -933,12 +933,12 @@ install-mplayer-man-en:
@@ -897,7 +897,7 @@ endef
define GUI_MAN_RULE
install-gui-man-$(lang): install-mplayer-man-$(lang)
@ -22,6 +21,9 @@ diff -up mplayer-export-2009-10-29/Makefile.manlinks mplayer-export-2009-10-29/M
+ echo ".so mplayer.1" > $(MANDIR)/$(lang)/man1/gmplayer.1
endef
define GUI_MSG_RULE
@@ -908,7 +908,7 @@ endef
define MENCODER_MAN_RULE
install-mencoder-man-$(lang): install-mplayer-man-$(lang)
- cd $(MANDIR)/$(lang)/man1 && ln -sf mplayer.1 mencoder.1
@ -29,4 +31,3 @@ diff -up mplayer-export-2009-10-29/Makefile.manlinks mplayer-export-2009-10-29/M
endef
define MPLAYER_MAN_RULE
E

@ -13,7 +13,7 @@ cleanup() {
unset CDPATH
pwd=$(pwd)
svn=$(date +%Y-%m-%d)
svn=2019-04-16
#svn=2019-04-16
dirname=mplayer-export-$svn
mplayer_rev={$svn}
#mplayer_rev=HEAD
@ -26,5 +26,5 @@ svn_revision=`LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2`
sed -i -e 's/\(SVN-r[0-9]* \)/\1rpmfusion /' -e "s/UNKNOWN/SVN-r$svn_revision/" version.sh
find . -type d -name .svn -print0 | xargs -0r rm -rf
cd ..
tar jcf "$pwd"/$dirname.tar.bz2 $dirname
tar Jcf "$pwd"/$dirname.tar.xz $dirname
cd - >/dev/null

@ -1,37 +0,0 @@
From 7ba6fc7408b5fb46c698e17471d12dd53d5685ec Mon Sep 17 00:00:00 2001
From: reimar <reimar@b3059339-0415-0410-9bf9-f77b7e298cf2>
Date: Sun, 1 Nov 2020 15:07:44 +0000
Subject: [PATCH] ad_spdif: Use avformat_free_context to free context.
This avoids memleaks and in newest FFmpeg versions also
compile errors.
git-svn-id: svn://git.mplayerhq.hu/mplayer/trunk@38199 b3059339-0415-0410-9bf9-f77b7e298cf2
---
libmpcodecs/ad_spdif.c | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/libmpcodecs/ad_spdif.c b/libmpcodecs/ad_spdif.c
index 1fc237b..8ee4724 100644
--- a/libmpcodecs/ad_spdif.c
+++ b/libmpcodecs/ad_spdif.c
@@ -298,14 +298,8 @@ static void uninit(sh_audio_t *sh)
if (spdif_ctx->header_written)
av_write_trailer(lavf_ctx);
av_freep(&lavf_ctx->pb);
- if (lavf_ctx->streams) {
- av_freep(&lavf_ctx->streams[0]->codec);
- av_freep(&lavf_ctx->streams[0]->info);
- av_freep(&lavf_ctx->streams[0]);
- }
- av_freep(&lavf_ctx->streams);
- av_freep(&lavf_ctx->priv_data);
+ avformat_free_context(lavf_ctx);
+ lavf_ctx = NULL;
}
- av_freep(&lavf_ctx);
av_freep(&spdif_ctx);
}
--
2.7.4

@ -3,16 +3,16 @@
%endif
%define codecdir %{_libdir}/codecs
#define pre 20190416svn
#define svn 1
#define svnbuild 2019-04-16
%define pre 20210313svn
%define svn 1
%define svnbuild 2021-03-13
Name: mplayer
Version: 1.4
Version: 1.4.1
%if 0%{?svn}
Release: 15{?pre:.%{pre}}%{?dist}
Release: 0.1%{?pre:.%{pre}}%{?dist}
%else
Release: 15%{?dist}
Release: 2%{?dist}
%endif
Summary: Movie player playing most video formats and DVDs
@ -24,7 +24,7 @@ License: GPLv2+
URL: https://www.mplayerhq.hu/
%if 0%{?svn}
# run ./mplayer-snapshot.sh to get this
Source0: mplayer-export-%{svnbuild}.tar.bz2
Source0: mplayer-export-%{svnbuild}.tar.xz
%else
Source0: https://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{?pre}.tar.xz
%endif
@ -35,12 +35,7 @@ Patch0: %{name}-config.patch
# use roff include statements instead of symlinks
Patch1: %{name}-manlinks.patch
# use system FFmpeg libraries
Patch3: %{name}-ffmpeg.patch
Patch4: 0001-codecs.conf-Add-AV1-decoder-dav1d-via-FFmpeg.patch
Patch5: 0002-codecs.conf-Add-AOM-AV1-decoder-via-FFmpeg.patch
Patch6: 0003-codecs.conf-Bump-version.patch
Patch7: mplayer.git-7ba6fc7408b5fb46c698e17471d12dd53d5685ec.patch
Patch2: %{name}-ffmpeg.patch
BuildRequires: SDL-devel
BuildRequires: a52dec-devel
@ -232,11 +227,7 @@ rm -rf ffmpeg
%endif
%patch0 -p1 -b .config
%patch1 -p1 -b .manlinks
%patch3 -p1 -b .ffmpeg
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch2 -p1 -b .ffmpeg
mkdir GUI
cp -a `ls -1|grep -v GUI` GUI/
@ -385,6 +376,9 @@ fi
%{_datadir}/mplayer/*.fp
%changelog
* Sat Mar 13 2021 Leigh Scott <leigh123linux@gmail.com> - 1.4.1-0.1.20210313svn
- Update to latest svn
* Wed Feb 03 2021 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.4-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

@ -1,2 +1 @@
de7b4438b68729089d92912f041abe54 Blue-1.11.tar.bz2
58d39f72bf7f3ddaa9e019224bffcb74 MPlayer-1.4.tar.xz
SHA512 (mplayer-export-2021-03-13.tar.xz) = d9a423e7d4ef8346f5944e8f0aab0dea4415aa85ff0fea0ff119fdbd48c1a7c683bd5e17f3efc1b7d3bced50466584456de615e2d312019958beabcc0694b4fe

Loading…
Cancel
Save