c8-stream-3.6
imports/c8-stream-3.6/mongo-java-driver-3.6.4-1.module_el8.0.0+31+fdc76a87
commit
01b6f5d2e2
@ -0,0 +1 @@
|
||||
SOURCES/r3.6.4.tar.gz
|
@ -0,0 +1 @@
|
||||
3a7089619035cdd0e70a9f0b0f6a532b9b696eb4 SOURCES/r3.6.4.tar.gz
|
@ -0,0 +1,616 @@
|
||||
From ce1fc6cd336f623101a72b6d3de3d95d42998316 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Fri, 23 Jun 2017 18:21:43 +0200
|
||||
Subject: [PATCH] Maven support
|
||||
|
||||
---
|
||||
bson/pom.xml | 90 ++++++++++++++
|
||||
driver-async/pom.xml | 106 +++++++++++++++++
|
||||
driver-core/pom.xml | 120 +++++++++++++++++++
|
||||
.../unit/com/mongodb/ConnectionStringTest.java | 2 +-
|
||||
driver/pom.xml | 77 ++++++++++++
|
||||
mongo-java-driver/pom.xml | 130 +++++++++++++++++++++
|
||||
pom.xml | 27 +++++
|
||||
7 files changed, 551 insertions(+), 1 deletion(-)
|
||||
create mode 100644 bson/pom.xml
|
||||
create mode 100644 driver-async/pom.xml
|
||||
create mode 100644 driver-core/pom.xml
|
||||
create mode 100644 driver/pom.xml
|
||||
create mode 100644 mongo-java-driver/pom.xml
|
||||
create mode 100644 pom.xml
|
||||
|
||||
diff --git a/bson/pom.xml b/bson/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..4076687
|
||||
--- /dev/null
|
||||
+++ b/bson/pom.xml
|
||||
@@ -0,0 +1,90 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <name>BSON</name>
|
||||
+ <description>The BSON library</description>
|
||||
+ <url>http://bsonspec.org</url>
|
||||
+ <packaging>bundle</packaging>
|
||||
+ <licenses>
|
||||
+ <license>
|
||||
+ <name>The Apache Software License, Version 2.0</name>
|
||||
+ <url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
+ <distribution>repo</distribution>
|
||||
+ </license>
|
||||
+ </licenses>
|
||||
+ <developers>
|
||||
+ <developer>
|
||||
+ <name>Various</name>
|
||||
+ <organization>MongoDB</organization>
|
||||
+ </developer>
|
||||
+ </developers>
|
||||
+ <scm>
|
||||
+ <connection>scm:https://github.com/mongodb/mongo-java-driver.git</connection>
|
||||
+ <developerConnection>scm:git@github.com:mongodb/mongo-java-driver.git</developerConnection>
|
||||
+ <url>https://github.com/mongodb/mongo-java-driver</url>
|
||||
+ </scm>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>org.slf4j</groupId>
|
||||
+ <artifactId>slf4j-api</artifactId>
|
||||
+ <version>1.7.6</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>junit</groupId>
|
||||
+ <artifactId>junit</artifactId>
|
||||
+ <version>4.12</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ <build>
|
||||
+ <sourceDirectory>src/main</sourceDirectory>
|
||||
+ <testSourceDirectory>src/test/unit</testSourceDirectory>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <configuration>
|
||||
+ <source>1.7</source>
|
||||
+ <target>1.7</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-jar-plugin</artifactId>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <goals>
|
||||
+ <goal>test-jar</goal>
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <extensions>true</extensions>
|
||||
+ <configuration>
|
||||
+ <instructions>
|
||||
+ <Bundle-Vendor>Red Hat, Inc.</Bundle-Vendor>
|
||||
+ <Bundle-SymbolicName>org.mongodb.bson</Bundle-SymbolicName>
|
||||
+ <Export-Package>org.bson,org.bson.*</Export-Package>
|
||||
+ <Import-Package>
|
||||
+ javax.xml.bind.*,
|
||||
+ org.slf4j;resolution:=optional,
|
||||
+ </Import-Package>
|
||||
+ <!-- Do not autogenerate uses clauses in Manifests -->
|
||||
+ <_nouses>true</_nouses>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+</project>
|
||||
diff --git a/driver-async/pom.xml b/driver-async/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..7771e1b
|
||||
--- /dev/null
|
||||
+++ b/driver-async/pom.xml
|
||||
@@ -0,0 +1,106 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </parent>
|
||||
+
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver-async</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <name>MongoDB Asynchronous Driver</name>
|
||||
+ <description>The MongoDB Asynchronous Driver</description>
|
||||
+ <url>http://www.mongodb.org</url>
|
||||
+ <packaging>bundle</packaging>
|
||||
+ <licenses>
|
||||
+ <license>
|
||||
+ <name>The Apache Software License, Version 2.0</name>
|
||||
+ <url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
+ <distribution>repo</distribution>
|
||||
+ </license>
|
||||
+ </licenses>
|
||||
+ <developers>
|
||||
+ <developer>
|
||||
+ <name>Various</name>
|
||||
+ <organization>MongoDB</organization>
|
||||
+ </developer>
|
||||
+ </developers>
|
||||
+ <scm>
|
||||
+ <connection>scm:https://github.com/mongodb/mongo-java-driver.git</connection>
|
||||
+ <developerConnection>scm:git@github.com:mongodb/mongo-java-driver.git</developerConnection>
|
||||
+ <url>https://github.com/mongodb/mongo-java-driver</url>
|
||||
+ </scm>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver-core</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-transport</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.slf4j</groupId>
|
||||
+ <artifactId>slf4j-api</artifactId>
|
||||
+ <version>1.7.6</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>junit</groupId>
|
||||
+ <artifactId>junit</artifactId>
|
||||
+ <version>4.12</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ <build>
|
||||
+ <sourceDirectory>src/main</sourceDirectory>
|
||||
+ <testSourceDirectory>src/test/unit</testSourceDirectory>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <configuration>
|
||||
+ <source>1.7</source>
|
||||
+ <target>1.7</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <extensions>true</extensions>
|
||||
+ <configuration>
|
||||
+ <instructions>
|
||||
+ <Bundle-Vendor>Red Hat, Inc.</Bundle-Vendor>
|
||||
+ <Bundle-SymbolicName>org.mongodb.driver-async</Bundle-SymbolicName>
|
||||
+ <Export-Package>com.mongodb.*</Export-Package>
|
||||
+ <Import-Package>
|
||||
+ org.bson.*,
|
||||
+ javax.crypto.*,
|
||||
+ javax.crypto.spec.*,
|
||||
+ javax.management.*,
|
||||
+ javax.net.*,
|
||||
+ javax.net.ssl.*,
|
||||
+ javax.security.sasl.*,
|
||||
+ javax.security.auth.callback.*,
|
||||
+ org.ietf.jgss.*,
|
||||
+ io.netty.*;resolution:=optional,
|
||||
+ org.slf4j;resolution:=optional,
|
||||
+ </Import-Package>
|
||||
+ <!-- Do not autogenerate uses clauses in Manifests -->
|
||||
+ <_nouses>true</_nouses>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+</project>
|
||||
diff --git a/driver-core/pom.xml b/driver-core/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..3f6804b
|
||||
--- /dev/null
|
||||
+++ b/driver-core/pom.xml
|
||||
@@ -0,0 +1,126 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver-core</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <name>MongoDB Java Driver Core</name>
|
||||
+ <description>The Java operations layer for the MongoDB Java Driver. Third parties can ' +
|
||||
+ 'wrap this layer to provide custom higher-level APIs</description>
|
||||
+ <url>http://www.mongodb.org</url>
|
||||
+ <packaging>bundle</packaging>
|
||||
+ <licenses>
|
||||
+ <license>
|
||||
+ <name>The Apache Software License, Version 2.0</name>
|
||||
+ <url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
+ <distribution>repo</distribution>
|
||||
+ </license>
|
||||
+ </licenses>
|
||||
+ <developers>
|
||||
+ <developer>
|
||||
+ <name>Various</name>
|
||||
+ <organization>MongoDB</organization>
|
||||
+ </developer>
|
||||
+ </developers>
|
||||
+ <scm>
|
||||
+ <connection>scm:https://github.com/mongodb/mongo-java-driver.git</connection>
|
||||
+ <developerConnection>scm:git@github.com:mongodb/mongo-java-driver.git</developerConnection>
|
||||
+ <url>https://github.com/mongodb/mongo-java-driver</url>
|
||||
+ </scm>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.xerial.snappy</groupId>
|
||||
+ <artifactId>snappy-java</artifactId>
|
||||
+ <version>1.1.4</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-buffer</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-transport</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-handler</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.slf4j</groupId>
|
||||
+ <artifactId>slf4j-api</artifactId>
|
||||
+ <version>1.7.6</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <type>test-jar</type>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>junit</groupId>
|
||||
+ <artifactId>junit</artifactId>
|
||||
+ <version>4.12</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ <build>
|
||||
+ <sourceDirectory>src/main</sourceDirectory>
|
||||
+ <testSourceDirectory>src/test/unit</testSourceDirectory>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <configuration>
|
||||
+ <source>1.7</source>
|
||||
+ <target>1.7</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <extensions>true</extensions>
|
||||
+ <configuration>
|
||||
+ <instructions>
|
||||
+ <Bundle-Vendor>Red Hat, Inc.</Bundle-Vendor>
|
||||
+ <Bundle-SymbolicName>org.mongodb.driver-core</Bundle-SymbolicName>
|
||||
+ <Export-Package>com.mongodb.*</Export-Package>
|
||||
+ <Import-Package>
|
||||
+ org.bson.*,
|
||||
+ javax.crypto.*,
|
||||
+ javax.crypto.spec.*,
|
||||
+ javax.management.*,
|
||||
+ javax.net.*,
|
||||
+ javax.net.ssl.*,
|
||||
+ javax.security.sasl.*,
|
||||
+ javax.security.auth.callback.*,
|
||||
+ org.ietf.jgss.*,
|
||||
+ io.netty.*;resolution:=optional,
|
||||
+ org.slf4j;resolution:=optional,
|
||||
+ </Import-Package>
|
||||
+ <!-- Do not autogenerate uses clauses in Manifests -->
|
||||
+ <_nouses>true</_nouses>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+</project>
|
||||
diff --git a/driver/pom.xml b/driver/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..c2b9606
|
||||
--- /dev/null
|
||||
+++ b/driver/pom.xml
|
||||
@@ -0,0 +1,77 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <name>MongoDB Driver</name>
|
||||
+ <description>The MongoDB Driver</description>
|
||||
+ <url>http://www.mongodb.org</url>
|
||||
+ <licenses>
|
||||
+ <license>
|
||||
+ <name>The Apache Software License, Version 2.0</name>
|
||||
+ <url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
+ <distribution>repo</distribution>
|
||||
+ </license>
|
||||
+ </licenses>
|
||||
+ <developers>
|
||||
+ <developer>
|
||||
+ <name>Various</name>
|
||||
+ <organization>MongoDB</organization>
|
||||
+ </developer>
|
||||
+ </developers>
|
||||
+ <scm>
|
||||
+ <connection>scm:https://github.com/mongodb/mongo-java-driver.git</connection>
|
||||
+ <developerConnection>scm:git@github.com:mongodb/mongo-java-driver.git</developerConnection>
|
||||
+ <url>https://github.com/mongodb/mongo-java-driver</url>
|
||||
+ </scm>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver-core</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.slf4j</groupId>
|
||||
+ <artifactId>slf4j-api</artifactId>
|
||||
+ <version>1.7.6</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>junit</groupId>
|
||||
+ <artifactId>junit</artifactId>
|
||||
+ <version>4.12</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.hamcrest</groupId>
|
||||
+ <artifactId>hamcrest-library</artifactId>
|
||||
+ <version>1.3</version>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ <build>
|
||||
+ <sourceDirectory>src/main</sourceDirectory>
|
||||
+ <testSourceDirectory>src/test/unit</testSourceDirectory>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <configuration>
|
||||
+ <source>1.7</source>
|
||||
+ <target>1.7</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+</project>
|
||||
diff --git a/mongo-java-driver/pom.xml b/mongo-java-driver/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..14092e0
|
||||
--- /dev/null
|
||||
+++ b/mongo-java-driver/pom.xml
|
||||
@@ -0,0 +1,130 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ </parent>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongo-java-driver</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <name>MongoDB Java Driver</name>
|
||||
+ <description>The MongoDB Java Driver uber-artifact, containing mongodb-driver, mongodb-driver-core, and bson</description>
|
||||
+ <url>http://www.mongodb.org</url>
|
||||
+ <packaging>bundle</packaging>
|
||||
+ <licenses>
|
||||
+ <license>
|
||||
+ <name>The Apache Software License, Version 2.0</name>
|
||||
+ <url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
|
||||
+ <distribution>repo</distribution>
|
||||
+ </license>
|
||||
+ </licenses>
|
||||
+ <developers>
|
||||
+ <developer>
|
||||
+ <name>Various</name>
|
||||
+ <organization>MongoDB</organization>
|
||||
+ </developer>
|
||||
+ </developers>
|
||||
+ <scm>
|
||||
+ <connection>scm:https://github.com/mongodb/mongo-java-driver.git</connection>
|
||||
+ <developerConnection>scm:git@github.com:mongodb/mongo-java-driver.git</developerConnection>
|
||||
+ <url>https://github.com/mongodb/mongo-java-driver</url>
|
||||
+ </scm>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-buffer</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-transport</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>io.netty</groupId>
|
||||
+ <artifactId>netty-handler</artifactId>
|
||||
+ <version>4.0.26.Final</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.slf4j</groupId>
|
||||
+ <artifactId>slf4j-api</artifactId>
|
||||
+ <version>1.7.6</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>mongodb-driver-core</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>bson</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <optional>true</optional>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ <build>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-shade-plugin</artifactId>
|
||||
+ <version>2.4.3</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <phase>package</phase>
|
||||
+ <goals>
|
||||
+ <goal>shade</goal>
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <configuration>
|
||||
+ <artifactSet>
|
||||
+ <includes>
|
||||
+ <include>org.mongodb:*</include>
|
||||
+ </includes>
|
||||
+ </artifactSet>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <extensions>true</extensions>
|
||||
+ <configuration>
|
||||
+ <instructions>
|
||||
+ <Bundle-Vendor>Red Hat, Inc.</Bundle-Vendor>
|
||||
+ <Bundle-SymbolicName>org.mongodb.mongo-java-driver</Bundle-SymbolicName>
|
||||
+ <Export-Package>
|
||||
+ com.mongodb.*,
|
||||
+ org.bson.*,
|
||||
+ </Export-Package>
|
||||
+ <Import-Package>
|
||||
+ javax.xml.bind.*,
|
||||
+ javax.crypto.*,
|
||||
+ javax.management.*,
|
||||
+ javax.net.*,
|
||||
+ javax.security.sasl.*,
|
||||
+ javax.security.auth.callback.*,
|
||||
+ org.ietf.jgss.*,
|
||||
+ io.netty.*;resolution:=optional,
|
||||
+ org.slf4j;resolution:=optional,
|
||||
+ </Import-Package>
|
||||
+ <!-- Do not autogenerate uses clauses in Manifests -->
|
||||
+ <_nouses>true</_nouses>
|
||||
+ </instructions>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+</project>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
new file mode 100644
|
||||
index 0000000..63c6925
|
||||
--- /dev/null
|
||||
+++ b/pom.xml
|
||||
@@ -0,0 +1,27 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
|
||||
+ <modelVersion>4.0.0</modelVersion>
|
||||
+ <groupId>org.mongodb</groupId>
|
||||
+ <artifactId>aggregator-project</artifactId>
|
||||
+ <version>@VERSION@</version>
|
||||
+ <packaging>pom</packaging>
|
||||
+ <modules>
|
||||
+ <module>mongo-java-driver</module>
|
||||
+ <module>bson</module>
|
||||
+ <module>driver-core</module>
|
||||
+ <module>driver-async</module>
|
||||
+ <module>driver</module>
|
||||
+ </modules>
|
||||
+ <build>
|
||||
+ <pluginManagement>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <groupId>org.apache.felix</groupId>
|
||||
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||
+ <version>1.4.0</version>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </pluginManagement>
|
||||
+ </build>
|
||||
+</project>
|
||||
--
|
||||
2.9.4
|
||||
|
@ -0,0 +1,202 @@
|
||||
%{?scl:%scl_package mongo-java-driver}
|
||||
%{!?scl:%global pkg_name %{name}}
|
||||
|
||||
Name: %{?scl_prefix}mongo-java-driver
|
||||
Version: 3.6.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A Java driver for MongoDB
|
||||
|
||||
Group: Development/Libraries
|
||||
BuildArch: noarch
|
||||
License: ASL 2.0
|
||||
URL: http://www.mongodb.org/display/DOCS/Java+Language+Center
|
||||
Source0: https://github.com/mongodb/%{pkg_name}/archive/r%{version}.tar.gz
|
||||
Patch0: 0001-Maven-support.patch
|
||||
|
||||
BuildRequires: %{?scl_prefix_maven}maven-local
|
||||
BuildRequires: %{?scl_prefix_maven}mvn(org.slf4j:slf4j-api)
|
||||
BuildRequires: %{?scl_prefix_maven}mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: %{?scl_prefix_maven}mvn(org.apache.maven.plugins:maven-shade-plugin)
|
||||
BuildRequires: %{?scl_prefix_maven}mvn(org.hamcrest:hamcrest-library)
|
||||
BuildRequires: %{?scl_prefix_maven}mvn(org.xerial.snappy:snappy-java)
|
||||
|
||||
BuildRequires: %{?scl_prefix}mvn(io.netty:netty-buffer)
|
||||
BuildRequires: %{?scl_prefix}mvn(io.netty:netty-transport)
|
||||
BuildRequires: %{?scl_prefix}mvn(io.netty:netty-handler)
|
||||
|
||||
%description
|
||||
This is the Java driver for MongoDB.
|
||||
|
||||
%package bson
|
||||
Summary: A Java-based BSON implementation
|
||||
Group: Development/Libraries
|
||||
|
||||
%description bson
|
||||
This is the Java implementation of BSON that the Java driver for
|
||||
MongoDB ships with. It can be used separately by Java applications
|
||||
that require BSON.
|
||||
# Upstream has hinted that eventually, their bson implementation will
|
||||
# be better separated out: http://bsonspec.org/#/implementation
|
||||
# To make things easier for when that does happen, for now the jar
|
||||
# and javadocs for this are in separate subpackages.
|
||||
|
||||
%package driver
|
||||
Summary: The MongoDB Java Driver
|
||||
Group: Development/Libraries
|
||||
|
||||
%description driver
|
||||
The MongoDB Java Driver
|
||||
|
||||
%package driver-core
|
||||
Summary: The MongoDB Java Operations Layer
|
||||
Group: Development/Libraries
|
||||
|
||||
%description driver-core
|
||||
The Java operations layer for the MongoDB Java Driver. Third
|
||||
parties can wrap this layer to provide custom higher-level APIs
|
||||
|
||||
%package driver-async
|
||||
Summary: The MongoDB Java Async Driver
|
||||
Group: Development/Libraries
|
||||
|
||||
%description driver-async
|
||||
The MongoDB Asynchronous Driver.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
Group: Documentation
|
||||
|
||||
%description javadoc
|
||||
This package contains the API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -qn %{pkg_name}-r%{version}
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
sed -i 's/@VERSION@/%{version}/g' `find -name pom.xml`
|
||||
|
||||
find -name '*.class' -exec rm -f '{}' \;
|
||||
find -name '*.jar' -exec rm -f '{}' \;
|
||||
|
||||
%mvn_package org.mongodb:bson:* %{pkg_name}-bson
|
||||
%mvn_package org.mongodb:%{pkg_name}:* %{pkg_name}
|
||||
%mvn_package org.mongodb:mongodb-driver-core:* %{pkg_name}-driver-core
|
||||
%mvn_package org.mongodb:mongodb-driver-async:* %{pkg_name}-driver-async
|
||||
%mvn_package org.mongodb:mongodb-driver:* %{pkg_name}-driver
|
||||
%mvn_package org.mongodb:mongodb-javadoc-utils:* __noinstall
|
||||
%mvn_file org.mongodb:bson:* %{pkg_name}/bson
|
||||
%mvn_file org.mongodb:%{pkg_name}:* %{pkg_name}/mongo
|
||||
%mvn_file org.mongodb:mongodb-driver-core:* %{pkg_name}/driver-core
|
||||
%mvn_file org.mongodb:mongodb-driver-async:* %{pkg_name}/driver-async
|
||||
%mvn_file org.mongodb:mongodb-driver:* %{pkg_name}/driver
|
||||
|
||||
%build
|
||||
export MAVEN_OPTS="-Xmx2048m"
|
||||
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles-%{pkg_name} -f .mfiles
|
||||
%doc README.md LICENSE.txt
|
||||
|
||||
%files bson -f .mfiles-%{pkg_name}-bson
|
||||
%doc README.md LICENSE.txt
|
||||
|
||||
%files driver -f .mfiles-%{pkg_name}-driver
|
||||
%doc README.md LICENSE.txt
|
||||
|
||||
%files driver-core -f .mfiles-%{pkg_name}-driver-core
|
||||
%doc README.md LICENSE.txt
|
||||
|
||||
%files driver-async -f .mfiles-%{pkg_name}-driver-async
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%doc README.md LICENSE.txt
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 06 2018 mskalick@redhat.com - 3.6.4-1
|
||||
- Rebase to upstream release 3.6.4
|
||||
|
||||
* Mon Feb 26 2018 Marek Skalický <mskalick@redhat.com> - 3.6.3-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Mon Aug 07 2017 Marek Skalický <mskalick@redhat.com> - 3.5.0-1
|
||||
- Update to latest upstream version
|
||||
|
||||
* Fri Jun 23 2017 Michael Simacek <msimacek@redhat.com> - 3.4.2-1
|
||||
- Update to 3.4.2 and rh-maven35
|
||||
|
||||
* Tue Mar 29 2016 Severin Gehwolf <sgehwolf@redhat.com> - 3.2.1-3
|
||||
- Add basic OSGi metadata.
|
||||
|
||||
* Thu Feb 18 2016 Marek Skalicky <mskalick@redhat.com> - 3.2.1-2
|
||||
- Fixed directory ownership
|
||||
|
||||
* Tue Feb 2 2016 Marek Skalicky <mskalick@redhat.com> - 3.2.1-1
|
||||
- Upgrade to 3.2.1 release (from Fedora 24)
|
||||
|
||||
* Mon Jul 27 2015 Severin Gehwolf <sgehwolf@redhat.com> - 2.13.2-5
|
||||
- Fix bugs in SCL-ization. Most importantly, pkg name prefix.
|
||||
|
||||
* Mon Jul 27 2015 Severin Gehwolf <sgehwolf@redhat.com> - 2.13.2-4
|
||||
- SCL-ize package.
|
||||
|
||||
* Mon Jun 22 2015 Omair Majid <omajid@redhat.com> - 2.13.2-3
|
||||
- Require javapackages-tools, not jpackage-utils.
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.13.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Jun 10 2015 Severin Gehwolf <sgehwolf@redhat.com> - 2.13.2-1
|
||||
- Update to lastest upstream version.
|
||||
- Resolves RHBZ#1178257.
|
||||
|
||||
* Tue Jun 10 2014 Severin Gehwolf <sgehwolf@redhat.com> - 2.11.3-4
|
||||
- Fix FTBFS. Resolves RHBZ#1106228.
|
||||
- Fix @VERSION@ substitution. Resolves RHBZ#1048200.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 2.11.3-2
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Tue Sep 24 2013 Severin Gehwolf <sgehwolf@redhat.com> - 2.11.3-1
|
||||
- Update to latest upstream release.
|
||||
|
||||
* Thu Sep 05 2013 Omair Majid <omajid@redhat.com> - 2.11.2-2
|
||||
- Do not require -bson subpackage. The classes are present in both jars.
|
||||
|
||||
* Fri Aug 30 2013 Omair Majid <omajid@redhat.com> - 2.11.2-1
|
||||
- Update to 2.11.2
|
||||
- Generate tarball from commit tag, according to packaging guidelines
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Apr 24 2012 Jon VanAlten <jon.vanalten@redhat.com> 2.7.3-1
|
||||
- Bump to 2.7.3.
|
||||
|
||||
* Mon Jan 16 2012 Alexander Kurtakov <akurtako@redhat.com> 2.6.5-4
|
||||
- Add depmap/pom.
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Nov 29 2011 Jon VanAlten <jon.vanalten@redhat.com> - 2.6.5-2
|
||||
- Sources moved to lookaside cache where they belong
|
||||
|
||||
* Tue Nov 29 2011 Jon VanAlten <jon.vanalten@redhat.com> - 2.6.5-1
|
||||
- Add missing BuildDep: git (git-hash is used during build)
|
||||
|
||||
* Tue Oct 11 2011 Jon VanAlten <jon.vanalten@redhat.com> - 2.6.5-1
|
||||
- Initial packaging of mongo-java-driver for Fedora.
|
Loading…
Reference in new issue