You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
mingw-SDL2/mingw-SDL2_lmingw32.patch

22 lines
783 B

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 644715a..23b7e13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1813,13 +1813,13 @@ elseif(WINDOWS)
file(GLOB VERSION_SOURCES ${SDL2_SOURCE_DIR}/src/main/windows/*.rc)
file(GLOB SDLMAIN_SOURCES ${SDL2_SOURCE_DIR}/src/main/windows/*.c)
if(MINGW OR CYGWIN)
- list(APPEND EXTRA_LIBS mingw32)
- list(APPEND EXTRA_LDFLAGS "-mwindows")
- list(APPEND SDL_LIBS "-lmingw32" "-mwindows")
if(NOT SDL2_DISABLE_SDL2MAIN)
set(SDL_CFLAGS "${SDL_CFLAGS} -Dmain=SDL_main")
list(APPEND SDL_LIBS "-lSDL2main")
endif(NOT SDL2_DISABLE_SDL2MAIN)
+ list(APPEND EXTRA_LIBS mingw32)
+ list(APPEND EXTRA_LDFLAGS "-mwindows")
+ list(APPEND SDL_LIBS "-lmingw32" "-mwindows")
endif()
elseif(APPLE)