You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
mingw-SDL2/mingw-SDL2_lmingw32.patch

13 lines
535 B

diff -rupN SDL2-2.0.20/CMakeLists.txt SDL2-2.0.20-new/CMakeLists.txt
--- SDL2-2.0.20/CMakeLists.txt 2022-01-08 22:13:56.000000000 +0100
+++ SDL2-2.0.20-new/CMakeLists.txt 2022-03-02 12:41:51.634494670 +0100
@@ -1787,7 +1787,7 @@ elseif(WINDOWS)
list(APPEND EXTRA_LIBS mingw32)
list(APPEND EXTRA_LDFLAGS "-mwindows")
set(SDL_CFLAGS "${SDL_CFLAGS} -Dmain=SDL_main")
- list(APPEND SDL_LIBS "-lmingw32" "-lSDL2main" "-mwindows")
+ list(APPEND SDL_LIBS "-lSDL2main" "-lmingw32" "-mwindows")
endif()
elseif(APPLE)