commit
70aa66ec9f
@ -0,0 +1 @@
|
||||
SOURCES/mesa-demos-9.0.0.tar.xz
|
@ -0,0 +1 @@
|
||||
fad7fab5acae45312fccbe19f33218ce34980654 SOURCES/mesa-demos-9.0.0.tar.xz
|
@ -0,0 +1,28 @@
|
||||
diff --git a/src/demos/meson.build b/src/demos/meson.build
|
||||
index 8f01036b..929f5405 100644
|
||||
--- a/src/demos/meson.build
|
||||
+++ b/src/demos/meson.build
|
||||
@@ -28,7 +28,6 @@ progs = [
|
||||
'copypix',
|
||||
'cubemap',
|
||||
'cuberender',
|
||||
- 'dinoshade',
|
||||
'dissolve',
|
||||
'drawpix',
|
||||
'engine',
|
||||
@@ -52,7 +51,6 @@ progs = [
|
||||
'multiarb',
|
||||
'paltex',
|
||||
'pixeltest',
|
||||
- 'pointblast',
|
||||
'projtex',
|
||||
'ray',
|
||||
'readpix',
|
||||
@@ -61,7 +59,6 @@ progs = [
|
||||
'shadowtex',
|
||||
'singlebuffer',
|
||||
'spectex',
|
||||
- 'spriteblast',
|
||||
'stex3d',
|
||||
'teapot',
|
||||
'terrain',
|
@ -0,0 +1,209 @@
|
||||
diff --git a/src/glsl/bezier.c b/src/glsl/bezier.c
|
||||
index 84e0367..62996fb 100644
|
||||
--- a/src/glsl/bezier.c
|
||||
+++ b/src/glsl/bezier.c
|
||||
@@ -13,7 +13,7 @@
|
||||
#include "glut_wrap.h"
|
||||
#include "shaderutil.h"
|
||||
|
||||
-static const char *filename = "bezier.geom";
|
||||
+static const char *filename = DEMOS_DATA_DIR "bezier.geom";
|
||||
|
||||
static GLuint fragShader;
|
||||
static GLuint vertShader;
|
||||
diff --git a/src/glsl/blinking-teapot.c b/src/glsl/blinking-teapot.c
|
||||
index 62451e9..3420066 100644
|
||||
--- a/src/glsl/blinking-teapot.c
|
||||
+++ b/src/glsl/blinking-teapot.c
|
||||
@@ -63,8 +63,8 @@ init_opengl (void)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- vshad_id = CompileShaderFile (GL_VERTEX_SHADER, "blinking-teapot.vert");
|
||||
- fshad_id = CompileShaderFile (GL_FRAGMENT_SHADER, "blinking-teapot.frag");
|
||||
+ vshad_id = CompileShaderFile (GL_VERTEX_SHADER, DEMOS_DATA_DIR "blinking-teapot.vert");
|
||||
+ fshad_id = CompileShaderFile (GL_FRAGMENT_SHADER, DEMOS_DATA_DIR "blinking-teapot.frag");
|
||||
prog_id = LinkShaders (vshad_id, fshad_id);
|
||||
|
||||
glUseProgram (prog_id);
|
||||
diff --git a/src/glsl/brick.c b/src/glsl/brick.c
|
||||
index 00d8349..f9f0ec7 100644
|
||||
--- a/src/glsl/brick.c
|
||||
+++ b/src/glsl/brick.c
|
||||
@@ -14,8 +14,8 @@
|
||||
#include "shaderutil.h"
|
||||
|
||||
|
||||
-static char *FragProgFile = "CH06-brick.frag";
|
||||
-static char *VertProgFile = "CH06-brick.vert";
|
||||
+static char *FragProgFile = DEMOS_DATA_DIR "CH06-brick.frag";
|
||||
+static char *VertProgFile = DEMOS_DATA_DIR "CH06-brick.vert";
|
||||
|
||||
/* program/shader objects */
|
||||
static GLuint fragShader;
|
||||
diff --git a/src/glsl/bump.c b/src/glsl/bump.c
|
||||
index 95ad19f..f40cba0 100644
|
||||
--- a/src/glsl/bump.c
|
||||
+++ b/src/glsl/bump.c
|
||||
@@ -15,9 +15,9 @@
|
||||
#include "readtex.h"
|
||||
|
||||
|
||||
-static char *FragProgFile = "CH11-bumpmap.frag";
|
||||
-static char *FragTexProgFile = "CH11-bumpmaptex.frag";
|
||||
-static char *VertProgFile = "CH11-bumpmap.vert";
|
||||
+static char *FragProgFile = DEMOS_DATA_DIR "CH11-bumpmap.frag";
|
||||
+static char *FragTexProgFile = DEMOS_DATA_DIR "CH11-bumpmaptex.frag";
|
||||
+static char *VertProgFile = DEMOS_DATA_DIR "CH11-bumpmap.vert";
|
||||
static char *TextureFile = DEMOS_DATA_DIR "tile.rgb";
|
||||
|
||||
/* program/shader objects */
|
||||
diff --git a/src/glsl/convolutions.c b/src/glsl/convolutions.c
|
||||
index 567b358..4c681dd 100644
|
||||
--- a/src/glsl/convolutions.c
|
||||
+++ b/src/glsl/convolutions.c
|
||||
@@ -340,7 +340,7 @@ static void init(void)
|
||||
|
||||
menuInit();
|
||||
readTexture(textureLocation);
|
||||
- createProgram("convolution.vert", "convolution.frag");
|
||||
+ createProgram(DEMOS_DATA_DIR "convolution.vert", DEMOS_DATA_DIR "convolution.frag");
|
||||
|
||||
glEnable(GL_TEXTURE_2D);
|
||||
glClearColor(1.0, 1.0, 1.0, 1.0);
|
||||
diff --git a/src/glsl/mandelbrot.c b/src/glsl/mandelbrot.c
|
||||
index 18b817c..6bbeffd 100644
|
||||
--- a/src/glsl/mandelbrot.c
|
||||
+++ b/src/glsl/mandelbrot.c
|
||||
@@ -14,8 +14,8 @@
|
||||
#include "shaderutil.h"
|
||||
|
||||
|
||||
-static char *FragProgFile = "CH18-mandel.frag";
|
||||
-static char *VertProgFile = "CH18-mandel.vert";
|
||||
+static char *FragProgFile = DEMOS_DATA_DIR "CH18-mandel.frag";
|
||||
+static char *VertProgFile = DEMOS_DATA_DIR "CH18-mandel.vert";
|
||||
|
||||
/* program/shader objects */
|
||||
static GLuint fragShader;
|
||||
diff --git a/src/glsl/meson.build b/src/glsl/meson.build
|
||||
index db8c613..13564a4 100644
|
||||
--- a/src/glsl/meson.build
|
||||
+++ b/src/glsl/meson.build
|
||||
@@ -83,3 +83,38 @@ executable(
|
||||
],
|
||||
install: true
|
||||
)
|
||||
+
|
||||
+glsl_data = [
|
||||
+ 'bezier.geom',
|
||||
+ 'blinking-teapot.frag',
|
||||
+ 'blinking-teapot.vert',
|
||||
+ 'brick.shtest',
|
||||
+ 'CH06-brick.frag',
|
||||
+ 'CH06-brick.vert',
|
||||
+ 'CH11-bumpmap.frag',
|
||||
+ 'CH11-bumpmaptex.frag',
|
||||
+ 'CH11-bumpmap.vert',
|
||||
+ 'CH11-toyball.frag',
|
||||
+ 'CH11-toyball.vert',
|
||||
+ 'CH18-mandel.frag',
|
||||
+ 'CH18-mandel.vert',
|
||||
+ 'convolution.frag',
|
||||
+ 'convolution.vert',
|
||||
+ 'cubemap.frag',
|
||||
+ 'mandelbrot.shtest',
|
||||
+ 'multitex.frag',
|
||||
+ 'multitex.shtest',
|
||||
+ 'multitex.vert',
|
||||
+ 'reflect.vert',
|
||||
+ 'shadowtex.frag',
|
||||
+ 'simple.vert',
|
||||
+ 'simplex-noise.glsl',
|
||||
+ 'skinning.frag',
|
||||
+ 'skinning.vert',
|
||||
+ 'toyball.shtest',
|
||||
+]
|
||||
+
|
||||
+install_data(
|
||||
+ glsl_data,
|
||||
+ install_dir: get_option('datadir') / 'mesa-demos'
|
||||
+)
|
||||
diff --git a/src/glsl/multitex.c b/src/glsl/multitex.c
|
||||
index 2f9a2fa..b51aba3 100644
|
||||
--- a/src/glsl/multitex.c
|
||||
+++ b/src/glsl/multitex.c
|
||||
@@ -35,8 +35,8 @@
|
||||
|
||||
static const char *Demo = "multitex";
|
||||
|
||||
-static const char *VertFile = "multitex.vert";
|
||||
-static const char *FragFile = "multitex.frag";
|
||||
+static const char *VertFile = DEMOS_DATA_DIR "multitex.vert";
|
||||
+static const char *FragFile = DEMOS_DATA_DIR "multitex.frag";
|
||||
|
||||
static const char *TexFiles[2] =
|
||||
{
|
||||
diff --git a/src/glsl/simplex-noise.c b/src/glsl/simplex-noise.c
|
||||
index a687508..9a2a029 100644
|
||||
--- a/src/glsl/simplex-noise.c
|
||||
+++ b/src/glsl/simplex-noise.c
|
||||
@@ -169,7 +169,7 @@ SpecialKey(int key, int x, int y)
|
||||
static void
|
||||
Init(void)
|
||||
{
|
||||
- const char *filename = "simplex-noise.glsl";
|
||||
+ const char *filename = DEMOS_DATA_DIR "simplex-noise.glsl";
|
||||
char noiseText[10000];
|
||||
FILE *f;
|
||||
int len;
|
||||
diff --git a/src/glsl/skinning.c b/src/glsl/skinning.c
|
||||
index b451d13..0f4e943 100644
|
||||
--- a/src/glsl/skinning.c
|
||||
+++ b/src/glsl/skinning.c
|
||||
@@ -20,8 +20,8 @@
|
||||
#define M_PI 3.1415926535
|
||||
#endif
|
||||
|
||||
-static char *FragProgFile = "skinning.frag";
|
||||
-static char *VertProgFile = "skinning.vert";
|
||||
+static char *FragProgFile = DEMOS_DATA_DIR "skinning.frag";
|
||||
+static char *VertProgFile = DEMOS_DATA_DIR "skinning.vert";
|
||||
|
||||
/* program/shader objects */
|
||||
static GLuint fragShader;
|
||||
diff --git a/src/glsl/texdemo1.c b/src/glsl/texdemo1.c
|
||||
index 861d696..42308d1 100644
|
||||
--- a/src/glsl/texdemo1.c
|
||||
+++ b/src/glsl/texdemo1.c
|
||||
@@ -35,11 +35,11 @@
|
||||
|
||||
static const char *Demo = "texdemo1";
|
||||
|
||||
-static const char *ReflectVertFile = "reflect.vert";
|
||||
-static const char *CubeFragFile = "cubemap.frag";
|
||||
+static const char *ReflectVertFile = DEMOS_DATA_DIR "reflect.vert";
|
||||
+static const char *CubeFragFile = DEMOS_DATA_DIR "cubemap.frag";
|
||||
|
||||
-static const char *SimpleVertFile = "simple.vert";
|
||||
-static const char *SimpleTexFragFile = "shadowtex.frag";
|
||||
+static const char *SimpleVertFile = DEMOS_DATA_DIR "simple.vert";
|
||||
+static const char *SimpleTexFragFile = DEMOS_DATA_DIR "shadowtex.frag";
|
||||
|
||||
static const char *GroundImage = DEMOS_DATA_DIR "tile.rgb";
|
||||
|
||||
diff --git a/src/glsl/toyball.c b/src/glsl/toyball.c
|
||||
index 17aa765..5b1f7d3 100644
|
||||
--- a/src/glsl/toyball.c
|
||||
+++ b/src/glsl/toyball.c
|
||||
@@ -14,8 +14,8 @@
|
||||
#include "shaderutil.h"
|
||||
|
||||
|
||||
-static char *FragProgFile = "CH11-toyball.frag";
|
||||
-static char *VertProgFile = "CH11-toyball.vert";
|
||||
+static char *FragProgFile = DEMOS_DATA_DIR "CH11-toyball.frag";
|
||||
+static char *VertProgFile = DEMOS_DATA_DIR "CH11-toyball.vert";
|
||||
|
||||
/* program/shader objects */
|
||||
static GLuint fragShader;
|
@ -0,0 +1,298 @@
|
||||
%global demodir %{_libdir}/mesa
|
||||
|
||||
Summary: Mesa demos
|
||||
Name: mesa-demos
|
||||
Version: 9.0.0
|
||||
Release: 7%{?dist}
|
||||
# SPDX
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
Source: https://archive.mesa3d.org/demos/%{name}-%{version}.tar.xz
|
||||
# Patch pointblast/spriteblast/dinoshade out for legal reasons
|
||||
# (not in public domain)
|
||||
Patch0: mesa-demos-8.5.0-legal.patch
|
||||
# Install glsl demos data
|
||||
Patch1: mesa-demos-system-data.patch
|
||||
BuildRequires: meson
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: freeglut-devel
|
||||
BuildRequires: glslang
|
||||
BuildRequires: mesa-libGL-devel
|
||||
BuildRequires: mesa-libEGL-devel
|
||||
BuildRequires: mesa-libGLES-devel
|
||||
BuildRequires: mesa-libgbm-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libdecor-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libxkbcommon-x11-devel
|
||||
BuildRequires: vulkan-loader-devel
|
||||
BuildRequires: wayland-devel
|
||||
BuildRequires: wayland-protocols-devel
|
||||
BuildRequires: freetype-devel
|
||||
|
||||
%description
|
||||
This package provides some demo applications for testing Mesa.
|
||||
|
||||
%package -n glx-utils
|
||||
Summary: GLX utilities
|
||||
Provides: glxinfo glxinfo%{?__isa_bits}
|
||||
# mesa-demos' glx-utils used to provide xdriinfo for a long time, but that has
|
||||
# always been an additional external source, so it was split into its own
|
||||
# package.
|
||||
# Recommend it here so that it still gets pulled at first for anyone expecting
|
||||
# it to be there, but it doesn't need to be a hard requirement anymore.
|
||||
Recommends: xdriinfo
|
||||
|
||||
%description -n glx-utils
|
||||
The glx-utils package provides the glxinfo and glxgears utilities.
|
||||
|
||||
%package -n egl-utils
|
||||
Summary: EGL utilities
|
||||
Provides: eglinfo es2_info
|
||||
|
||||
%description -n egl-utils
|
||||
The egl-utils package provides the eglinfo and es2_info utilities.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .legal
|
||||
%patch1 -p1 -b .systemdata
|
||||
|
||||
# These two files are distributable, but non-free (lack of permission to modify).
|
||||
rm -rf src/demos/pointblast.c
|
||||
rm -rf src/demos/spriteblast.c
|
||||
|
||||
%build
|
||||
%meson \
|
||||
--bindir=%{demodir} \
|
||||
-Dwith-system-data-files=true \
|
||||
-Dx11=enabled \
|
||||
-Dwayland=enabled \
|
||||
-Degl=enabled \
|
||||
-Dgles2=enabled \
|
||||
-Dvulkan=enabled \
|
||||
-Dlibdrm=enabled \
|
||||
-Dosmesa=disabled
|
||||
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
install -m 0755 %{_vpath_builddir}/src/xdemos/glxgears %{buildroot}%{_bindir}
|
||||
install -m 0755 %{_vpath_builddir}/src/xdemos/glxinfo %{buildroot}%{_bindir}
|
||||
%if 0%{?__isa_bits} != 0
|
||||
install -m 0755 %{_vpath_builddir}/src/xdemos/glxinfo %{buildroot}%{_bindir}/glxinfo%{?__isa_bits}
|
||||
%endif
|
||||
|
||||
install -m 0755 %{_vpath_builddir}/src/egl/opengl/eglinfo %{buildroot}%{_bindir}
|
||||
install -m 0755 %{_vpath_builddir}/src/egl/opengles2/es2_info %{buildroot}%{_bindir}
|
||||
|
||||
%check
|
||||
|
||||
%files
|
||||
%{demodir}
|
||||
%{_datadir}/%{name}/
|
||||
|
||||
%files -n glx-utils
|
||||
%{_bindir}/glxinfo*
|
||||
%{_bindir}/glxgears
|
||||
|
||||
%files -n egl-utils
|
||||
%{_bindir}/eglinfo
|
||||
%{_bindir}/es2_info
|
||||
|
||||
%changelog
|
||||
* Tue Nov 26 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 9.0.0-7
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 9.0.0-7
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Tue Oct 03 2023 Erico Nunes <ernunes@redhat.com> - 9.0.0-4
|
||||
- Split xdriinfo into its own package
|
||||
- Remove xdriinfo additional source build and autotools dependencies
|
||||
|
||||
* Thu Sep 07 2023 José Expósito <jexposit@redhat.com>
|
||||
- SPDX migration: license is already SPDX compatible
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Apr 25 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 9.0.0-2
|
||||
- Install all necessary shader files (#1373299)
|
||||
|
||||
* Mon Mar 27 2023 Erico Nunes <ernunes@redhat.com> - 9.0.0-1
|
||||
- Update to 9.0.0
|
||||
- Enable vulkan demos
|
||||
|
||||
* Fri Feb 03 2023 Erico Nunes <ernunes@redhat.com> - 8.5.0-1
|
||||
- Update to 8.5.0
|
||||
- Change build system to meson
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-15.20210504git0f9e7d9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-14.20210504git0f9e7d9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-13.20210504git0f9e7d9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-12.20210504git0f9e7d9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue May 04 2021 Adam Jackson <ajax@redhat.com> - 8.4.0-11.20210504git0f9e7d995a14f15
|
||||
- Sync with upstream to drop the glew dependency
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-9.20181118git1830dcb
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Tom Stellard <tstellar@redhat.com> - 8.4.0-8.20181118git1830dcb
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-7.20181118git1830dcb
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-6.20181118git1830dcb
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Oct 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 8.4.0-5.20181118git1830dcb
|
||||
- Rebuilt for new freeglut.
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-4.20181118git1830dcb
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.4.0-3.20181118git1830dcb
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Nov 19 2018 Lyude Paul <lyude@redhat.com> - 8.4.0-2.20181118git1830dcb
|
||||
- Start using proper git version strings for rawhide
|
||||
- Enabling building of wayland and freetype demos
|
||||
|
||||
* Sun Nov 18 2018 Lyude Paul <lyude@redhat.com> - 8.4.0-1
|
||||
- New git snapshot
|
||||
|
||||
* Thu Aug 23 2018 Nicolas Chauvet <kwizart@gmail.com> - 8.3.0-12
|
||||
- Rebuilt for glew 2.1.0
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Oct 27 2017 Adam Jackson <ajax@redhat.com> - 8.3.0-9
|
||||
- New git snapshot
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Mar 13 2017 Hans de Goede <hdegoede@redhat.com> - 8.3.0-6
|
||||
- Fix xdriinfo not working with libglvnd (rhbz#1429894)
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jan 10 2017 Orion Poplawski <orion@cora.nwra.com> - 8.3.0-4
|
||||
- Rebuild for glew 2.0.0
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jan 14 2016 Adam Jackson <ajax@redhat.com> - 8.3.0-2
|
||||
- Rebuild for glew 1.13
|
||||
|
||||
* Fri Dec 18 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 8.3.0-1
|
||||
- 8.3.0
|
||||
|
||||
* Thu Dec 03 2015 Adam Jackson <ajax@redhat.com> 8.2.0-5
|
||||
- New git snap
|
||||
- Add EGL/GLES buildreqs and egl-utils subpackage
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 8.2.0-3
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jul 05 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 8.2.0-1
|
||||
- 8.2.0 upstream release
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sun Nov 17 2013 Dave Airlie <airlied@redhat.com> - 8.1.0-5
|
||||
- rebuilt for glew 1.10
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Mar 27 2013 Adam Jackson <ajax@redhat.com> 8.1.0-3
|
||||
- Build with --as-needed so glxinfo doesn't needlessly drag in GLEW
|
||||
|
||||
* Wed Feb 27 2013 Adam Jackson <ajax@redhat.com> 8.1.0-2
|
||||
- Copy glxinfo to glxinfo%%{__isa_bits}, to allow people to check that their
|
||||
compatibility drivers are working.
|
||||
|
||||
* Sun Feb 24 2013 Dave Airlie <airlied@redhat.com> 8.1.0-1
|
||||
- package upstream demos release 8.1.0 (mainly for new glxinfo)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.0.1-2.20121218git6eef979
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Jan 8 2013 Tom Callaway <spot@fedoraproject.org> - 8.0.1-1.20121218git6eef979
|
||||
- update to 8.0.1 (git checkout from 20121218)
|
||||
- update xdriinfo to 1.0.4
|
||||
- remove non-free files (bz892925)
|
||||
|
||||
* Thu Dec 13 2012 Adam Jackson <ajax@redhat.com> - 7.10-9.20101028
|
||||
- Rebuild for glew 1.9.0
|
||||
|
||||
* Fri Jul 27 2012 Kalev Lember <kalevlember@gmail.com> - 7.10-8.20101028
|
||||
- Rebuilt for GLEW soname bump
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.10-7.20101028
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.10-6.20101028
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Jun 20 2011 ajax@redhat.com - 7.10-5.20101028
|
||||
- Rebuild for new glew soname
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.10-4.20101028
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Nov 01 2010 Adam Jackson <ajax@redhat.com> 7.10-3.20101028
|
||||
- Install rgba images too (#640688)
|
||||
|
||||
* Sat Oct 30 2010 Dave Airlie <airlied@redhat.com> 7.10-2.20101028
|
||||
- fix install of gears/info (#647947)
|
||||
|
||||
* Thu Oct 28 2010 Adam Jackson <ajax@redhat.com> 7.10-1.20101028
|
||||
- Today's git snapshot
|
||||
- Arbitrary EVR bump to be newer than when the mesa source package dropped
|
||||
the demos subpackage.
|
||||
|
||||
* Tue Jun 15 2010 Jerome Glisse <jglisse@redhat.com> 7.7
|
||||
- Initial build.
|
Loading…
Reference in new issue