add Python 3 exception output to test-lfs-serve-access.t

i8-stream-4.8
Arkady L. Shane 4 months ago
parent fc5efe612c
commit 187512a541
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,36 @@
From 9fa00dd4895facd51a28ede0546d31691efdd558 Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Mon, 20 May 2024 14:07:16 +0300
Subject: [PATCH 2/2] add Python 3 exception output to test-lfs-serve-access.t
---
tests/test-lfs-serve-access.t | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/tests/test-lfs-serve-access.t b/tests/test-lfs-serve-access.t
index 6331c5a..e91d256 100644
--- a/tests/test-lfs-serve-access.t
+++ b/tests/test-lfs-serve-access.t
@@ -337,7 +337,8 @@ Test a checksum failure during the processing of the GET request
$LOCALIP - - [$ERRDATE$] HG error: localstore.download(oid, req.bodyfh) (glob)
$LOCALIP - - [$ERRDATE$] HG error: super(badstore, self).download(oid, src) (glob)
$LOCALIP - - [$ERRDATE$] HG error: % oid) (glob)
- $LOCALIP - - [$ERRDATE$] HG error: LfsCorruptionError: corrupt remote lfs object: b5bb9d8014a0f9b1d61e21e796d78dccdf1352f23cd32812f4850b878ae4944c (glob)
+ $LOCALIP - - [$ERRDATE$] HG error: LfsCorruptionError: corrupt remote lfs object: b5bb9d8014a0f9b1d61e21e796d78dccdf1352f23cd32812f4850b878ae4944c (no-py3 !)
+ $LOCALIP - - [$ERRDATE$] HG error: hgext.lfs.blobstore.LfsCorruptionError: b'corrupt remote lfs object: b5bb9d8014a0f9b1d61e21e796d78dccdf1352f23cd32812f4850b878ae4944c' (py3 !)
$LOCALIP - - [$ERRDATE$] HG error: (glob)
$LOCALIP - - [$ERRDATE$] Exception happened during processing request '/.hg/lfs/objects/276f73cfd75f9fb519810df5f5d96d6594ca2521abd86cbcd92122f7d51a1f3d': (glob)
Traceback (most recent call last):
@@ -359,7 +360,8 @@ Test a checksum failure during the processing of the GET request
$LOCALIP - - [$ERRDATE$] HG error: blob = self._read(self.vfs, oid, verify) (glob)
$LOCALIP - - [$ERRDATE$] HG error: blobstore._verify(oid, 'dummy content') (glob)
$LOCALIP - - [$ERRDATE$] HG error: hint=_('run hg verify')) (glob)
- $LOCALIP - - [$ERRDATE$] HG error: LfsCorruptionError: detected corrupt lfs object: 276f73cfd75f9fb519810df5f5d96d6594ca2521abd86cbcd92122f7d51a1f3d (glob)
+ $LOCALIP - - [$ERRDATE$] HG error: LfsCorruptionError: detected corrupt lfs object: 276f73cfd75f9fb519810df5f5d96d6594ca2521abd86cbcd92122f7d51a1f3d (no-py3 !)
+ $LOCALIP - - [$ERRDATE$] HG error: hgext.lfs.blobstore.LfsCorruptionError: b'detected corrupt lfs object: 276f73cfd75f9fb519810df5f5d96d6594ca2521abd86cbcd92122f7d51a1f3d' (py3 !)
$LOCALIP - - [$ERRDATE$] HG error: (glob)
Basic Authorization headers are returned by the Batch API, and sent back with
--
2.45.0

@ -15,7 +15,8 @@ URL: http://www.selenic.com/mercurial/
Source0: https://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz
Source1: mercurial-site-start.el
Source2: blacklist
Patch0: 0001-tests-make-test-archive.t-pass-on-py3.9-issue6504.patch
Patch1: 0001-tests-make-test-archive.t-pass-on-py3.9-issue6504.patch
Patch2: 0002-add-Python-3-exception-output-to-test-lfs-serve-acce.patch
BuildRequires: python2 python2-devel bash-completion
BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils
BuildRequires: gcc
@ -55,7 +56,8 @@ documentation.
%prep
%setup -q -n %{name}-%{upstreamversion}
%patch -P0 -p1 -b .py392
%patch -P1 -p1 -b .py392
%patch -P2 -p1 -b .py392-exeption
# Patch files to use python2 instead of (since lately) non existent python binary.
sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile
@ -156,6 +158,7 @@ cd tests && %{__python2} run-tests.py -t 360 --blacklist %{SOURCE2}
- Something got stricter at parsing URL query parameters and now the
parameters need to be separated by "&"; ";" is no longer allowed. See
issue6504 for details
- add Python 3 exception output to test-lfs-serve-access.t
* Sun Dec 10 2023 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.8.2-1
- Rebuilt for MSVSphere 8.8

Loading…
Cancel
Save