parent
bb3568e732
commit
d0bb3056a0
@ -0,0 +1 @@
|
||||
mdds_0.3.0.tar.bz2
|
@ -0,0 +1,17 @@
|
||||
diff -up mdds_0.3.0/Makefile.dt mdds_0.3.0/Makefile
|
||||
--- mdds_0.3.0/Makefile.dt 2010-06-30 16:39:41.040576534 +0200
|
||||
+++ mdds_0.3.0/Makefile 2010-06-30 16:39:47.798687886 +0200
|
||||
@@ -77,11 +77,11 @@ test.pqt: point_quad_tree_test
|
||||
test.pqt.mem: point_quad_tree_test
|
||||
valgrind --tool=memcheck --leak-check=full ./point_quad_tree_test
|
||||
|
||||
-test.recset.perf: rectangle-set_test
|
||||
+test.recset.perf: rectangle_set_test
|
||||
./rectangle_set_test perf
|
||||
|
||||
test.recset.mem: rectangle_set_test
|
||||
- valgrind --tool=memcheck --leak-check=full ./rectangle-set_test func
|
||||
+ valgrind --tool=memcheck --leak-check=full ./rectangle_set_test func
|
||||
|
||||
test.fst.mem: flat_segment_tree_test
|
||||
valgrind --tool=memcheck --leak-check=full ./flat_segment_tree_test
|
@ -0,0 +1,91 @@
|
||||
%global do_mem_tests 0
|
||||
%global do_perf_tests 0
|
||||
|
||||
Name: mdds
|
||||
Version: 0.3.0
|
||||
Release: 2%{?dist}
|
||||
Summary: A collection of multi-dimensional data structures and indexing algorithms
|
||||
|
||||
Group: Development/Libraries
|
||||
License: MIT
|
||||
URL: http://code.google.com/p/multidimalgorithm/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Source0: http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
|
||||
Patch0: mdds-0.3.0.fix-test-prog-name.patch
|
||||
|
||||
BuildRequires: boost-devel
|
||||
%if %{do_mem_tests}
|
||||
BuildRequires: valgrind
|
||||
%endif
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
|
||||
%description
|
||||
A collection of multi-dimensional data structures and indexing algorithms.
|
||||
|
||||
It implements the following data structures:
|
||||
|
||||
* flat segment tree
|
||||
* segment tree
|
||||
* rectangle set
|
||||
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Headers for %{name}
|
||||
Requires: boost-devel
|
||||
|
||||
%description devel
|
||||
Headers for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_%{version}
|
||||
%patch0 -p 1 -b .fix-test-prog-name.patch
|
||||
# this is only used in tests
|
||||
sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{optflags} -std/' Makefile
|
||||
|
||||
|
||||
%build
|
||||
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
mkdir -p %{buildroot}/%{_includedir}
|
||||
mkdir %{buildroot}/%{_includedir}/mdds
|
||||
cp -p inc/mdds/* %{buildroot}/%{_includedir}/mdds
|
||||
|
||||
|
||||
%check
|
||||
make %{?_smp_mflags}
|
||||
for t in fst pqt recset st; do
|
||||
make test.$t
|
||||
done
|
||||
%if %{do_perf_tests}
|
||||
for t in recset st; do
|
||||
make test.$t.perf
|
||||
done
|
||||
make test.stl
|
||||
%endif
|
||||
%if %{do_mem_tests}
|
||||
for t in fst pqt recset st; do
|
||||
make test.$t.mem
|
||||
done
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/mdds
|
||||
%doc AUTHORS NEWS README
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 07 2010 Caolán McNamara <caolanm@redhat.com> - 0.3.0-2
|
||||
- rpmlint warnings
|
||||
|
||||
* Wed Jun 30 2010 David Tardon <dtardon@redhat.com> - 0.3.0-1
|
||||
- initial import
|
Loading…
Reference in new issue