You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
14 lines
677 B
14 lines
677 B
Harden the "hardened" flags even more to comply with RHEL8 security rules
|
|
|
|
--- mariadb-10.3.25/CMakeLists.txt 2020-10-05 18:19:45.000000000 +0200
|
|
+++ mariadb-10.3.25/CMakeLists.txt_patched 2020-11-03 01:29:52.369426705 +0100
|
|
@@ -247,7 +247,7 @@ IF(NOT WITH_TSAN)
|
|
# security-enhancing flags
|
|
MY_CHECK_AND_SET_COMPILER_FLAG("-pie -fPIC")
|
|
MY_CHECK_AND_SET_LINKER_FLAG("-Wl,-z,relro,-z,now")
|
|
- MY_CHECK_AND_SET_COMPILER_FLAG("-fstack-protector --param=ssp-buffer-size=4")
|
|
+ MY_CHECK_AND_SET_COMPILER_FLAG("-fstack-protector-strong --param=ssp-buffer-size=4")
|
|
MY_CHECK_AND_SET_COMPILER_FLAG("-D_FORTIFY_SOURCE=2" RELEASE RELWITHDEBINFO)
|
|
ENDIF()
|
|
ENDIF()
|