diff --git a/man2html-hman-section.patch b/man2html-hman-section.patch
new file mode 100644
index 0000000..c9d972e
--- /dev/null
+++ b/man2html-hman-section.patch
@@ -0,0 +1,20 @@
+--- ../man-1.6g-orig/man2html/hman.sh 2005-08-20 16:26:06.000000000 -0700
++++ ./man2html/hman.sh 2012-05-24 17:00:56.488558100 -0700
+@@ -72,7 +72,7 @@
+ 0) $BROWSER $CG/man2html ;;
+ 1) case "$1" in
+ 1|2|3|4|5|6|7|8|l|n)
+- $BROWSER "$CG/mansec?$CG+$1" ;;
++ $BROWSER "$CG/mansec?$1" ;;
+ /*)
+ $BROWSER "$CG/man2html?$1" ;;
+ */*)
+@@ -85,7 +85,7 @@
+ $BROWSER "$CG/mansearch?$2" ;;
+ *)
+ if [ "$2" = index ]; then
+- $BROWSER "$CG/manwhatis?$CG+$1"
++ $BROWSER "$CG/manwhatis?$1"
+ else
+ $BROWSER "$CG/man2html?$1+$2"
+ fi ;;
diff --git a/man2html.spec b/man2html.spec
index 9ab3842..7fcd723 100644
--- a/man2html.spec
+++ b/man2html.spec
@@ -3,7 +3,7 @@
Name: man2html
Version: 1.6
-Release: 5.%{posttag}%{?dist}
+Release: 6.%{posttag}%{?dist}
Summary: Convert man pages to HTML - CGI scripts
# man2html.c and debian/sources/man2html.cgi.c are Copyright Only
@@ -102,6 +102,10 @@ Patch6: man2html-doc.patch
# remembers how to use their bugtracker
Patch7: man2html-format.patch
+# fix a bug in hman that linked to the wrong URL for mansec and manwhatis
+# (e.g. when just invoking `hman 1`)
+Patch8: man2html-hman-section.patch
+
BuildRequires: recode
Requires: %{name}-core%{?_isa} = %{version}-%{release}
@@ -154,16 +158,12 @@ make -C man2html DESTDIR=%{buildroot} install install-hman
#install CGI scripts
make -C debian/sources PREFIX=%{buildroot} install
-#install localized manpages
+#install localized manpages (French only; Italian is in man-pages-it)
install -Dpm0644 man2html/locales/fr/man2html.1 %{buildroot}%{_mandir}/fr/man1/man2html.1
-install -Dpm0644 man2html/locales/it/man2html.1 %{buildroot}%{_mandir}/it/man1/man2html.1
-install -Dpm0644 man2html/locales/it/hman.1 %{buildroot}%{_mandir}/it/man1/hman.1
#convert localized manpages to UTF-8
recode latin1..utf8 \
- %{buildroot}%{_mandir}/fr/man1/man2html.1 \
- %{buildroot}%{_mandir}/it/man1/man2html.1 \
- %{buildroot}%{_mandir}/it/man1/hman.1
+ %{buildroot}%{_mandir}/fr/man1/man2html.1
#install httpd configuration
install -Dpm0644 %SOURCE2 %{buildroot}%{_sysconfdir}/httpd/conf.d/man2html.conf
@@ -193,17 +193,20 @@ fi
%attr(0775,root,apache) %{_localstatedir}/cache/man2html
%config(noreplace) %{_sysconfdir}/httpd/conf.d/man2html.conf
%{_mandir}/man1/hman.1.*
-%{_mandir}/it/man1/hman.1.*
%files core
%{_bindir}/man2html/
%{_mandir}/man1/man2html.1.*
-%{_mandir}/*/man1/man2html.1.*
+%{_mandir}/fr/man1/man2html.1.*
%doc COPYING HISTORY man2html/README man2html/TODO
%changelog
+* Thu May 24 2012 T.C. Hollingsworth - 1.6-6.g
+- fix hman bug that caused linked to wrong URLs for sections (e.g. `hman 1`)
+- don't ship Italian man pages; they're provided by man-pages-it
+
* Fri May 18 2012 T.C. Hollingsworth - 1.6-5.g
- fix accidental use of wrong macro in %%post