Old patches removed BR qt5-qtquickcontrols2-devel added Licenses are LGPLv3 and BSD Signed-off-by: Onuralp SEZER <thunderbirdtr@fedoraproject.org>epel9 imports/epel9/maliit-keyboard-2.3.1-1.el9
parent
2f6f9c163f
commit
6ae121f5ca
@ -1,2 +1,3 @@
|
||||
/keyboard-2.0.0.tar.gz
|
||||
/maliit-keyboard-2.2.0.tar.gz
|
||||
/maliit-keyboard-2.3.1.tar.gz
|
||||
|
@ -1,64 +0,0 @@
|
||||
From 2078913c2735cfb8322af5430511ec1d6d43d3dd Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Thu, 10 Feb 2022 19:38:49 +0900
|
||||
Subject: [PATCH] Enable anthy-unicode build
|
||||
|
||||
anthy is no longer maintained currently and anthy-unicode is generated
|
||||
to convert internal EUC data to UTF-8 and maintained.
|
||||
If anthy-unicode package is found, it can be used instead of anthy.
|
||||
---
|
||||
CMakeLists.txt | 9 ++++++++-
|
||||
cmake/FindAnthyUnicode.cmake | 14 ++++++++++++++
|
||||
2 files changed, 22 insertions(+), 1 deletion(-)
|
||||
create mode 100644 cmake/FindAnthyUnicode.cmake
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2233e11b..869458b1 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -35,6 +35,7 @@ find_package(Qt5Multimedia)
|
||||
find_package(Qt5Feedback)
|
||||
find_package(Intl REQUIRED)
|
||||
|
||||
+find_package(AnthyUnicode)
|
||||
find_package(Anthy)
|
||||
find_package(Pinyin)
|
||||
find_package(Chewing)
|
||||
@@ -353,7 +354,13 @@ abstract_language_plugin(en@dv englishdvorak
|
||||
abstract_language_plugin(fr-ch french LIBRARIES westernsupport)
|
||||
abstract_language_plugin(th thai DIRECTORY qml/keys)
|
||||
|
||||
-if(Anthy_FOUND)
|
||||
+if(AnthyUnicode_FOUND)
|
||||
+ abstract_language_plugin(ja japanese ABSTRACT_LANGUAGE_PLUGIN
|
||||
+ SOURCES anthyadapter.cpp anthyadapter.h
|
||||
+ LIBRARIES ${AnthyUnicode_LIBRARIES}
|
||||
+ INCLUDE_DIRS ${AnthyUnicode_INCLUDE_DIRS}
|
||||
+ DIRECTORY qml/keys)
|
||||
+elseif(Anthy_FOUND)
|
||||
abstract_language_plugin(ja japanese ABSTRACT_LANGUAGE_PLUGIN
|
||||
SOURCES anthyadapter.cpp anthyadapter.h
|
||||
LIBRARIES ${Anthy_LIBRARIES}
|
||||
diff --git a/cmake/FindAnthyUnicode.cmake b/cmake/FindAnthyUnicode.cmake
|
||||
new file mode 100644
|
||||
index 00000000..6c13a222
|
||||
--- /dev/null
|
||||
+++ b/cmake/FindAnthyUnicode.cmake
|
||||
@@ -0,0 +1,14 @@
|
||||
+include(FeatureSummary)
|
||||
+set_package_properties(anthyunicode PROPERTIES
|
||||
+ URL "https://github.com/fujiwarat/anthy-unicode"
|
||||
+ DESCRIPTION "Anthy provides the library to input Japanese on the applications.")
|
||||
+
|
||||
+find_package(PkgConfig)
|
||||
+pkg_check_modules(PC_AnthyUnicode QUIET anthy-unicode)
|
||||
+
|
||||
+find_library(AnthyUnicode_LIBRARIES NAMES anthy-unicode ${PC_AnthyUnicode_LIBRARIES} HINTS ${PC_AnthyUnicode_LIBRARY_DIRS})
|
||||
+find_path(AnthyUnicode_INCLUDE_DIRS anthy/anthy.h HINTS ${PC_AnthyUnicode_INCLUDE_DIRS})
|
||||
+
|
||||
+include(FindPackageHandleStandardArgs)
|
||||
+find_package_handle_standard_args(AnthyUnicode DEFAULT_MSG AnthyUnicode_LIBRARIES AnthyUnicode_INCLUDE_DIRS)
|
||||
+mark_as_advanced(AnthyUnicode_INCLUDE_DIRS AnthyUnicode_LIBRARIES)
|
||||
--
|
||||
2.33.1
|
||||
|
@ -1,50 +0,0 @@
|
||||
From 1aba6e338ce2d4662f6374e59e195761d44901eb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Andr=C3=A9s=20B=2ES?= <andresbs@opensuse.org>
|
||||
Date: Tue, 15 Feb 2022 17:23:30 -0600
|
||||
Subject: [PATCH] Fix 3 QML import typos in some languages.
|
||||
|
||||
---
|
||||
plugins/fr-ch/qml/Keyboard_fr-ch_url.qml | 2 +-
|
||||
plugins/fr-ch/qml/Keyboard_fr-ch_url_search.qml | 2 +-
|
||||
plugins/tr/qml/Keyboard_tr_url.qml | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/plugins/fr-ch/qml/Keyboard_fr-ch_url.qml b/plugins/fr-ch/qml/Keyboard_fr-ch_url.qml
|
||||
index 1874c932..b7905bc6 100644
|
||||
--- a/plugins/fr-ch/qml/Keyboard_fr-ch_url.qml
|
||||
+++ b/plugins/fr-ch/qml/Keyboard_fr-ch_url.qml
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
import QtQuick 2.4
|
||||
|
||||
-import MaliitKeyobard 2.0
|
||||
+import MaliitKeyboard 2.0
|
||||
|
||||
import keys 1.0
|
||||
|
||||
diff --git a/plugins/fr-ch/qml/Keyboard_fr-ch_url_search.qml b/plugins/fr-ch/qml/Keyboard_fr-ch_url_search.qml
|
||||
index c5469141..38b5e716 100644
|
||||
--- a/plugins/fr-ch/qml/Keyboard_fr-ch_url_search.qml
|
||||
+++ b/plugins/fr-ch/qml/Keyboard_fr-ch_url_search.qml
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
import QtQuick 2.4
|
||||
|
||||
-import MaliitKeyobard 2.0
|
||||
+import MaliitKeyboard 2.0
|
||||
|
||||
import keys 1.0
|
||||
|
||||
diff --git a/plugins/tr/qml/Keyboard_tr_url.qml b/plugins/tr/qml/Keyboard_tr_url.qml
|
||||
index 60b3b75d..726d0126 100644
|
||||
--- a/plugins/tr/qml/Keyboard_tr_url.qml
|
||||
+++ b/plugins/tr/qml/Keyboard_tr_url.qml
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
import QtQuick 2.4
|
||||
|
||||
-import MaliitKeyobard 2.0
|
||||
+import MaliitKeyboard 2.0
|
||||
|
||||
import keys 1.0
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (maliit-keyboard-2.2.0.tar.gz) = 6083b12d953c37273e9186009a1fed49aeca4cfbeedff7fea9acfece2965429323b94cdfefaa9514cb101b25bcbee66ffcf0349c00926a8a8780fc850ceca3a9
|
||||
SHA512 (maliit-keyboard-2.3.1.tar.gz) = bf6eee534d6fceb6e9d1ac5b20d085db9ccd0c7859137d3840349974eaff9cc3d49b6d4ee52543810b33ff85e228fd4a9c37501e0c69b0394c2848a229e5ab8e
|
||||
|
Loading…
Reference in new issue