You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lxcfs/lxcfs-5.0.0-unitdir.patch

23 lines
798 B

diff --git a/config/init/meson.build b/config/init/meson.build
index 5061973..e39c2ab 100644
--- a/config/init/meson.build
+++ b/config/init/meson.build
@@ -1,6 +1,8 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
if init_script == 'systemd'
+ systemd = dependency('systemd')
+ systemd_system_unit_dir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
systemd_service = custom_target(
'lxcfs.service',
input: 'systemd/lxcfs.service.in',
@@ -12,7 +14,7 @@ if init_script == 'systemd'
'@OUTPUT@',
],
install: true,
- install_dir: '/lib/systemd/system')
+ install_dir: systemd_system_unit_dir)
elif init_script == 'upstart'
install_data('upstart/lxcfs.conf', install_dir: join_paths(sysconfdir, 'init'))