You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lirc/lirc-0.9.0-libusb-config-is...

96 lines
2.7 KiB

diff --git a/configure.ac b/configure.ac
index 6c07e0d..1a3347e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,11 +20,11 @@ AC_PROG_MAKE_SET
AC_PATH_PROG(mknod, mknod, /bin/mknod)
AC_PATH_PROG(mkfifo, mkfifo, /usr/bin/mkfifo)
AC_PATH_PROG(depmod, depmod, /sbin/depmod, $PATH:/sbin)
-AC_PATH_PROG(LIBUSB_CONFIG, libusb-config)
AC_PROG_LN_S
AC_PROG_LIBTOOL
AM_PATH_PYTHON(,, [:])
AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != ""])
+LIBUSB_CONFIG="pkg-config libusb"
dnl Checks for header files.
AC_HEADER_STDC
@@ -310,15 +310,14 @@ AH_TEMPLATE([SYSCONFDIR],
AH_TEMPLATE([USE_SYSLOG],
[define if you want to log to syslog instead of logfile])
-if test -n "${LIBUSB_CONFIG}"; then
- AC_DEFINE(HAVE_LIBUSB)
- possible_drivers="${possible_drivers} (atilibusb) (awlibusb) (dfclibusb) (commandir) (srm7500libusb)"
-fi
-
AC_CHECK_LIB(caraca_client, caraca_init,
AC_DEFINE(HAVE_LIBCARACA)
possible_drivers="${possible_drivers} (caraca)"
)
+AC_CHECK_HEADER(usb.h,
+ AC_DEFINE(HAVE_LIBUSB)
+ possible_drivers="${possible_drivers} (atilibusb) (awlibusb) (dfclibusb) (commandir) (srm7500libusb)"
+)
AC_CHECK_HEADER(ftdi.h,
AC_DEFINE(HAVE_FTDI)
possible_drivers="${possible_drivers} (ftdi)"
@@ -1449,7 +1448,7 @@ Get it at:
Or install these packages from your distro:
libusb
- libusb-dev
+ libusb-devel
])
;;
--- lirc-0.9.0/configure.orig 2011-06-07 00:08:14.850212313 -0400
+++ lirc-0.9.0/configure 2011-06-07 00:11:07.140109458 -0400
@@ -865,7 +865,6 @@ build_cpu
build
LIBTOOL
LN_S
-LIBUSB_CONFIG
depmod
mkfifo
mknod
@@ -4160,37 +4159,7 @@ $as_echo "no" >&6; }
fi
-# Extract the first word of "libusb-config", so it can be a program name with args.
-set dummy libusb-config; ac_word=$2
-{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if test "${ac_cv_path_LIBUSB_CONFIG+set}" = set; then
- $as_echo_n "(cached) " >&6
-else
- case $LIBUSB_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_LIBUSB_CONFIG="$LIBUSB_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_LIBUSB_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-LIBUSB_CONFIG=$ac_cv_path_LIBUSB_CONFIG
+LIBUSB_CONFIG="pkg-config libusb"
if test -n "$LIBUSB_CONFIG"; then
{ $as_echo "$as_me:$LINENO: result: $LIBUSB_CONFIG" >&5
$as_echo "$LIBUSB_CONFIG" >&6; }