lirc 0.9.0-pre1

Signed-off-by: Jarod Wilson <jarod@redhat.com>
epel8
Jarod Wilson 14 years ago
parent 928ece96bd
commit 71e0fe193c

1
.gitignore vendored

@ -5,3 +5,4 @@ lirc-*/
lirc-0.8.7pre2.tar.bz2
/lirc-0.8.7-pre3.tar.bz2
/lirc-0.8.7.tar.bz2
/lirc-0.9.0-pre1.tar.bz2

@ -1,67 +0,0 @@
Index: lirc-0.8.6/drivers/lirc.h
===================================================================
--- lirc-0.8.6.orig/drivers/lirc.h
+++ lirc-0.8.6/drivers/lirc.h
@@ -11,6 +11,7 @@
#define __USE_LINUX_IOCTL_DEFS
#include <sys/ioctl.h>
#endif
+#include <stdint.h>
#define PULSE_BIT 0x01000000
#define PULSE_MASK 0x00FFFFFF
@@ -68,27 +68,27 @@ typedef int lirc_t;
/*** IOCTL commands for lirc driver ***/
-#define LIRC_GET_FEATURES _IOR('i', 0x00000000, unsigned long)
+#define LIRC_GET_FEATURES _IOR('i', 0x00000000, uint64_t)
-#define LIRC_GET_SEND_MODE _IOR('i', 0x00000001, unsigned long)
-#define LIRC_GET_REC_MODE _IOR('i', 0x00000002, unsigned long)
-#define LIRC_GET_SEND_CARRIER _IOR('i', 0x00000003, unsigned int)
-#define LIRC_GET_REC_CARRIER _IOR('i', 0x00000004, unsigned int)
-#define LIRC_GET_SEND_DUTY_CYCLE _IOR('i', 0x00000005, unsigned int)
-#define LIRC_GET_REC_DUTY_CYCLE _IOR('i', 0x00000006, unsigned int)
-#define LIRC_GET_REC_RESOLUTION _IOR('i', 0x00000007, unsigned int)
+#define LIRC_GET_SEND_MODE _IOR('i', 0x00000001, uint64_t)
+#define LIRC_GET_REC_MODE _IOR('i', 0x00000002, uint64_t)
+#define LIRC_GET_SEND_CARRIER _IOR('i', 0x00000003, uint32_t)
+#define LIRC_GET_REC_CARRIER _IOR('i', 0x00000004, uint32_t)
+#define LIRC_GET_SEND_DUTY_CYCLE _IOR('i', 0x00000005, uint32_t)
+#define LIRC_GET_REC_DUTY_CYCLE _IOR('i', 0x00000006, uint32_t)
+#define LIRC_GET_REC_RESOLUTION _IOR('i', 0x00000007, uint32_t)
/* code length in bits, currently only for LIRC_MODE_LIRCCODE */
-#define LIRC_GET_LENGTH _IOR('i', 0x0000000f, unsigned long)
+#define LIRC_GET_LENGTH _IOR('i', 0x0000000f, uint64_t)
-#define LIRC_SET_SEND_MODE _IOW('i', 0x00000011, unsigned long)
-#define LIRC_SET_REC_MODE _IOW('i', 0x00000012, unsigned long)
+#define LIRC_SET_SEND_MODE _IOW('i', 0x00000011, uint64_t)
+#define LIRC_SET_REC_MODE _IOW('i', 0x00000012, uint64_t)
/* Note: these can reset the according pulse_width */
-#define LIRC_SET_SEND_CARRIER _IOW('i', 0x00000013, unsigned int)
-#define LIRC_SET_REC_CARRIER _IOW('i', 0x00000014, unsigned int)
-#define LIRC_SET_SEND_DUTY_CYCLE _IOW('i', 0x00000015, unsigned int)
-#define LIRC_SET_REC_DUTY_CYCLE _IOW('i', 0x00000016, unsigned int)
-#define LIRC_SET_TRANSMITTER_MASK _IOW('i', 0x00000017, unsigned int)
+#define LIRC_SET_SEND_CARRIER _IOW('i', 0x00000013, uint32_t)
+#define LIRC_SET_REC_CARRIER _IOW('i', 0x00000014, uint32_t)
+#define LIRC_SET_SEND_DUTY_CYCLE _IOW('i', 0x00000015, uint32_t)
+#define LIRC_SET_REC_DUTY_CYCLE _IOW('i', 0x00000016, uint32_t)
+#define LIRC_SET_TRANSMITTER_MASK _IOW('i', 0x00000017, uint32_t)
/*
* to set a range use
@@ -97,8 +97,8 @@ typedef int lirc_t;
* LIRC_SET_REC_DUTY_CYCLE/LIRC_SET_REC_CARRIER with the upper bound
*/
-#define LIRC_SET_REC_DUTY_CYCLE_RANGE _IOW('i', 0x0000001e, unsigned int)
-#define LIRC_SET_REC_CARRIER_RANGE _IOW('i', 0x0000001f, unsigned int)
+#define LIRC_SET_REC_DUTY_CYCLE_RANGE _IOW('i', 0x0000001e, uint32_t)
+#define LIRC_SET_REC_CARRIER_RANGE _IOW('i', 0x0000001f, uint32_t)
#define LIRC_NOTIFY_DECODE _IO('i', 0x00000020)

@ -1,20 +0,0 @@
--- daemons/lircd.c 2008/05/09 18:40:59 5.77
+++ daemons/lircd.c 2008/08/21 18:39:25 5.78
@@ -515,10 +515,13 @@
{
if(!hw.init_func())
{
- shutdown(clis[0],2);
- close(clis[0]);
- clin=0;
- dosigterm(SIGTERM);
+ logprintf(LOG_WARNING,
+ "Failed to initialize hardware");
+ /* Don't exit here, otherwise lirc
+ * bails out, and lircd exits, making
+ * it impossible to connect to when we
+ * have a device actually plugged
+ * in. */
}
}
}

@ -1,116 +0,0 @@
Index: lirc-0.8.7pre2/drivers/lirc.h
===================================================================
--- lirc-0.8.7pre2.orig/drivers/lirc.h
+++ lirc-0.8.7pre2/drivers/lirc.h
@@ -11,6 +11,9 @@
#define __USE_LINUX_IOCTL_DEFS
#include <sys/ioctl.h>
#endif
+#include <stdint.h>
+
+typedef uint32_t __u32;
/* <obsolete> */
#define PULSE_BIT 0x01000000
@@ -95,60 +96,60 @@ typedef int lirc_t;
/*** IOCTL commands for lirc driver ***/
-#define LIRC_GET_FEATURES _IOR('i', 0x00000000, unsigned long)
+#define LIRC_GET_FEATURES _IOR('i', 0x00000000, __u32)
-#define LIRC_GET_SEND_MODE _IOR('i', 0x00000001, unsigned long)
-#define LIRC_GET_REC_MODE _IOR('i', 0x00000002, unsigned long)
-#define LIRC_GET_SEND_CARRIER _IOR('i', 0x00000003, unsigned int)
-#define LIRC_GET_REC_CARRIER _IOR('i', 0x00000004, unsigned int)
-#define LIRC_GET_SEND_DUTY_CYCLE _IOR('i', 0x00000005, unsigned int)
-#define LIRC_GET_REC_DUTY_CYCLE _IOR('i', 0x00000006, unsigned int)
-#define LIRC_GET_REC_RESOLUTION _IOR('i', 0x00000007, unsigned int)
-
-#define LIRC_GET_MIN_TIMEOUT _IOR('i', 0x00000008, lirc_t)
-#define LIRC_GET_MAX_TIMEOUT _IOR('i', 0x00000009, lirc_t)
-
-#define LIRC_GET_MIN_FILTER_PULSE _IOR('i', 0x0000000a, lirc_t)
-#define LIRC_GET_MAX_FILTER_PULSE _IOR('i', 0x0000000b, lirc_t)
-#define LIRC_GET_MIN_FILTER_SPACE _IOR('i', 0x0000000c, lirc_t)
-#define LIRC_GET_MAX_FILTER_SPACE _IOR('i', 0x0000000d, lirc_t)
+#define LIRC_GET_SEND_MODE _IOR('i', 0x00000001, __u32)
+#define LIRC_GET_REC_MODE _IOR('i', 0x00000002, __u32)
+#define LIRC_GET_SEND_CARRIER _IOR('i', 0x00000003, __u32)
+#define LIRC_GET_REC_CARRIER _IOR('i', 0x00000004, __u32)
+#define LIRC_GET_SEND_DUTY_CYCLE _IOR('i', 0x00000005, __u32)
+#define LIRC_GET_REC_DUTY_CYCLE _IOR('i', 0x00000006, __u32)
+#define LIRC_GET_REC_RESOLUTION _IOR('i', 0x00000007, __u32)
+
+#define LIRC_GET_MIN_TIMEOUT _IOR('i', 0x00000008, __u32)
+#define LIRC_GET_MAX_TIMEOUT _IOR('i', 0x00000009, __u32)
+
+#define LIRC_GET_MIN_FILTER_PULSE _IOR('i', 0x0000000a, __u32)
+#define LIRC_GET_MAX_FILTER_PULSE _IOR('i', 0x0000000b, __u32)
+#define LIRC_GET_MIN_FILTER_SPACE _IOR('i', 0x0000000c, __u32)
+#define LIRC_GET_MAX_FILTER_SPACE _IOR('i', 0x0000000d, __u32)
/* code length in bits, currently only for LIRC_MODE_LIRCCODE */
-#define LIRC_GET_LENGTH _IOR('i', 0x0000000f, unsigned long)
+#define LIRC_GET_LENGTH _IOR('i', 0x0000000f, __u32)
/* all values set should be reset by the driver when the device is
reopened */
/* obsolete: drivers only support one mode */
-#define LIRC_SET_SEND_MODE _IOW('i', 0x00000011, unsigned long)
+#define LIRC_SET_SEND_MODE _IOW('i', 0x00000011, __u32)
/* obsolete: drivers only support one mode */
-#define LIRC_SET_REC_MODE _IOW('i', 0x00000012, unsigned long)
+#define LIRC_SET_REC_MODE _IOW('i', 0x00000012, __u32)
/* Note: these can reset the according pulse_width */
-#define LIRC_SET_SEND_CARRIER _IOW('i', 0x00000013, unsigned int)
-#define LIRC_SET_REC_CARRIER _IOW('i', 0x00000014, unsigned int)
-#define LIRC_SET_SEND_DUTY_CYCLE _IOW('i', 0x00000015, unsigned int)
-#define LIRC_SET_REC_DUTY_CYCLE _IOW('i', 0x00000016, unsigned int)
-#define LIRC_SET_TRANSMITTER_MASK _IOW('i', 0x00000017, unsigned int)
+#define LIRC_SET_SEND_CARRIER _IOW('i', 0x00000013, __u32)
+#define LIRC_SET_REC_CARRIER _IOW('i', 0x00000014, __u32)
+#define LIRC_SET_SEND_DUTY_CYCLE _IOW('i', 0x00000015, __u32)
+#define LIRC_SET_REC_DUTY_CYCLE _IOW('i', 0x00000016, __u32)
+#define LIRC_SET_TRANSMITTER_MASK _IOW('i', 0x00000017, __u32)
/* a value of 0 disables all hardware timeouts and data should be
reported as soon as possible */
-#define LIRC_SET_REC_TIMEOUT _IOW('i', 0x00000018, lirc_t)
+#define LIRC_SET_REC_TIMEOUT _IOW('i', 0x00000018, __u32)
/* 1 enables, 0 disables timeout reports in MODE2 */
-#define LIRC_SET_REC_TIMEOUT_REPORTS _IOW('i', 0x00000019, unsigned int)
+#define LIRC_SET_REC_TIMEOUT_REPORTS _IOW('i', 0x00000019, __u32)
/* pulses shorter than this are filtered out by hardware (software
emulation in lirc_dev/lircd?) */
-#define LIRC_SET_REC_FILTER_PULSE _IOW('i', 0x0000001a, lirc_t)
+#define LIRC_SET_REC_FILTER_PULSE _IOW('i', 0x0000001a, __u32)
/* spaces shorter than this are filtered out by hardware (software
emulation in lirc_dev/lircd?) */
-#define LIRC_SET_REC_FILTER_SPACE _IOW('i', 0x0000001b, lirc_t)
+#define LIRC_SET_REC_FILTER_SPACE _IOW('i', 0x0000001b, __u32)
/* if filter cannot be set independently for pulse/space, this should
be used */
-#define LIRC_SET_REC_FILTER _IOW('i', 0x0000001c, lirc_t)
+#define LIRC_SET_REC_FILTER _IOW('i', 0x0000001c, __u32)
/* if enabled from the next key press on the driver will send
LIRC_MODE2_FREQUENCY packets */
-#define LIRC_SET_MEASURE_CARRIER_MODE _IOW('i', 0x0000001d, unsigned int)
+#define LIRC_SET_MEASURE_CARRIER_MODE _IOW('i', 0x0000001d, __u32)
/*
* to set a range use
@@ -157,8 +158,8 @@ typedef int lirc_t;
* LIRC_SET_REC_DUTY_CYCLE/LIRC_SET_REC_CARRIER with the upper bound
*/
-#define LIRC_SET_REC_DUTY_CYCLE_RANGE _IOW('i', 0x0000001e, unsigned int)
-#define LIRC_SET_REC_CARRIER_RANGE _IOW('i', 0x0000001f, unsigned int)
+#define LIRC_SET_REC_DUTY_CYCLE_RANGE _IOW('i', 0x0000001e, __u32)
+#define LIRC_SET_REC_CARRIER_RANGE _IOW('i', 0x0000001f, __u32)
#define LIRC_NOTIFY_DECODE _IO('i', 0x00000020)

@ -1,21 +0,0 @@
From 3e45e512719feccaa16edfd208273bade4f724e4 Mon Sep 17 00:00:00 2001
From: Mathias Hasselmann <mathias@openismus.com>
Date: Wed, 13 Feb 2008 21:16:09 +0100
Subject: Use '.new' instead of '.conf' as filename suffix in template mode,
and append that the suffix to 'filename_new' instead of 'filename',
to prevent a buffer overrun for 'argv[optind]'.
---
Index: lirc-0.8.7pre2/daemons/irrecord.c
===================================================================
--- lirc-0.8.7pre2.orig/daemons/irrecord.c
+++ lirc-0.8.7pre2/daemons/irrecord.c
@@ -514,7 +514,7 @@ int main(int argc,char **argv)
exit(EXIT_FAILURE);
}
strcpy(filename_new, filename);
- strcat(filename_new, ".conf");
+ strcat(filename_new, ".new");
filename = filename_new;
}
else

@ -16,12 +16,13 @@
%bcond_with svgalib
%bcond_without irman
%bcond_without ftdi
%bcond_with iguanaIR
%global released 1
%define pre pre3
%global released 0
%define pre pre1
Name: lirc
Version: 0.8.7
Version: 0.9.0
%if 0%{?released}
Release: 1%{?dist}
%else
@ -39,13 +40,11 @@ Source0: http://www.lirc.org/software/snapshots/%{name}-%{version}-%{pre}
%endif
Source1: %{name}.init
Source2: %{name}.sysconfig
Patch0: lirc-use-new-instead-of-conf-as-filename-suffix.patch
Patch1: lirc-in-kernel-ioctls.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=457273
# http://thread.gmane.org/gmane.comp.hardware.lirc/6884
Patch2: lirc-0.8.6-standardized-remote-keycodes.patch
Patch3: lirc-0.8.4-make-remote-names-all-unique.patch
Patch4: lirc-0.8.6-firefly-def.patch
Patch0: lirc-0.8.6-standardized-remote-keycodes.patch
Patch1: lirc-0.8.4-make-remote-names-all-unique.patch
Patch2: lirc-0.8.6-firefly-def.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{__perl}
@ -69,6 +68,9 @@ BuildRequires: svgalib-devel
%if %{with x}
BuildRequires: libXt-devel
%endif
%if %{with iguanaIR}
BuildRequires: iguanaIR-devel
%endif
Requires: %{name}-libs = %{version}-%{release}
Requires(post): /sbin/chkconfig
Requires(post): /sbin/ldconfig
@ -140,8 +142,6 @@ of remote control configuration files.
%else
%setup -q -n %{name}-%{version}-%{pre}
%endif
%patch0 -p1
%patch1 -p1
chmod 644 contrib/*
chmod +x contrib/hal
@ -182,9 +182,9 @@ touch -r aclocal.m4 configure.ac # avoid autofoo re-run
# Do this after, as we're touching the remote definitions earlier
# Don't create a backup, or the original definitions will get installed
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
# Re-run autofoo for new cvs features
#autoreconf -i -f
#automake
@ -310,6 +310,11 @@ fi
%changelog
* Tue Oct 26 2010 Jarod Wilson <jarod@redhat.com> 0.9.0-0.1.pre1
- Update to lirc 0.9.0-pre1 snapshot
- Add conditional flag for building with iguanaIR support (there's an
iguanaIR package awaiting review right now)
* Mon Sep 06 2010 Jarod Wilson <jarod@redhat.com> 0.8.7-1
- Update to lirc 0.8.7 release

@ -1 +1 @@
fb1dcddbc8ca3d03c7f3a2d40cf28b71 lirc-0.8.7.tar.bz2
13ba59178adee4e6be8a9a1966ab3133 lirc-0.9.0-pre1.tar.bz2

Loading…
Cancel
Save