Updating for new upstream release 0.9.2a

epel8
Alec Leamas 10 years ago
parent b0cd3ef064
commit 7032784419

1
.gitignore vendored

@ -7,3 +7,4 @@ lirc-0.8.7pre2.tar.bz2
/lirc-0.8.7.tar.bz2
/lirc-0.9.0-pre1.tar.bz2
/lirc-0.9.2.tar.gz
/lirc-0.9.2a.tar.gz

@ -1,24 +1,25 @@
From 184366b6200c80fae167853bab0038a54538ad16 Mon Sep 17 00:00:00 2001
From bd400dc047567d230d194c2be8c911a300c0f723 Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Thu, 11 Dec 2014 00:30:23 +0100
Subject: [PATCH] Changing effective-user default
Date: Mon, 9 Feb 2015 12:46:17 +0100
Subject: [PATCH] lirc_options: Set effective user to lirc.
---
lirc_options.conf | 1 +
1 file changed, 1 insertion(+)
lirc_options.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lirc_options.conf b/lirc_options.conf
index 9dc672a..bf342c1 100644
index 9346de8..bf342c1 100644
--- a/lirc_options.conf
+++ b/lirc_options.conf
@@ -12,6 +12,7 @@ plugindir = /usr/lib/lirc/plugins
@@ -12,7 +12,7 @@ plugindir = /usr/lib/lirc/plugins
permission = 666
allow-simulate = No
repeat-max = 600
-#effective-user =
+effective-user = lirc
#listen = [address:]port
#connect = host[:port]
#debug = 6
--
1.9.3
2.1.0

File diff suppressed because it is too large Load Diff

@ -1,42 +0,0 @@
From 1b347e9e7909afd08fce12992da67340144aeb70 Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Thu, 11 Dec 2014 04:44:49 +0100
Subject: [PATCH 1/5] tools: Make make_rel_symlink.py use python3.
---
tools/make_rel_symlink.py | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/tools/make_rel_symlink.py b/tools/make_rel_symlink.py
index 5c89305..896637f 100755
--- a/tools/make_rel_symlink.py
+++ b/tools/make_rel_symlink.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
import os
import os.path
@@ -32,16 +32,16 @@ if sys.argv[1] == "-p":
sys.argv = sys.argv[ 1:]
if len( sys.argv ) != 3:
- print USAGE
+ print(USAGE)
sys.exit( 1 )
if os.path.isdir( sys.argv[2] ):
- print "Removing link target dir:" + sys.argv[2]
+ print("Removing link target dir:" + sys.argv[2])
shutil.rmtree( sys.argv[2])
link_path = relative_ln_s( sys.argv[1], sys.argv[2] )
if just_print:
- print link_path
+ print(link_path)
else:
os.chdir( os.path.dirname( sys.argv[2]))
target = os.path.basename( sys.argv[2])
--
1.9.3

@ -1,87 +0,0 @@
From 18933e88521431abea8f0bf720cf35cc37d2def4 Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Thu, 11 Dec 2014 11:03:12 +0100
Subject: [PATCH 4/5] all: Sanitize feature tests macros.
---
daemons/lircd.c | 3 ---
lib/lirc_client.c | 6 +-----
plugins/srm7500libusb.c | 1 +
tools/lirc-lsplugins.c | 0
tools/lirc-lsremotes.c | 4 ----
5 files changed, 2 insertions(+), 12 deletions(-)
diff --git a/daemons/lircd.c b/daemons/lircd.c
index ab44e80..d1bdc7c 100644
--- a/daemons/lircd.c
+++ b/daemons/lircd.c
@@ -31,9 +31,6 @@
# include <config.h>
#endif
-#define _GNU_SOURCE
-#define _BSD_SOURCE
-
#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
diff --git a/lib/lirc_client.c b/lib/lirc_client.c
index 4720f3f..b161f0e 100644
--- a/lib/lirc_client.c
+++ b/lib/lirc_client.c
@@ -17,11 +17,6 @@
* @author Christoph Bartelmus, Trent Piepho, Michal Svec
*/
-// define _XOPEN_SOURCE for WEXITSTATUS
-#define _XOPEN_SOURCE
-// define _BSD_SOURCE for strdup()
-#define _BSD_SOURCE
-
#ifdef HAVE_CONFIG_H
# include <config.h>
#endif
@@ -34,6 +29,7 @@
#include <stdlib.h>
#include <stdarg.h>
#include <string.h>
+#include <strings.h>
#include <sys/param.h>
#include <sys/socket.h>
#include <sys/stat.h>
diff --git a/plugins/srm7500libusb.c b/plugins/srm7500libusb.c
index f598f4d..06206bc 100644
--- a/plugins/srm7500libusb.c
+++ b/plugins/srm7500libusb.c
@@ -33,6 +33,7 @@
#endif
#define _GNU_SOURCE
+
#include <errno.h>
#include <signal.h>
#include <string.h>
diff --git a/tools/lirc-lsremotes.c b/tools/lirc-lsremotes.c
index 11e806a..7c6ab06 100644
--- a/tools/lirc-lsremotes.c
+++ b/tools/lirc-lsremotes.c
@@ -7,16 +7,12 @@
*
*/
-#define _GNU_SOURCE
-
#include <config.h>
#include <dirent.h>
#include <getopt.h>
#include <errno.h>
#include <fnmatch.h>
-
-
#include <glob.h>
#include <libgen.h>
#include <limits.h>
--
1.9.3

@ -1,53 +0,0 @@
From 192e627fa81c3e8df086801dea228cb2fdcbb8bb Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Thu, 11 Dec 2014 11:24:27 +0100
Subject: [PATCH] configure.ac: Use pkg-config to locate ftdi.
This picks up changed locations e. g., in fedora-22.
---
configure.ac | 13 ++++++++++---
plugins/Makefile.am | 2 +-
2 files changed, 11 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index aaba636..b32b1e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,11 +183,18 @@ AC_CHECK_HEADER(usb.h,[
],[
AM_CONDITIONAL([BUILD_USB],[false])]
)
-AC_CHECK_HEADER(ftdi.h,[
+PKG_CHECK_MODULES([FTDI],[libftdi],,[true])
+test -z "$FTDI_LIBS" && PKG_CHECK_MODULES([FTDI], [libftdi1],,[true])
+
+if test -n "$FTDI_LIBS"; then
+ CFLAGS="$CFLAGS $SYSTEMD_CFLAGS"
+ LDFLAGS="$LDFLAGS $FTDI_LIBS"
+ AC_DEFINE(HAVE_FTDI)
AM_CONDITIONAL([BUILD_FTDI],[true])
- ],[
+ AC_SUBST(FTDI_LIBS)
+else
AM_CONDITIONAL([BUILD_FTDI],[false])]
-)
+fi
AC_CHECK_HEADER(iguanaIR.h,[
AM_CONDITIONAL([BUILD_IGUANAIR],[true])
],[
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 175b025..07cf187 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -47,7 +47,7 @@ endif
if BUILD_FTDI
plugin_LTLIBRARIES += ftdi.la
ftdi_la_SOURCES = ftdi.c
-ftdi_la_LDFLAGS = $(AM_LDFLAGS) -lftdi
+ftdi_la_LDFLAGS = $(AM_LDFLAGS) @FTDI_LIBS@
endif
if BUILD_IGUANAIR
--
1.9.3

File diff suppressed because it is too large Load Diff

@ -7,7 +7,7 @@
#define pre pre3
Name: lirc
Version: 0.9.2
Version: 0.9.2a
%global src_vers %(echo %{version} | sed 's/_/-/g' )
%if 0%{?released}
Release: 1%{?dist}
@ -30,12 +30,7 @@ Source6: README.fedora
Source7: 99-remote-control-lirc.rules
# Config only, cannot be upstreamed.
Patch1: 0001-Changing-effective-user-default.patch
# Already upstream (0002..0006).
Patch2: 0002-tools-Make-make_rel_symlink.py-use-python3.patch
Patch3: 0003-all-Use-puts-instead-of-printf-when-applicable.patch
Patch4: 0004-all-Sanitize-feature-tests-macros.patch
Patch5: 0005-configure.ac-Use-pkg-config-to-locate-ftdi.patch
Patch6: 0006-Add-Doxyfile-not-part-of-dist-tarball.patch
Patch2: 0002-Use-puts-instead-of-printf-when-applicalble.patch
BuildRequires: alsa-lib-devel
Buildrequires: autoconf
@ -223,17 +218,13 @@ full support for the ftdi device.
%endif
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
sed -i -e 's|/usr/local/etc/|/etc/|' contrib/irman2lirc
%build
autoreconf -fi
CFLAGS="-I/usr/include/libftdi1 %{optflags}" %configure --libdir=%{_libdir}
CFLAGS="%{optflags}" %configure --libdir=%{_libdir}
make %{?_smp_mflags}
@ -383,6 +374,9 @@ find /etc/systemd -name lirc.service -xtype l -delete || :
%changelog
* Mon Feb 09 2015 Alec Leamas <leamas.alec@gmail.com> - 0.9.2a-1
- Updating for new release 0.9.2a, most patches upstreamed.
* Wed Dec 10 2014 Alec Leamas <leamas.alec@nowhere.net> - 0.9.2-1
- Major upstream update.
- New package structure with more, smaller packages.

@ -1 +1 @@
c9154bf61947dde0ba1b91f7dd54c2e5 lirc-0.9.2.tar.gz
c39d6bc901157c308163e6fd58727346 lirc-0.9.2a.tar.gz

Loading…
Cancel
Save