You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
linphone-desktop/SOURCES/0001-Fix-RPATH.patch

26 lines
795 B

From 49198f9497f53bcc7fc70c69774f1aeaf56e052e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
Date: Mon, 1 Jan 2024 15:04:12 +0200
Subject: [PATCH] Fix RPATH
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a52815..3232cfd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -235,7 +235,7 @@ if(NOT APPLE OR MONO_ARCH)
if(APPLE)
set(CMAKE_INSTALL_RPATH "@executable_path/../Frameworks")
elseif(UNIX)
- set(CMAKE_INSTALL_RPATH "$ORIGIN:$ORIGIN/lib64:$ORIGIN/../lib64:$ORIGIN/lib:$ORIGIN/../lib")
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}/linphone")
endif()
add_subdirectory("external/ispell")
add_subdirectory("linphone-app")
--
2.43.0