You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
1.1 KiB
36 lines
1.1 KiB
diff -rupN --no-dereference libwebp-1.3.1/CMakeLists.txt libwebp-1.3.1-new/CMakeLists.txt
|
|
--- libwebp-1.3.1/CMakeLists.txt 2023-06-23 20:52:38.000000000 +0200
|
|
+++ libwebp-1.3.1-new/CMakeLists.txt 2023-06-30 13:58:57.206935155 +0200
|
|
@@ -564,8 +564,8 @@ endif()
|
|
|
|
if(WEBP_BUILD_VWEBP)
|
|
# vwebp
|
|
- find_package(GLUT)
|
|
- if(GLUT_FOUND)
|
|
+ find_package(FreeGLUT)
|
|
+ if(FreeGLUT_FOUND)
|
|
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
|
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
|
add_executable(vwebp ${VWEBP_SRCS})
|
|
@@ -573,7 +573,7 @@ if(WEBP_BUILD_VWEBP)
|
|
vwebp
|
|
${OPENGL_LIBRARIES}
|
|
exampleutil
|
|
- GLUT::GLUT
|
|
+ glut
|
|
imageioutil
|
|
webp
|
|
webpdemux)
|
|
diff -rupN --no-dereference libwebp-1.3.1/examples/vwebp.c libwebp-1.3.1-new/examples/vwebp.c
|
|
--- libwebp-1.3.1/examples/vwebp.c 2023-06-23 20:52:38.000000000 +0200
|
|
+++ libwebp-1.3.1-new/examples/vwebp.c 2023-06-30 13:58:57.207935140 +0200
|
|
@@ -27,7 +27,7 @@
|
|
#if defined(HAVE_GLUT_GLUT_H)
|
|
#include <GLUT/glut.h>
|
|
#else
|
|
-#include <GL/glut.h>
|
|
+#include <GL/freeglut.h>
|
|
#ifdef FREEGLUT
|
|
#include <GL/freeglut.h>
|
|
#endif
|