You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
43 lines
1.2 KiB
43 lines
1.2 KiB
From 3348a7e42e86dfb98dd7458ad29def476cf6096f Mon Sep 17 00:00:00 2001
|
|
From: Christian Beier <dontmind@freeshell.org>
|
|
Date: Sat, 9 Feb 2019 13:23:26 +0100
|
|
Subject: [PATCH] CMake: replace hardcoded 'lib' with ${CMAKE_INSTALL_LIBDIR}
|
|
|
|
Closes #281
|
|
---
|
|
CMakeLists.txt | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 873cc7b5..55f7e650 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -9,6 +9,7 @@ include(CheckTypeSize)
|
|
include(TestBigEndian)
|
|
include(CheckCSourceCompiles)
|
|
include(CheckCSourceRuns)
|
|
+include(GNUInstallDirs)
|
|
|
|
enable_testing()
|
|
|
|
@@ -666,8 +667,8 @@ get_link_libraries(PRIVATE_LIBS vncclient)
|
|
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libvncclient.pc.cmakein ${CMAKE_CURRENT_BINARY_DIR}/libvncclient.pc @ONLY)
|
|
|
|
|
|
-install_targets(/lib vncserver)
|
|
-install_targets(/lib vncclient)
|
|
+install_targets(/${CMAKE_INSTALL_LIBDIR} vncserver)
|
|
+install_targets(/${CMAKE_INSTALL_LIBDIR} vncclient)
|
|
install_files(/include/rfb FILES
|
|
rfb/keysym.h
|
|
rfb/rfb.h
|
|
@@ -677,7 +678,7 @@ install_files(/include/rfb FILES
|
|
rfb/rfbregion.h
|
|
)
|
|
|
|
-install_files(/lib/pkgconfig FILES
|
|
+install_files(/${CMAKE_INSTALL_LIBDIR}/pkgconfig FILES
|
|
libvncserver.pc
|
|
libvncclient.pc
|
|
)
|