Rex Dieter 8 years ago
parent 737f850d68
commit 947ff9ef95

1
.gitignore vendored

@ -3,3 +3,4 @@
/LibVNCServer-0.9.10-646f844f.tar.gz
/LibVNCServer-0.9.10-9453be42.tar.gz
/LibVNCServer-0.9.10.tar.gz
/LibVNCServer-0.9.11.tar.gz

@ -1,99 +0,0 @@
diff -Nur libvncserver-LibVNCServer-0.9.10.than/libvncclient/listen.c libvncserver-LibVNCServer-0.9.10/libvncclient/listen.c
--- libvncserver-LibVNCServer-0.9.10.than/libvncclient/listen.c 2014-10-21 17:57:11.000000000 +0200
+++ libvncserver-LibVNCServer-0.9.10/libvncclient/listen.c 2016-02-18 13:13:26.265271713 +0100
@@ -99,7 +99,7 @@
if(listen6Socket >= 0)
FD_SET(listen6Socket, &fds);
- r = select(max(listenSocket, listen6Socket)+1, &fds, NULL, NULL, NULL);
+ r = select(VNC_MAX(listenSocket, listen6Socket)+1, &fds, NULL, NULL, NULL);
if (r > 0) {
if (FD_ISSET(listenSocket, &fds))
@@ -195,9 +195,9 @@
FD_SET(client->listen6Sock, &fds);
if (timeout < 0)
- r = select(max(client->listenSock, client->listen6Sock) +1, &fds, NULL, NULL, NULL);
+ r = select(VNC_MAX(client->listenSock, client->listen6Sock) +1, &fds, NULL, NULL, NULL);
else
- r = select(max(client->listenSock, client->listen6Sock) +1, &fds, NULL, NULL, &to);
+ r = select(VNC_MAX(client->listenSock, client->listen6Sock) +1, &fds, NULL, NULL, &to);
if (r > 0)
{
diff -Nur libvncserver-LibVNCServer-0.9.10.than/libvncserver/httpd.c libvncserver-LibVNCServer-0.9.10/libvncserver/httpd.c
--- libvncserver-LibVNCServer-0.9.10.than/libvncserver/httpd.c 2014-10-21 17:57:11.000000000 +0200
+++ libvncserver-LibVNCServer-0.9.10/libvncserver/httpd.c 2016-02-18 13:13:56.527062313 +0100
@@ -192,7 +192,7 @@
}
tv.tv_sec = 0;
tv.tv_usec = 0;
- nfds = select(max(rfbScreen->httpListen6Sock, max(rfbScreen->httpSock,rfbScreen->httpListenSock)) + 1, &fds, NULL, NULL, &tv);
+ nfds = select(VNC_MAX(rfbScreen->httpListen6Sock, VNC_MAX(rfbScreen->httpSock,rfbScreen->httpListenSock)) + 1, &fds, NULL, NULL, &tv);
if (nfds == 0) {
return;
}
diff -Nur libvncserver-LibVNCServer-0.9.10.than/libvncserver/rfbserver.c libvncserver-LibVNCServer-0.9.10/libvncserver/rfbserver.c
--- libvncserver-LibVNCServer-0.9.10.than/libvncserver/rfbserver.c 2014-10-21 17:57:11.000000000 +0200
+++ libvncserver-LibVNCServer-0.9.10/libvncserver/rfbserver.c 2016-02-18 13:13:40.808171081 +0100
@@ -367,7 +367,7 @@
}
FD_SET(sock,&(rfbScreen->allFds));
- rfbScreen->maxFd = max(sock,rfbScreen->maxFd);
+ rfbScreen->maxFd = VNC_MAX(sock,rfbScreen->maxFd);
INIT_MUTEX(cl->outputMutex);
INIT_MUTEX(cl->refCountMutex);
diff -Nur libvncserver-LibVNCServer-0.9.10.than/libvncserver/sockets.c libvncserver-LibVNCServer-0.9.10/libvncserver/sockets.c
--- libvncserver-LibVNCServer-0.9.10.than/libvncserver/sockets.c 2014-10-21 17:57:11.000000000 +0200
+++ libvncserver-LibVNCServer-0.9.10/libvncserver/sockets.c 2016-02-18 13:13:48.695116507 +0100
@@ -193,7 +193,7 @@
rfbLog("Autoprobing selected TCP6 port %d\n", rfbScreen->ipv6port);
FD_SET(rfbScreen->listen6Sock, &(rfbScreen->allFds));
- rfbScreen->maxFd = max((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
+ rfbScreen->maxFd = VNC_MAX((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
#endif
}
else
@@ -220,7 +220,7 @@
rfbLog("Listening for VNC connections on TCP6 port %d\n", rfbScreen->ipv6port);
FD_SET(rfbScreen->listen6Sock, &(rfbScreen->allFds));
- rfbScreen->maxFd = max((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
+ rfbScreen->maxFd = VNC_MAX((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
}
#endif
@@ -236,7 +236,7 @@
rfbLog("Listening for VNC connections on TCP port %d\n", rfbScreen->port);
FD_SET(rfbScreen->udpSock, &(rfbScreen->allFds));
- rfbScreen->maxFd = max((int)rfbScreen->udpSock,rfbScreen->maxFd);
+ rfbScreen->maxFd = VNC_MAX((int)rfbScreen->udpSock,rfbScreen->maxFd);
}
}
@@ -555,7 +555,7 @@
/* AddEnabledDevice(sock); */
FD_SET(sock, &rfbScreen->allFds);
- rfbScreen->maxFd = max(sock,rfbScreen->maxFd);
+ rfbScreen->maxFd = VNC_MAX(sock,rfbScreen->maxFd);
return sock;
}
diff -Nur libvncserver-LibVNCServer-0.9.10.than/rfb/rfbproto.h libvncserver-LibVNCServer-0.9.10/rfb/rfbproto.h
--- libvncserver-LibVNCServer-0.9.10.than/rfb/rfbproto.h 2014-10-21 17:57:11.000000000 +0200
+++ libvncserver-LibVNCServer-0.9.10/rfb/rfbproto.h 2016-02-18 13:14:08.672978267 +0100
@@ -93,7 +93,7 @@
#endif
#if !defined(WIN32) || defined(__MINGW32__)
-#define max(a,b) (((a)>(b))?(a):(b))
+#define VNC_MAX(a,b) (((a)>(b))?(a):(b))
#ifdef LIBVNCSERVER_HAVE_SYS_TIME_H
#include <sys/time.h>
#endif

@ -1,67 +0,0 @@
diff -Naur libvncserver-LibVNCServer-0.9.10.old/libvncclient/Makefile.am libvncserver-LibVNCServer-0.9.10/libvncclient/Makefile.am
--- libvncserver-LibVNCServer-0.9.10.old/libvncclient/Makefile.am 2015-12-12 00:14:37.269157918 +0100
+++ libvncserver-LibVNCServer-0.9.10/libvncclient/Makefile.am 2015-12-12 00:17:43.040435309 +0100
@@ -13,10 +13,10 @@
endif
-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
-libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS)
+libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c $(TLSSRCS)
+libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS) -lminilzo
-noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h
+noinst_HEADERS=tls.h
rfbproto.o: rfbproto.c corre.c hextile.c rre.c tight.c zlib.c zrle.c ultra.c
diff -Naur libvncserver-LibVNCServer-0.9.10.old/libvncclient/rfbproto.c libvncserver-LibVNCServer-0.9.10/libvncclient/rfbproto.c
--- libvncserver-LibVNCServer-0.9.10.old/libvncclient/rfbproto.c 2015-12-12 00:14:37.269157918 +0100
+++ libvncserver-LibVNCServer-0.9.10/libvncclient/rfbproto.c 2015-12-12 00:17:43.041435322 +0100
@@ -66,7 +66,7 @@
#include <gcrypt.h>
#endif
-#include "minilzo.h"
+#include <lzo/minilzo.h>
#include "tls.h"
#ifdef _MSC_VER
diff -Naur libvncserver-LibVNCServer-0.9.10.old/libvncserver/Makefile.am libvncserver-LibVNCServer-0.9.10/libvncserver/Makefile.am
--- libvncserver-LibVNCServer-0.9.10.old/libvncserver/Makefile.am 2015-12-12 00:14:37.270157930 +0100
+++ libvncserver-LibVNCServer-0.9.10/libvncserver/Makefile.am 2015-12-12 00:17:43.042435334 +0100
@@ -37,7 +37,7 @@
noinst_HEADERS=../common/d3des.h ../rfb/default8x16.h zrleoutstream.h \
zrlepalettehelper.h zrletypes.h private.h scale.h rfbssl.h rfbcrypto.h \
- ../common/minilzo.h ../common/lzoconf.h ../common/lzodefs.h ../common/md5.h ../common/sha1.h \
+ ../common/md5.h ../common/sha1.h \
$(TIGHTVNCFILETRANSFERHDRS)
EXTRA_DIST=tableinit24.c tableinittctemplate.c tabletranstemplate.c \
@@ -54,11 +54,11 @@
LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c $(WEBSOCKETSSRCS) \
stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
httpd.c cursor.c font.c \
- draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \
+ draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ultra.c scale.c \
$(ZLIBSRCS) $(TIGHTSRCS) $(TIGHTVNCFILETRANSFERSRCS)
libvncserver_la_SOURCES=$(LIB_SRCS)
-libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS)
+libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS) -lminilzo
lib_LTLIBRARIES=libvncserver.la
diff -Naur libvncserver-LibVNCServer-0.9.10.old/libvncserver/ultra.c libvncserver-LibVNCServer-0.9.10/libvncserver/ultra.c
--- libvncserver-LibVNCServer-0.9.10.old/libvncserver/ultra.c 2015-12-12 00:14:37.271157942 +0100
+++ libvncserver-LibVNCServer-0.9.10/libvncserver/ultra.c 2015-12-12 00:17:43.042435334 +0100
@@ -8,7 +8,7 @@
*/
#include <rfb/rfb.h>
-#include "minilzo.h"
+#include <lzo/minilzo.h>
/*
* cl->beforeEncBuf contains pixel data in the client's format.

@ -0,0 +1,55 @@
diff -up libvncserver-LibVNCServer-0.9.11/libvncclient/Makefile.am.system_minilzo libvncserver-LibVNCServer-0.9.11/libvncclient/Makefile.am
--- libvncserver-LibVNCServer-0.9.11/libvncclient/Makefile.am.system_minilzo 2017-02-14 10:54:54.308402791 -0600
+++ libvncserver-LibVNCServer-0.9.11/libvncclient/Makefile.am 2017-02-14 10:56:28.007379315 -0600
@@ -13,8 +13,8 @@ endif
endif
-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
-libvncclient_la_LIBADD=$(TLSLIBS)
+libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c $(TLSSRCS)
+libvncclient_la_LIBADD=$(TLSLIBS) -lminilzo
noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h
diff -up libvncserver-LibVNCServer-0.9.11/libvncclient/rfbproto.c.system_minilzo libvncserver-LibVNCServer-0.9.11/libvncclient/rfbproto.c
--- libvncserver-LibVNCServer-0.9.11/libvncclient/rfbproto.c.system_minilzo 2016-12-30 07:01:28.000000000 -0600
+++ libvncserver-LibVNCServer-0.9.11/libvncclient/rfbproto.c 2017-02-14 10:54:54.309402801 -0600
@@ -66,7 +66,7 @@
#include <gcrypt.h>
#endif
-#include "minilzo.h"
+#include <lzo/minilzo.h>
#include "tls.h"
#ifdef _MSC_VER
diff -up libvncserver-LibVNCServer-0.9.11/libvncserver/Makefile.am.system_minilzo libvncserver-LibVNCServer-0.9.11/libvncserver/Makefile.am
--- libvncserver-LibVNCServer-0.9.11/libvncserver/Makefile.am.system_minilzo 2017-02-14 10:54:54.309402801 -0600
+++ libvncserver-LibVNCServer-0.9.11/libvncserver/Makefile.am 2017-02-14 10:57:28.495009713 -0600
@@ -53,11 +53,11 @@ endif
LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c $(WEBSOCKETSSRCS) \
stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
httpd.c cursor.c font.c \
- draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \
+ draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ultra.c scale.c \
$(ZLIBSRCS) $(TIGHTSRCS) $(TIGHTVNCFILETRANSFERSRCS)
libvncserver_la_SOURCES=$(LIB_SRCS)
-libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS)
+libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS) -lminilzo
if WITH_SYSTEMD
AM_CPPFLAGS += -DLIBVNCSERVER_WITH_SYSTEMD
diff -up libvncserver-LibVNCServer-0.9.11/libvncserver/ultra.c.system_minilzo libvncserver-LibVNCServer-0.9.11/libvncserver/ultra.c
--- libvncserver-LibVNCServer-0.9.11/libvncserver/ultra.c.system_minilzo 2016-12-30 07:01:28.000000000 -0600
+++ libvncserver-LibVNCServer-0.9.11/libvncserver/ultra.c 2017-02-14 10:54:54.309402801 -0600
@@ -8,7 +8,7 @@
*/
#include <rfb/rfb.h>
-#include "minilzo.h"
+#include <lzo/minilzo.h>
/*
* cl->beforeEncBuf contains pixel data in the client's format.

@ -1,26 +1,22 @@
Summary: Library to make writing a VNC server easy
Name: libvncserver
Version: 0.9.10
Release: 6%{?dist}
Version: 0.9.11
Release: 1%{?dist}
# NOTE: --with-filetransfer => GPLv2
License: GPLv2+
URL: http://libvnc.github.io/
Source0: https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz
Patch1: LibVNCServer-0.9.10-system_minilzo.patch
Patch1: libvncserver-0.9.11-system_minilzo.patch
Patch2: libvncserver-0.9.1-multilib.patch
Patch3: LibVNCServer-0.9.10-system-crypto-policy.patch
# https://github.com/LibVNC/libvncserver/issues/102
Patch4: LibVNCServer-0.9.10-max-gcc6.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libgcrypt-devel
BuildRequires: libjpeg-devel
BuildRequires: libtool
## FIXME/TODO: --with-va FTBFS
#BuildRequires: libva-devel
BuildRequires: lzo-devel
BuildRequires: lzo-minilzo
BuildRequires: pkgconfig(gnutls)
@ -63,12 +59,13 @@ developing applications that use %{name}.
%prep
%setup -q -n %{name}-LibVNCServer-%{version}
%patch1 -p1 -b .system_minilzo
# Nuke bundled minilzo
rm -fv common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
#rm -fv common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
%patch2 -p1 -b .multilib
%patch3 -p1
%patch4 -p1
# Fix encoding
for file in ChangeLog ; do
@ -87,7 +84,6 @@ autoreconf -vif
--disable-static \
--without-filetransfer \
--with-gcrypt \
--without-libva \
--with-png \
--with-x11vnc
@ -109,16 +105,15 @@ rm -fv %{buildroot}%{_libdir}/lib*.la
%check
make -C test test ||:
%post -p /sbin/ldconfig
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc AUTHORS ChangeLog NEWS README TODO
%{_libdir}/libvncclient.so.0*
%{_libdir}/libvncserver.so.0*
%{_libdir}/libvncclient.so.1*
%{_libdir}/libvncserver.so.1*
%files devel
%{_bindir}/libvncserver-config
@ -130,6 +125,9 @@ make -C test test ||:
%changelog
* Tue Feb 14 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.9.11-1
- 0.9.11 (#1421948)
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.10-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

@ -1 +1 @@
e1b888fae717b06896f8aec100163d27 LibVNCServer-0.9.10.tar.gz
SHA512 (LibVNCServer-0.9.11.tar.gz) = e473c081b68dd3cdd96a1756b4f4945ece79d3c8e4cef62140be1699671555fc16d3080e81d764197a14ea83203ffcd0e18c3cc182e012d036e3faae943003fb

Loading…
Cancel
Save