Update to the latest git commit 646f844 (#1092245)

epel9
Rex Dieter 11 years ago
parent 2de2888588
commit 3812732acd

1
.gitignore vendored

@ -1,2 +1,3 @@
/LibVNCServer-0.9.8.2.tar.gz
/LibVNCServer-0.9.9.tar.gz
/LibVNCServer-0.9.10-646f844f.tar.gz

@ -1,29 +0,0 @@
From 66282f58000c8863e104666c30cb67b1d5cbdee3 Mon Sep 17 00:00:00 2001
From: "Kyle J. McKay" <mackyle@gmail.com>
Date: Fri, 18 May 2012 00:30:11 -0700
Subject: [PATCH 05/32] libvncserver/sockets.c: do not segfault when
listenSock/listen6Sock == -1
---
libvncserver/sockets.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libvncserver/sockets.c b/libvncserver/sockets.c
index 84c9c98..3ff2aac 100644
--- a/libvncserver/sockets.c
+++ b/libvncserver/sockets.c
@@ -402,9 +402,9 @@ rfbProcessNewConnection(rfbScreenInfoPtr rfbScreen)
rfbLogPerror("rfbProcessNewConnection: error in select");
return FALSE;
}
- if (FD_ISSET(rfbScreen->listenSock, &listen_fds))
+ if (rfbScreen->listenSock >= 0 && FD_ISSET(rfbScreen->listenSock, &listen_fds))
chosen_listen_sock = rfbScreen->listenSock;
- if (FD_ISSET(rfbScreen->listen6Sock, &listen_fds))
+ if (rfbScreen->listen6Sock >= 0 && FD_ISSET(rfbScreen->listen6Sock, &listen_fds))
chosen_listen_sock = rfbScreen->listen6Sock;
if ((sock = accept(chosen_listen_sock,
--
1.8.3.1

@ -1,48 +0,0 @@
From 584542ba97d35706a9e5c001b5cdf64296b5dd7f Mon Sep 17 00:00:00 2001
From: Oliver Loch <o.loch@gmx.net>
Date: Wed, 8 Aug 2012 22:09:13 +0200
Subject: [PATCH 10/32] Patched sockets.c to allow the use of IPv6 without
IPv4.
As requested only those lines are indented that have been changed.
---
libvncserver/sockets.c | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/libvncserver/sockets.c b/libvncserver/sockets.c
index 3ff2aac..15b40ac 100644
--- a/libvncserver/sockets.c
+++ b/libvncserver/sockets.c
@@ -176,7 +176,9 @@ rfbInitSockets(rfbScreenInfoPtr rfbScreen)
rfbScreen->maxFd = max((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
#endif
}
- else if(rfbScreen->port>0) {
+ else
+ {
+ if(rfbScreen->port>0) {
FD_ZERO(&(rfbScreen->allFds));
if ((rfbScreen->listenSock = rfbListenOnTCPPort(rfbScreen->port, iface)) < 0) {
@@ -187,8 +189,10 @@ rfbInitSockets(rfbScreenInfoPtr rfbScreen)
FD_SET(rfbScreen->listenSock, &(rfbScreen->allFds));
rfbScreen->maxFd = rfbScreen->listenSock;
+ }
#ifdef LIBVNCSERVER_IPv6
+ if (rfbScreen->ipv6port>0) {
if ((rfbScreen->listen6Sock = rfbListenOnTCP6Port(rfbScreen->ipv6port, rfbScreen->listen6Interface)) < 0) {
/* ListenOnTCP6Port has its own detailed error printout */
return;
@@ -197,6 +201,7 @@ rfbInitSockets(rfbScreenInfoPtr rfbScreen)
FD_SET(rfbScreen->listen6Sock, &(rfbScreen->allFds));
rfbScreen->maxFd = max((int)rfbScreen->listen6Sock,rfbScreen->maxFd);
+ }
#endif
}
--
1.8.3.1

@ -1,7 +1,7 @@
diff -up LibVNCServer-0.9.9/configure.ac.system_minilzo LibVNCServer-0.9.9/configure.ac
--- LibVNCServer-0.9.9/configure.ac.system_minilzo 2012-05-04 11:27:08.000000000 -0500
+++ LibVNCServer-0.9.9/configure.ac 2012-05-07 08:22:19.473583597 -0500
@@ -992,7 +992,7 @@ if test "$build_x11vnc" = "yes"; then
diff -up LibVNCServer-0.9.10/configure.ac.no_x11vnc LibVNCServer-0.9.10/configure.ac
--- LibVNCServer-0.9.10/configure.ac.no_x11vnc 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/configure.ac 2014-04-29 09:06:27.336448096 -0500
@@ -1020,7 +1020,7 @@ if test "$build_x11vnc" = "yes"; then
#
# configure.ac:690: required file `x11vnc/Makefile.in' not found
#
@ -10,9 +10,9 @@ diff -up LibVNCServer-0.9.9/configure.ac.system_minilzo LibVNCServer-0.9.9/confi
if test ! -z "$with_system_libvncserver" -a "x$with_system_libvncserver" != "xno"; then
# need to move local tarball rfb headers aside:
diff -up LibVNCServer-0.9.9/Makefile.am.system_minilzo LibVNCServer-0.9.9/Makefile.am
--- LibVNCServer-0.9.9/Makefile.am.system_minilzo 2012-05-04 09:19:00.000000000 -0500
+++ LibVNCServer-0.9.9/Makefile.am 2012-05-07 08:22:19.475583573 -0500
diff -up LibVNCServer-0.9.10/Makefile.am.no_x11vnc LibVNCServer-0.9.10/Makefile.am
--- LibVNCServer-0.9.10/Makefile.am.no_x11vnc 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/Makefile.am 2014-04-29 09:06:27.337448086 -0500
@@ -1,6 +1,6 @@
-if WITH_X11VNC
-X11VNC=x11vnc
@ -20,7 +20,6 @@ diff -up LibVNCServer-0.9.9/Makefile.am.system_minilzo LibVNCServer-0.9.9/Makefi
+#if WITH_X11VNC
+#X11VNC=x11vnc
+#endif
SUBDIRS=libvncserver examples libvncclient vncterm webclients client_examples test $(X11VNC)
DIST_SUBDIRS=libvncserver examples libvncclient vncterm webclients client_examples test

@ -1,24 +1,24 @@
diff -up LibVNCServer-0.9.9/libvncclient/Makefile.am.system_minilzo LibVNCServer-0.9.9/libvncclient/Makefile.am
--- LibVNCServer-0.9.9/libvncclient/Makefile.am.system_minilzo 2012-05-04 09:19:00.000000000 -0500
+++ LibVNCServer-0.9.9/libvncclient/Makefile.am 2012-05-07 08:22:19.474583585 -0500
diff -up LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncclient/Makefile.am
--- LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/libvncclient/Makefile.am 2014-04-29 08:56:27.861761880 -0500
@@ -13,10 +13,10 @@ endif
endif
-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
-libvncclient_la_LIBADD=$(TLSLIBS)
-libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS)
+libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c $(TLSSRCS)
+libvncclient_la_LIBADD=$(TLSLIBS) -lminilzo
+libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS) -lminilzo
-noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h
+noinst_HEADERS=tls.h
rfbproto.o: rfbproto.c corre.c hextile.c rre.c tight.c zlib.c zrle.c ultra.c
diff -up LibVNCServer-0.9.9/libvncclient/rfbproto.c.system_minilzo LibVNCServer-0.9.9/libvncclient/rfbproto.c
--- LibVNCServer-0.9.9/libvncclient/rfbproto.c.system_minilzo 2012-05-04 09:19:00.000000000 -0500
+++ LibVNCServer-0.9.9/libvncclient/rfbproto.c 2012-05-07 08:22:19.474583585 -0500
@@ -59,7 +59,7 @@
diff -up LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo LibVNCServer-0.9.10/libvncclient/rfbproto.c
--- LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/libvncclient/rfbproto.c 2014-04-29 08:39:57.638331693 -0500
@@ -61,7 +61,7 @@
#include <gcrypt.h>
#endif
@ -27,9 +27,9 @@ diff -up LibVNCServer-0.9.9/libvncclient/rfbproto.c.system_minilzo LibVNCServer-
#include "tls.h"
/*
diff -up LibVNCServer-0.9.9/libvncserver/Makefile.am.system_minilzo LibVNCServer-0.9.9/libvncserver/Makefile.am
--- LibVNCServer-0.9.9/libvncserver/Makefile.am.system_minilzo 2012-05-04 09:19:00.000000000 -0500
+++ LibVNCServer-0.9.9/libvncserver/Makefile.am 2012-05-07 08:31:01.342059345 -0500
diff -up LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncserver/Makefile.am
--- LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/libvncserver/Makefile.am 2014-04-29 08:39:57.638331693 -0500
@@ -37,7 +37,7 @@ include_HEADERS=../rfb/rfb.h ../rfb/rfbc
noinst_HEADERS=../common/d3des.h ../rfb/default8x16.h zrleoutstream.h \
@ -53,9 +53,9 @@ diff -up LibVNCServer-0.9.9/libvncserver/Makefile.am.system_minilzo LibVNCServer
lib_LTLIBRARIES=libvncserver.la
diff -up LibVNCServer-0.9.9/libvncserver/ultra.c.system_minilzo LibVNCServer-0.9.9/libvncserver/ultra.c
--- LibVNCServer-0.9.9/libvncserver/ultra.c.system_minilzo 2012-05-04 09:19:00.000000000 -0500
+++ LibVNCServer-0.9.9/libvncserver/ultra.c 2012-05-07 08:22:19.475583573 -0500
diff -up LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo LibVNCServer-0.9.10/libvncserver/ultra.c
--- LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
+++ LibVNCServer-0.9.10/libvncserver/ultra.c 2014-04-29 08:39:57.638331693 -0500
@@ -8,7 +8,7 @@
*/

@ -1,24 +1,31 @@
%define git_commit 646f844f69cc74b8eebf25cc76663b2ee851e5d3
%define git_short 646f844f
%define snap 20140405
Summary: Library to make writing a vnc server easy
Name: libvncserver
Version: 0.9.9
Release: 11%{?dist}
Version: 0.9.10
Release: 0.1.%{snap}git%{git_short}%{?dist}
# NOTE: --with-tightvnc-filetransfer => GPLv2
License: GPLv2+
URL: http://libvncserver.sourceforge.net/
%if 0%{?snap:1}
# git archive --prefix=LibVNCServer-0.9.10/ 646f844f69cc74b8eebf25cc76663b2ee851e5d3 | gzip -9 > LibVNCServer-0.9.10-646f844f.tar.gz
Source0: LibVNCServer-%{version}-%{git_short}.tar.gz
%else
Source0: http://downloads.sf.net/libvncserver/LibVNCServer-%{version}.tar.gz
%endif
# workaround there being no x11vnc/ dir in tarball
Patch0: LibVNCServer-0.9.9-no_x11vnc.patch
Patch1: LibVNCServer-0.9.9-system_minilzo.patch
Patch0: LibVNCServer-0.9.10-no_x11vnc.patch
Patch1: LibVNCServer-0.9.10-system_minilzo.patch
Patch2: libvncserver-0.9.1-multilib.patch
# pkgconfig love (upstreamable)
Patch3: LibVNCServer-0.9.9-pkgconfig.patch
## upstream patches
Patch105: 0005-libvncserver-sockets.c-do-not-segfault-when-listenSo.patch
Patch110: 0010-Patched-sockets.c-to-allow-the-use-of-IPv6-without-I.patch
# upstream name
Obsoletes: LibVNCServer < 0.9.1
@ -27,6 +34,8 @@ Provides: LibVNCServer = %{version}-%{release}
BuildRequires: automake autoconf
BuildRequires: libgcrypt-devel
BuildRequires: libjpeg-devel
## FIXME/TODO: --with-va FTBFS
#BuildRequires: libva-devel
BuildRequires: lzo-minilzo lzo-devel
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libcrypto) pkgconfig(libssl)
@ -64,13 +73,10 @@ Provides: LibVNCServer-devel = %{version}-%{release}
%prep
%setup -q -n LibVNCServer-%{version}
%patch105 -p1 -b .0005
%patch110 -p1 -b .0010
%patch0 -p1 -b .no_x11vnc
%patch1 -p1 -b .system_minilzo
#nuke bundled minilzo
rm -f common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
rm -fv common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
%patch2 -p1 -b .multilib
%patch3 -p1 -b .pkgconfig
@ -82,7 +88,11 @@ touch --reference ${file}.OLD $file
done
# needed by patch 1 (and to nuke rpath's)
autoreconf
%if 0%{?snap:1}
./autogen.sh
%else
autoreconf -is
%endif
%build
@ -91,6 +101,7 @@ autoreconf
--disable-static \
--without-tightvnc-filetransfer \
--with-gcrypt \
--without-libva \
--with-png \
--with-x11vnc
@ -135,6 +146,9 @@ xvfb-run -a make -C test test ||:
%changelog
* Tue Apr 29 2014 Rex Dieter <rdieter@fedoraproject.org> 0.9.10-0.1.20140405git646f844f
- Update to the latest git commit 646f844 (#1092245)
* Mon Mar 31 2014 Rex Dieter <rdieter@fedoraproject.org> 0.9.9-11
- x11vnc crash when client connect (#972618)
pull in some upstream commits that may help

@ -1 +1 @@
70422169b122765693d2a294d13e3714 LibVNCServer-0.9.9.tar.gz
8cc7125fdd5ea6fb5cea4266bb55db74 LibVNCServer-0.9.10-646f844f.tar.gz

Loading…
Cancel
Save