You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
25 lines
1.1 KiB
25 lines
1.1 KiB
This patch disables building of the (effectively empty)
|
|
dl-iterate-phdr.c source file. Symbols generated by annobin confuse
|
|
the run-check-namespace test because nm -g prints hidden weak symbols
|
|
in DSOs (they are considered external):
|
|
|
|
ERROR: Extraneous symbols:
|
|
000000000000de51 W dl_iterate_phdr.c.a8d8d212
|
|
ERROR: Extraneous symbols:
|
|
00000000000120b0 W dl_iterate_phdr.c.a8d8d212
|
|
|
|
This patch is downstream-specific due to annobin.
|
|
|
|
diff -up libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr libunwind-1.8.0/src/Makefile.am
|
|
--- libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr 2024-01-29 16:30:52.230008417 -0500
|
|
+++ libunwind-1.8.0/src/Makefile.am 2024-01-29 16:31:40.476692706 -0500
|
|
@@ -346,7 +346,7 @@ noinst_LTLIBRARIES += $(libunwind_elf_li
|
|
libunwind_la_LIBADD += $(libunwind_elf_libs)
|
|
|
|
if OS_LINUX
|
|
- libunwind_la_SOURCES_os = os-linux.c dl-iterate-phdr.c
|
|
+ libunwind_la_SOURCES_os = os-linux.c
|
|
libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_linux_local)
|
|
libunwind_la_SOURCES_aarch64_os = aarch64/Gos-linux.c
|
|
libunwind_la_SOURCES_aarch64_os_local = aarch64/Los-linux.c
|