|
|
|
@ -10,16 +10,15 @@ in DSOs (they are considered external):
|
|
|
|
|
|
|
|
|
|
This patch is downstream-specific due to annobin.
|
|
|
|
|
|
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
|
|
|
index 2b5b02959e99eb8f..e5ff21515c36d30f 100644
|
|
|
|
|
--- a/src/Makefile.am
|
|
|
|
|
+++ b/src/Makefile.am
|
|
|
|
|
@@ -147,7 +147,7 @@ libunwind_la_SOURCES_local = \
|
|
|
|
|
$(libunwind_la_SOURCES_local_unwind)
|
|
|
|
|
|
|
|
|
|
noinst_HEADERS += os-linux.h
|
|
|
|
|
-libunwind_la_SOURCES_os_linux = os-linux.c dl-iterate-phdr.c
|
|
|
|
|
+libunwind_la_SOURCES_os_linux = os-linux.c
|
|
|
|
|
|
|
|
|
|
libunwind_la_SOURCES_os_hpux = os-hpux.c
|
|
|
|
|
diff -up libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr libunwind-1.8.0/src/Makefile.am
|
|
|
|
|
--- libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr 2024-01-29 16:30:52.230008417 -0500
|
|
|
|
|
+++ libunwind-1.8.0/src/Makefile.am 2024-01-29 16:31:40.476692706 -0500
|
|
|
|
|
@@ -346,7 +346,7 @@ noinst_LTLIBRARIES += $(libunwind_elf_li
|
|
|
|
|
libunwind_la_LIBADD += $(libunwind_elf_libs)
|
|
|
|
|
|
|
|
|
|
if OS_LINUX
|
|
|
|
|
- libunwind_la_SOURCES_os = os-linux.c dl-iterate-phdr.c
|
|
|
|
|
+ libunwind_la_SOURCES_os = os-linux.c
|
|
|
|
|
libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_linux_local)
|
|
|
|
|
libunwind_la_SOURCES_aarch64_os = aarch64/Gos-linux.c
|
|
|
|
|
libunwind_la_SOURCES_aarch64_os_local = aarch64/Los-linux.c
|
|
|
|
|