You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libtommath/libtommath.spec

62 lines
1.6 KiB

Name: libtommath
Version: 1.2.0
Release: %autorelease
Summary: A portable number theoretic multiple-precision integer library
License: Public Domain
URL: http://www.libtom.net/
Source0: https://github.com/libtom/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch: CVE-2023-36328.patch
BuildRequires: make
BuildRequires: libtool
%description
A free open source portable number theoretic multiple-precision integer library
written entirely in C. (phew!). The library is designed to provide a simple to
work with API that provides fairly efficient routines that build out of the box
without configuration.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for developing
applications that use %{name}.
%prep
%autosetup -p1
# Fix permissions on installed library
sed -i -e 's/644 $(LIBNAME)/755 $(LIBNAME)/g' makefile.shared
# Fix pkgconfig path
sed -i \
-e 's|^prefix=.*|prefix=%{_prefix}|g' \
-e 's|^libdir=.*|libdir=%{_libdir}|g' \
%{name}.pc.in
%build
%set_build_flags
%make_build V=1 CFLAGS="$CFLAGS -I./" -f makefile.shared
%install
%make_install V=1 CFLAGS="$CFLAGS -I./" PREFIX=%{_prefix} LIBPATH=%{_libdir} -f makefile.shared
find %{buildroot} -name '*.la' -delete
find %{buildroot} -name '*.a' -delete
%ldconfig_scriptlets
%files
%license LICENSE
%{_libdir}/*.so.*
%files devel
%{_includedir}/*.h
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%changelog
%autochangelog