You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libsvm/libsvm-3.0.pythonDir.patch

23 lines
588 B

diff -up ./python/Makefile.pythonDir ./python/Makefile
--- ./python/Makefile.pythonDir 2010-06-16 14:04:46.000000000 +1000
+++ ./python/Makefile 2010-11-08 11:07:55.950510378 +1000
@@ -1,4 +1,16 @@
-all = lib
+PYTHON_PATH ?= python${PYTHON_VERSION}/site-packages/libsvm
+PYTHON_TARGETDIR=${LIB_INSTDIR}/${PYTHON_PATH}
-lib:
+all: lib
+
+lib: ../svm.cpp ../svm.h
cd ..; make lib; cd -
+
+install: all
+ mkdir -p ${PYTHON_TARGETDIR}
+ install -m 755 *.py ${PYTHON_TARGETDIR}
+ install -m 755 ../tools/*.py ${PYTHON_TARGETDIR}
+
+uninstall:
+ rm -fr ${LIBDIR}/${PYTHON_PATH}all = lib
+