diff --git a/.cvsignore b/.cvsignore
index 12c8c4b..0b08845 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1,2 +1,2 @@
guide.pdf
-libsvm-2.88.tar.gz
+libsvm-2.89.tar.gz
diff --git a/import.log b/import.log
index dda8e06..4383245 100644
--- a/import.log
+++ b/import.log
@@ -1,3 +1,4 @@
libsvm-2_88-0_fc9:HEAD:libsvm-2.88-0.fc9.src.rpm:1226043285
libsvm-2_88-1_fc9:HEAD:libsvm-2.88-1.fc9.src.rpm:1226296273
libsvm-2_88-2_fc9:HEAD:libsvm-2.88-2.fc9.src.rpm:1226365469
+libsvm-2_89-1_fc10:HEAD:libsvm-2.89-1.fc10.src.rpm:1238738697
diff --git a/libsvm-2.88.patch b/libsvm-2.89.patch
similarity index 72%
rename from libsvm-2.88.patch
rename to libsvm-2.89.patch
index 7d31237..680186a 100644
--- a/libsvm-2.88.patch
+++ b/libsvm-2.89.patch
@@ -1,36 +1,32 @@
-diff -up ./FAQ.html.orig ./FAQ.html
-diff -up ./java/Makefile.orig ./java/Makefile
---- ./java/Makefile.orig 2007-11-11 22:17:30.000000000 +1000
-+++ ./java/Makefile 2008-11-11 10:54:50.000000000 +1000
-@@ -3,13 +3,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
- libsvm/svm_parameter.class libsvm/svm_problem.class \
- svm_train.class svm_predict.class svm_toy.class svm_scale.class
+diff -up ./java/Makefile.bak ./java/Makefile
+--- ./java/Makefile.bak 2009-02-18 10:41:04.000000000 +1000
++++ ./java/Makefile 2009-04-03 15:13:40.000000000 +1000
+@@ -4,13 +4,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
+ libsvm/svm_print_interface.class \
+ svm_train.class svm_predict.class svm_toy.class svm_scale.class
--#JAVAC = jikes
--JAVAC_FLAGS = -target 1.5 -source 1.5
--JAVAC = javac
--# JAVAC_FLAGS =
+JAVA_TARGETDIR=${INSTDIR}/share/libsvm/java
+JAVA_DOCDIR=${INSTDIR}/share/javadoc/libsvm-${LIBSVM_VER}
+CLASSPATH = .
-+JAVAC_FLAGS = -target 1.5 -source 1.5 -classpath ${CLASSPATH}
-+
+ #JAVAC = jikes
+-JAVAC_FLAGS = -target 1.5 -source 1.5
++JAVAC_FLAGS = -target 1.5 -source 1.5 -classpath ${CLASSPATH}
+ifndef JAVAC
-+JAVAC=javac
+ JAVAC = javac
+endif
-+
+ # JAVAC_FLAGS =
+
+ifndef JAR
+JAR=jar
+endif
+
-
all: $(FILES)
- jar cvf libsvm.jar *.class libsvm/*.class
+ ${JAR} cvf libsvm.jar *.class libsvm/*.class
.java.class:
$(JAVAC) $(JAVAC_FLAGS) $<
-@@ -17,8 +26,24 @@ all: $(FILES)
+@@ -18,8 +27,24 @@ all: $(FILES)
libsvm/svm.java: libsvm/svm.m4
m4 libsvm/svm.m4 > libsvm/svm.java
@@ -55,17 +51,17 @@ diff -up ./java/Makefile.orig ./java/Makefile
dist: clean all
rm *.class libsvm/*.class
-diff -up ./java/test_applet.html.orig ./java/test_applet.html
---- ./java/test_applet.html.orig 2003-07-12 14:07:32.000000000 +1000
-+++ ./java/test_applet.html 2008-11-05 14:08:00.000000000 +1000
+diff -up ./java/test_applet.html.bak ./java/test_applet.html
+--- ./java/test_applet.html.bak 2003-07-12 14:07:32.000000000 +1000
++++ ./java/test_applet.html 2009-04-03 15:04:06.000000000 +1000
@@ -1 +1,3 @@
-
+
+
+
-diff -up ./Makefile.orig ./Makefile
---- ./Makefile.orig 2008-09-15 14:36:48.000000000 +1000
-+++ ./Makefile 2008-11-10 14:17:06.000000000 +1000
+diff -up ./Makefile.bak ./Makefile
+--- ./Makefile.bak 2008-09-15 14:36:48.000000000 +1000
++++ ./Makefile 2009-04-03 15:04:06.000000000 +1000
@@ -1,11 +1,40 @@
CXX? = g++
-CFLAGS = -Wall -Wconversion -O3 -fPIC
@@ -171,37 +167,27 @@ diff -up ./Makefile.orig ./Makefile
+ rm -f ${INSTDIR}/bin/svm-toy-qt
+
+
-diff -up ./python/cross_validation.py.orig ./python/cross_validation.py
-diff -up ./python/Makefile.orig ./python/Makefile
---- ./python/Makefile.orig 2007-10-14 16:29:12.000000000 +1000
-+++ ./python/Makefile 2008-11-05 14:08:00.000000000 +1000
-@@ -2,9 +2,16 @@ CXX? = g++
+diff -up ./python/Makefile.bak ./python/Makefile
+--- ./python/Makefile.bak 2008-12-10 09:05:08.000000000 +1000
++++ ./python/Makefile 2009-04-03 15:21:19.000000000 +1000
+@@ -2,9 +2,11 @@ CXX? = g++
SWIG ?= swig
#Windows: see ../README ../Makefile.win
--PYTHON_INCLUDEDIR ?= /usr/include/python2.4
-+#PYTHON_TEMP:=${shell mktemp}
-+#PYTHON_VERSION:=${shell python -V 2> ${PYTHON_TEMP} ; cat ${PYTHON_TEMP} | awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f ${PYTHON_TEMP}}
-+ifndef PYTHON_INCLUDEDIR
-
--CFLAGS = -O3 -I$(PYTHON_INCLUDEDIR) -I..
-+PYTHON_INCLUDEDIR?= /usr/include/python${PYTHON_VERSION}
-+
-+endif
+-PYTHON_INCLUDEDIR ?= /usr/include/python2.5
++PYTHON_INCLUDEDIR ?= /usr/include/python${PYTHON_VERSION}
+PYTHON_TARGETDIR=${LIB_INSTDIR}/python${PYTHON_VERSION}/site-packages/libsvm
-+
+
+ CFLAGS = -O3 -I$(PYTHON_INCLUDEDIR) -I..
+CFLAGS_PYTHON = ${CFLAGS} -O3 -I$(PYTHON_INCLUDEDIR) -I..
LDFLAGS = -shared
# Mac OS
# LDFLAGS = -framework Python -bundle
-@@ -15,16 +22,34 @@ svmc.so: svmc_wrap.o svm.o
+@@ -15,16 +17,31 @@ svmc.so: svmc_wrap.o svm.o
$(CXX) $(LDFLAGS) -o svmc.so svmc_wrap.o svm.o
svmc_wrap.o: svmc_wrap.c ../svm.h
- $(CXX) $(CFLAGS) -fPIC -c svmc_wrap.c
-+# echo "PYTHON_VERSION=${PYTHON_VERSION}"
-+# echo "CFLAGS=${CFLAGS}"
-+# echo "CFLAGS_PYTHON=${CFLAGS_PYTHON}"
+ $(CXX) $(CFLAGS_PYTHON) -fPIC -c svmc_wrap.c
svmc_wrap.c: svmc.i
@@ -231,14 +217,9 @@ diff -up ./python/Makefile.orig ./python/Makefile
+uninstall:
+ rm -fr ${LIBDIR}/python${PYTHON_VERSION}/site-packages/libsvm
+
-diff -up ./python/setup.py.orig ./python/setup.py
-diff -up ./python/svm.py.orig ./python/svm.py
-diff -up ./python/svm_test.py.orig ./python/svm_test.py
-diff -up ./python/test_cross_validation.py.orig ./python/test_cross_validation.py
-diff -up ./svm.cpp.orig ./svm.cpp
-diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
---- ./svm-toy/gtk/callbacks.cpp.orig 2006-03-04 17:40:12.000000000 +1000
-+++ ./svm-toy/gtk/callbacks.cpp 2008-11-05 14:08:00.000000000 +1000
+diff -up ./svm-toy/gtk/callbacks.cpp.bak ./svm-toy/gtk/callbacks.cpp
+--- ./svm-toy/gtk/callbacks.cpp.bak 2006-03-04 17:40:12.000000000 +1000
++++ ./svm-toy/gtk/callbacks.cpp 2009-04-03 15:04:06.000000000 +1000
@@ -2,6 +2,7 @@
#include
#include
@@ -247,9 +228,9 @@ diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
#include "callbacks.h"
#include "interface.h"
#include "../../svm.h"
-diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
---- ./svm-toy/gtk/Makefile.orig 2007-10-14 16:29:12.000000000 +1000
-+++ ./svm-toy/gtk/Makefile 2008-11-05 16:18:10.000000000 +1000
+diff -up ./svm-toy/gtk/Makefile.bak ./svm-toy/gtk/Makefile
+--- ./svm-toy/gtk/Makefile.bak 2007-10-14 16:29:12.000000000 +1000
++++ ./svm-toy/gtk/Makefile 2009-04-03 15:04:06.000000000 +1000
@@ -2,21 +2,27 @@ CC? = gcc
CXX? = g++
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
@@ -286,16 +267,14 @@ diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
clean:
- rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o ../../svm.o
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
-diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
---- ./svm-toy/qt/Makefile.orig 2008-05-01 22:42:15.000000000 +1000
-+++ ./svm-toy/qt/Makefile 2008-11-05 17:42:43.000000000 +1000
-@@ -1,17 +1,24 @@
+diff -up ./svm-toy/qt/Makefile.bak ./svm-toy/qt/Makefile
+--- ./svm-toy/qt/Makefile.bak 2008-12-19 16:42:05.000000000 +1000
++++ ./svm-toy/qt/Makefile 2009-04-03 15:25:25.000000000 +1000
+@@ -1,17 +1,20 @@
CXX? = g++
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
+CFLAGS = -Wall -O3
-+
+FLAGS:=${CFLAGS} `pkg-config --cflags --libs QtGui`
-+
+LOCAL_LIBDIR=../../
+LIBS= -L${LOCAL_LIBDIR} -lsvm
+
@@ -303,29 +282,25 @@ diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
MOC = /usr/bin/moc-qt4
-svm-toy: svm-toy.cpp svm-toy.moc ../../svm.o
-- $(CXX) $(FLAGS) svm-toy.cpp ../../svm.o -o svm-toy
+- $(CXX) $(CFLAGS) svm-toy.cpp ../../svm.o -o svm-toy
+all: svm-toy-qt
+
+svm-toy-qt: svm-toy.cpp svm-toy.moc
+ $(CXX) $(FLAGS) svm-toy.cpp ${LIBS} -o svm-toy-qt
-+
svm-toy.moc: svm-toy.cpp
$(MOC) svm-toy.cpp -o svm-toy.moc
-../../svm.o:
- cd ../..; make svm.o
-
+-
clean:
- rm -f *~ svm-toy svm-toy.moc ../../svm.o
+ rm -f *~ svm-toy-qt svm-toy.moc ../../svm.o
-diff -up ./svm-toy/qt/svm-toy.cpp.orig ./svm-toy/qt/svm-toy.cpp
-diff -up ./svm-toy/windows/svm-toy.cpp.orig ./svm-toy/windows/svm-toy.cpp
-diff -up ./tools/checkdata.py.orig ./tools/checkdata.py
-diff -up ./tools/easy.py.orig ./tools/easy.py
---- ./tools/easy.py.orig 2008-02-10 22:12:43.000000000 +1000
-+++ ./tools/easy.py 2008-11-05 14:08:00.000000000 +1000
+diff -up ./tools/easy.py.bak ./tools/easy.py
+--- ./tools/easy.py.bak 2009-01-14 07:13:26.000000000 +1000
++++ ./tools/easy.py 2009-04-03 15:04:06.000000000 +1000
@@ -2,6 +2,7 @@
import sys
@@ -349,9 +324,9 @@ diff -up ./tools/easy.py.orig ./tools/easy.py
gnuplot_exe = "/usr/bin/gnuplot"
else:
# example for windows
-diff -up ./tools/grid.py.orig ./tools/grid.py
---- ./tools/grid.py.orig 2008-08-08 20:41:11.000000000 +1000
-+++ ./tools/grid.py 2008-11-05 14:08:00.000000000 +1000
+diff -up ./tools/grid.py.bak ./tools/grid.py
+--- ./tools/grid.py.bak 2008-08-08 20:41:11.000000000 +1000
++++ ./tools/grid.py 2009-04-03 15:04:06.000000000 +1000
@@ -11,7 +11,7 @@ from subprocess import *
is_win32 = (sys.platform == 'win32')
@@ -369,4 +344,3 @@ diff -up ./tools/grid.py.orig ./tools/grid.py
assert os.path.exists(svmtrain_exe),"svm-train executable not found"
assert os.path.exists(gnuplot_exe),"gnuplot executable not found"
assert os.path.exists(dataset_pathname),"dataset not found"
-diff -up ./tools/subset.py.orig ./tools/subset.py
diff --git a/libsvm.spec b/libsvm.spec
index 88fa453..b588976 100644
--- a/libsvm.spec
+++ b/libsvm.spec
@@ -1,6 +1,6 @@
Name: libsvm
-Version: 2.88
-Release: 4%{?dist}
+Version: 2.89
+Release: 1%{?dist}
Summary: A Library for Support Vector Machines
Group: Development/Libraries
@@ -97,7 +97,7 @@ display the derived separating hyperplane.
%prep
%setup -q
-%patch0 -p0 -b .bak
+%patch0 -p0 -b .orig
cp %{SOURCE1} ChangeLog
cp %{SOURCE2} .
cp %{SOURCE3} .
@@ -203,14 +203,23 @@ rm -rf $RPM_BUILD_ROOT
%changelog
-* Wed Feb 25 2009 Fedora Release Engineering - 2.88-4
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
-
-* Sat Nov 29 2008 Ignacio Vazquez-Abrams - 2.88-3
-- Rebuild for Python 2.6
+* Fri Apr 03 2009 Ding-Yi Chen - 2.89-1
+- Upstream Update to 2.89:
+ + reduce input/loading time of svm-train/svm-predict by half
+ + pointer function so users can specify their own outputs
+ + remove info_flush()
+ + a extern variable libsvm_version
+ + svm-train -q option (disable outputs)
+ + svm-scale: warning if more nonzero produced
+ + easy.py: popel.communiate() to avoid some deadlock (if lots of
+ outputs when #classes is large)
* Mon Nov 10 2008 Ding-Yi Chen - 2.88-2
- Fix java BuildRequire and Build
+- javadoc have been removed because ppc and ppc64 do not have a
+ suitable package to build javadoc in F-8, nor does javadoc
+ provide much useful information.
+
* Wed Nov 05 2008 Ding-Yi Chen - 2.88-0
- Note:
diff --git a/sources b/sources
index 2a65311..3321f93 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
aae7a8f7e357e86e1c893b706bb02a63 guide.pdf
-1b69c7d887d349b13f9f2cf245310fea libsvm-2.88.tar.gz
+71975f20d37b30eb13a3ec8897f4f546 libsvm-2.89.tar.gz