Adds MSVSphere plugin initial implementation

i9
Eugene Zamriy 2 years ago
parent 2284439cfa
commit 6301b6a315
Signed by: ezamriy
GPG Key ID: 7EBF95C7DCFA496C

@ -0,0 +1,678 @@
From e4562f47a922c687ca4dcb6bd330216128d96ed3 Mon Sep 17 00:00:00 2001
From: Eugene Zamriy <ezamriy@msvsphere.ru>
Date: Mon, 20 Mar 2023 23:50:30 +0300
Subject: [PATCH] MSVSphere plugin initial implementation
---
doc/Makefile.am | 5 +-
doc/msvsphere_report_event.conf.5 | 1 +
doc/report_MSVSphereBugTracker.conf.txt | 45 +++++++++++++
doc/report_msvsphere.conf.txt | 41 ++++++++++++
po/POTFILES.in | 10 +++
src/plugins/Makefile.am | 12 ++--
src/plugins/mantisbt.c | 4 +-
src/plugins/msvsphere_report_event.conf | 38 +++++++++++
src/plugins/report_MSVSphereBugTracker.conf | 4 ++
src/plugins/report_MSVSphereBugTracker.xml.in | 66 +++++++++++++++++++
src/plugins/reporter-mantisbt.c | 4 +-
src/plugins/reporter-ureport.c | 2 +-
src/plugins/ureport.conf | 2 +-
src/workflows/Makefile.am | 25 ++++++-
src/workflows/report_msvsphere.conf | 31 +++++++++
src/workflows/workflow_MSVSphereCCpp.xml.in | 12 ++++
src/workflows/workflow_MSVSphereJava.xml.in | 11 ++++
.../workflow_MSVSphereJavaScript.xml.in | 11 ++++
.../workflow_MSVSphereKerneloops.xml.in | 11 ++++
.../workflow_MSVSphereLibreport.xml.in | 9 +++
src/workflows/workflow_MSVSpherePython.xml.in | 11 ++++
.../workflow_MSVSpherePython3.xml.in | 11 ++++
src/workflows/workflow_MSVSphereVmcore.xml.in | 12 ++++
src/workflows/workflow_MSVSphereXorg.xml.in | 9 +++
24 files changed, 373 insertions(+), 14 deletions(-)
create mode 100644 doc/msvsphere_report_event.conf.5
create mode 100644 doc/report_MSVSphereBugTracker.conf.txt
create mode 100644 doc/report_msvsphere.conf.txt
create mode 100644 src/plugins/msvsphere_report_event.conf
create mode 100644 src/plugins/report_MSVSphereBugTracker.conf
create mode 100644 src/plugins/report_MSVSphereBugTracker.xml.in
create mode 100644 src/workflows/report_msvsphere.conf
create mode 100644 src/workflows/workflow_MSVSphereCCpp.xml.in
create mode 100644 src/workflows/workflow_MSVSphereJava.xml.in
create mode 100644 src/workflows/workflow_MSVSphereJavaScript.xml.in
create mode 100644 src/workflows/workflow_MSVSphereKerneloops.xml.in
create mode 100644 src/workflows/workflow_MSVSphereLibreport.xml.in
create mode 100644 src/workflows/workflow_MSVSpherePython.xml.in
create mode 100644 src/workflows/workflow_MSVSpherePython3.xml.in
create mode 100644 src/workflows/workflow_MSVSphereVmcore.xml.in
create mode 100644 src/workflows/workflow_MSVSphereXorg.xml.in
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4734f7f..37f345d 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -53,6 +53,7 @@ MAN5_TXT = \
report_event.conf.txt \
report_fedora.conf.txt \
report_centos.conf.txt \
+ report_msvsphere.conf.txt \
report_Logger.conf.txt \
report_rhel_bugzilla.conf.txt \
report_uReport.conf.txt \
@@ -61,6 +62,7 @@ MAN5_TXT = \
report_uploader.conf.txt \
report_Uploader.conf.txt \
report_CentOSBugTracker.conf.txt \
+ report_MSVSphereBugTracker.conf.txt \
uploader_event.conf.txt \
ureport.conf.txt \
upload.conf.txt
@@ -73,7 +75,8 @@ EXTRA_DIST += $(MAN1_BUGZILLA) $(MAN5_BUGZILLA)
endif
MAN5_PREFORMATTED =
-MAN5_PREFORMATTED += centos_report_event.conf.5
+MAN5_PREFORMATTED += centos_report_event.conf.5 \
+ msvsphere_report_event.conf.5
# Manual pages are generated from .txt via Docbook
man1_MANS = ${MAN1_TXT:%.txt=%.1}
diff --git a/doc/msvsphere_report_event.conf.5 b/doc/msvsphere_report_event.conf.5
new file mode 100644
index 0000000..71c3fcb
--- /dev/null
+++ b/doc/msvsphere_report_event.conf.5
@@ -0,0 +1 @@
+.so man5/report_event.conf.5
diff --git a/doc/report_MSVSphereBugTracker.conf.txt b/doc/report_MSVSphereBugTracker.conf.txt
new file mode 100644
index 0000000..07b2109
--- /dev/null
+++ b/doc/report_MSVSphereBugTracker.conf.txt
@@ -0,0 +1,45 @@
+report_MSVSphereBugTracker.conf(5)
+==================================
+
+NAME
+----
+report_MSVSphereBugTracker.conf - libreport's configuration file for 'report_MSVSphereBugTracker' events.
+
+DESCRIPTION
+-----------
+This configuration file contains values for options defined in
+/usr/share/libreport/events/report_MSVSphereBugTracker.xml
+
+Configuration file lines should have 'PARAM = VALUE' format. The parameters are:
+
+'Mantisbt_Login'::
+ Login to MantisBT account.
+
+'Mantisbt_Password'::
+ Password to MantisBT account.
+
+'Mantisbt_MantisbtURL'::
+ MantisBT HTTP(S) address. (default: https://bugs.msvsphere.ru)
+
+'Mantisbt_SSLVerify'::
+ Use yes/true/on/1 to verify server's SSL certificate. (default: yes)
+
+'Mantisbt_Project'::
+ Project issue field value. Useful if you needed different project than specified in /etc/os-release
+
+'Mantisbt_ProjectVersion'::
+ Version issue field value. Useful if you needed different project version than specified in /etc/os-release
+
+'http_proxy'::
+ the proxy server to use for HTTP
+
+'HTTPS_PROXY'::
+ the proxy server to use for HTTPS
+
+SEE ALSO
+--------
+report_event.conf(5), reporter-mantisbt(1)
+
+AUTHOR
+------
+* MSVSphere Packaging Team
diff --git a/doc/report_msvsphere.conf.txt b/doc/report_msvsphere.conf.txt
new file mode 100644
index 0000000..90259d4
--- /dev/null
+++ b/doc/report_msvsphere.conf.txt
@@ -0,0 +1,41 @@
+report_msvsphere.conf(5)
+========================
+
+NAME
+----
+report_msvsphere.conf - configuration file for libreport.
+
+DESCRIPTION
+-----------
+This configuration file specifies which of the reporting work flow definitions
+are applicable for all problems types on MSVSphere.
+
+All applicable work flows are presented to users in User Interface as
+possibilities for processing of any problems. A particular work flow becomes
+applicable if its conditions are satisfied.
+
+This configuration file consists from one condition per line.
+
+Each condition line must start with EVENT=workflow_NAME where "workflow_" is
+constant prefix and "workflow_NAME" is base name of path to reporting work flow
+configuration file.
+
+The rest of condition line has form VAR=VAL, VAR!=VAL or VAL~=REGEX, where VAR
+is a name of problem directory element to be checked (for example,
+"executable", "package", hostname" etc). The condition may consists
+from as many element checks as it is necessary.
+
+EXAMPLES
+--------
+Condition line::
+ EVENT=workflow_MSVSphereCCpp analyzer=CCpp
+
+The condition line above expects existence of /usr/share/libreport/workflows/workflow_MSVSphereCCpp.xml
+
+SEE ALSO
+--------
+report-gtk(1)
+
+AUTHOR
+------
+* MSVSphere Packaging Team
diff --git a/po/POTFILES.in b/po/POTFILES.in
index d1a6064..809deb3 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -42,6 +42,7 @@ src/plugins/reporter-systemd-journal.c
src/plugins/reporter-upload.c
src/plugins/reporter-mantisbt.c
src/plugins/report_CentOSBugTracker.xml.in
+src/plugins/report_MSVSphereBugTracker.xml.in
src/plugins/report_Kerneloops.xml.in
src/plugins/report_Logger.xml.in
src/plugins/report_Mailx.xml.in
@@ -73,6 +74,15 @@ src/workflows/workflow_FedoraXorg.xml.in
src/workflows/workflow_FedoraLibreport.xml.in
src/workflows/workflow_FedoraJava.xml.in
src/workflows/workflow_FedoraJavaScript.xml.in
+src/workflows/workflow_MSVSphereCCpp.xml.in
+src/workflows/workflow_MSVSphereJava.xml.in
+src/workflows/workflow_MSVSphereJavaScript.xml.in
+src/workflows/workflow_MSVSphereKerneloops.xml.in
+src/workflows/workflow_MSVSphereLibreport.xml.in
+src/workflows/workflow_MSVSpherePython.xml.in
+src/workflows/workflow_MSVSpherePython3.xml.in
+src/workflows/workflow_MSVSphereVmcore.xml.in
+src/workflows/workflow_MSVSphereXorg.xml.in
src/workflows/workflow_LoggerCCpp.xml.in
src/workflows/workflow_Logger.xml.in
src/workflows/workflow_MailxCCpp.xml.in
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 5198905..c417bf6 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -68,9 +68,11 @@ reporters_events_conf += report_Bugzilla.conf
endif
if BUILD_MANTISBT
-reporters_events += report_CentOSBugTracker.xml
+reporters_events += report_CentOSBugTracker.xml \
+ report_MSVSphereBugTracker.xml
-reporters_events_conf += report_CentOSBugTracker.conf
+reporters_events_conf += report_CentOSBugTracker.conf \
+ report_MSVSphereBugTracker.conf
endif
if BUILD_UREPORT
@@ -95,7 +97,8 @@ dist_eventsdef_DATA = \
mailx_event.conf \
print_event.conf \
uploader_event.conf \
- centos_report_event.conf
+ centos_report_event.conf \
+ msvsphere_report_event.conf
reporters_extra_dist =
if BUILD_BUGZILLA
@@ -109,7 +112,8 @@ reporters_extra_dist += report_uReport.xml.in
endif
if BUILD_MANTISBT
-reporters_extra_dist += report_CentOSBugTracker.xml.in
+reporters_extra_dist += report_CentOSBugTracker.xml.in \
+ report_MSVSphereBugTracker.xml.in
endif
EXTRA_DIST = $(reporters_extra_dist) \
diff --git a/src/plugins/mantisbt.c b/src/plugins/mantisbt.c
index 9682e65..0a6511f 100644
--- a/src/plugins/mantisbt.c
+++ b/src/plugins/mantisbt.c
@@ -335,7 +335,7 @@ soap_add_new_issue_parameters(soap_request_t *req,
error_msg_and_die(_("SOAP: Failed to create a new property in custom fields."));
}
- soap_node_add_child_node(issue_node, "os_build", SOAP_STRING, version);
+ soap_node_add_child_node(issue_node, "version", SOAP_STRING, version);
soap_node_add_child_node(issue_node, "category", SOAP_STRING, category);
soap_node_add_child_node(issue_node, "summary", SOAP_STRING, summary);
soap_node_add_child_node(issue_node, "description", SOAP_STRING, description);
@@ -862,7 +862,7 @@ mantisbt_search_duplicate_issues(mantisbt_settings_t *settings, const char *cate
// version
if (version != NULL)
- soap_filter_add_new_array_parameter(filter_node, "os_build", SOAP_STRINGARRAY, version);
+ soap_filter_add_new_array_parameter(filter_node, "version", SOAP_STRINGARRAY, version);
soap_request_add_method_parameter(req, "page_number", SOAP_INTEGER, "1");
soap_request_add_method_parameter(req, "per_page", SOAP_INTEGER, /* -1 means get all issues */ "-1");
diff --git a/src/plugins/msvsphere_report_event.conf b/src/plugins/msvsphere_report_event.conf
new file mode 100644
index 0000000..da36775
--- /dev/null
+++ b/src/plugins/msvsphere_report_event.conf
@@ -0,0 +1,38 @@
+EVENT=report_MSVSphereBugTracker type=xorg
+ reporter-mantisbt
+
+EVENT=report_MSVSphereBugTracker type=Kerneloops
+ reporter-mantisbt
+
+EVENT=report_MSVSphereBugTracker type=vmcore
+ reporter-mantisbt
+
+EVENT=report_MSVSphereBugTracker type=Python component!=anaconda
+ test -f component || abrt-action-save-package-data
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup.conf
+
+EVENT=report_MSVSphereBugTracker type=Python3 component!=anaconda
+ test -f component || abrt-action-save-package-data
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup.conf
+
+EVENT=report_MSVSphereBugTracker type=CCpp duphash!=
+ test -f component || abrt-action-save-package-data
+ component="`cat component`"
+ format="mantisbt_format.conf"
+ test -f "/etc/libreport/plugins/mantisbt_format_$component.conf" \
+ && format="mantisbt_format_$component.conf"
+ formatdup="mantisbt_formatdup.conf"
+ test -f "/etc/libreport/plugins/mantisbt_formatdup_$component.conf" \
+ && formatdup="mantisbt_formatdup_$component.conf"
+ reporter-mantisbt \
+ -F "/etc/libreport/plugins/$format" \
+ -A "/etc/libreport/plugins/$formatdup"
+
+EVENT=report_MSVSphereBugTracker analyzer=libreport
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format_analyzer_libreport.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
diff --git a/src/plugins/report_MSVSphereBugTracker.conf b/src/plugins/report_MSVSphereBugTracker.conf
new file mode 100644
index 0000000..08bd29a
--- /dev/null
+++ b/src/plugins/report_MSVSphereBugTracker.conf
@@ -0,0 +1,4 @@
+Mantisbt_MantisbtURL = https://bugs.msvsphere.ru
+Mantisbt_Login =
+Mantisbt_Password =
+Mantisbt_SSLVerify = yes
diff --git a/src/plugins/report_MSVSphereBugTracker.xml.in b/src/plugins/report_MSVSphereBugTracker.xml.in
new file mode 100644
index 0000000..6a1b500
--- /dev/null
+++ b/src/plugins/report_MSVSphereBugTracker.xml.in
@@ -0,0 +1,66 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<event>
+ <_name>MSVSphere Bug Tracker</_name>
+ <_description>Report to MSVSphere Bug Tracker</_description>
+
+ <requires-items>component,duphash,os_release</requires-items>
+ <exclude-items-by-default>coredump,count,event_log,reported_to,vmcore</exclude-items-by-default>
+ <exclude-items-always></exclude-items-always>
+ <exclude-binary-items>no</exclude-binary-items>
+ <include-items-by-default></include-items-by-default>
+ <minimal-rating>3</minimal-rating>
+ <gui-review-elements>yes</gui-review-elements>
+ <support-restricted-access optionname="Mantisbt_CreatePrivate">yes</support-restricted-access>
+
+ <options>
+ <option type="text" name="Mantisbt_Login">
+ <_label>User name</_label>
+ <allow-empty>no</allow-empty>
+ <_description>MSVSphere Bug Tracker account user name</_description>
+ <_note-html>You can create bugs.msvsphere.ru account &lt;a href="https://bugs.msvsphere.ru/signup_page.php"&gt;here&lt;/a&gt;</_note-html>
+ </option>
+ <option type="password" name="Mantisbt_Password">
+ <_label>Password</_label>
+ <allow-empty>no</allow-empty>
+ <_description>MSVSphere Bug Tracker account password</_description>
+ </option>
+ <option type="bool" name="Mantisbt_CreatePrivate">
+ <_label>Restrict access</_label>
+ <_note-html>The issue will be accessible only to users with access to 'Private Issues'</_note-html>
+ <default-value>no</default-value>
+ </option>
+ <advanced-options>
+ <option type="text" name="Mantisbt_MantisbtURL">
+ <_label>MSVSphere Bug Tracker URL</_label>
+ <allow-empty>no</allow-empty>
+ <_note-html>Address of MSVSphere Bug Tracker server</_note-html>
+ <default-value>https://bugs.msvsphere.ru</default-value>
+ </option>
+ <option type="bool" name="Mantisbt_SSLVerify">
+ <_label>Verify SSL</_label>
+ <_note-html>Check SSL key validity</_note-html>
+ <default-value>yes</default-value>
+ </option>
+ <option type="text" name="Mantisbt_Project">
+ <_label>MSVSphere Bug Tracker project</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Specify this only if you needed different project than specified in /etc/os-release</_note-html>
+ </option>
+ <option type="text" name="Mantisbt_ProjectVersion">
+ <_label>MSVSphere Bug Tracker project version</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Specify this only if you needed different project version than specified in /etc/os-release</_note-html>
+ </option>
+ <option type="text" name="http_proxy">
+ <_label>HTTP Proxy</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Sets the proxy server to use for HTTP</_note-html>
+ </option>
+ <option type="text" name="HTTPS_PROXY">
+ <_label>HTTPS Proxy</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Sets the proxy server to use for HTTPS</_note-html>
+ </option>
+ </advanced-options>
+ </options>
+</event>
diff --git a/src/plugins/reporter-mantisbt.c b/src/plugins/reporter-mantisbt.c
index 909b2bb..0ff82ec 100644
--- a/src/plugins/reporter-mantisbt.c
+++ b/src/plugins/reporter-mantisbt.c
@@ -25,11 +25,11 @@
static void
parse_osinfo_for_mantisbt(GHashTable *osinfo, char** project, char** version)
{
- const char *name = g_hash_table_lookup(osinfo, "CENTOS_MANTISBT_PROJECT");
+ const char *name = g_hash_table_lookup(osinfo, "MSVSPHERE_MANTISBT_PROJECT");
if (!name)
name = g_hash_table_lookup(osinfo, OSINFO_NAME);
- const char *version_id = g_hash_table_lookup(osinfo, "CENTOS_MANTISBT_PROJECT_VERSION");
+ const char *version_id = g_hash_table_lookup(osinfo, "MSVSPHERE_MANTISBT_PROJECT_VERSION");
if (!version_id)
version_id = g_hash_table_lookup(osinfo, OSINFO_VERSION_ID);
diff --git a/src/plugins/reporter-ureport.c b/src/plugins/reporter-ureport.c
index 17ce506..fc089a0 100644
--- a/src/plugins/reporter-ureport.c
+++ b/src/plugins/reporter-ureport.c
@@ -22,7 +22,7 @@
#include "ureport.h"
#include "libreport_curl.h"
-#define DEFAULT_WEB_SERVICE_URL "https://retrace.fedoraproject.org/faf"
+#define DEFAULT_WEB_SERVICE_URL "https://retrace.msvsphere.ru/faf"
int main(int argc, char **argv)
{
diff --git a/src/plugins/ureport.conf b/src/plugins/ureport.conf
index 240a8b6..0ca8a25 100644
--- a/src/plugins/ureport.conf
+++ b/src/plugins/ureport.conf
@@ -1,5 +1,5 @@
# Base URL to uReport server
-# URL = https://retrace.fedoraproject.org/faf
+# URL = https://retrace.msvsphere.ru/faf
# no means that ssl certificates will not be checked
# SSLVerify = no
diff --git a/src/workflows/Makefile.am b/src/workflows/Makefile.am
index 4fa145f..bb8d217 100644
--- a/src/workflows/Makefile.am
+++ b/src/workflows/Makefile.am
@@ -28,7 +28,16 @@ dist_workflows_DATA += \
workflow_CentOSXorg.xml \
workflow_CentOSLibreport.xml \
workflow_CentOSJava.xml \
- workflow_CentOSJavaScript.xml
+ workflow_CentOSJavaScript.xml \
+ workflow_MSVSphereCCpp.xml \
+ workflow_MSVSphereKerneloops.xml \
+ workflow_MSVSpherePython.xml \
+ workflow_MSVSpherePython3.xml \
+ workflow_MSVSphereVmcore.xml \
+ workflow_MSVSphereXorg.xml \
+ workflow_MSVSphereLibreport.xml \
+ workflow_MSVSphereJava.xml \
+ workflow_MSVSphereJavaScript.xml
endif
if BUILD_BUGZILLA
@@ -54,7 +63,8 @@ dist_workflowsdef_DATA =\
report_mailx.conf \
report_logger.conf \
report_uploader.conf \
- report_centos.conf
+ report_centos.conf \
+ report_msvsphere.conf
if BUILD_BUGZILLA
dist_workflowsdef_DATA += \
@@ -108,5 +118,14 @@ EXTRA_DIST += \
workflow_CentOSXorg.xml.in \
workflow_CentOSLibreport.xml.in \
workflow_CentOSJava.xml.in \
- workflow_CentOSJavaScript.xml.in
+ workflow_CentOSJavaScript.xml.in \
+ workflow_MSVSphereCCpp.xml.in \
+ workflow_MSVSphereKerneloops.xml.in \
+ workflow_MSVSpherePython.xml.in \
+ workflow_MSVSpherePython3.xml.in \
+ workflow_MSVSphereVmcore.xml.in \
+ workflow_MSVSphereXorg.xml.in \
+ workflow_MSVSphereLibreport.xml.in \
+ workflow_MSVSphereJava.xml.in \
+ workflow_MSVSphereJavaScript.xml.in
endif
diff --git a/src/workflows/report_msvsphere.conf b/src/workflows/report_msvsphere.conf
new file mode 100644
index 0000000..136e22a
--- /dev/null
+++ b/src/workflows/report_msvsphere.conf
@@ -0,0 +1,31 @@
+EVENT=workflow_MSVSphereLibreport analyzer=libreport
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSphereCCpp type=CCpp
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSpherePython type=Python component!=anaconda
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSpherePython3 type=Python3 component!=anaconda
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSphereKerneloops type=Kerneloops
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSphereVmcore type=vmcore
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSphereXorg type=xorg
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_MSVSphereJava type=Java
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
diff --git a/src/workflows/workflow_MSVSphereCCpp.xml.in b/src/workflows/workflow_MSVSphereCCpp.xml.in
new file mode 100644
index 0000000..863da8c
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereCCpp.xml.in
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the C/C++ crash using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>analyze_CCpp</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereJava.xml.in b/src/workflows/workflow_MSVSphereJava.xml.in
new file mode 100644
index 0000000..ab1cb02
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereJava.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the Java exception using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereJavaScript.xml.in b/src/workflows/workflow_MSVSphereJavaScript.xml.in
new file mode 100644
index 0000000..1b4bf13
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereJavaScript.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the JavaScript exception using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereKerneloops.xml.in b/src/workflows/workflow_MSVSphereKerneloops.xml.in
new file mode 100644
index 0000000..1f92d6e
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereKerneloops.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the kerneloops using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereLibreport.xml.in b/src/workflows/workflow_MSVSphereLibreport.xml.in
new file mode 100644
index 0000000..e5a4750
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereLibreport.xml.in
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the problem using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSpherePython.xml.in b/src/workflows/workflow_MSVSpherePython.xml.in
new file mode 100644
index 0000000..b0c856b
--- /dev/null
+++ b/src/workflows/workflow_MSVSpherePython.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the python exception using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSpherePython3.xml.in b/src/workflows/workflow_MSVSpherePython3.xml.in
new file mode 100644
index 0000000..27f7272
--- /dev/null
+++ b/src/workflows/workflow_MSVSpherePython3.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the python 3 exception using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereVmcore.xml.in b/src/workflows/workflow_MSVSphereVmcore.xml.in
new file mode 100644
index 0000000..0eaf33b
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereVmcore.xml.in
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the kernel crash using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>analyze_VMcore</event>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_MSVSphereXorg.xml.in b/src/workflows/workflow_MSVSphereXorg.xml.in
new file mode 100644
index 0000000..aeb9d7f
--- /dev/null
+++ b/src/workflows/workflow_MSVSphereXorg.xml.in
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to MSVSphere Bug Tracker</_name>
+ <_description>Process the X Server problem using the MSVSphere infrastructure</_description>
+
+ <events>
+ <event>report_MSVSphereBugTracker</event>
+ </events>
+</workflow>
--
2.39.2

@ -15,13 +15,16 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.15.2
Release: 6%{?dist}
Release: 6%{?dist}.inferit
License: GPLv2+
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch1: 0001-Change-the-default-Bugzilla-group.patch
Patch2: 0002-rhbz-Be-a-little-bit-more-defensive-when-working-wit.patch
Patch3: 0003-rhbz-Retry-XML-RPC-calls-when-uploading-attachments.patch
# MSVSphere patches
Patch9000: 9000-MSVSphere-plugin-initial-implementation.patch
BuildRequires: %{dbus_devel}
BuildRequires: gtk3-devel
BuildRequires: curl-devel
@ -205,14 +208,14 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-mantisbt
Plugin to report bugs into the mantisbt.
%package centos
Summary: %{name}'s CentOS Bug Tracker workflow
%package msvsphere
Summary: %{name}'s MSVSphere Bug Tracker workflow
Requires: %{name} = %{version}-%{release}
Requires: libreport-web = %{version}-%{release}
Requires: libreport-plugin-mantisbt = %{version}-%{release}
%description centos
Workflows to report issues into the CentOS Bug Tracker.
%description msvsphere
Workflows to report issues into the MSVSphere Bug Tracker.
%package plugin-ureport
Summary: %{name}'s micro report plugin
@ -231,40 +234,6 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-reportuploader
Plugin to report bugs into anonymous FTP site associated with ticketing system.
%if 0%{?fedora} || 0%{?eln}
%package fedora
Summary: Default configuration for reporting bugs via Fedora infrastructure
Requires: %{name} = %{version}-%{release}
%description fedora
Default configuration for reporting bugs via Fedora infrastructure
used to easily configure the reporting process for Fedora systems. Just
install this package and you're done.
%endif
%if 0%{?rhel} && ! 0%{?eln}
%package rhel-bugzilla
Summary: Default configuration for reporting bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
Requires: libreport-plugin-ureport = %{version}-%{release}
%description rhel-bugzilla
Default configuration for reporting bugs to Red Hat Bugzilla used to easily
configure the reporting process for Red Hat systems. Just install this package
and you're done.
%package rhel-anaconda-bugzilla
Summary: Default configuration for reporting anaconda bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
%description rhel-anaconda-bugzilla
Default configuration for reporting Anaconda problems to Red Hat Bugzilla used
to easily configure the reporting process for Red Hat systems. Just install this
package and you're done.
%endif
%if %{with bugzilla}
%package anaconda
Summary: Default configuration for reporting anaconda bugs
@ -281,6 +250,10 @@ data over ftp/scp...
%prep
%autosetup -p 1
# MSVSphere: reuse CentOS plugin translations for our plugin
sed -e 's/CentOS/MSVSphere/g' -i po/*.po
sed -e 's/Centos/MSVSphere/g' -i po/*.po
sed -e 's/centos/msvsphere/g' -i po/*.po
%build
./autogen.sh
@ -339,7 +312,6 @@ rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
%endif
# Remove unwanted RHEL specific workflow configuration files
%if ! 0%{?rhel} || 0%{?eln}
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_uReport.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_RHELBugzillaCCpp.xml
@ -362,7 +334,28 @@ rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_uReport.conf
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
rm -f %{buildroot}%{_mandir}/man5/report_uReport.conf.5
rm -f %{buildroot}%{_mandir}/man5/report_rhel_bugzilla.conf.5
%endif
rm -f %{buildroot}%{_mandir}/man1/reporter-rhtsupport.1
rm -f %{buildroot}%{_mandir}/man5/rhtsupport.conf.5
rm -f %{buildroot}%{_mandir}/man5/rhtsupport_event.conf.5
rm -f %{buildroot}/%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
# Remove unwanted CentOS specific workflow configuration files
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSCCpp.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSKerneloops.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSPython.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSPython3.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSVmcore.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSXorg.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSLibreport.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSJava.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSJavaScript.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_centos.conf
rm -f %{buildroot}/%{_mandir}/man5/report_centos.conf.5
rm -f %{buildroot}/%{_datadir}/%{name}/events/report_CentOSBugTracker.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
rm -f %{buildroot}/%{_mandir}/man5/report_CentOSBugTracker.conf.5
rm -f %{buildroot}/%{_sysconfdir}/libreport/events.d/centos_report_event.conf
rm -f %{buildroot}/%{_mandir}/man5/centos_report_event.conf.5
%check
make check|| {
@ -524,11 +517,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man1/reporter-ureport.1.gz
%{_mandir}/man5/ureport.conf.5.gz
%{_datadir}/%{name}/events/report_uReport.xml
%if 0%{?rhel} && ! 0%{?eln}
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
%{_datadir}/%{name}/workflows/workflow_uReport.xml
%{_mandir}/man5/report_uReport.conf.5.*
%endif
%if %{with bugzilla}
%files plugin-bugzilla
@ -571,24 +559,24 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5.*
%{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5.*
%files centos
%{_datadir}/%{name}/workflows/workflow_CentOSCCpp.xml
%{_datadir}/%{name}/workflows/workflow_CentOSKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython3.xml
%{_datadir}/%{name}/workflows/workflow_CentOSVmcore.xml
%{_datadir}/%{name}/workflows/workflow_CentOSXorg.xml
%{_datadir}/%{name}/workflows/workflow_CentOSLibreport.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJava.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
%{_mandir}/man5/report_centos.conf.5.*
%{_datadir}/%{name}/events/report_CentOSBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
%{_mandir}/man5/report_CentOSBugTracker.conf.5.*
# report_CentOSBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
%{_mandir}/man5/centos_report_event.conf.5.gz
%files msvsphere
%{_datadir}/%{name}/workflows/workflow_MSVSphereCCpp.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_MSVSpherePython.xml
%{_datadir}/%{name}/workflows/workflow_MSVSpherePython3.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereVmcore.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereXorg.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereLibreport.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereJava.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_msvsphere.conf
%{_mandir}/man5/report_msvsphere.conf.5.*
%{_datadir}/%{name}/events/report_MSVSphereBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_MSVSphereBugTracker.conf
%{_mandir}/man5/report_MSVSphereBugTracker.conf.5.*
# report_MSVSphereBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/msvsphere_report_event.conf
%{_mandir}/man5/msvsphere_report_event.conf.5.gz
%files plugin-reportuploader
%{_mandir}/man*/reporter-upload.*
@ -606,38 +594,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
%{_mandir}/man5/report_Uploader.conf.5.*
%if 0%{?fedora} || 0%{?eln}
%files fedora
%{_datadir}/%{name}/workflows/workflow_FedoraCCpp.xml
%{_datadir}/%{name}/workflows/workflow_FedoraKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython3.xml
%{_datadir}/%{name}/workflows/workflow_FedoraVmcore.xml
%{_datadir}/%{name}/workflows/workflow_FedoraXorg.xml
%{_datadir}/%{name}/workflows/workflow_FedoraLibreport.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJava.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
%{_mandir}/man5/report_fedora.conf.5.*
%endif
%if 0%{?rhel} && ! 0%{?eln}
%files rhel-bugzilla
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaCCpp.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaVmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaXorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJava.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
%{_mandir}/man5/report_rhel_bugzilla.conf.5.*
%files rhel-anaconda-bugzilla
%{_datadir}/%{name}/workflows/workflow_AnacondaRHELBugzilla.xml
%endif
%if %{with bugzilla}
%files anaconda
%if 0%{?fedora} || 0%{?eln}
@ -655,6 +611,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%changelog
* Tue Mar 21 2023 Eugene Zamriy <ezamriy@msvsphere.ru> - 2.15.2-6.inferit
- Added support for MSVSphere bug tracker
- Removed libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzilla
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 2.15.2-6
- Rebuilt for MSVSphere 9.1.

Loading…
Cancel
Save