- Added support for MSVSphere bug tracker

- Removed libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzilla
i8
Arkady L. Shane 1 year ago
parent d1a4ebdb01
commit 37a72508aa
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,227 @@
From 202caba7132aeb5b6b088623818582e7065717be Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Wed, 20 Dec 2023 20:06:20 +0300
Subject: [PATCH] MSVSphere plugin initial implementation
---
doc/Makefile.am | 5 ++++-
po/POTFILES.in | 10 ++++++++++
src/plugins/Makefile.am | 12 ++++++++----
src/plugins/mantisbt.c | 4 ++--
src/plugins/reporter-mantisbt.c | 4 ++--
src/plugins/reporter-ureport.c | 2 +-
src/plugins/ureport.conf | 2 +-
src/workflows/Makefile.am | 25 ++++++++++++++++++++++---
8 files changed, 50 insertions(+), 14 deletions(-)
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 837036b..6fb4b7a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -55,6 +55,7 @@ MAN5_TXT += report_Bugzilla.conf.txt
MAN5_TXT += report_event.conf.txt
MAN5_TXT += report_fedora.conf.txt
MAN5_TXT += report_centos.conf.txt
+MAN5_TXT += report_msvsphere.conf.txt
MAN5_TXT += report_Logger.conf.txt
MAN5_TXT += report_rhel.conf.txt
MAN5_TXT += report_rhel_bugzilla.conf.txt
@@ -64,6 +65,7 @@ MAN5_TXT += report_mailx.conf.txt
MAN5_TXT += report_uploader.conf.txt
MAN5_TXT += report_Uploader.conf.txt
MAN5_TXT += report_CentOSBugTracker.conf.txt
+MAN5_TXT += report_MSVSphereBugTracker.conf.txt
MAN5_TXT += rhtsupport.conf.txt
MAN5_TXT += rhtsupport_event.conf.txt
MAN5_TXT += uploader_event.conf.txt
@@ -71,7 +73,8 @@ MAN5_TXT += ureport.conf.txt
MAN5_TXT += upload.conf.txt
MAN5_PREFORMATTED =
-MAN5_PREFORMATTED += centos_report_event.conf.5
+MAN5_PREFORMATTED += centos_report_event.conf.5 \
+ msvsphere_report_event.conf.5
# Manual pages are generated from .txt via Docbook
man1_MANS = ${MAN1_TXT:%.txt=%.1}
diff --git a/po/POTFILES.in b/po/POTFILES.in
index fc740ff..70fc837 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -46,6 +46,7 @@ src/plugins/reporter-systemd-journal.c
src/plugins/reporter-upload.c
src/plugins/reporter-mantisbt.c
src/plugins/report_CentOSBugTracker.xml.in
+src/plugins/report_MSVSphereBugTracker.xml.in
src/plugins/report_Kerneloops.xml.in
src/plugins/report_Logger.xml.in
src/plugins/report_Mailx.xml.in
@@ -81,6 +82,15 @@ src/workflows/workflow_FedoraXorg.xml.in
src/workflows/workflow_FedoraLibreport.xml.in
src/workflows/workflow_FedoraJava.xml.in
src/workflows/workflow_FedoraJavaScript.xml.in
+src/workflows/workflow_MSVSphereCCpp.xml.in
+src/workflows/workflow_MSVSphereJava.xml.in
+src/workflows/workflow_MSVSphereJavaScript.xml.in
+src/workflows/workflow_MSVSphereKerneloops.xml.in
+src/workflows/workflow_MSVSphereLibreport.xml.in
+src/workflows/workflow_MSVSpherePython.xml.in
+src/workflows/workflow_MSVSpherePython3.xml.in
+src/workflows/workflow_MSVSphereVmcore.xml.in
+src/workflows/workflow_MSVSphereXorg.xml.in
src/workflows/workflow_LoggerCCpp.xml.in
src/workflows/workflow_Logger.xml.in
src/workflows/workflow_MailxCCpp.xml.in
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index f73e7dc..a418690 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -70,9 +70,11 @@ reporters_events_conf += report_Bugzilla.conf
endif
if BUILD_MANTISBT
-reporters_events += report_CentOSBugTracker.xml
+reporters_events += report_CentOSBugTracker.xml \
+ report_MSVSphereBugTracker.xml
-reporters_events_conf += report_CentOSBugTracker.conf
+reporters_events_conf += report_CentOSBugTracker.conf \
+ report_MSVSphereBugTracker.conf
endif
if BUILD_UREPORT
@@ -102,7 +104,8 @@ dist_eventsdef_DATA = \
rhtsupport_event.conf \
uploader_event.conf \
emergencyanalysis_event.conf \
- centos_report_event.conf
+ centos_report_event.conf \
+ msvsphere_report_event.conf
reporters_extra_dist =
if BUILD_BUGZILLA
@@ -116,7 +119,8 @@ reporters_extra_dist += report_uReport.xml.in
endif
if BUILD_MANTISBT
-reporters_extra_dist += report_CentOSBugTracker.xml.in
+reporters_extra_dist += report_CentOSBugTracker.xml.in \
+ report_MSVSphereBugTracker.xml.in
endif
EXTRA_DIST = $(reporters_extra_dist) \
diff --git a/src/plugins/mantisbt.c b/src/plugins/mantisbt.c
index 1750dc5..92804d4 100644
--- a/src/plugins/mantisbt.c
+++ b/src/plugins/mantisbt.c
@@ -336,7 +336,7 @@ soap_add_new_issue_parameters(soap_request_t *req,
free(type);
}
- soap_node_add_child_node(issue_node, "os_build", SOAP_STRING, version);
+ soap_node_add_child_node(issue_node, "version", SOAP_STRING, version);
soap_node_add_child_node(issue_node, "category", SOAP_STRING, category);
soap_node_add_child_node(issue_node, "summary", SOAP_STRING, summary);
soap_node_add_child_node(issue_node, "description", SOAP_STRING, description);
@@ -891,7 +891,7 @@ mantisbt_search_duplicate_issues(mantisbt_settings_t *settings, const char *cate
// version
if (version != NULL)
- soap_filter_add_new_array_parameter(filter_node, "os_build", SOAP_STRINGARRAY, version);
+ soap_filter_add_new_array_parameter(filter_node, "version", SOAP_STRINGARRAY, version);
soap_request_add_method_parameter(req, "page_number", SOAP_INTEGER, "1");
soap_request_add_method_parameter(req, "per_page", SOAP_INTEGER, /* -1 means get all issues */ "-1");
diff --git a/src/plugins/reporter-mantisbt.c b/src/plugins/reporter-mantisbt.c
index 67597d5..16f94b9 100644
--- a/src/plugins/reporter-mantisbt.c
+++ b/src/plugins/reporter-mantisbt.c
@@ -25,11 +25,11 @@
static void
parse_osinfo_for_mantisbt(map_string_t *osinfo, char** project, char** version)
{
- const char *name = get_map_string_item_or_NULL(osinfo, "CENTOS_MANTISBT_PROJECT");
+ const char *name = get_map_string_item_or_NULL(osinfo, "MSVSPHERE_MANTISBT_PROJECT");
if (!name)
name = get_map_string_item_or_NULL(osinfo, OSINFO_NAME);
- const char *version_id = get_map_string_item_or_NULL(osinfo, "CENTOS_MANTISBT_PROJECT_VERSION");
+ const char *version_id = get_map_string_item_or_NULL(osinfo, "MSVSPHERE_MANTISBT_PROJECT_VERSION");
if (!version_id)
version_id = get_map_string_item_or_NULL(osinfo, OSINFO_VERSION_ID);
diff --git a/src/plugins/reporter-ureport.c b/src/plugins/reporter-ureport.c
index 0aa3324..fac29cf 100644
--- a/src/plugins/reporter-ureport.c
+++ b/src/plugins/reporter-ureport.c
@@ -22,7 +22,7 @@
#include "ureport.h"
#include "libreport_curl.h"
-#define DEFAULT_WEB_SERVICE_URL "https://bug-report.redhat.com"
+#define DEFAULT_WEB_SERVICE_URL "https://retrace.msvsphere-os.ru/faf"
int main(int argc, char **argv)
{
diff --git a/src/plugins/ureport.conf b/src/plugins/ureport.conf
index 11f4531..15c7b2a 100644
--- a/src/plugins/ureport.conf
+++ b/src/plugins/ureport.conf
@@ -1,5 +1,5 @@
# Base URL to uReport server
-# URL = https://bug-report.redhat.com
+# URL = https://retrace.msvsphere-os.ru/faf
# no means that ssl certificates will not be checked
# SSLVerify = no
diff --git a/src/workflows/Makefile.am b/src/workflows/Makefile.am
index e4d7b26..26a19d3 100644
--- a/src/workflows/Makefile.am
+++ b/src/workflows/Makefile.am
@@ -44,7 +44,16 @@ dist_workflows_DATA += \
workflow_CentOSXorg.xml \
workflow_CentOSLibreport.xml \
workflow_CentOSJava.xml \
- workflow_CentOSJavaScript.xml
+ workflow_CentOSJavaScript.xml \
+ workflow_MSVSphereCCpp.xml \
+ workflow_MSVSphereKerneloops.xml \
+ workflow_MSVSpherePython.xml \
+ workflow_MSVSpherePython3.xml \
+ workflow_MSVSphereVmcore.xml \
+ workflow_MSVSphereXorg.xml \
+ workflow_MSVSphereLibreport.xml \
+ workflow_MSVSphereJava.xml \
+ workflow_MSVSphereJavaScript.xml
endif
if BUILD_BUGZILLA
@@ -73,7 +82,8 @@ dist_workflowsdef_DATA =\
report_mailx.conf \
report_logger.conf \
report_uploader.conf \
- report_centos.conf
+ report_centos.conf \
+ report_msvsphere.conf
if BUILD_BUGZILLA
dist_workflowsdef_DATA += \
@@ -144,5 +154,14 @@ EXTRA_DIST += \
workflow_CentOSXorg.xml.in \
workflow_CentOSLibreport.xml.in \
workflow_CentOSJava.xml.in \
- workflow_CentOSJavaScript.xml.in
+ workflow_CentOSJavaScript.xml.in \
+ workflow_MSVSphereCCpp.xml.in \
+ workflow_MSVSphereKerneloops.xml.in \
+ workflow_MSVSpherePython.xml.in \
+ workflow_MSVSpherePython3.xml.in \
+ workflow_MSVSphereVmcore.xml.in \
+ workflow_MSVSphereXorg.xml.in \
+ workflow_MSVSphereLibreport.xml.in \
+ workflow_MSVSphereJava.xml.in \
+ workflow_MSVSphereJavaScript.xml.in
endif
--
2.43.0

@ -29,7 +29,7 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.9.5
Release: 15%{?dist}
Release: 15%{?dist}.inferit
License: GPLv2+
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
@ -77,6 +77,9 @@ Patch0032: 0032-Drop-remaining-references-to-removed-command-line-op.patch
# autogen.sh is need to regenerate all the Makefile files
Patch9000: 9000-Add-autogen.sh.patch
# MSVSphere patch
Patch9500: 9500-MSVSphere-plugin-initial-implementation.patch
BuildRequires: %{dbus_devel}
BuildRequires: gtk3-devel
BuildRequires: curl-devel
@ -283,14 +286,14 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-mantisbt
Plugin to report bugs into the mantisbt.
%package centos
Summary: %{name}'s CentOS Bug Tracker workflow
%package msvsphere
Summary: %{name}'s MSVSphere Bug Tracker workflow
Requires: %{name} = %{version}-%{release}
Requires: libreport-web = %{version}-%{release}
Requires: libreport-plugin-mantisbt = %{version}-%{release}
%description centos
Workflows to report issues into the CentOS Bug Tracker.
%description msvsphere
Workflows to report issues into the MSVSPhere Bug Tracker.
%package plugin-ureport
Summary: %{name}'s micro report plugin
@ -336,49 +339,6 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-reportuploader
Plugin to report bugs into anonymous FTP site associated with ticketing system.
%if 0%{?fedora}
%package fedora
Summary: Default configuration for reporting bugs via Fedora infrastructure
Requires: %{name} = %{version}-%{release}
%description fedora
Default configuration for reporting bugs via Fedora infrastructure
used to easily configure the reporting process for Fedora systems. Just
install this package and you're done.
%endif
%if 0%{?rhel}
%package rhel
Summary: Default configuration for reporting bugs via Red Hat infrastructure
Requires: %{name} = %{version}-%{release}
%description rhel
Default configuration for reporting bugs via Red Hat infrastructure
used to easily configure the reporting process for Red Hat systems. Just
install this package and you're done.
%package rhel-bugzilla
Summary: Default configuration for reporting bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
Requires: libreport-plugin-ureport = %{version}-%{release}
%description rhel-bugzilla
Default configuration for reporting bugs to Red Hat Bugzilla used to easily
configure the reporting process for Red Hat systems. Just install this package
and you're done.
%package rhel-anaconda-bugzilla
Summary: Default configuration for reporting anaconda bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
%description rhel-anaconda-bugzilla
Default configuration for reporting Anaconda problems to Red Hat Bugzilla used
to easily configure the reporting process for Red Hat systems. Just install this
package and you're done.
%endif
%if %{with bugzilla}
%package anaconda
Summary: Default configuration for reporting anaconda bugs
@ -401,7 +361,12 @@ data over ftp/scp...
# doesn't allow us to create a new file within a patch, so we have to use
# 'git am' (see /usr/lib/rpm/macros for more details)
%define __scm_apply_git(qp:m:) %{__git} am
%autosetup -S git
%autosetup -p1
#Z-S git
# MSVSphere: reuse CentOS plugin translations for our plugin
sed -e 's/CentOS/MSVSphere/g' -i po/*.po
sed -e 's/Centos/MSVSphere/g' -i po/*.po
sed -e 's/centos/msvsphere/g' -i po/*.po
%build
./autogen.sh
@ -448,7 +413,6 @@ mkdir -p %{buildroot}/%{_datadir}/%{name}/workflows/
rm -f %{buildroot}/%{_infodir}/dir
# Remove unwanted Fedora specific workflow configuration files
%if 0%{!?fedora:1}
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_FedoraCCpp.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_FedoraKerneloops.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_FedoraPython.xml
@ -461,10 +425,8 @@ rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_FedoraJavaScript.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_fedora.conf
rm -f %{buildroot}%{_mandir}/man5/report_fedora.conf.5
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
%endif
# Remove unwanted RHEL specific workflow configuration files
%if 0%{!?rhel:1}
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_RHELCCpp.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_RHELKerneloops.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_RHELPython.xml
@ -499,7 +461,29 @@ rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.con
rm -f %{buildroot}%{_mandir}/man5/report_rhel.conf.5
rm -f %{buildroot}%{_mandir}/man5/report_uReport.conf.5
rm -f %{buildroot}%{_mandir}/man5/report_rhel_bugzilla.conf.5
%endif
rm -f %{buildroot}%{_mandir}/man1/reporter-rhtsupport.1
rm -f %{buildroot}%{_mandir}/man5/rhtsupport.conf.5
rm -f %{buildroot}%{_mandir}/man5/rhtsupport_event.conf.5
rm -f %{buildroot}/%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
# Remove unwanted CentOS specific workflow configuration files
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSCCpp.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSKerneloops.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSPython.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSPython3.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSVmcore.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSXorg.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSLibreport.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSJava.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_CentOSJavaScript.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_centos.conf
rm -f %{buildroot}/%{_mandir}/man5/report_centos.conf.5
rm -f %{buildroot}/%{_datadir}/%{name}/events/report_CentOSBugTracker.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
rm -f %{buildroot}/%{_mandir}/man5/report_CentOSBugTracker.conf.5
rm -f %{buildroot}/%{_sysconfdir}/libreport/events.d/centos_report_event.conf
rm -f %{buildroot}/%{_mandir}/man5/centos_report_event.conf.5
%check
make check|| {
@ -724,37 +708,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5.*
%{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5.*
%files centos
%{_datadir}/%{name}/workflows/workflow_CentOSCCpp.xml
%{_datadir}/%{name}/workflows/workflow_CentOSKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython3.xml
%{_datadir}/%{name}/workflows/workflow_CentOSVmcore.xml
%{_datadir}/%{name}/workflows/workflow_CentOSXorg.xml
%{_datadir}/%{name}/workflows/workflow_CentOSLibreport.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJava.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
%{_mandir}/man5/report_centos.conf.5.*
%{_datadir}/%{name}/events/report_CentOSBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
%{_mandir}/man5/report_CentOSBugTracker.conf.5.*
# report_CentOSBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
%{_mandir}/man5/centos_report_event.conf.5.gz
%files plugin-rhtsupport
%config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
%{_datadir}/%{name}/conf.d/plugins/rhtsupport.conf
%{_datadir}/%{name}/events/report_RHTSupport.xml
%{_datadir}/%{name}/events/report_RHTSupport_AddData.xml
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
%config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
%{_mandir}/man1/reporter-rhtsupport.1.gz
%{_mandir}/man5/rhtsupport.conf.5.*
%{_mandir}/man5/rhtsupport_event.conf.5.*
%{_bindir}/reporter-rhtsupport
%if %{with bugzilla}
%files compat
%{_bindir}/report
@ -777,70 +730,30 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
%{_mandir}/man5/report_Uploader.conf.5.*
%if 0%{?fedora}
%files fedora
%{_datadir}/%{name}/workflows/workflow_FedoraCCpp.xml
%{_datadir}/%{name}/workflows/workflow_FedoraKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython3.xml
%{_datadir}/%{name}/workflows/workflow_FedoraVmcore.xml
%{_datadir}/%{name}/workflows/workflow_FedoraXorg.xml
%{_datadir}/%{name}/workflows/workflow_FedoraLibreport.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJava.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
%{_mandir}/man5/report_fedora.conf.5.*
%endif
%if 0%{?rhel}
%files rhel
%{_datadir}/%{name}/workflows/workflow_RHELCCpp.xml
%{_datadir}/%{name}/workflows/workflow_RHELKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_RHELPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELvmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELxorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELJava.xml
%{_datadir}/%{name}/workflows/workflow_RHELJavaScript.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataCCpp.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataJava.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDatavmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataxorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELAddDataJavaScript.xml
%{_datadir}/%{name}/workflows/workflow_uReport.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
%{_mandir}/man5/report_rhel.conf.5.*
%{_mandir}/man5/report_uReport.conf.5.*
%files rhel-bugzilla
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaCCpp.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaVmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaXorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJava.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
%{_mandir}/man5/report_rhel_bugzilla.conf.5.*
%files rhel-anaconda-bugzilla
%{_datadir}/%{name}/workflows/workflow_AnacondaRHELBugzilla.xml
%endif
%files msvsphere
%{_datadir}/%{name}/workflows/workflow_MSVSphereCCpp.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_MSVSpherePython.xml
%{_datadir}/%{name}/workflows/workflow_MSVSpherePython3.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereVmcore.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereXorg.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereLibreport.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereJava.xml
%{_datadir}/%{name}/workflows/workflow_MSVSphereJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_msvsphere.conf
%{_mandir}/man5/report_msvsphere.conf.5.*
%{_datadir}/%{name}/events/report_MSVSphereBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_MSVSphereBugTracker.conf
%{_mandir}/man5/report_MSVSphereBugTracker.conf.5.*
# report_MSVSphereBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/msvsphere_report_event.conf
%{_mandir}/man5/msvsphere_report_event.conf.5.gz
%if %{with bugzilla}
%files anaconda
%if 0%{?fedora}
%{_datadir}/%{name}/workflows/workflow_AnacondaFedora.xml
%endif
%if 0%{?rhel}
%{_datadir}/%{name}/workflows/workflow_AnacondaRHEL.xml
%endif
%{_datadir}/%{name}/workflows/workflow_AnacondaUpload.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
@ -853,6 +766,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%changelog
* Wed Dec 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.9.5-15.inferit
- Added support for MSVSphere bug tracker
- Removed libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzilla
* Wed Jul 26 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 2.9.5-15
- Rebuilt for MSVSphere 8.8

Loading…
Cancel
Save