- Removed libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzillai8
parent
d1a4ebdb01
commit
37a72508aa
@ -0,0 +1,227 @@
|
||||
From 202caba7132aeb5b6b088623818582e7065717be Mon Sep 17 00:00:00 2001
|
||||
From: tigro <tigro@msvsphere-os.ru>
|
||||
Date: Wed, 20 Dec 2023 20:06:20 +0300
|
||||
Subject: [PATCH] MSVSphere plugin initial implementation
|
||||
|
||||
---
|
||||
doc/Makefile.am | 5 ++++-
|
||||
po/POTFILES.in | 10 ++++++++++
|
||||
src/plugins/Makefile.am | 12 ++++++++----
|
||||
src/plugins/mantisbt.c | 4 ++--
|
||||
src/plugins/reporter-mantisbt.c | 4 ++--
|
||||
src/plugins/reporter-ureport.c | 2 +-
|
||||
src/plugins/ureport.conf | 2 +-
|
||||
src/workflows/Makefile.am | 25 ++++++++++++++++++++++---
|
||||
8 files changed, 50 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
||||
index 837036b..6fb4b7a 100644
|
||||
--- a/doc/Makefile.am
|
||||
+++ b/doc/Makefile.am
|
||||
@@ -55,6 +55,7 @@ MAN5_TXT += report_Bugzilla.conf.txt
|
||||
MAN5_TXT += report_event.conf.txt
|
||||
MAN5_TXT += report_fedora.conf.txt
|
||||
MAN5_TXT += report_centos.conf.txt
|
||||
+MAN5_TXT += report_msvsphere.conf.txt
|
||||
MAN5_TXT += report_Logger.conf.txt
|
||||
MAN5_TXT += report_rhel.conf.txt
|
||||
MAN5_TXT += report_rhel_bugzilla.conf.txt
|
||||
@@ -64,6 +65,7 @@ MAN5_TXT += report_mailx.conf.txt
|
||||
MAN5_TXT += report_uploader.conf.txt
|
||||
MAN5_TXT += report_Uploader.conf.txt
|
||||
MAN5_TXT += report_CentOSBugTracker.conf.txt
|
||||
+MAN5_TXT += report_MSVSphereBugTracker.conf.txt
|
||||
MAN5_TXT += rhtsupport.conf.txt
|
||||
MAN5_TXT += rhtsupport_event.conf.txt
|
||||
MAN5_TXT += uploader_event.conf.txt
|
||||
@@ -71,7 +73,8 @@ MAN5_TXT += ureport.conf.txt
|
||||
MAN5_TXT += upload.conf.txt
|
||||
|
||||
MAN5_PREFORMATTED =
|
||||
-MAN5_PREFORMATTED += centos_report_event.conf.5
|
||||
+MAN5_PREFORMATTED += centos_report_event.conf.5 \
|
||||
+ msvsphere_report_event.conf.5
|
||||
|
||||
# Manual pages are generated from .txt via Docbook
|
||||
man1_MANS = ${MAN1_TXT:%.txt=%.1}
|
||||
diff --git a/po/POTFILES.in b/po/POTFILES.in
|
||||
index fc740ff..70fc837 100644
|
||||
--- a/po/POTFILES.in
|
||||
+++ b/po/POTFILES.in
|
||||
@@ -46,6 +46,7 @@ src/plugins/reporter-systemd-journal.c
|
||||
src/plugins/reporter-upload.c
|
||||
src/plugins/reporter-mantisbt.c
|
||||
src/plugins/report_CentOSBugTracker.xml.in
|
||||
+src/plugins/report_MSVSphereBugTracker.xml.in
|
||||
src/plugins/report_Kerneloops.xml.in
|
||||
src/plugins/report_Logger.xml.in
|
||||
src/plugins/report_Mailx.xml.in
|
||||
@@ -81,6 +82,15 @@ src/workflows/workflow_FedoraXorg.xml.in
|
||||
src/workflows/workflow_FedoraLibreport.xml.in
|
||||
src/workflows/workflow_FedoraJava.xml.in
|
||||
src/workflows/workflow_FedoraJavaScript.xml.in
|
||||
+src/workflows/workflow_MSVSphereCCpp.xml.in
|
||||
+src/workflows/workflow_MSVSphereJava.xml.in
|
||||
+src/workflows/workflow_MSVSphereJavaScript.xml.in
|
||||
+src/workflows/workflow_MSVSphereKerneloops.xml.in
|
||||
+src/workflows/workflow_MSVSphereLibreport.xml.in
|
||||
+src/workflows/workflow_MSVSpherePython.xml.in
|
||||
+src/workflows/workflow_MSVSpherePython3.xml.in
|
||||
+src/workflows/workflow_MSVSphereVmcore.xml.in
|
||||
+src/workflows/workflow_MSVSphereXorg.xml.in
|
||||
src/workflows/workflow_LoggerCCpp.xml.in
|
||||
src/workflows/workflow_Logger.xml.in
|
||||
src/workflows/workflow_MailxCCpp.xml.in
|
||||
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
|
||||
index f73e7dc..a418690 100644
|
||||
--- a/src/plugins/Makefile.am
|
||||
+++ b/src/plugins/Makefile.am
|
||||
@@ -70,9 +70,11 @@ reporters_events_conf += report_Bugzilla.conf
|
||||
endif
|
||||
|
||||
if BUILD_MANTISBT
|
||||
-reporters_events += report_CentOSBugTracker.xml
|
||||
+reporters_events += report_CentOSBugTracker.xml \
|
||||
+ report_MSVSphereBugTracker.xml
|
||||
|
||||
-reporters_events_conf += report_CentOSBugTracker.conf
|
||||
+reporters_events_conf += report_CentOSBugTracker.conf \
|
||||
+ report_MSVSphereBugTracker.conf
|
||||
endif
|
||||
|
||||
if BUILD_UREPORT
|
||||
@@ -102,7 +104,8 @@ dist_eventsdef_DATA = \
|
||||
rhtsupport_event.conf \
|
||||
uploader_event.conf \
|
||||
emergencyanalysis_event.conf \
|
||||
- centos_report_event.conf
|
||||
+ centos_report_event.conf \
|
||||
+ msvsphere_report_event.conf
|
||||
|
||||
reporters_extra_dist =
|
||||
if BUILD_BUGZILLA
|
||||
@@ -116,7 +119,8 @@ reporters_extra_dist += report_uReport.xml.in
|
||||
endif
|
||||
|
||||
if BUILD_MANTISBT
|
||||
-reporters_extra_dist += report_CentOSBugTracker.xml.in
|
||||
+reporters_extra_dist += report_CentOSBugTracker.xml.in \
|
||||
+ report_MSVSphereBugTracker.xml.in
|
||||
endif
|
||||
|
||||
EXTRA_DIST = $(reporters_extra_dist) \
|
||||
diff --git a/src/plugins/mantisbt.c b/src/plugins/mantisbt.c
|
||||
index 1750dc5..92804d4 100644
|
||||
--- a/src/plugins/mantisbt.c
|
||||
+++ b/src/plugins/mantisbt.c
|
||||
@@ -336,7 +336,7 @@ soap_add_new_issue_parameters(soap_request_t *req,
|
||||
free(type);
|
||||
}
|
||||
|
||||
- soap_node_add_child_node(issue_node, "os_build", SOAP_STRING, version);
|
||||
+ soap_node_add_child_node(issue_node, "version", SOAP_STRING, version);
|
||||
soap_node_add_child_node(issue_node, "category", SOAP_STRING, category);
|
||||
soap_node_add_child_node(issue_node, "summary", SOAP_STRING, summary);
|
||||
soap_node_add_child_node(issue_node, "description", SOAP_STRING, description);
|
||||
@@ -891,7 +891,7 @@ mantisbt_search_duplicate_issues(mantisbt_settings_t *settings, const char *cate
|
||||
|
||||
// version
|
||||
if (version != NULL)
|
||||
- soap_filter_add_new_array_parameter(filter_node, "os_build", SOAP_STRINGARRAY, version);
|
||||
+ soap_filter_add_new_array_parameter(filter_node, "version", SOAP_STRINGARRAY, version);
|
||||
|
||||
soap_request_add_method_parameter(req, "page_number", SOAP_INTEGER, "1");
|
||||
soap_request_add_method_parameter(req, "per_page", SOAP_INTEGER, /* -1 means get all issues */ "-1");
|
||||
diff --git a/src/plugins/reporter-mantisbt.c b/src/plugins/reporter-mantisbt.c
|
||||
index 67597d5..16f94b9 100644
|
||||
--- a/src/plugins/reporter-mantisbt.c
|
||||
+++ b/src/plugins/reporter-mantisbt.c
|
||||
@@ -25,11 +25,11 @@
|
||||
static void
|
||||
parse_osinfo_for_mantisbt(map_string_t *osinfo, char** project, char** version)
|
||||
{
|
||||
- const char *name = get_map_string_item_or_NULL(osinfo, "CENTOS_MANTISBT_PROJECT");
|
||||
+ const char *name = get_map_string_item_or_NULL(osinfo, "MSVSPHERE_MANTISBT_PROJECT");
|
||||
if (!name)
|
||||
name = get_map_string_item_or_NULL(osinfo, OSINFO_NAME);
|
||||
|
||||
- const char *version_id = get_map_string_item_or_NULL(osinfo, "CENTOS_MANTISBT_PROJECT_VERSION");
|
||||
+ const char *version_id = get_map_string_item_or_NULL(osinfo, "MSVSPHERE_MANTISBT_PROJECT_VERSION");
|
||||
if (!version_id)
|
||||
version_id = get_map_string_item_or_NULL(osinfo, OSINFO_VERSION_ID);
|
||||
|
||||
diff --git a/src/plugins/reporter-ureport.c b/src/plugins/reporter-ureport.c
|
||||
index 0aa3324..fac29cf 100644
|
||||
--- a/src/plugins/reporter-ureport.c
|
||||
+++ b/src/plugins/reporter-ureport.c
|
||||
@@ -22,7 +22,7 @@
|
||||
#include "ureport.h"
|
||||
#include "libreport_curl.h"
|
||||
|
||||
-#define DEFAULT_WEB_SERVICE_URL "https://bug-report.redhat.com"
|
||||
+#define DEFAULT_WEB_SERVICE_URL "https://retrace.msvsphere-os.ru/faf"
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
diff --git a/src/plugins/ureport.conf b/src/plugins/ureport.conf
|
||||
index 11f4531..15c7b2a 100644
|
||||
--- a/src/plugins/ureport.conf
|
||||
+++ b/src/plugins/ureport.conf
|
||||
@@ -1,5 +1,5 @@
|
||||
# Base URL to uReport server
|
||||
-# URL = https://bug-report.redhat.com
|
||||
+# URL = https://retrace.msvsphere-os.ru/faf
|
||||
|
||||
# no means that ssl certificates will not be checked
|
||||
# SSLVerify = no
|
||||
diff --git a/src/workflows/Makefile.am b/src/workflows/Makefile.am
|
||||
index e4d7b26..26a19d3 100644
|
||||
--- a/src/workflows/Makefile.am
|
||||
+++ b/src/workflows/Makefile.am
|
||||
@@ -44,7 +44,16 @@ dist_workflows_DATA += \
|
||||
workflow_CentOSXorg.xml \
|
||||
workflow_CentOSLibreport.xml \
|
||||
workflow_CentOSJava.xml \
|
||||
- workflow_CentOSJavaScript.xml
|
||||
+ workflow_CentOSJavaScript.xml \
|
||||
+ workflow_MSVSphereCCpp.xml \
|
||||
+ workflow_MSVSphereKerneloops.xml \
|
||||
+ workflow_MSVSpherePython.xml \
|
||||
+ workflow_MSVSpherePython3.xml \
|
||||
+ workflow_MSVSphereVmcore.xml \
|
||||
+ workflow_MSVSphereXorg.xml \
|
||||
+ workflow_MSVSphereLibreport.xml \
|
||||
+ workflow_MSVSphereJava.xml \
|
||||
+ workflow_MSVSphereJavaScript.xml
|
||||
endif
|
||||
|
||||
if BUILD_BUGZILLA
|
||||
@@ -73,7 +82,8 @@ dist_workflowsdef_DATA =\
|
||||
report_mailx.conf \
|
||||
report_logger.conf \
|
||||
report_uploader.conf \
|
||||
- report_centos.conf
|
||||
+ report_centos.conf \
|
||||
+ report_msvsphere.conf
|
||||
|
||||
if BUILD_BUGZILLA
|
||||
dist_workflowsdef_DATA += \
|
||||
@@ -144,5 +154,14 @@ EXTRA_DIST += \
|
||||
workflow_CentOSXorg.xml.in \
|
||||
workflow_CentOSLibreport.xml.in \
|
||||
workflow_CentOSJava.xml.in \
|
||||
- workflow_CentOSJavaScript.xml.in
|
||||
+ workflow_CentOSJavaScript.xml.in \
|
||||
+ workflow_MSVSphereCCpp.xml.in \
|
||||
+ workflow_MSVSphereKerneloops.xml.in \
|
||||
+ workflow_MSVSpherePython.xml.in \
|
||||
+ workflow_MSVSpherePython3.xml.in \
|
||||
+ workflow_MSVSphereVmcore.xml.in \
|
||||
+ workflow_MSVSphereXorg.xml.in \
|
||||
+ workflow_MSVSphereLibreport.xml.in \
|
||||
+ workflow_MSVSphereJava.xml.in \
|
||||
+ workflow_MSVSphereJavaScript.xml.in
|
||||
endif
|
||||
--
|
||||
2.43.0
|
||||
|
Loading…
Reference in new issue