You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
761 lines
24 KiB
761 lines
24 KiB
From 2e137e4696e8278c3d56ba8a49a8b255534bd048 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Sun, 23 Oct 2016 22:41:23 +0200
|
|
Subject: [PATCH] allow to build bundled libzmf on aarch64
|
|
|
|
Change-Id: I76d695c922a072b0edd010f5583bafe0dfeb0dd8
|
|
---
|
|
external/libzmf/UnpackedTarball_libzmf.mk | 1 +
|
|
external/libzmf/libzmf-config-guess.patch.1 | 727 ++++++++++++++++++++++++++++
|
|
2 files changed, 728 insertions(+)
|
|
create mode 100644 external/libzmf/libzmf-config-guess.patch.1
|
|
|
|
diff --git a/external/libzmf/UnpackedTarball_libzmf.mk b/external/libzmf/UnpackedTarball_libzmf.mk
|
|
index 782aeb8..e9cf715 100644
|
|
--- a/external/libzmf/UnpackedTarball_libzmf.mk
|
|
+++ b/external/libzmf/UnpackedTarball_libzmf.mk
|
|
@@ -25,6 +25,7 @@ $(eval $(call gb_UnpackedTarball_add_patches,libzmf, \
|
|
external/libzmf/0001-add-missing-include.patch.1 \
|
|
external/libzmf/0001-allow-build-with-boost-1.56.patch.1 \
|
|
external/libzmf/0001-allow-build-with-boost-1.56-part-II.patch.1 \
|
|
+ external/libzmf/libzmf-config-guess.patch.1 \
|
|
))
|
|
|
|
# vim: set noet sw=4 ts=4:
|
|
diff --git a/external/libzmf/libzmf-config-guess.patch.1 b/external/libzmf/libzmf-config-guess.patch.1
|
|
new file mode 100644
|
|
index 0000000..bf9fffb
|
|
--- /dev/null
|
|
+++ b/external/libzmf/libzmf-config-guess.patch.1
|
|
@@ -0,0 +1,727 @@
|
|
+diff -up ./config.guess.dt ./config.guess
|
|
+--- ./config.guess.dt 2016-10-23 22:39:12.641388777 +0200
|
|
++++ ./config.guess 2016-10-23 22:32:42.022632241 +0200
|
|
+@@ -1,10 +1,8 @@
|
|
+ #! /bin/sh
|
|
+ # Attempt to guess a canonical system name.
|
|
+-# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
|
+-# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
|
+-# 2011, 2012, 2013 Free Software Foundation, Inc.
|
|
++# Copyright 1992-2015 Free Software Foundation, Inc.
|
|
+
|
|
+-timestamp='2012-12-29'
|
|
++timestamp='2015-01-01'
|
|
+
|
|
+ # This file is free software; you can redistribute it and/or modify it
|
|
+ # under the terms of the GNU General Public License as published by
|
|
+@@ -26,12 +24,12 @@ timestamp='2012-12-29'
|
|
+ # program. This Exception is an additional permission under section 7
|
|
+ # of the GNU General Public License, version 3 ("GPLv3").
|
|
+ #
|
|
+-# Originally written by Per Bothner.
|
|
++# Originally written by Per Bothner; maintained since 2000 by Ben Elliston.
|
|
+ #
|
|
+ # You can get the latest version of this script from:
|
|
+ # http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
|
|
+ #
|
|
+-# Please send patches with a ChangeLog entry to config-patches@gnu.org.
|
|
++# Please send patches to <config-patches@gnu.org>.
|
|
+
|
|
+
|
|
+ me=`echo "$0" | sed -e 's,.*/,,'`
|
|
+@@ -52,9 +50,7 @@ version="\
|
|
+ GNU config.guess ($timestamp)
|
|
+
|
|
+ Originally written by Per Bothner.
|
|
+-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
|
+-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011,
|
|
+-2012, 2013 Free Software Foundation, Inc.
|
|
++Copyright 1992-2015 Free Software Foundation, Inc.
|
|
+
|
|
+ This is free software; see the source for copying conditions. There is NO
|
|
+ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
|
+@@ -136,6 +132,27 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` |
|
|
+ UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
|
|
+ UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
|
|
+
|
|
++case "${UNAME_SYSTEM}" in
|
|
++Linux|GNU|GNU/*)
|
|
++ # If the system lacks a compiler, then just pick glibc.
|
|
++ # We could probably try harder.
|
|
++ LIBC=gnu
|
|
++
|
|
++ eval $set_cc_for_build
|
|
++ cat <<-EOF > $dummy.c
|
|
++ #include <features.h>
|
|
++ #if defined(__UCLIBC__)
|
|
++ LIBC=uclibc
|
|
++ #elif defined(__dietlibc__)
|
|
++ LIBC=dietlibc
|
|
++ #else
|
|
++ LIBC=gnu
|
|
++ #endif
|
|
++ EOF
|
|
++ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^LIBC' | sed 's, ,,g'`
|
|
++ ;;
|
|
++esac
|
|
++
|
|
+ # Note: order is significant - the case branches are not exclusive.
|
|
+
|
|
+ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
|
+@@ -562,8 +579,9 @@ EOF
|
|
+ else
|
|
+ IBM_ARCH=powerpc
|
|
+ fi
|
|
+- if [ -x /usr/bin/oslevel ] ; then
|
|
+- IBM_REV=`/usr/bin/oslevel`
|
|
++ if [ -x /usr/bin/lslpp ] ; then
|
|
++ IBM_REV=`/usr/bin/lslpp -Lqc bos.rte.libc |
|
|
++ awk -F: '{ print $3 }' | sed s/[0-9]*$/0/`
|
|
+ else
|
|
+ IBM_REV=${UNAME_VERSION}.${UNAME_RELEASE}
|
|
+ fi
|
|
+@@ -809,7 +827,7 @@ EOF
|
|
+ *:MINGW*:*)
|
|
+ echo ${UNAME_MACHINE}-pc-mingw32
|
|
+ exit ;;
|
|
+- i*:MSYS*:*)
|
|
++ *:MSYS*:*)
|
|
+ echo ${UNAME_MACHINE}-pc-msys
|
|
+ exit ;;
|
|
+ i*:windows32*:*)
|
|
+@@ -857,21 +875,21 @@ EOF
|
|
+ exit ;;
|
|
+ *:GNU:*:*)
|
|
+ # the GNU system
|
|
+- echo `echo ${UNAME_MACHINE}|sed -e 's,[-/].*$,,'`-unknown-gnu`echo ${UNAME_RELEASE}|sed -e 's,/.*$,,'`
|
|
++ echo `echo ${UNAME_MACHINE}|sed -e 's,[-/].*$,,'`-unknown-${LIBC}`echo ${UNAME_RELEASE}|sed -e 's,/.*$,,'`
|
|
+ exit ;;
|
|
+ *:GNU/*:*:*)
|
|
+ # other systems with GNU libc and userland
|
|
+- echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-${LIBC}
|
|
+ exit ;;
|
|
+ i*86:Minix:*:*)
|
|
+ echo ${UNAME_MACHINE}-pc-minix
|
|
+ exit ;;
|
|
+ aarch64:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ aarch64_be:Linux:*:*)
|
|
+ UNAME_MACHINE=aarch64_be
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ alpha:Linux:*:*)
|
|
+ case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
|
|
+@@ -884,59 +902,54 @@ EOF
|
|
+ EV68*) UNAME_MACHINE=alphaev68 ;;
|
|
+ esac
|
|
+ objdump --private-headers /bin/sh | grep -q ld.so.1
|
|
+- if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
|
|
++ if test "$?" = 0 ; then LIBC="gnulibc1" ; fi
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
++ exit ;;
|
|
++ arc:Linux:*:* | arceb:Linux:*:*)
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ arm*:Linux:*:*)
|
|
+ eval $set_cc_for_build
|
|
+ if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
|
|
+ | grep -q __ARM_EABI__
|
|
+ then
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ else
|
|
+ if echo __ARM_PCS_VFP | $CC_FOR_BUILD -E - 2>/dev/null \
|
|
+ | grep -q __ARM_PCS_VFP
|
|
+ then
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnueabi
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}eabi
|
|
+ else
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnueabihf
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}eabihf
|
|
+ fi
|
|
+ fi
|
|
+ exit ;;
|
|
+ avr32*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ cris:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-axis-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-axis-linux-${LIBC}
|
|
+ exit ;;
|
|
+ crisv32:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-axis-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-axis-linux-${LIBC}
|
|
+ exit ;;
|
|
+ frv:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ hexagon:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ i*86:Linux:*:*)
|
|
+- LIBC=gnu
|
|
+- eval $set_cc_for_build
|
|
+- sed 's/^ //' << EOF >$dummy.c
|
|
+- #ifdef __dietlibc__
|
|
+- LIBC=dietlibc
|
|
+- #endif
|
|
+-EOF
|
|
+- eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^LIBC'`
|
|
+- echo "${UNAME_MACHINE}-pc-linux-${LIBC}"
|
|
++ echo ${UNAME_MACHINE}-pc-linux-${LIBC}
|
|
+ exit ;;
|
|
+ ia64:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ m32r*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ m68*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ mips:Linux:*:* | mips64:Linux:*:*)
|
|
+ eval $set_cc_for_build
|
|
+@@ -955,54 +968,63 @@ EOF
|
|
+ #endif
|
|
+ EOF
|
|
+ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^CPU'`
|
|
+- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
|
|
++ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
|
|
+ ;;
|
|
+- or32:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ openrisc*:Linux:*:*)
|
|
++ echo or1k-unknown-linux-${LIBC}
|
|
++ exit ;;
|
|
++ or32:Linux:*:* | or1k*:Linux:*:*)
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ padre:Linux:*:*)
|
|
+- echo sparc-unknown-linux-gnu
|
|
++ echo sparc-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ parisc64:Linux:*:* | hppa64:Linux:*:*)
|
|
+- echo hppa64-unknown-linux-gnu
|
|
++ echo hppa64-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ parisc:Linux:*:* | hppa:Linux:*:*)
|
|
+ # Look for CPU level
|
|
+ case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
|
|
+- PA7*) echo hppa1.1-unknown-linux-gnu ;;
|
|
+- PA8*) echo hppa2.0-unknown-linux-gnu ;;
|
|
+- *) echo hppa-unknown-linux-gnu ;;
|
|
++ PA7*) echo hppa1.1-unknown-linux-${LIBC} ;;
|
|
++ PA8*) echo hppa2.0-unknown-linux-${LIBC} ;;
|
|
++ *) echo hppa-unknown-linux-${LIBC} ;;
|
|
+ esac
|
|
+ exit ;;
|
|
+ ppc64:Linux:*:*)
|
|
+- echo powerpc64-unknown-linux-gnu
|
|
++ echo powerpc64-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ ppc:Linux:*:*)
|
|
+- echo powerpc-unknown-linux-gnu
|
|
++ echo powerpc-unknown-linux-${LIBC}
|
|
++ exit ;;
|
|
++ ppc64le:Linux:*:*)
|
|
++ echo powerpc64le-unknown-linux-${LIBC}
|
|
++ exit ;;
|
|
++ ppcle:Linux:*:*)
|
|
++ echo powerpcle-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ s390:Linux:*:* | s390x:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-ibm-linux
|
|
++ echo ${UNAME_MACHINE}-ibm-linux-${LIBC}
|
|
+ exit ;;
|
|
+ sh64*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ sh*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ sparc:Linux:*:* | sparc64:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ tile*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ vax:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-dec-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-dec-linux-${LIBC}
|
|
+ exit ;;
|
|
+ x86_64:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ xtensa*:Linux:*:*)
|
|
+- echo ${UNAME_MACHINE}-unknown-linux-gnu
|
|
++ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
|
|
+ exit ;;
|
|
+ i*86:DYNIX/ptx:4*:*)
|
|
+ # ptx 4.0 does uname -s correctly, with DYNIX/ptx in there.
|
|
+@@ -1235,19 +1257,31 @@ EOF
|
|
+ exit ;;
|
|
+ *:Darwin:*:*)
|
|
+ UNAME_PROCESSOR=`uname -p` || UNAME_PROCESSOR=unknown
|
|
+- case $UNAME_PROCESSOR in
|
|
+- i386)
|
|
+- eval $set_cc_for_build
|
|
+- if [ "$CC_FOR_BUILD" != 'no_compiler_found' ]; then
|
|
+- if (echo '#ifdef __LP64__'; echo IS_64BIT_ARCH; echo '#endif') | \
|
|
+- (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) | \
|
|
+- grep IS_64BIT_ARCH >/dev/null
|
|
+- then
|
|
+- UNAME_PROCESSOR="x86_64"
|
|
+- fi
|
|
+- fi ;;
|
|
+- unknown) UNAME_PROCESSOR=powerpc ;;
|
|
+- esac
|
|
++ eval $set_cc_for_build
|
|
++ if test "$UNAME_PROCESSOR" = unknown ; then
|
|
++ UNAME_PROCESSOR=powerpc
|
|
++ fi
|
|
++ if test `echo "$UNAME_RELEASE" | sed -e 's/\..*//'` -le 10 ; then
|
|
++ if [ "$CC_FOR_BUILD" != 'no_compiler_found' ]; then
|
|
++ if (echo '#ifdef __LP64__'; echo IS_64BIT_ARCH; echo '#endif') | \
|
|
++ (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) | \
|
|
++ grep IS_64BIT_ARCH >/dev/null
|
|
++ then
|
|
++ case $UNAME_PROCESSOR in
|
|
++ i386) UNAME_PROCESSOR=x86_64 ;;
|
|
++ powerpc) UNAME_PROCESSOR=powerpc64 ;;
|
|
++ esac
|
|
++ fi
|
|
++ fi
|
|
++ elif test "$UNAME_PROCESSOR" = i386 ; then
|
|
++ # Avoid executing cc on OS X 10.9, as it ships with a stub
|
|
++ # that puts up a graphical alert prompting to install
|
|
++ # developer tools. Any system running Mac OS X 10.7 or
|
|
++ # later (Darwin 11 and later) is required to have a 64-bit
|
|
++ # processor. This is not true of the ARM version of Darwin
|
|
++ # that Apple uses in portable devices.
|
|
++ UNAME_PROCESSOR=x86_64
|
|
++ fi
|
|
+ echo ${UNAME_PROCESSOR}-apple-darwin${UNAME_RELEASE}
|
|
+ exit ;;
|
|
+ *:procnto*:*:* | *:QNX:[0123456789]*:*)
|
|
+@@ -1338,154 +1372,6 @@ EOF
|
|
+ exit ;;
|
|
+ esac
|
|
+
|
|
+-eval $set_cc_for_build
|
|
+-cat >$dummy.c <<EOF
|
|
+-#ifdef _SEQUENT_
|
|
+-# include <sys/types.h>
|
|
+-# include <sys/utsname.h>
|
|
+-#endif
|
|
+-main ()
|
|
+-{
|
|
+-#if defined (sony)
|
|
+-#if defined (MIPSEB)
|
|
+- /* BFD wants "bsd" instead of "newsos". Perhaps BFD should be changed,
|
|
+- I don't know.... */
|
|
+- printf ("mips-sony-bsd\n"); exit (0);
|
|
+-#else
|
|
+-#include <sys/param.h>
|
|
+- printf ("m68k-sony-newsos%s\n",
|
|
+-#ifdef NEWSOS4
|
|
+- "4"
|
|
+-#else
|
|
+- ""
|
|
+-#endif
|
|
+- ); exit (0);
|
|
+-#endif
|
|
+-#endif
|
|
+-
|
|
+-#if defined (__arm) && defined (__acorn) && defined (__unix)
|
|
+- printf ("arm-acorn-riscix\n"); exit (0);
|
|
+-#endif
|
|
+-
|
|
+-#if defined (hp300) && !defined (hpux)
|
|
+- printf ("m68k-hp-bsd\n"); exit (0);
|
|
+-#endif
|
|
+-
|
|
+-#if defined (NeXT)
|
|
+-#if !defined (__ARCHITECTURE__)
|
|
+-#define __ARCHITECTURE__ "m68k"
|
|
+-#endif
|
|
+- int version;
|
|
+- version=`(hostinfo | sed -n 's/.*NeXT Mach \([0-9]*\).*/\1/p') 2>/dev/null`;
|
|
+- if (version < 4)
|
|
+- printf ("%s-next-nextstep%d\n", __ARCHITECTURE__, version);
|
|
+- else
|
|
+- printf ("%s-next-openstep%d\n", __ARCHITECTURE__, version);
|
|
+- exit (0);
|
|
+-#endif
|
|
+-
|
|
+-#if defined (MULTIMAX) || defined (n16)
|
|
+-#if defined (UMAXV)
|
|
+- printf ("ns32k-encore-sysv\n"); exit (0);
|
|
+-#else
|
|
+-#if defined (CMU)
|
|
+- printf ("ns32k-encore-mach\n"); exit (0);
|
|
+-#else
|
|
+- printf ("ns32k-encore-bsd\n"); exit (0);
|
|
+-#endif
|
|
+-#endif
|
|
+-#endif
|
|
+-
|
|
+-#if defined (__386BSD__)
|
|
+- printf ("i386-pc-bsd\n"); exit (0);
|
|
+-#endif
|
|
+-
|
|
+-#if defined (sequent)
|
|
+-#if defined (i386)
|
|
+- printf ("i386-sequent-dynix\n"); exit (0);
|
|
+-#endif
|
|
+-#if defined (ns32000)
|
|
+- printf ("ns32k-sequent-dynix\n"); exit (0);
|
|
+-#endif
|
|
+-#endif
|
|
+-
|
|
+-#if defined (_SEQUENT_)
|
|
+- struct utsname un;
|
|
+-
|
|
+- uname(&un);
|
|
+-
|
|
+- if (strncmp(un.version, "V2", 2) == 0) {
|
|
+- printf ("i386-sequent-ptx2\n"); exit (0);
|
|
+- }
|
|
+- if (strncmp(un.version, "V1", 2) == 0) { /* XXX is V1 correct? */
|
|
+- printf ("i386-sequent-ptx1\n"); exit (0);
|
|
+- }
|
|
+- printf ("i386-sequent-ptx\n"); exit (0);
|
|
+-
|
|
+-#endif
|
|
+-
|
|
+-#if defined (vax)
|
|
+-# if !defined (ultrix)
|
|
+-# include <sys/param.h>
|
|
+-# if defined (BSD)
|
|
+-# if BSD == 43
|
|
+- printf ("vax-dec-bsd4.3\n"); exit (0);
|
|
+-# else
|
|
+-# if BSD == 199006
|
|
+- printf ("vax-dec-bsd4.3reno\n"); exit (0);
|
|
+-# else
|
|
+- printf ("vax-dec-bsd\n"); exit (0);
|
|
+-# endif
|
|
+-# endif
|
|
+-# else
|
|
+- printf ("vax-dec-bsd\n"); exit (0);
|
|
+-# endif
|
|
+-# else
|
|
+- printf ("vax-dec-ultrix\n"); exit (0);
|
|
+-# endif
|
|
+-#endif
|
|
+-
|
|
+-#if defined (alliant) && defined (i860)
|
|
+- printf ("i860-alliant-bsd\n"); exit (0);
|
|
+-#endif
|
|
+-
|
|
+- exit (1);
|
|
+-}
|
|
+-EOF
|
|
+-
|
|
+-$CC_FOR_BUILD -o $dummy $dummy.c 2>/dev/null && SYSTEM_NAME=`$dummy` &&
|
|
+- { echo "$SYSTEM_NAME"; exit; }
|
|
+-
|
|
+-# Apollos put the system type in the environment.
|
|
+-
|
|
+-test -d /usr/apollo && { echo ${ISP}-apollo-${SYSTYPE}; exit; }
|
|
+-
|
|
+-# Convex versions that predate uname can use getsysinfo(1)
|
|
+-
|
|
+-if [ -x /usr/convex/getsysinfo ]
|
|
+-then
|
|
+- case `getsysinfo -f cpu_type` in
|
|
+- c1*)
|
|
+- echo c1-convex-bsd
|
|
+- exit ;;
|
|
+- c2*)
|
|
+- if getsysinfo -f scalar_acc
|
|
+- then echo c32-convex-bsd
|
|
+- else echo c2-convex-bsd
|
|
+- fi
|
|
+- exit ;;
|
|
+- c34*)
|
|
+- echo c34-convex-bsd
|
|
+- exit ;;
|
|
+- c38*)
|
|
+- echo c38-convex-bsd
|
|
+- exit ;;
|
|
+- c4*)
|
|
+- echo c4-convex-bsd
|
|
+- exit ;;
|
|
+- esac
|
|
+-fi
|
|
+-
|
|
+ cat >&2 <<EOF
|
|
+ $0: unable to guess system type
|
|
+
|
|
+diff -up ./config.sub.dt ./config.sub
|
|
+--- ./config.sub.dt 2016-10-23 22:39:18.202299893 +0200
|
|
++++ ./config.sub 2016-10-23 22:32:42.024632209 +0200
|
|
+@@ -1,10 +1,8 @@
|
|
+ #! /bin/sh
|
|
+ # Configuration validation subroutine script.
|
|
+-# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
|
+-# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
|
+-# 2011, 2012, 2013 Free Software Foundation, Inc.
|
|
++# Copyright 1992-2015 Free Software Foundation, Inc.
|
|
+
|
|
+-timestamp='2012-12-29'
|
|
++timestamp='2015-01-01'
|
|
+
|
|
+ # This file is free software; you can redistribute it and/or modify it
|
|
+ # under the terms of the GNU General Public License as published by
|
|
+@@ -27,7 +25,7 @@ timestamp='2012-12-29'
|
|
+ # of the GNU General Public License, version 3 ("GPLv3").
|
|
+
|
|
+
|
|
+-# Please send patches with a ChangeLog entry to config-patches@gnu.org.
|
|
++# Please send patches to <config-patches@gnu.org>.
|
|
+ #
|
|
+ # Configuration subroutine to validate and canonicalize a configuration type.
|
|
+ # Supply the specified configuration type as an argument.
|
|
+@@ -70,9 +68,7 @@ Report bugs and patches to <config-patch
|
|
+ version="\
|
|
+ GNU config.sub ($timestamp)
|
|
+
|
|
+-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
|
+-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011,
|
|
+-2012, 2013 Free Software Foundation, Inc.
|
|
++Copyright 1992-2015 Free Software Foundation, Inc.
|
|
+
|
|
+ This is free software; see the source for copying conditions. There is NO
|
|
+ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
|
+@@ -256,19 +252,20 @@ case $basic_machine in
|
|
+ | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
+ | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
+ | am33_2.0 \
|
|
+- | arc \
|
|
++ | arc | arceb \
|
|
+ | arm | arm[bl]e | arme[lb] | armv[2-8] | armv[3-8][lb] | armv7[arm] \
|
|
+ | avr | avr32 \
|
|
+ | be32 | be64 \
|
|
+ | bfin \
|
|
+- | c4x | clipper \
|
|
++ | c4x | c8051 | clipper \
|
|
+ | d10v | d30v | dlx | dsp16xx \
|
|
+ | epiphany \
|
|
+- | fido | fr30 | frv \
|
|
++ | fido | fr30 | frv | ft32 \
|
|
+ | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
|
|
+ | hexagon \
|
|
+ | i370 | i860 | i960 | ia64 \
|
|
+ | ip2k | iq2000 \
|
|
++ | k1om \
|
|
+ | le32 | le64 \
|
|
+ | lm32 \
|
|
+ | m32c | m32r | m32rle | m68000 | m68k | m88k \
|
|
+@@ -286,23 +283,26 @@ case $basic_machine in
|
|
+ | mips64vr5900 | mips64vr5900el \
|
|
+ | mipsisa32 | mipsisa32el \
|
|
+ | mipsisa32r2 | mipsisa32r2el \
|
|
++ | mipsisa32r6 | mipsisa32r6el \
|
|
+ | mipsisa64 | mipsisa64el \
|
|
+ | mipsisa64r2 | mipsisa64r2el \
|
|
++ | mipsisa64r6 | mipsisa64r6el \
|
|
+ | mipsisa64sb1 | mipsisa64sb1el \
|
|
+ | mipsisa64sr71k | mipsisa64sr71kel \
|
|
++ | mipsr5900 | mipsr5900el \
|
|
+ | mipstx39 | mipstx39el \
|
|
+ | mn10200 | mn10300 \
|
|
+ | moxie \
|
|
+ | mt \
|
|
+ | msp430 \
|
|
+ | nds32 | nds32le | nds32be \
|
|
+- | nios | nios2 \
|
|
++ | nios | nios2 | nios2eb | nios2el \
|
|
+ | ns16k | ns32k \
|
|
+- | open8 \
|
|
+- | or32 \
|
|
++ | open8 | or1k | or1knd | or32 \
|
|
+ | pdp10 | pdp11 | pj | pjl \
|
|
+ | powerpc | powerpc64 | powerpc64le | powerpcle \
|
|
+ | pyramid \
|
|
++ | riscv32 | riscv64 \
|
|
+ | rl78 | rx \
|
|
+ | score \
|
|
+ | sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
|
|
+@@ -313,6 +313,7 @@ case $basic_machine in
|
|
+ | tahoe | tic4x | tic54x | tic55x | tic6x | tic80 | tron \
|
|
+ | ubicom32 \
|
|
+ | v850 | v850e | v850e1 | v850e2 | v850es | v850e2v3 \
|
|
++ | visium \
|
|
+ | we32k \
|
|
+ | x86 | xc16x | xstormy16 | xtensa \
|
|
+ | z8k | z80)
|
|
+@@ -327,7 +328,10 @@ case $basic_machine in
|
|
+ c6x)
|
|
+ basic_machine=tic6x-unknown
|
|
+ ;;
|
|
+- m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
|
|
++ leon|leon[3-9])
|
|
++ basic_machine=sparc-$basic_machine
|
|
++ ;;
|
|
++ m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | nvptx | picochip)
|
|
+ basic_machine=$basic_machine-unknown
|
|
+ os=-none
|
|
+ ;;
|
|
+@@ -369,13 +373,13 @@ case $basic_machine in
|
|
+ | aarch64-* | aarch64_be-* \
|
|
+ | alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
|
+ | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
+- | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
++ | alphapca5[67]-* | alpha64pca5[67]-* | arc-* | arceb-* \
|
|
+ | arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
+ | avr-* | avr32-* \
|
|
+ | be32-* | be64-* \
|
|
+ | bfin-* | bs2000-* \
|
|
+ | c[123]* | c30-* | [cjt]90-* | c4x-* \
|
|
+- | clipper-* | craynv-* | cydra-* \
|
|
++ | c8051-* | clipper-* | craynv-* | cydra-* \
|
|
+ | d10v-* | d30v-* | dlx-* \
|
|
+ | elxsi-* \
|
|
+ | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
|
|
+@@ -384,6 +388,7 @@ case $basic_machine in
|
|
+ | hexagon-* \
|
|
+ | i*86-* | i860-* | i960-* | ia64-* \
|
|
+ | ip2k-* | iq2000-* \
|
|
++ | k1om-* \
|
|
+ | le32-* | le64-* \
|
|
+ | lm32-* \
|
|
+ | m32c-* | m32r-* | m32rle-* \
|
|
+@@ -403,18 +408,22 @@ case $basic_machine in
|
|
+ | mips64vr5900-* | mips64vr5900el-* \
|
|
+ | mipsisa32-* | mipsisa32el-* \
|
|
+ | mipsisa32r2-* | mipsisa32r2el-* \
|
|
++ | mipsisa32r6-* | mipsisa32r6el-* \
|
|
+ | mipsisa64-* | mipsisa64el-* \
|
|
+ | mipsisa64r2-* | mipsisa64r2el-* \
|
|
++ | mipsisa64r6-* | mipsisa64r6el-* \
|
|
+ | mipsisa64sb1-* | mipsisa64sb1el-* \
|
|
+ | mipsisa64sr71k-* | mipsisa64sr71kel-* \
|
|
++ | mipsr5900-* | mipsr5900el-* \
|
|
+ | mipstx39-* | mipstx39el-* \
|
|
+ | mmix-* \
|
|
+ | mt-* \
|
|
+ | msp430-* \
|
|
+ | nds32-* | nds32le-* | nds32be-* \
|
|
+- | nios-* | nios2-* \
|
|
++ | nios-* | nios2-* | nios2eb-* | nios2el-* \
|
|
+ | none-* | np1-* | ns16k-* | ns32k-* \
|
|
+ | open8-* \
|
|
++ | or1k*-* \
|
|
+ | orion-* \
|
|
+ | pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
|
|
+ | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
|
|
+@@ -432,6 +441,7 @@ case $basic_machine in
|
|
+ | ubicom32-* \
|
|
+ | v850-* | v850e-* | v850e1-* | v850es-* | v850e2-* | v850e2v3-* \
|
|
+ | vax-* \
|
|
++ | visium-* \
|
|
+ | we32k-* \
|
|
+ | x86-* | x86_64-* | xc16x-* | xps100-* \
|
|
+ | xstormy16-* | xtensa*-* \
|
|
+@@ -769,6 +779,9 @@ case $basic_machine in
|
|
+ basic_machine=m68k-isi
|
|
+ os=-sysv
|
|
+ ;;
|
|
++ leon-*|leon[3-9]-*)
|
|
++ basic_machine=sparc-`echo $basic_machine | sed 's/-.*//'`
|
|
++ ;;
|
|
+ m68knommu)
|
|
+ basic_machine=m68k-unknown
|
|
+ os=-linux
|
|
+@@ -796,7 +809,7 @@ case $basic_machine in
|
|
+ os=-mingw64
|
|
+ ;;
|
|
+ mingw32)
|
|
+- basic_machine=i386-pc
|
|
++ basic_machine=i686-pc
|
|
+ os=-mingw32
|
|
+ ;;
|
|
+ mingw32ce)
|
|
+@@ -824,6 +837,10 @@ case $basic_machine in
|
|
+ basic_machine=powerpc-unknown
|
|
+ os=-morphos
|
|
+ ;;
|
|
++ moxiebox)
|
|
++ basic_machine=moxie-unknown
|
|
++ os=-moxiebox
|
|
++ ;;
|
|
+ msdos)
|
|
+ basic_machine=i386-pc
|
|
+ os=-msdos
|
|
+@@ -832,7 +849,7 @@ case $basic_machine in
|
|
+ basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
|
|
+ ;;
|
|
+ msys)
|
|
+- basic_machine=i386-pc
|
|
++ basic_machine=i686-pc
|
|
+ os=-msys
|
|
+ ;;
|
|
+ mvs)
|
|
+@@ -1354,7 +1371,7 @@ case $os in
|
|
+ -gnu* | -bsd* | -mach* | -minix* | -genix* | -ultrix* | -irix* \
|
|
+ | -*vms* | -sco* | -esix* | -isc* | -aix* | -cnk* | -sunos | -sunos[34]*\
|
|
+ | -hpux* | -unos* | -osf* | -luna* | -dgux* | -auroraux* | -solaris* \
|
|
+- | -sym* | -kopensolaris* \
|
|
++ | -sym* | -kopensolaris* | -plan9* \
|
|
+ | -amigaos* | -amigados* | -msdos* | -newsos* | -unicos* | -aof* \
|
|
+ | -aos* | -aros* \
|
|
+ | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
|
|
+@@ -1369,14 +1386,14 @@ case $os in
|
|
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
|
+ | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
|
|
+ | -linux-newlib* | -linux-musl* | -linux-uclibc* \
|
|
+- | -uxpv* | -beos* | -mpeix* | -udk* \
|
|
++ | -uxpv* | -beos* | -mpeix* | -udk* | -moxiebox* \
|
|
+ | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
|
|
+ | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
|
|
+ | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
|
|
+ | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
|
|
+ | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
|
|
+ | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
|
|
+- | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es*)
|
|
++ | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es* | -tirtos*)
|
|
+ # Remember, each alternative MUST END IN *, to match a version number.
|
|
+ ;;
|
|
+ -qnx*)
|
|
+@@ -1500,9 +1517,6 @@ case $os in
|
|
+ -aros*)
|
|
+ os=-aros
|
|
+ ;;
|
|
+- -kaos*)
|
|
+- os=-kaos
|
|
+- ;;
|
|
+ -zvmoe)
|
|
+ os=-zvmoe
|
|
+ ;;
|
|
+@@ -1551,6 +1565,9 @@ case $basic_machine in
|
|
+ c4x-* | tic4x-*)
|
|
+ os=-coff
|
|
+ ;;
|
|
++ c8051-*)
|
|
++ os=-elf
|
|
++ ;;
|
|
+ hexagon-*)
|
|
+ os=-elf
|
|
+ ;;
|
|
--
|
|
2.9.3
|
|
|