You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libreoffice/0001-Related-rhbz-753201-fe...

83 lines
3.6 KiB

From fd567018ec52a53b00b5da7782b3100177b2c028 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 11 Nov 2011 15:45:58 +0000
Subject: [PATCH] Related: rhbz#753201 fedora ant+java-1.5.0-gcj won't resolve
env variables
---
rhino/makefile.mk | 4 ++--
rhino/rhino1_5R5-find_swing.patch | 5 ++---
2 files changed, 4 insertions(+), 5 deletions(-)
diff --git a/rhino/makefile.mk b/rhino/makefile.mk
index 91117d9..577d030 100644
--- a/rhino/makefile.mk
+++ b/rhino/makefile.mk
@@ -58,9 +58,9 @@ FIXED_TARFILE_LOCATION=$(TARFILE_LOCATION)
.IF "$(JAVACISGCJ)"=="yes"
JAVA_HOME=
.EXPORT : JAVA_HOME
-BUILD_ACTION=$(ANT) -Dbuild.label="build-$(RSCREVISION)" -Dbuild.compiler=gcj jar
+BUILD_ACTION=$(ANT) -DTARFILE_LOCATION="$(FIXED_TARFILE_LOCATION)" -Dbuild.label="build-$(RSCREVISION)" -Dbuild.compiler=gcj jar
.ELSE
-BUILD_ACTION=TARFILE_LOCATION="$(FIXED_TARFILE_LOCATION)" $(ANT) -Dbuild.label="build-$(RSCREVISION)" -Dant.build.javac.source=$(JAVA_SOURCE_VER) -Dant.build.javac.target=$(JAVA_TARGET_VER) jar
+BUILD_ACTION=$(ANT) -DTARFILE_LOCATION="$(FIXED_TARFILE_LOCATION)" -Dbuild.label="build-$(RSCREVISION)" -Dant.build.javac.source=$(JAVA_SOURCE_VER) -Dant.build.javac.target=$(JAVA_TARGET_VER) jar
.ENDIF
# --- Targets ------------------------------------------------------
diff --git a/rhino/rhino1_5R5-find_swing.patch b/rhino/rhino1_5R5-find_swing.patch
index 220c4f4..f074fa8 100644
--- a/rhino/rhino1_5R5-find_swing.patch
+++ b/rhino/rhino1_5R5-find_swing.patch
@@ -1,11 +1,10 @@
--- misc/rhino1_5R5/toolsrc/build.xml 2009-10-29 18:29:46.605524507 +0100
+++ misc/build/rhino1_5R5/toolsrc/build.xml 2009-10-29 18:29:26.536908810 +0100
-@@ -12,6 +12,8 @@
+@@ -12,6 +12,7 @@
<os family="unix"/>
</and>
</condition>
-+ <property environment="solenv"/>
-+ <property name="swing_zip" value="${solenv.TARFILE_LOCATION}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip"/>
++ <property name="swing_zip" value="${TARFILE_LOCATION}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip"/>
<path id="macPath" location="${java.home}/../Classes/classes.jar"/>
<!-- rhino.jar from OpenJDK breaks build -->
<path id="nonMacPath">
--
1.7.6.4
diff -up libreoffice-3.4.4.2/scripting/java/build.xml.dt libreoffice-3.4.4.2/scripting/java/build.xml
--- libreoffice-3.4.4.2/scripting/java/build.xml.dt 2011-12-07 12:31:17.491262301 +0100
+++ libreoffice-3.4.4.2/scripting/java/build.xml 2011-12-07 12:32:04.561151965 +0100
@@ -42,9 +42,6 @@
Not needed in default build -->
<property name="netbeans.install.path" value="/export/home/netbeans"/>
- <property environment="env"/>
- <property name="env.BSH_JAR" value="${solar.jar}/bsh.jar"/>
-
<!-- ==================== classpath setting ============================ -->
<path id="idlclasspath">
<pathelement location="${solar.jar}/jurt.jar"/>
@@ -52,7 +49,7 @@
<pathelement location="${solar.jar}/juh.jar"/>
<pathelement location="${solar.jar}/java_uno.jar"/>
<pathelement location="${solar.jar}/ridl.jar"/>
- <pathelement location="${env.BSH_JAR}"/>
+ <pathelement location="${BSH_JAR}"/>
<pathelement location="${solar.jar}/js.jar"/>
<pathelement location="${jardir}"/>
</path>
diff -up libreoffice-3.4.4.2/scripting/java/makefile.mk.dt libreoffice-3.4.4.2/scripting/java/makefile.mk
--- libreoffice-3.4.4.2/scripting/java/makefile.mk.dt 2011-12-07 12:31:11.820396072 +0100
+++ libreoffice-3.4.4.2/scripting/java/makefile.mk 2011-12-07 12:31:28.111011791 +0100
@@ -29,6 +29,8 @@ PRJ=..
PRJNAME=scripting
TARGET=scriptruntimeforjava
+ANT_FLAGS := -DBSH_JAR="$(BSH_JAR)"
+
.INCLUDE : ant.mk
.IF "$(L10N_framework)"==""