You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
68 lines
2.4 KiB
68 lines
2.4 KiB
From 6fa0780b933babbb3c5f16e0bb865eaf141b6412 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
|
Date: Thu, 20 Feb 2014 11:36:38 +0000
|
|
Subject: [PATCH] poppler fixes
|
|
|
|
Change-Id: Iaad3d6ba494a00e7581c5d7a35ec3ec5f57134dc
|
|
---
|
|
configure.ac | 10 ----------
|
|
sdext/Module_sdext.mk | 5 -----
|
|
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 +++-
|
|
3 files changed, 3 insertions(+), 16 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 30f7def..eced7e9 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -10515,16 +10515,6 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
|
|
AC_MSG_RESULT([external])
|
|
SYSTEM_POPPLER=TRUE
|
|
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
|
|
- AC_LANG_PUSH([C++])
|
|
- save_CXXFLAGS=$CXXFLAGS
|
|
- save_CPPFLAGS=$CPPFLAGS
|
|
- CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
|
|
- CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
|
|
- AC_CHECK_HEADER([cpp/poppler-version.h], [],
|
|
- [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
|
|
- CXXFLAGS=$save_CXXFLAGS
|
|
- CPPFLAGS=$save_CPPFLAGS
|
|
- AC_LANG_POP([C++])
|
|
libo_MINGW_CHECK_DLL([libpoppler])
|
|
POPPLER_CFLAGS=$(printf '%s' "$POPPLER_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
|
|
else
|
|
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
|
|
index f706e9c..94baf45 100644
|
|
--- a/sdext/Module_sdext.mk
|
|
+++ b/sdext/Module_sdext.mk
|
|
@@ -26,11 +26,6 @@ $(eval $(call gb_Module_add_targets,sdext,\
|
|
StaticLibrary_pdfimport_s \
|
|
))
|
|
|
|
-$(eval $(call gb_Module_add_check_targets,sdext,\
|
|
- CppunitTest_sdext_pdfimport \
|
|
- Executable_pdf2xml \
|
|
- Executable_pdfunzip \
|
|
-))
|
|
endif
|
|
|
|
# vim:set noet sw=4 ts=4:
|
|
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
index 067a132..342e4eb 100644
|
|
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
@@ -54,7 +54,9 @@
|
|
class GfxPath;
|
|
class GfxFont;
|
|
class PDFDoc;
|
|
-#include <cpp/poppler-version.h>
|
|
+#define POPPLER_VERSION_MAJOR 0
|
|
+#define POPPLER_VERSION_MINOR 12
|
|
+#define POPPLER_VERSION_MICRO 4
|
|
#define POPPLER_CHECK_VERSION(major,minor,micro) \
|
|
(POPPLER_VERSION_MAJOR > (major) || \
|
|
(POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
|
|
--
|
|
1.9.0
|
|
|